Having problems with your Cars & Trucks ?

Pt cruiser headlights

\015 I've replaced the bulb twice, the conneector twice, and have found the following, I have 12 volts at the connector, until I plug in the bulb and then I lose all power. Passenger side works fine. Found a listing for a headlight relay, purchased it, but cant find in in the engine compartment fuse paanel or any where in the interior. Any thoughts?\015 Posted / edited by AnonymousUser on : 19-03-2018

Answers :

First off its not a relay that would cause that problem a relay is wired in a series with both headlights to protect the circuit for heating in the wires its basically a contactor with selenoid in it. this problem is a grounding problem at or near the headlight that has the problem check for proper grounding of wires it may look clean or tight but take it lose and clean the terminal and then put a dielectric grease on it to put it back together
Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0054 seconds