Having problems with your 2003 Chevrolet S-10 ?

Miss fire but plugs and wire are good - 2003 Chevrolet S-10

Posted / edited by AnonymousUser on : 19-03-2018

Answers :

Injectors. cylinder head issues. improper spark plug gap. coil. the list can go on and on really. if no check engine light is on try running the truck with a spark plug disconnected from the wire one by one you can eliminate what cylinder is having a problem (if you un plug one and the mis doesn't change that likely your trouble spot) check that specific wire by replacing the one with a stock wire you can pick up at auto zone for a few bucks. check that specific plug for cracks or replace it with a new matching one.
Is check engine light on? if so go to autozone and get them to read the code or codes, write them down so you can look on the internet for common causes for the specific codes you have. Do your research, parts jockeys will be quick to sell you stuff you don't need. - you can buy a non-contact voltage tester


run it along the plug wire it will beep and flash, when the pattern gets erratic you have found the bad spot.

good luck
Repair Help & Product Troubleshooting for 2003 Chevrolet S-10

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0054 seconds