Having problems with your 2000 Ford Ranger SuperCab ?

Have a 2000 ford ranger manual transmission truck used, after driving it 5 miles, going from 2 nd 3rd gears, it makes a grinding sound, even if you just ease into it, like a skip, then a grind. The engine check light came on after 30m to 60 miles after i drove it off the used lot, I took it back, they had their mechanic fix the chck engine light, 2 days later the light came back on, im wondering if the transmission needs to be serviced, I took it to "Ford" they did a quick analysis on it, somet

Posted / edited by AnonymousUser on : 19-02-2018

Answers :

All gears will make noise especially when they are synchronized as your \015\012transmission is. Hhow is the tranny fluid? When was it last changed? Has\015\012 it ever been changed? What kind of fluid in the tranny?

Hope you dont \015\012go to drain it and find metal shavings to say the least.. if I'm not \015\012mistake they also had a problem with the plugs on the top of the tranny \015\012getting hard and letting the fluid out, causing low tranny fluid.

Keep us updated.
Sounds like the Used car lot just Unhooked the battery and re hooked it up to clear the codes temporary. the Grinding noise could be your Synchro's in your transmission or a clutch problem ..
I hate to tell you this if you can return it and get your money back do it sounds like you got a lemon . some states have laws just for this issue to protect you. look into it
good luck
Repair Help & Product Troubleshooting for 2000 Ford Ranger SuperCab

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0066 seconds