Having problems with your Volkswagen Passat ?

How to change intermotor auto rpm sensor

\015 Gears does not change properlly.have changed the gearbox ecu but still not working.will someone pls help\015 Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Repair Help & Product Troubleshooting for Volkswagen Passat

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

How to change intermotor auto rpm sensor


... Volkswagen Passat

98 ram 2500. when it gets warmed up and i plow, it doesn't allow me to accelerate and the rpm's get erratic. it sounds like it is misfiring or something. it never quits and always starts. when it cools down, it is back to normal until it gets warm again. i have changed the coil, cam sensor, throttle postion sensor, crank sensor a year ago. i am leaning towards the auto shutdown relay that maybe on it's way out. i am stumped....


... Dodge Ram 2500

I have a 99 oldsmobile silhouette van - we have changed the plugs, o2 sensor, had the njectors cleaned, and the car runs bad.... if you press on the gas the RPM go down - it is like it is smothering.. Went to the auto store and they say they are receiving readings of Cam Shaft, oxy sensor 1 and 2 air in fuel line, dist cap rotor bad (not on brakes) When you give it gas it it like it smothers the engine....


Look under your distributor cap. It should be clean have good metal contacts. Also look at the rotor button right under that. It should have a nice shiny metal contact. This spins under your distributor and fires your spark plugs. Wipe it with y ... Oldsmobile Silhouette

I have a 98 vt commodore that has a surging like problem when under load. It started out rarely however now it is hard to rev it above 3000 rpm without it limiting, like a rev limiter would do. That's in neutral too. I could get 4500rpm but now less. The things that have been changed are the coil pack, plugs, leads, fuel filter, oxygen sensor, crank angle sensor, harmonic balancer (it was old). It has been put on two different scan tools. One a snap on aftermarket and the other is a auto electri


... 2006 Holden Commodore SS

1995 chevy 350 5.7 ltr egr problem solved I have had this frustration with my 1995 chevy c1500 350 5.7 ltr , no codes show up, but it stumbles around 1500 rpm. I checked sensor after sensor and even changed a few. I had replaced the motor with a crate motor and at that time I put a new EGR valve on. It runs fine when the egr valve solenoid is unplugged. Well it turns out that the auto parts store gave me the wrong egr valve. The correct one is the BWD EGR 101D which is a referenced to the OE num


... 1995 Chevrolet S-10 CA Edition

Car starts, runs, no engine light.Have changed plugs, coil, oxygen sensors, etc. At 3800 rpms, engine has a miss and if under a light load (going uphill) engine has intermentent miss. Engine miss is at the same rpm regardless of all the changes. Have had three different auto stores and one repair shop run the engine codes with no results. I am currently stumped, can find cause of engine miss. Any suggestions?


Now instead of wasting time with checking for codes,actually have a shop diagnose the issue ... 2001 Mercury Sable

2002 auto. jetta. 2.0 4 cyl. Check engine light came on today. no precious issues. still running okay. when i put it in to "D" and go about 40 to 50 mph, my rpm is at 50 to 60 rpms. there is no change in that. engine is not running hot though. My brother noticed that there was zero difference between how the car drove and accelerated in 3rd then into drive. he also did not notice a shift from 3rd into drive. He believes this to be a sensor issue. I am in college...i really do not have anymoney t


Did you just fill up gas? could be a bad gas cap.only way to know is to have codes pulled out to see why lite is on. As long as lite is not flashing you are fine. If it flashes shut it off as soon as you can. But as far as rpms awith the ... Volkswagen Jetta

95 Chevy Cavalier with the 2.2 engine in it. The Speedometer does not work and the Odometer doesn't work either But the Auto meter does work. Me and My father thought by changing the vehicle speed sensor that the problem would fix itself. So after changing the sensor the problem still occurs. My next step would be to change the sensors harness. If that does not fix the problem what do you suggest i look into next? I'm a DIY type of mechanic and I work at Napa Auto Parts so all of the parts i nee


More then likely its the speedometer cluster itself thats bad. ... Chevrolet Cavalier

Oxygen sensor Good Morning, Had my 2004 grand caravan diagnostic test done, when engine light came on, at dealer. They told me the O2 sensor prior to catalitic converter is bad. How hard is it to replace and what is a good price? Should I go ahead and change both sensors or just the one? Also, checked at auto zone and advanced autos for prices, there is huge difference in price. Auto zone being almost double the price of advanced auto, @ $100 to @ $50. Why the huge difference and which would be


Sometimes you'll find Chrysler dealer parts cheaper or as cheap as aftermarket, so make sure you price it through them too. Should only take a few minutes to change so I can't see labor being too much. I'd just do the one for now, like I said, a few ... 2004 Dodge Grand Caravan

I have chevy trailblazer 2004 .... at idle rpm goes to 1000 ... cam shaft sensor changed, gas pedal changed, throttle body changed o2 sensor changed, spark plugs changed, fuel filter changed and checked the obd codes... ive got p0452 code... is it resposible for this.... please help


Presure sensor evap ... 2004 Chevrolet TrailBlazer

1998 GMC JIMMY 4.3 LITER VORTEC WILL NOT REV OVER 2000 RPM ,CHANGED DISTRIBUTOR , TIMING CHAIN,SPIDER, FUEL PUMP,COMPUTOR DOES NOT RECOGNISE MAS AIR FLOW SENSOR , CHANGED AIR SENSOR , RAN WIRE FROM AIR FLOW SENSOR TO COMPUTOR NO CHANGE


... 1998 GMC Jimmy

My car engine service soon light came on ,i tuke the car to auto zone for diagnostic day said its was misfire , the light was flashinf at the time ,so i dit wat they told me an change a lot of the things and the service engine soon got fix but now its stalling and loss of power when asseleration like the gas its choking i try to fix more things but no luck i have change from pcv ,fuel pump , oxygen sensor , throtle position sensor, air cleaner sensor , mas flow sensor, fuel sending sensor , coil


Problem is did they tell you what # 301,303 or 305.this mean you have bad ;coil,wire,plug. ... Cars & Trucks

I have a 2003 suburban that has me stumped! I was on the freeway and it lost power (foot on the accelerator and it wouldn't go!), I limped it to an Auto Zone to scan it and it said maf sensor and map sensor and random misfire. I changed both sensors with no positive results. I limped the truck home and since have changed spark plugs, wires, fuel pressure regulator, fuel filter, fuel pump, I have checked the coils, intake manifold gasket, injectors, fuel relay, O2 sensors, catalytic convertors an


Hello, Have a look at your Crankshaft and Camshaft sensors. As I remember there was a problem on some Chevies with the Crank sensor and it caused a different problem with the timing. But it probably could cause more problems so its' suspect.\ ... 2003 Chevrolet Suburban 1500

Acting as if it will stall in idle, changed fuel filter, plugs and wires, recently had oil change. Ran good for a few days and now doing the same thing is was before I started. In the begining I had and Auto parts store hook it up to their diagnostics computer. They told me it was running lean, check the fuel filter and maybe O2 sensors. couldn't find O2 sensors. Changed fuel filter and it was VERY dirty. took it back hooked it up again they said it was missing on cylinder #1. Changed spark plug


You will have a vaccume leak on the bottom side of the plentium by your throtle body, it is the left side if sitting in driver seat. it is hard to see but a hose has colapsed and created a vaccume leak. dont know what the hose is called but if i ca ... 2001 Ford Taurus

My check engine light came on and gave me a p0032 code. Bank 1 Sensor 1 heater malfunction. I changed the sensor out, twice from Advance Auto and now a third time from Auto Zone. Now I get a new code. P0135 again with the bank 1 sensor 1 O2 Sensor. What is going on?


Its not uncommon to replacea sensor and then another to trip as well. Reset your computer by disconnecting the battery for 30 minutes. If the light comes back on then the sensor is truely bad. t will not hurt to drive with bad O2 sensors. overtim ... 2003 Dodge Caravan

I have a 1999 Silverado with the 5.3 in it. I have changed the O2 sensor(downstream) on the passenger side. It keeps flooding bank 2 and that sensor changes very slowly compared to the others. I am on my 6th Bosch Premium(warranty). The sensor lasts about 20-40 miles. It seems to act up more when I start the engine when it is warmed up. When cold it isn't an issue. Once I get over 2000 rpm it clears up and runs fine. Below that it floods the right bank causing the code to read, 'Multiple


CHECK IGNITION SYSTEM,WIRES,PLUGS,COILS.\012\012\012\012\012\012\012\012\012\012\012\012TIM ... 1999 Chevrolet Silverado 1500

Hello i need your help lexus ls430 2004 auto transmition, my problem is when the vehicle not running engine start slowly rpm go to 2500 hold rpm 5 sec check engine & vsc indecation on i read the dtc p0500 vehicle speed sensor i check speed sensor wirring,replace speed sensor but dtc p0500 on speed meter working normaly.car driving normal when driving no dtc display speed meter working normal pls suggest me what i do my mail adres [email protected] thanks.


... Cars & Trucks

2003 Toyota Rav4 low voltage light is on after changing Mass Air Flow Sensor, alternator, and battery is good as it's 1 year old. Battery was checked and is good. Car is still stalling and voltage light is still on. Took it for free diagnostic at Auto Zone for a second time and code reads Mass Air Flow Sensor. Sensor has been changed. What else could it be?


Did you have the computer reset after the part was changed? That is what you need to do. It may also take some time for the computer to relearn everything. Was it a bad maf sensor or a probem in th circuit itself? There is a difference. If it was jus ... 2003 Toyota RAV4

I have a 1996 328is. After you run the engine at about 2500 rpm for a couple of minutes, it will misfire, and the reason for the misfire is it looses injector pulse to a cylinder. If you turn the car off for about 30 seconds and re-start the car, the miss is gone until you run it at about 2500 rpm, and again, the miss will return. The miss changes to different cylinders, and every time, it looses injector pulse to various cylinders. I changed the cam position sensor, and it made no change. Any h


The 1st thing u need to do here is run a trouble code test on the engine control system, it is called an OBD 2 trouble code test, but based on the symptom it sounds like u either have a defective camshaft or crankshaft po ... 1996 BMW 318

I have a 1996 camaro, 3.8. Have really been having alot of problems, idle seems low, i get a code P300 ( random misfire) and a Cam shaft sensor code, I replaced the cam sensor 2 times, changed the plugs and wires, Changed the PCM, also fixed and replaced vaccum lines, Replaced wires that was damaged from the harness to the Cam sensor, We ran injector cleaner in last tank of gas, Our idle is running about 8-900 rpm with it going up and down at cold start. I guess my question is how do i get rid o


You can disconnect the battery for about 2 min and that should clear any codes that are stored in in it or take it to autozone or someplace that will erase the codes for you i hope this helps ... 1996 Chevrolet Camaro

Geo storm my geo wasnt running then i changed the air flow sensor and it started running but with really high rpm's also i changed the throttle positioning sensor but nothing changed


Try uplugging throttle sensor see if any change ... 1991 Geo Storm

Code PO131 My '99 Honda Civic has 77,800 miles and I change the oil every 3,000 miles. I work at an auto deqlership so anything that goes wrong I can have repaired here., In December my check engine light came on and the computer noted to change the O2 sensor, so they did. All was well for about a week, then the check engine light came on again. Once again the computer noted to change the O2 sensor, so we did again. Everything was good until a week ago the check engine light came on again. This


Code PO131 is O2 sensor circuit low voltage , bank 1, sensor 1. That sensor I would say is the one in the exhaust manifold. I would check voltage to the sensor from the computer. If the voltage is not 5 volts, then it could be a computer problem or a ... 1999 Honda Civic

MY TRUCK IS A CHEV Z71 1998 WITH 5.7 ENGINE THE WHOLE STORY IS THIS ...IT STARTED RUNNING ROUGH WHILE I WAS DRIVING HOME ON THE INTERSTATE IT WOULD NOT TAKE GAS BUT WOULD IDLE AT STOP LIGHTS.I CHANGED THE PLUGS AND WIRES...NO HELP...HOOKED IT TO OBD2 DIAGNOSTIC AND THE CODE WAS P0452 I CHANGED THE FUEL SENSOR ON TOP OF THE TANK...NO HELP..CHANGED THE KNOCK SENSOR...NO HELP SO NOW I DON'T HAVE A CLUE IDLES OK BUT SHAKES BADLY WHEN IT IS IN GEAR. IT WILL REV AT 3000 RPM AND I STILL SMELL GAS.


Hmm did you check your mass air flow sensor and your throttle body position sensor ???also have a look at your engine mounts ....pop hood,, have someone start the vehicle,, look at the engine for movement.. put in drive and se ... Chevrolet 1500

My 2002 bmw 325ci, I just had head gasket and both camshaft sensors plus temperature sensor changed. Cold start is very rough, but if you keep the rpm at 2000 for 30seconds it will work with no rough idling. Now the car works but the temperature will pass the half mark and lean towards the red side, but it fluctuates back and forth depending on engine speed. At 2500 rpm it will drop but if the rpm drops to 1000 the temperature guage will go up to the almost red??? Need help with your best advice


For the temp problem, check the fan clutch maybe broke. change the center part of the fan. ... 2001 BMW 325

I took my car to auto zone and got it check it said the map sensor was bad,egr, throttle pos.I changed all but the map sensor.but i changed the fuelpunp,fuelfilter,coilpacks,sparkplugs,but it stills stalls when starting sometimes back fires could it be the map sensor i did not change


1ST OFF NEVER LISTEN TO THE AUTOZONE PARTS PEOPLE, THEY ARE NOT AUTOMOTUIVE TENCHNICIANS, OBD 2 SYSTEM TROUBLE CODES DON'T INDICATE THAT A PARTICULAR PART IS BAD, JUST THAT THE CIRCUIT OR SYSTEM THAT PART IS IN HAS A PROBLEM, THAT CA ... 1997 Cadillac DeVille
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 2.3913 seconds