Having problems with your Saab 9 5 ?

How do you go about changing the fuel pressure sensor on a 2003 Saab 9-5 Linear 2.3 Wagon? Saab wanted $615 to replace the sensor.

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for Saab 9 5

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I HAVE A P0300 OBD CODE I DID A COMPRESSION TEST TO ENGINE AND IT PASS THE TEST,I DID CHECK EGR VALVE,CHANGE SPARK PLUGS,IGNITION WIRES, CAP AND ROTOR, I DID CHECK TPS SENSOR MAF SENSOR,FUEL PRESSURE,AND OXIGEN SENSORSI I FOUND THAT ON BANK 1 BOTH SENSORS (UP STREAM & DOWN STREAM )WORKS NORMALY BUT ON BANK 2 THE SENSOR 1 CHANGE FROM 0 TO 600 MILIVOLTS BUT NO CHANGES FROM RICH TO LEAN &SENSOR 2 HAS 0 MILIVOLTS & NO CHANGES FROM RICH TO LEAN SO I SWICHT SENSOR TO TEST THEM FROM BANK 2 TO BANK 1 AN


... 1997 Nissan Pathfinder

How do you go about changing the fuel pressure sensor on a 2003 Saab 9-5 Linear 2.3 Wagon? Saab wanted $615 to replace the sensor.


... Saab 9 5

1997 Chevrolet s10 2.2L 4cyl. I run a dianostic computer on it said change exhaust sensor after cataletic converter an engine running lean! I changed it, after about 5 miles service engine soon light came back on,did the same now a code P1133,P0171,The 1133 heated oxygen sensor-Bank 1 sensor,0171 fuel trim bank one condition they say its the oxgen sensor before the catalitic converter! I don't want to replace all the sensors,it says one of the probable cause - failed HO2S11 (Bank 1 Sensor 1) hea


Engine is probably sucking air causing the lean condition ... 1997 Chevrolet S-10 Pickup

Fuel problem !986 Ford Ranger with 2.9 engine,Truck will not start,no electricity any where on the fuel system,replace module,mapp sensor,new fuel pumps,it has low and high pressure pumps,replaced fuel relay. Everything is firing like it should.You can hotwire the fuel system anywhere you want to and the pumps will work,but truck still will not start.Any ideals. PS Already changed computers.


On the negitive battery cable there is also a small black wire this is you fuel ground make sure this had a good connection the the negitive side of the battery. ... 2006 Ford Ranger

SL2 Won't start; previous codes=PO 133 + PO341 + po420; REPLACED O2 sENSOR - Bank 1 Camshaft Position Sensor Apparently is OK; Resistance=Approx 800 ohms & Output >600 mv; Can't locate Cam position sensor; Think it is near oil filter and has only one wire, but not sure of wire color or sensor resistance or output. Fuel pump relay seems OK; Switched relay with identical one. Fuel pump spins, but didn't measure pressure. Also changed plugs & wires previously & it ran then. WHAT'S


I HAVE A 98 SATURN, WON'T EVEN TRY TO START EVERY ONCE IN A WHILE. TURNS OUT TO BE THE CRANKSHAFT POSITION SENSOR ... 1999 Saturn SL

Ok i got a 2002 saturn vue..code was saying bank 1 bank 2 running lean..the vue runs perfect ,sometime at park it would idle hi.anyways i have replaced the mass air flow unit..turn off light,comes back on same code.then they say the sensors on the manifolds..i changed them both upper and lower..turn off light same problem..bank 1 bank 2 running lean...it runs fine...read it could be the fuel pressure regualtor...ok trying to find location,i heard the gas tank on fuel pump,i heard inside the fuel


I had exactly the same problem .Mine was corrected with replacing the O2 sensors .The sensors cost less than $30 each but cost about 20 mins labor per sensor .So if you got an honest mechanic the total cost will be around $130 . ... 2002 Saturn VUE

I have a 01 GMC sierra 4.3 and my check engine light is on and says bank 1 and Bank 2 is running to rich and it also does not want to start on a cold start. If i turn the truck on and cut it off really quick and start it again it starts right up. i have already replaced, plugs,wires,cap,rotor,iginition module,iginiton coil, fuel pressure regulator, two O2 sensors, throttle positon sensor, map sensor,engine coolant temp sensor.


Chek injectors posible leak ... 2002 GMC Sierra 1500

After replacing the MAP sensor, the Throttle position sensor, the fuel filter, and gas cap-changing the oil, adding Gumout, octane booster, the car still wants to hesitate while first accelerating on the highway or stall when first running after shutting down. If we gun it in neutral, it will not stall... and the gas cap, though new, still has no vacumn when releasing the pressure taking it off. I suspect that there is a hose leak, crack, etc. My son checked it, but that is all that seems to be


What year & engine on this vehicle? ... Plymouth Grand Voyager

Using my OBD II on 2000 honda prelude trouble codes PO401 & (PO401 pd) all reads MIL on, monitors, 1 INC, EVAP, 7 ready, MISFIRE, FUEL, COMP, CATLYST, 02 sensor, 02 HTR, EGR. Will be cleaning out EGR, BUT do I need to replace my Solenoid? My prelude stalls and ideals out of first gear. (Autotranny). Is this stall caused by these trouble codes? Also with 1 pending code, what do you recomend? I ran car and used OBD II a 2nd time and only change was (0 inc) and 8 (ready).


... Cars & Trucks

My ford f150 is flooding out, gets about 4 mpg, spark plugs last about 1 month, ive changed egr valve, o2 sensor, fuel pressure reg, tps and still no luck really need some help The colder it gets the worse it gets, it has a terrible miss to it, it feels like the motor wants to jump out of the truck, from no throttle at all to about 1/4 throttle it has a dead spot and just wants to die


I would check for excessive fuel preasure, and or preasure relief valve ... 1991 Ford F150

Fuel problems 1999 Grand Prix GTP 3800 Supercharged VIN 1: car starts, but shuts down within 10 seconds. You can see the fuel pressure drop within those 10 seconds. If I flutter the throttle, the fuel pressure will jump back up to 50lbs & back down to 0-10. But, you can keep the car running by doing that. I have replaced the fuel filter & helped a little bit, but still shuts down. Replaced fuel pressure regulator & fuel pump & oil pressure switch & still nothing. HELP....


T.p.s. censor ... 1999 Pontiac Grand Prix

1996 Chrysler Sebring LXi Coupe V6 -- Check engine light came on and had Auto Zone put the tester on the car. Report shows Oxygen Sensor at Bank 1, Sensor 1 was inoperable, fuel mixture is too lean/rich, misfire code, and a code for the fuel pressure relay. Replaced battery, battery terminals, distributor cap, rotor button, and Oxygen Sensor at Bank 1 Sensor 1. The engine spins over but will not crank. Verified there is spark by pulling one of the plugs. Is there anything specific I should


... 1996 Chrysler Sebring

1987 chevy s10 will not run. changed weak fuel pump and prssure is fine now, swapped out ecm, replace fuel pressure switch, oil pressure sensor, distrib cap, rotor, elec chip on distrib, o2 sensor, map sensor, engines runs fine when spraying fuel starter but will not continue to run engine dies. Comments: Jul 14, 2009 - i checked the fuel line going to the carb and it is getting plenty fuel


It does sound like a fuel problem, try running some jet cleaner through as you may have clogged jets. Sometimes, removal of air filter and placing the palm of your hand over the top of the carb's butterfly valve, will clear blocked jets when engine c ... 1987 Chevrolet S-10 Pickup

Bank 2 o2 sensor 1 stays around 420 to 480 stuck in lean comes up with p1054 no activity replaced all 3 plugs on that bank very fuel fowled replaced heated o2 sensor a lot of carbon build up no change bank 1 o2 sensor working correctly switching from lean to rich. even swapped both o2 sensors then bank 2 sensor that was stuck started working perfectly on bank 1. engine runs smooth with new plugs not fouling yet. but will not go into closed loop ever


There is either a problem with the wiring between that O2 sensor and the ECM (Engine Control Module) or "Engine Control Computer" (you will need a DVOM "Digital Volt Ohm Meter' to test those wires) or the problem will be the ECM itself, and the probl ... 1994 Chevrolet S-10

Ford f150 2003 po171 always lean bank 1. replaced bank 1 o2 sensor smoked intake. replaced egr valve. still code po171 short term trim 0123 but long term trim is up bank 1 30 anb bank 2 is 27. idle is a little rough, replaced plugs air filter pcv from dealer. no change in long term trim. no misfires reported. MAF has been replaced before all this. fuel pressureis 35 to 38. plug off vacumm accessorys long term is 25 and 25. still cant find any vacumm leaks. did a fuel injector cleaning but n


Code Po171 indicates a lean condition on cylinder bank #1 of the engine. This is the drivers side of the engine. I would suggest replacing both front oxygen sensors as a pair to start. An oxygen sensor has a life span of about 5 years and yours are ... Ford F-150

2006 chevy equinox, when i try to turn on my car it sometimes takes awhile to turn over. auto zone diagnostic recognized a rich or leancondition on one engine bank. suggested to check/change mass air flowsensor, fuel pressure, o2 sensor, ignition misfire repair, fuelinjector problem. i dont want to replace anything i dont have to, ialready have to change front brakes, 4 tires and i only have 50,000miles...


First off its not the throttel body you probley have a blown intake gasket 3.4 are known for it and thats the number one thing with an equinox ... 2006 Chevrolet Equinox

1987 chevy s10 will not run. changed weak fuel pump and prssure is fine now, swapped out ecm, replace fuel pressure switch, oil pressure sensor, distrib cap, rotor, elec chip on distrib, o2 sensor, map sensor, engines runs fine when spraying fuel starter but will not continue to run engine dies.


The problem is fuel related. Disconnect the fuel line to see if fuel is reaching the carb. ... 1987 Chevrolet S-10 Pickup

Engine light was on and van was running rough. The local repair center says that it needs a new fuel pump (2 of 6 sensors are receiving low fuel pressure ratings). I keep getting different answers on what this involves. I thought it would just be a fuel pump and a filter, but now I'm hearing there are 3 pieces to the fuel pump system - pump, motor, filter. Want to replace this myself, but I don't want to have to repair it twice. What exactly do I need to replace the "fuel pump"??


First check the pressure at the fuel rail at the top of the engine with a fuel pressure gauge these ar fairly expensive for what they are about a 100$ so if you can borrow one it would be great. doing this ensures you truly have low fuel pressure in ... 2004 Ford Freestar

2004 Volvo S40 2.4I engine check light is on, light is cleared and returns a week later, engine drives normal with light on. codes read P0172 system too rich bank one, P0191 fuel rail pressure sensor circuit range/performance, P1090 fuel rail pressure sensor circuit. now i need to know how to test to see if its the sensor that is faulty or the wiring circuit, replacement of the sensor is over $1000 and cant be returned so need to know im making the right choice by changing the sensor. thanks


... 2005 Volvo S40

2006 chevrolet suburban 5.3 SFI flex fuel OBD II trouble codes 172 and 175. I have replaced MAF sensor 2 times, New spark plugs, fuel injector cleaner in fuel tank multiple times, replaced drivers side O2 sensor ahead of converter just to see if something would change. I have a scan tool and have reset the computer each time. The service light usually seems to come on with engine warm and during a coasting situation (IE: down hill or during stopping. could this be fuel pressure regulator? Does


... Chevrolet Suburban 1500

Having issues with a 1992 chev 1500 4.3l I think its a fuel issue. replaced fuel pump, replace injectors and fuel pressure regulator from known running truck. had a power issue to the fuel pump so i have it hard wired to a switch right now so i know it is working all the time. I have good clean spark and have changed the icm. changed out the coolant temp sensor. Help please?????


Maybe a stopped up cat converter. ... Cars & Trucks

I have the following codes 1999 Izusu Rodeo: P0137 O2 SENSOR BANK 1 P0137 O2 SENSOR BANK 2 P0171 SYSTEM TOO LEAN BANK 1 P1171 MANUFACTURE CONTROL FUEL AIR METERING P0174 SYSTEM TOO LEAN BANK 2 P0452 EVAP EMISSION I HAVE REPLACED; EGR VALVE; MAP & MAF SENSOR; o2 SENSORS 2 BANK ONE AND TWO; THE PCV VALVE....? WHEN COLD STARTS it SHUTS OFF A FEW TIMES THEN WARMED UP IT IDLES FINE. NO DIFFERENCE AFTER REPLACING ALL ABOVE PARTS...IT STILL HAS NO POWER WHEN DRIVING? DONT WANT TO GO TO THE DEALERSHIP!!


I have a van that had a similar problem. Not sure if the rodeo has O rings. That was my problem. ... 1999 Isuzu Rodeo

I own a subaru outback limited sedan 2002 with the ej251. I replaced the engine and the car ran fine....at first. Now 1&3 cylendars are not firing at all. I've replaced the cam angle sensor, engine control harness, fuel pump, injectors, fuel pressure regulator, map sensor, and tps sensor. All to no avail. What else would cause this. The engine is in perfect timing and no vaccuum leaks have been found. Compression test checks out.


My first thought would have been a failed coil. Most 4 cylinder coils fire odd cylinders together, one positive and one negative voltage.The crank sensor could be faulty too, but I would rule out the coil first. ... Cars & Trucks

2002 1.9 sohc mp efi missing badly on #1 cylinder. new plug .wires,fuel filter.compression good.check engine light been on for several months showing egr fault. cleaned no help.installed another no help,change injectors around still missing on #1..check fuel pressure at idle 48 psi clamped off return fuel line pressure went up to 55 psi miss went away.keep trying different things and found that when i disconnected the map sensor in the top of intake manifold it also made the miss go away but the


SOUND LIKE A BAD OR DIRTY FUEL INJECTOR. ... 2002 Saturn S-Series

Replaced bad alternator;after replacing alternator car dumps fuel injector pulse width is 34.5-39ms with unstable idle.No vacuum leaks;goodfuel pressure and spark;no fault codes.Has good compression,180 psi on all 4 clinders.MAF TPS and engine coolant temp sensor all check ok iac cleaned and replaced shows good on scan tool.Replaced PCM no change scan tool displays calculated engine load as 78%.disconnected alternator no change in engine performance.Removed front o2 sensor no change.Any ideas?


Go to advance auto use computer to check car for free read code look up to get answer sounds like a fuel njection sensor or fuel filter ... 1999 Mazda 626
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 5.0374 seconds