Having problems with your Kia Optima ?

I have a 2005 Kia Optima 2.4. The care will not start and showing a code P0343. I have replaced the sensor and is still no good. The time is dead on. There is no power going to the sensor. Can you give any suggestions?

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

If you have no power going to the sensor then you prob have bad wires check the wires that run the sensor to make sure they are not broken and r connected properly
Repair Help & Product Troubleshooting for Kia Optima

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 2005 Kia Optima 2.4. The care will not start and showing a code P0343. I have replaced the sensor and is still no good. The time is dead on. There is no power going to the sensor. Can you give any suggestions?


If you have no power going to the sensor then you prob have bad wires check the wires that run the sensor to make sure they are not broken and r connected properly ... Kia Optima

When going up hills car loses power and shuts down. it would start after sitting overnight. after doing this 3 times our dealer told us they could not find anything wrong with it.they kept giving us the car back . when it happened again the car went completely dead no power anywhere.we had it towed back to the dealer and now he is telling us it needs a new computer, which is under our waranty but he also says all the coils are bad and it will cost 1300.00 to fix . does this sound right?


Did they say why the computer is covered on warranty, but the coils aren't? Would they have been covered had they found the problem the first time you took it there for problem? Tell them to do computer only, and then you try it and see how it's run ... 2004 Suzuki Grand Vitara

I have a 1997 oldsmobile aurora and the problem is when im going slow or at a complete stop the wheel is very hard to turn to the right but it has no problem whennim driving and never gives me a hard time when i turn to the left whether im driving or at a dead stop...any suggestions?? thnak you


The rack and pinion needs to be replaced to rectify the one side turning easily and the other side not turning so easily. It's like a flapper in the rack and pinion, I think.\015\012\015\012There must be enough pressure built up by the po ... 1997 Oldsmobile 88

My 2008 Ford Mustang started having problems a couple of days ago. The radio would come on and off, and at the same time the power in the car (lights, windshield wipers, power locks, power windows) would come and go. Now my car will not start and the battery appears to be dead. I try to start and hear the clicking sound. I had it jumped twice today. Both times the car turned itself off after running for a couple of minutes. During this time I couldn't shift the automatic out of park. Please advi


Hi\015\012it sounds like a bad earth conection, check the battery leads and ensure the black earth wire has a good tight conatct to the battery and also a good tight connection to the car body, if the wire is loose then when driving will touch ... 2008 Ford Mustang

2002 Yukon loses power going down the road and will go dead. Try to crank it back up sometime it will immediately and sometimes you have to let it sit a few minutes but it will crank and run. Starting to happen more often. When it first started doing this it would go several weeks or even months in between occurances. Yesterday it was really bad and make a knocking sound under the hood a couple of times. This is the first time it has ever made the sound under the hood. No lights on the dash boar


A cheap parts store scanner will not find but a good service station high end machine moslikely will, sounds like fuel issue poor flow check filter and fuel pressure, filter clogging or pump going bad maybe loose wire but not likely ... 2002 GMC Yukon XL

I was driving my 1999 Saab 9-5 today, it was raining, right after going through a puddle, my power steering stopped working, the battery light came on, so I pulled into a gas station, turned the engine off, when I tried restarting it, the battery was completely dead. I had someone jump it, and was barely able to make it home. Every time I came close to a stop, it felt as though the battery was going to die, and the power steering still was not working. Did I do something going through that puddl


LOL, nooooooo. You didn't hurt anything. In fact, you identified a problem by going through that puddle. You need a new serpentine belt and/or tensioner pulley. It sounds like the spring in your tensioner pulley may be worn, and not pulling your ... 1999 Saab 9-5

The battery will not hold a charge. Took it to Service center two years ago for a new battery but said the battery was now fully charged and I did not need a new one. BUT since that time the car would not start because of dead battery four more times. And had to give it a jump. The dealer at the service center said that the batterys are so small in the Accents that it will not take much to have them go dead. This being true in the cold weather. Could I up grade to a regular size battery ?


You can upgrade your battery,i suggest that you do so. the more cold cranking amps on your battery the better.if theres an advance auto parts store near you they will have what you need and also install it for free. autozone does the same thing also. ... Hyundai Accent

My 2004 Chev 6 cylinder Trailblazer is going dead on me while idling. It says: reduced engine power. It also is very rough sounding and feeling while I'm driving it. If I don't keep my foot on the gas at all times it will go dead on me.


... 2004 Chevrolet TrailBlazer

I have a 1999 Chevy Tahoe. Has approx. 178,000 on it. HAVING major engine issues. If it sits for any amt. of time and I get in it to drive it, 9 times out of 10 i will not have enough power to go. Once i get going, it works itself out.....but doesn't seem to get better. I have had the whole fuel assembly replaced in the fuel tank. I have dumped bottles of stuff in to 'clean' injectors. Just had all the injectors replaced. STILL DOES IT! ANY suggestions.


You didn't mention the fuel pressure regulator. Is your check engine light on? faulty ignition coil? corrosion on plug wires? spark plugs fouled? crankshaft position sensor? Did it die all at once or slowly over time get sucky? ... 1999 Chevrolet Tahoe

Power locks my power locks go off by themselves all the time and it keeps making my battery go dead. can i just siconnect them? how do i do it?


One of the activation switches is fauilty, more than likley the drivers side. ... 1992 Oldsmobile Bravada

Our vitara lost power going up hills and shut down 3 times . after sitting overnight the car would start and seem to run fine. we kept taking it to the dealer and they said nothing was wrong with it. they said they were driving it and their computers said everything seemed o.k. when the car shut down the fourth time it went completely dead. no power anywhere. it would not start the next morning. we towed it to the dealer and now they tell us the computer is shot and is under waranty but they sai


... 2004 Suzuki Grand Vitara

Stability system disabled, comes on while going down the road for no reason, and reduced engine power, and traction control light comes on at the same time. it will go 3-4 mo. without doing it and then like tonight it will do it 6 times in 35 mi. we have to shut it off, and the best luck i have is to change the preset from #2 which i use to #1 which my wife uses, it also gives problems for her while driving with #1 preset.confusing, no clue as to when it might do it either.


... 2003 GMC Yukon Denali

I have a 1990 Honda Civic Hatchback, it loses power going up hills, goes from 60mph to 40mph rapidly. Once I am over the hill it runs fine again. Also when losing power going up hill it wants to overheat if i try to give it more gas, but only during this time. Other than this it never overheats or slows down.


It could be that your car came out of time a little or you need a tune up ... 1990 Honda Civic

Smoke problem started to give smoke, when I drive fast no smoke power is ok, no loosing oil, no loosing water BUT when stop and leave the engine running, after 15 minuts the grey smoke starts to build up very badly, Now after two months I was driving down, first time she started to loose the power then the engine cut off, then I called AA , he checked the wire plug feeding to fule pump, he found no power going to fule pump. Can any body let me know that what this problem could be and the best so


Heythere are couple of smoke type.blue smoke is oil, black smoke is fuel, and white smoke is \015\012water, if it clears after starting and running a few minutes it's probably your \015\012valve guide seals leaking oil down on top of your pisto ... Peugeot Liberte

EVERY MORNING MY BATTERY IS DEAD OR NEAR DEAD THE PROBLEM STARTED A COUPLE OF MONTHS AGO WHERE I WOULD (ONCE IN A WHILE) GET A LOW BATTERY MESSAGE IN THE MORNING. THIS BECAME MORE FREQUENT SO I REPLACED THE BATTERY. DIDN'T HELP. NOW HAS GOTTEN TO WHERE IT DEAD EVERY MORNING. I'VE THROUGHLY CHECKED FOR SOMETHING LEFT ON. WHAT COULD BE GOING ON THAT GOT WORSE OVER TIME. I DID ADD A BLUETOOTH ADAPTOR IN THE M.O.S.T. RING, BUT THE POWER TO THAT IS ON THE FRONT CIGERETTE LIGHTER AND I KNOW THAT


If you know 100% that there is no light on such as under hood, glove box, trunk, interior dome, vanity mirror light, brake lights, or any other lights, then I suspect you may have a relay stuck. To find out if something is pulling power from the batt ... Mercedes-Benz E-Class

I have a 96 Cadillac Seville STS the engine is strong with low miles. The ignition was replaced about 6 months ago at the dealer because the car power would not go on. Well, same problem. I will be driving along, and suddenly the car will just die - all power, no lights, no nothing just GOES TOTALLY DEAD. It usually starts right back up but this last time it took about 45 seconds before the power was restored, and I could use the ignition. Help me.


Nothing is more frustrating then an intermittent problem (to both the mechanic and the car owner) Your description leads me to think that there is wiring that is overheating and is causing an ignition breaker to trip. Or maybe there is a related ign ... 1996 Cadillac DeVille

Whe driving my truick losses power big time, i cant go up hills, just no power. how do i no if its my fuel pump or injectors thats giving me my low power,


You can disconnect the fuel line preferably on the top of the engine but the easyest place you can find Put the line into a plastic bottle turn the key to run to energize the pump and see what the out put is It should fill the bottle at least a thrid ... 1999 Ford F350 Regular Cab

Clicking sound when trying to start and no start (sometimes). I think it sounds like the starter is clicking. it is a lot like when the battery is going dead and does not supply enough power to engage the silinoid (sp?). sometimes it starts right up and other times it only makes a clicking sound. it is easier to start when warm. also after starting it gets a rough low idle and feels like it is going to stall. the idle sort of fixes itself quickly and then it runs ok. 2001 tahoe, 5.3 L, 4x


Check starter if you have a silinoid mounted directly to the side of the case your starter may be on the way out, also battery could also have a bad cell (warm weather starts easier) trouble shoot start with cheap, rough idle check vacume hoses that ... 2001 Chevrolet Tahoe

I have a 98 mercedes c230 it sometimes surges at idle if you hit the gas it clears up and loss of power i have replaced both oxygen senors,replaced the fuel pressure regulator and the manifold becaused it was cracked. when i first start it up for the first time it acts like its slow about getting gas to start running then when you give it gas to go it starts stumbling and the more gas you give it the more it stumbles but when you get around the block it acts fine.


It's like faulty air flow meter, first start engine is the engine running rough disconnect electric socket from air flow meter is the engine running better than before replace air flow meter. if not need to be diagnose to find the fault code is this ... 1998 Mercedes-Benz C-Class

My '99 Dodge surges when I go out to start it. I usually have to cycle the key at least three times before I try to crank the motor before it will start at all. It does this every time, however, sometime it takes more attempts than others. It has taken me up to 5 minutes to get it started before. It always starts eventually, and when it does, it runs great. No problems with power at all. When it's surging, the pedal is completely dead. It will not move or do anything other than surge. After a fe


... 2000 Dodge Ram 3500

The engine was running and then it suddenly stopped loosing all the power. I have the same problem with a Toyota Yaris. I have cleaned the MAF sensor a couple of times which SEEMS to help for a short time, although I am not quite sure as it has been happening intermittently for over a year now. It seems to happen more when going slowly but, again, that might only be coincidental. Would appreciate if anyone could give a definite solution as I don't wish to pay out over £200.00 only to find out I


In order to know what is causing this problem you need to test the maf sensor voltage, and if your car is that new only the dealer should be handing the 2009, they are the only ones who will have information on that new of car. Maf sensor ... 2009 Toyota Yaris

Dead Battery I have a 2000 Deville with 82k. the battery keep going dead about every 2 weeks after re-charging. i have had the battery tested 3 times and its still good the next step would be the alternator. but after reading prior Posts i am a bit hesitant to do so. Can anyone suggest anything please.


Sure..you need to get a volt/amp tester to verify alternator strength. If that is OK then each one of your circuits has to be checked for too much electrical draw. It sounds like that is your problem because as you run the car the alternator takes ca ... 2000 Cadillac DeVille

WANT CRANK IT STARTED LOSING POWER GOING UP SMALL INCLINES. WHEN I WOULD STOP AT A LIGHT IT WOULD GO DEAD. GOT IN IT ONE MORNING AND IT WOULD NOT CRANK. IT WILL TURN OVER BUT WILL NOT CRANK. HELP! CAN ANYONE GIVE ME SOME POSSIBLE SOLUTIONS?


Also it could be the mass air flow sensor in back of the air filter i had the ame promble and thats what it was there like 200 ... 2001 Ford Escort ZX2

1996 chevy blazer 4.3 keeps going into 3rd gear limp mode and throwing just about every code imaginable!!! have noticed there is a dead 12g wire that goes into the computer that has no power going thru it.....any suggestions? 2-3 shift solenoids have been replaced.


Sounds like an Ignition switch to me. If the trans doesn't get power to it, it will go into 3rd gear no matter what you do. ... 1996 Chevrolet Blazer

2006 Chevy Colorado doesn't start all of the time. have to wait about 15 minutes and then it will usually start up like there was nothing wrong. When I try to start it right away, it either: Turns over, but doesn't start. or It does a clicking noise like the battery is dead. Or it will act like it isn't going to turn over, do a voltage interruption (clock resets), tries to restart on its own and then starts up. Sometimes it starts up strong the first time for a month straight and then gives me p


Did the solution #1 help at all?or did you ever solve the problem? ... Chevrolet Colorado
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.4039 seconds