Having problems with your Kia Cars & Trucks ?

2008 kia rio hard to start after fill up then works just fine untill next fill up

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for Kia Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

2008 kia rio hard to start after fill up then works just fine untill next fill up


... Kia Cars & Trucks

2000 s10 2wd, abs works fine untill you accelrate hard then light comes on and engine reves high untill you shot car off and back on then it works normal untill you accelrate hard agian . this is werd dont know what to do


Check with computer db2 monitor sounds like idle control sensor or mass air flow sensor. ... 2000 Chevrolet S-10

1999 Town Car Running Lights Not Working... I have a hard wired a flat-4 trailer light receptical that I use occasionally. It has worked fine for me for the past several years. A few days ago I connected to a trailer that was mis-wired and later discovered that the cars running lights (front, rear, side marker and License plate lights) no longer work. I figured I blew a fuse, but I checked and they are all fine. My next thought was I had fried the Lighting Control Module (LCM). I bought a used L


Hello! Since fuses did not blow I would suspect that when you plugged in the trailer excessive current flow may have damaged the LCM...However to install another at random with the same fault is rare...Check fuse #31 just to be sure...Drop the LCM ba ... 1995 Lincoln Town Car

I WAS WORKING ON GRAND AM GT 3.4L GT. I REPLACE THE HEAD GASKETS AND REPAIR 2 CYLINDER ROCKER ARM TORQUE EVERYTHING AND REINSTALL ALL THE PARTS. I RUN THE ENGINE FILL THE COOLANT AND BLEED IT WORKS VERY FINE FOR 2 HOURS. SECOND DAY I RUN THE ENGINE RUNS VERY FINE NO SHAKE NO NOICE I JUST FIND VERY SMALL LEAK FROM THE FUEL PRESSURE REGULATOR AND WRITE ON MY NEXT ORDER LIST THEN VEHICLE JUST STOPED. NOW I HAVE CRANKING SOUND LIKE ENGINE WANNA START BUT NOT RUNING. WHAT COULD BE.? THANKS


The manual is very specific about instillation of the presure regulator. All of the o rings need to be replaced, and the pressure regulator mounting screw should be the very last thing you tighten or else leaks will develop. Also coat the o rings wi ... 2000 Pontiac Grand Am GT

On 1991 stealth r/t 5 speed manual , yesterday shifted fine, have had issue with 2nd gear, ( a little hard to hit sometimes ) , But other than that shifted smoothly. Today all gears very hard to shift to, and once in gear works fine. Clutch seems good too. Have no background on car as to when fluid was changed,in either trans or clutch master.three things to ask. One where are fill and drain on trans. two, what type fluid goes in clutch master? and three. what would cause this ? possibly slave


Ok starting where you did... on the side of the transmission itself there will be a 1/2 inch socketed plug that can be undone to add gear oil there will be another on the bottom that can be used to drain the oil. for clutch master, standard brake flu ... 1991 Dodge Stealth

Intermittent problem with starting the vehicle. Sometimes it will start and run fine, no problem at all. Then the next time , it will not start. The starter turns the engine and all electrical guages seem to be working fine, the radio and lights all work correctly. At first I suspected a fuel problem, but you can smell fuel as though the engine is flooding. Now I am suspecting an electrical issue. The engine will "try" to start but then will misfire and lug untill it dies, then will not fire at


When this happens see if you are getting spark to the cylinders. You can pull out the high tension wires at the end where it goes to the plugs, pot it over the engine block and see if you are getting spark. Do this for each of the cylinders. You s ... Nissan Titan

03 dodge Caravan while driving home speedometer went haywire. It would go from 0-120 then it would down shift hard. I think the speed sensor is out. I drove it home and parked it and went back to work. Now i can't get it to start at all. I pulled the altanator it is fine Battery is fine fuses and relays are fine. I'm not sure what to do. Please help my wife is driving my Truck and i'm having to drive Motorcycle. It's December and it's to cold for a motorcycle. HELP!!!


Check body control module - or theft detereant module ... Dodge Caravan

Speaker issue on my 1998 Chevy S-10 I put in a new stereo in my truck yesterday, I was having a hard time with finding the wires even though I had a diagram. Come to find out, One of the power wires was actually Green?? I don't know, But when I try to hook up my Left Rear Speaker, It works fine untill I turn on my truck and then none of the speakers work. Also, The Left rear setup is Brown is + and Yellow is -. When I hooked up the yellow, the speaker turned on without the brown even b


Unhook all wires and clarify you have the proper diagram and wory bout the wires is says to wire togethe , often you will have extra wires. ... Chevrolet S 10

Shifting problem My 2003 Pilot has a hard time shifting when first started - sometimes. Last week I left work and fired up the engine, only to find I couldn't shift out of park. After about an hour of frustration and much hair-pulling, I had to walk home. Next day I hawked a ride to work, and tried starting my car again. It fired up right away, and shifted fine. Anybody have any ideas??


One solution could be the break/safety solenoid. Make sure that the break/safety solenoid is clicking. If it isn't clicking, the AT gear shift is not going to move. If the break/safety solenoid isn't working you can get around it by releasing the A ... 2003 Honda Pilot

Started running hot one day, and filled coolant. Couple of days later it ran hot and I decided to change the thermostat. Worked fine until later the next day. Coolant started coming out of the coolant resovoir after getting off the highway. If its a blockage, would it not run hot all the time?? Water pump seems fine. Only leakeage is from the resovoir.


Check your oil and see if it looks like chocolate milk. If the engine is completely cool (like it's been sitting overnight), unthread your oil drainplug a little until fluid starts to come out. You might have coolant in it. If you don't have coola ... 1998 Ford Taurus

My 2008 KIA RIO has problems after sitting overnight or all day at work. It kills when you put it in reversei roll forward and back to get it going then the rpms runs really high. By the time I get to work or home it runs fine. they told me it was the battery I find that hard to belive. need advice!


Well you're right it is not a battery problem, get diagnostics done on the proper computer as this sounds like one of the sensors is faulty or at least dirty. ... 2008 Kia Rio

Very hard to steer, had the power steering pump replaced, worked fine the night it was replaced, on my way to work the next morning, it started having problems steering again. Please help!


Check the fluid level and add if it's low on fluid, look for visible leaks that will need to be addressed. The only other thing to that may have gone bad is the power steering rack and will need to be replaced. Good luck and keep me posted, be glad t ... 1999 Oldsmobile Alero

When I stop to fill up on gas and I go to restart my 2006 Suburban it is hard to get it to crank. Once it cranks it runs fine until the next fill up. The check engine light came on and I had my friend to check the code. It showed PO460. What the heck is going on. I am affraid one day it will not start back at all.


( P0460 ) - Fuel level sensor circuit malfunctionNot sure it has anything to do with the starting though, sounds like 2 faults you have there. Is the battery good? is it cold lately where you are?RegardsDan ... Chevrolet Suburban 1500

Speaker issue on my 1998 Chevy S-10 I put in a new stereo in my truck yesterday, I was having a hard time with finding the wires even though I had a diagram. Come to find out, One of the power wires was actually Green?? I don't know, But when I try to hook up my Left Rear Speaker, It works fine untill I turn on my truck and then none of the speakers work. Also, The Left rear setup is Brown is + and Yellow is -. When I hooked up the yellow, the speaker turned on without the brown even being ho


Logiczero21,\015\012\015\012It sounds like two speaker wires are hooked up to two speakers at the same time, which cancel them out - \015\012\015\012Disconnect all the speaker from where they are mounted and take note (write d ... 1998 Chevrolet S-10 Pickup

I have a 2006 suburban with 215,000 miles on it. When I go and fill up with gas it will not hardly crank back. When it does there is a little miss. Once it clears up it cranks and runs fine until the next fill up. The code says PO460. Can you help


... 2006 Chevrolet Suburban

2008 chevy cobalt remote starter wont work on first start of the morning after using key it works fine untill the next morning


... 2005 Chevrolet Cobalt

When turning steering wheel to left very hard to turn untill car starts to move, when turn to right works fine


Sounds like the begining of a bad rack n pinion. We can eliminate the pump because the car turns to the right fine. There is no loss of fluid? The only thing left is the rack. It is a fairly commin issue. Use to call it morning sickness, The cars wou ... 2000 Pontiac Grand Prix

I have a 1996 ford e350 and the speedometer and over drive quit working along with abs and it wont hardly shift it was fine one day then quit the next


These problems usually stems from a faulty speed sensor located on the rear differential unit. Not very difficult to replace. All of the components you mentioned get their signals from the speed sensor. Some vehicles have it on the transmission ho ... 2007 Ford E-350 Super Duty Length XLT

The left rear brake caliper on my 1998 Lincoln Mark VIII doesn't get as much pressure as the other 3 wheels which makes the car pull to the right when you put on the brakes.I have replaced the rotors, pads, calipers and hoses on all 4 wheels but still have the problem. Is there a pressure equalizer valve & if so where is it. This problem started suddenly. Brakes worked fine one day and started pulling right the next. If I hit the brakes hard it doesn't do it as bad as when I brake lightly. I di


... Lincoln Mark VIII

My speedometer reads 0 untill about 45mph then reads 65 no matter how fast I am going. I was told it is probably the speedometer itself since the odometer works fine. What do you think?


Maybe could also be the speed sensor on the transmission. ... 1993 Toyota Corolla

Coolant wiring I just replaced the coolant sensor on my 98 pontiac sunfire. The temperature gage still doesn't work so we retested the code to make sure that it said the coolant sensor and it did. So we took out the sensor and had it checked and it is fine. I'm wondering where I can get wire for coolant sensor and how hard it is to install in the car as we figure it's a a short in the wire. Our next step is to take it to the dealer if we can't fix it with replacing the wire. Thanks


Ensure you are checking the right sensor.\015\012The coolant level sensor is usually located in the coolant resevoir. It generally performs a hi/lo monitor switch function.\015\012The coolant temperature sensor is usually located on the m ... 1998 Pontiac Sunfire

Got a p0300 code on a 2000 Buick Regal GS. Put new plugs, new wires, and swapped coil packs and the check engine light still flashes at above 70 MPH. Runs fine so i am wondering what to do next. I also dumped injector cleaner in the gas tank last time i filled up and didnt work.


... 2006 Toyota Sienna

Starting problem hi there. I have problem, my maxima QX 3.0 automatic was starting very hard, i've had to crank it good few times for a long time before it started but one day my wife came back from work, shut it down and the next day it didn't start at all, you could crank it and crank it for ages.I've had a same problem few months ago and in a nissan service they changed starter and catalic converters and it was fine for month before i've got that starting problem again. to the point.


Try the idle air control valve it is located near the throttle body it has a four wire plug and has two small hoses attached to it this is a small stepper motor that controls the amount of air on start up this part will cost about $200 from a popular ... 2000 Nissan Maxima

We have a 2003 Chevy S10 Pick-up. The heater was not working properly so we checked and the antifreeze was extremely low. Filled it back up and drove the truck for a while and everything seemed to be fine. The truck would not start this morning, it tries very hard to start but doesn't, could it possibly be the fuel pump and how would we check to see if it is?


Could have a leak in your radiator if your antifreeze was extremely low ... 1998 Chevrolet S-10 Pickup

Hey there can any one help me to solve this problem please. Mazda familiar interplay 1989 has got a manual conversation but while i try to bleed the brakes,its fine as in the brakes are hard it fills normal while pumping and holding, but as soon as i turn the car on and go for a ride the brake paddle goes right in and the brakes don't work properly as while i was bleeding them...


It sounds like your master cylinder is in need of replacement or rebuild. Unless you have an air bubble in the line somewhere (bleeding should have fixed that), you have a worn master cylinder that is cracked weak. There are various rebuild kits on ... 1989 Mazda 626
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.1459 seconds