Having problems with your Kia Avella ?

KIA AVELLA does not start with good battery,and gas.cannot crank engine

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for Kia Avella

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

KIA AVELLA does not start with good battery,and gas.cannot crank engine


... Kia Avella

I have a 1997chevy astro van with 4.3 engine my problem now is after i repl ignition coil wich was good advice from tech i drove van for about 4 hours then i park inside the garage when to restar engine no luck crank but no start good spak good fuel pressure but do not start remove air cleaner put some gasoline inside maf sensor engine start right away repite same after two ours with out gasoline no luck engine wont start only crank try again with gasoline run ok drve for two hours park van tr


Well since you say you have good spark and good fuel pressure, and since the car is running (at random times) the compression is most likely good. I would recommend replacing the crankshaft position sensor and camshaft position sensor. These have a d ... Chevrolet Astro

Kia Avella can crank engine but failed to start


... Kia Avella

1990 mazda b2200 pickup after 15 to 30 min of running the engine quits then in about 10 to 15 min it runs fine. I crank the engine but it just cranks and cranks I checked to see if it had spark. I checked at the coil wire then plug 1 spark was good I removed the gas line to the fuel injection system and pumped gas into a bottle and it pumped as the engine cranked put the hose back on still would not start then I wait 10-15 min starts right up runs very smooth and has a lot of power new plugs new


... 1988 Mazda B2200

I have a 2000 jeep wrangler 4.0 engine it ran good for 16 miles then would quit no check engine light on so i scanned it anyway came up with a p 1391 mis fire so i changed can sensor ran good about 30 minutes and died scanned again same 1391 i returned cam sensor and got a new coil pack and crank sensor i installed coil pack ran good about 30 minutes and died so i installed crank sensor and put back on old coil pack ran good 45 minutes then actually started missing and check engine light on it s


It does sound like the ecu is bad the only other thing it could be is the antitheft system is having problems ... 2001 Jeep Grand Cherokee

I put a timing belt on my 2004 kia spectra and change the crank and cam senors. i check all my codes and they were clears. why does my engine vibrate. it start up good.


Check timing again a plug still off or a vacum line maybe cracked or the engine might be damaged if it jumped at high rev ... 2004 Kia Spectra

Have an 85 chevy 4x4. I just had the 305 engine rebuilt with a new intake and carb. It was working fine for a couple days and one morning I went to start er up and the engine just cranked and cranked, wouldnt turn over. So I left it there for a day, went back the next day and tried it,and it started right up. Worked good for a a day, then the next day I went to start it up and same thing, it just cranked but wouldnt fire up.....so I left it there for the majority of the day, went back, and tried


Sounds like the electronic ignition. (the thing that replaced points in the early 70's) ... 1983 GMC K2500

Somedays my car will start ok, and often, there is not even a cranking sound from the engine. The dash lights are on, but only a soft clicking sound is heard. The battery starter, and alternator checks out ok. I replaced the fuel filter, and spark plugs. It is a stick shift. when it runs, it runs very good. The intermittent starting seems to be a mystery to me. Also it seems like when the engine is starting to crank, forcing the key forward seems to keep it cranking continuously as if there is a


A common problem is the ignition switch.When it does not start....with the car in park or neutral jump it at the starter....or check for power at the small wire at the starter while trying to crank the engine.Power in the small wire ... Honda Prelude

1995 Jeep Grand cherokee limited V8, Won't start. engine cranks just fine, good battery. 12+volts to the coil. Doesn't seem to have any pressure in fuel rail after cranking. Picked up jeep yesterday AM and drove it from Chicago to Ohio without any problems. Started cleaning engine with a rag ( no fluids or water). Tried and it wouldn't start. I've looked all over the engine to see if I knocked loose a connection somewhere. I couldn't find anything disconnected. Auto shut down relay wa


Hi, this could be you have not reset the ALARM, when you toke the battery off. please undo the NAGATIVE lead OFF the BATTERY and hold the battery lead ON (for 2 seconds) then take battery lead OFF. you will hear the ALARM make a funny noise (this res ... 1995 Jeep Grand Cherokee

My neighbor has a 2007 Trailblazer SS. It will crank but no start. Checked fuel pressure good at 58 no bleed down.Replaced ignition box, same problem. Hooked it up to a Snap-on scanner tested check engine light, it will turn on and off we can also activate relays with it so we think the PCM is good. With the scanner hooked up we cycle the ignition and we get an RPM reading upon cranking but no start so we think the crank sensor is good because of RPM reading.Have not checked the cam sensor yet


I have the same exact issue. Did you ever fix? If so, what was it? ... 2007 Chevrolet TrailBlazer SS

I have a 2002 Nissan Altima 2.5S, 4 cyl. with mannual transmission. It never gave me any problem before.rn On Dec. 30, 2010, I tried to start but won't start. The engine cranks but but not start. Battery is new (10/10) and fuel pump is good. A freelance mechanic who admits he's not good on foreign cars did a spark test and there was no spark. He says 95% is the Crankshaft sensor. So I have replaced the crank sensor and the camshaft sensor and still no spark and won't start. Finally I borrowed


... 2002 Nissan Altima

I have a 2003 super duty 550 with a 6 litre diesel The engine runs great but will not start after it has been shut down and try to start 15 min later The engine cranks good but will not start.Let it sit any amount of time it will start and sometimes it cranks and dont start.Adventualy it will start and run fine.


How many miles and has it been maintained. Is this only in colder months or even on hot summer days? Start with the oil (the injectors fire off of high oil pressure from the HPOP) is it low/clean? I would want to rule out glow plugs/glow plug relay ... 2005 Ford F 350 Super Duty

1989 Mazda MPV V6 RWD: Intermittent starting problem. Battery checks out good, and just replaced starter/solenoid. connections are good at both the battery and the starter. Solenoid clicks but engine does not turn over. after several tries the engine cranks and starts. sometimes will start several times in a row and then the problem occurs for a while. What am I missing?


More than likely the starter solenoid has burnt contacts in it, this is a common problem with all Denso designed starter motors used in almost all Japanese cars and light trucks. You can either try and find a solenoid or just replace the starter. The ... 1989 Mazda MPV

Engine cranks but wont start good fuel pressure changed spider but still doesnt seem to get fuel will start with starting fluid good spark also driving me crazy 5.7 vortec engine


I know this may sound crazy, but I had the same problem on mine.. But check your fuses.. I believe it's ECM 2 .. that fuse also runs the fuel pump...I really dont know how its tied into it, but it is .. Good Luck.. ... Chevrolet 1500

2001 gmc safari, cranks but no start. Fuel pressure good, has spark, no codes, no engine light. Vehicle was running fine then shutdown. Will not run on starting fluid. Tried PCM from sister vehicle, still will not start even with security code programmed. Has TPS signal. Battery voltage good. All fuses ok. Fuel pump relay ok. Has voltage to crank sensor. Need help!!!!!!!!!!!!!!!!!!!!!!


... 2001 GMC Safari

2003 tahoe sounded like it was going to start but would die out. At one point I jump started it. Then it wouldn't jump start. The next mornning Tahoe just turned on. Then when I turned it off, wouldn't turn back on again. 66Charger tried to help me. Battery is good, all connections are good, no clicking at the relay, replaced the starter, still will not turn on. Engine cranks, no security light flashing. Now engine doesn't seem to be getting fuel because no sputtering anymore, just eee,eee, eee,


Sounds like the fuel pumpis out on it now ... Chevrolet Tahoe

2001 gmc safari, cranks but no start. Fuel pressure good, has spark, no codes, no engine light. Vehicle was running fine then shutdown. Will not run on starting fluid. Tried PCM from sister vehicle, still will not start even with security code programmed. Has TPS signal. Battery voltage good. All fuses ok. Fuel pump relay ok. Has voltage to crank sensor. Need help!!!!!!!!!!!!!!!!!!!!!!


... 2001 GMC Safari

1992 MZDA-6cyl MPV body type SV No engine start-up not even turnning of engine starter. New battery installed, circuitbrkr good at first turnning of key sounds and alerts all good, just no cranking to start engine Thank you in advance, for your help and effort


... Mazda MPV

I have a kia optima 2006 2.4 ex 4 cilnders, when I start the engine it runs good but after 10 minutes the engine stops, it again to start the engine start, if the car is running the engine shuts down


You will need to replace the crankshaf sensor ... 2006 Kia Optima

Hm.. How to describe it.. i totally rebuilt the bottom of my engine. So the crank bearings. Oil pump. Etc.. And now with the engine in everythings good its all timed good and fuel pump seems to be getting to the fuel injectors and it seems to want to start but is right at that point where it won't. What should i try to get it to start?


It sounds as if you ave done alot; aswell spent quite some time!! Not to sugest you you have not done but. check the distributor to spark plug connections. If you are not sure as to wha it should be, find the same vehicle that does run and write the ... Cars & Trucks

1996 Cherokee Sport 4.0 liter Six Quit running while traveling approximateley 40 mph. Engine cranks but will not start. Good fuel pressure, no spark from the coil cam senser (Coil Pickup), crank sensor, and Coil replaced. All fuses checked. ASD Relay checked. Two used PCM's exchenged in place of the existing but the engine will still not start. What else could be the cause?


... 1995 Jeep Grand Cherokee

I have a 2002 VW Passat 3.0 litre 4 Motion Wagon runs great but sometimes after driving when the engine is warm and shut it off for a while it will not start just cranks and cranks. If you let it sit for a while 1/2 hour to around an hour it starts great and runs good no check engine light comes on. I have had the fuel pump replaced and same issue remains. Any ideas? thanks Chuck


... Volkswagen Passat

I have an 89 Chevy 2500 P/U with a 5.7, that will not start. The engine cranks at a good speed, it has spark at the right time according to the timing light on #1 spark plug, with a fuel psi addapter istalled in place of the fuel filter I have 10 psi/9psi while cranking and fuel spraying from the fuel injectors in the throttle body. Compression test shows between 135 to 145 psi and the engine will not start. Do you have some suggestions for me? Thanks, Arnold


Does it even try? Spit and sputter? Start and die? Or does it not even fire? Fuel pressure is a little low but it should start with 9 psi. ... 1989 Chevrolet C1500

Wont start I have a 1996 Dodge Grandcaravan with 3.3 V6. Engine cranks over but wont start. I checked fuel supply checked good. Removed fwd three spark plugs cranked engine. No spark.


You could have a bad coil. You might want to check your plug wiresIf they look a little old the could be bad. Also check you distributer. Goodluck and PEACE ... 1996 Dodge Grand Caravan

89 wrangler 2.5 5 speed.replaced crank sensor last year along with engine rebuild. Jeep runs than shuts off engine cranks but won't start. let set 4 or 5 min. starts right up runs good a mile or so shuts off again. any sugestions?


It sounds like your new crank sensor is defective. It should be under warranty. ... 1989 Jeep Wrangler
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.8343 seconds