Having problems with your GMC Sonoma ?

I have a 1997 gmc sonoma, 2.2L, manual trans. When I try to start it, it usually cranks and locks up like timing is off. It backfires sometimes. Then if it starts, it misses and backfires sometimes. Then it will straighten out and run great. Other times it start great and runs great. Usually backfires when weather is wet, rainy.

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

I would guess fuel pump or filter, Tim
Repair Help & Product Troubleshooting for GMC Sonoma

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 1997 gmc sonoma, 2.2L, manual trans. When I try to start it, it usually cranks and locks up like timing is off. It backfires sometimes. Then if it starts, it misses and backfires sometimes. Then it will straighten out and run great. Other times it start great and runs great. Usually backfires when weather is wet, rainy.


I would guess fuel pump or filter, Tim ... GMC Sonoma

87 Buick century 3.8l I replaced almost everything under the Hood plus fuel pump.filter runs great. Then starts missing like its running out of gas. But keep pumping the gas and it starts backfiring sometimes it dies then it clears up and runs great again


Unplug the mass air flow sensor and see if it runs steady will not run good but steady ... Cars & Trucks

Sputtering-missing-vibrating-knocking-backfire-bucking Sometimes my 2.3L runs great. Then for no apparent reason it will start vibrating and bucking, along with a huge loss of power, even backfiring. I have to mash the gas to maintain 45mph. Its almost like one of the coil packs stops working. I can smell fuel while this is happening. At idle it will still sputter and vibrate and want to die. Plugs/wires are new (thought it might have been a shorted wire) Sometimes it will buck a few times then


I'm having the same problem with my 90 2.3L Ranger. I replaced the EGR Valve back in August and the truck ran fine (but the gas mileage was bad) until late December . I knew it needed an O2 Sensor back in August but didn't replace it until last Satur ... 1993 Ford Ranger SuperCab

87 4Runner, 22re, 4x4 SR5 issue; I'll try to be as clear as possible....... 1 Month ago, running great cold till warm up, then Crappy from there on out(hesitation, backfiring, etc.)....Replaced O2 Sensor, ...now, Runs like **** Cold, great Warm(No big missing, backfires, blue smoke, white smoke, etc....VERY smooth). Now, when starting cold, I sometimes get a pretty loud ''POP!'' from what seems to be the MAF area(or somewhere in the intake or combustion chambers). Today it even stalled and con


... 1987 Toyota 4Runner

I have a 1994 W900L with a red top N14. It has miss wether it warmed up or just starting out. It usually corrects itself if I let off the throttle &step on it again. Sometimes it takes 2-3 times to correct. Then it runs great. 6-7MPG. NO hard starting issues or smoking at start up.


... Cars & Trucks

2001 ford f250 v-10 sometimes wont start turns over fine but nothing I usually mess with the air filter then try it and then switcth out the relay switches and try it usually after 20-30 min it will start like nothings wrong it has happened 4 or 5 times in the last month. Sometimes it starts right up and when it runs it runs great


It sounds like a problem with the tumbler, my sierra has done this before, next tim it does this dont try the fuses, just turn the key to the off position and give er a whack on the underdied of the column right under the key area. some trucke for wh ... 2002 Ford F250 Super Duty SuperCab

2002 ford escape 3.0 v-6 32 valve washed engine at car wash, didnot start -backfired, misses - waited for an hour to start , starts now, but runs poorly- in park throttles great- no misses- checked plugs, no water found -replaced plugs and all gaskets - checked all vacuums- what gives - all computer shows good to go ?


Pull every single engine wiring harness connector apart and blow it out with compressed air, u have water in a connector shell, i am 100% sure of that, also pull the bulk head/firewall connector off and check it for water. ... Ford Escape

My 95 s-10 has a4.3 engine most of the time it runs great ,but sometimes when i start itup it wont idle ,if you hold p[edal down eventually it will take off then runs fine. then sometimes you will be driving down road and it starts missing real bad, normally if you hold it to floor it will straighten right back out..it never puts out any black smoke and check engine light does not come on


Sounds like spark plugs and or wires a easy and affordable fix.. ... 1995 Chevrolet S-10 CA Edition

I have bought a 1995 jeep wrangler with the 4.0 6 cyl engine.It will run great at times, but then go into a mode that the engine will start surging, wanting to stall, then finally stops. sometimes it will start right back up but surges bad.smells like it is running rich when it is doing this, it will backfire thru the exhaust when trying to accelerate.It then will come out of this and run great like there is no problem. previous owner has replaced just about every sensor and ignition. I have had


Hello! The fault is caused by one of two sensors...Since previous owner changed sensors, do you know if the Throttle Positioning Sensor (TPS) or the Manifold Absolute Pressures sensor (MAP) was changed?The MAP sensor is controlled in part ... Jeep Wrangler

Car shuts off periodically, usually starts back up,sometimes have to wait several minutes. sometimes car runs great for several days. the car lately shut off 4 times in a 20 mile drive , started back up except for last time, had to let it sit for a while. the car also does this when it is cold . i have replaced fuel filter and crank sensor im debating on a distributor change. whats your input. JON, 98 sentra


Since you've handled the usual suspects, I'd suspect the coil and/or power transistor in the distributor. ... 1998 Nissan Sentra

I have a 2002 Chevy Impala, it starts great in the morning when the engine is cold, but once the engine warms up it is very difficult to start. It cranks alot and even backfires sometimes. Also I noticed that the car seems to Idle at a lower RPM then before and sometimes will stall in traffic when idling. Any ideas? Thanks


Engine is difficult to start when cold \015\012\015\012 \015\012\015\012Check the battery condition, battery state of \015\012charge and starter motor current draw. Replace the battery if marginal\015\ ... 2002 Chevrolet Impala

My 1990 lesabre starts easy and runs a short distance and shuts off, usually while driving, the engine starts immediately and will continue on sometimes quiting sometimes running great any ideas, im thinking fuel pump


Check the ECM for this number on it. 1228253 these ecms are junk. These would do that cutting off and restarting. They also made the car speed up to about 30mph without pressing the gas pedal. Replace with 16198264 or newest number. My car did the sa ... 1990 Buick LeSabre

I have a 96 Mercury Grand Marquis. The car lurches while driving feeling like it will conk out. Usually when going uphill on the highway and trying to accelerate or maintain speed. This does not happen all the time and usually starts after drving about 30 minutes, but sometimes it happens after drving just few minutes.Then it will do it when slowing down or stopping and trying to accelerate. We just had the right catalytic converter replaced. It ran great for 1 day then started doing it again.


I have a 96 Grand Marquis with a similar problem. Also on the highway it would just conk out on me suddenly, almost felt like I was hitting the brakes, then it would pick up again. Eventually got to the point where it was stalling out on the highway ... 1996 Mercury Grand Marquis

My '99 Dodge surges when I go out to start it. I usually have to cycle the key at least three times before I try to crank the motor before it will start at all. It does this every time, however, sometime it takes more attempts than others. It has taken me up to 5 minutes to get it started before. It always starts eventually, and when it does, it runs great. No problems with power at all. When it's surging, the pedal is completely dead. It will not move or do anything other than surge. After a fe


... 2000 Dodge Ram 3500

When my 2003 Alero gets wet (rain) it will not start....nothing happens. Usually, we are able to start it after @ 30 mins., but yesterday and today...nothing. It all started when my battery died in the alarm system/auto door opener on a rainy night. The car wouldn't start, but the radio and lights were on....any ideas?


... 2003 Oldsmobile Alero

I have an 87 park avenue that has intermittent starting problems... my mechanics have replaced many sensors, a coil, and wires and plugs...it runs great when it runs yet periodically refuses to start. usually if i continue to try to start it will sometimes start after 30-40 minutes trying. again it runs fine at that point. kookie, huh? my mechanics have all but given up on it and they are awesome mechanics! any ideas? by the way it's a v-6... the car IS AN 87.....THE PRODUCT CATEGORY ONLY GOES T


It sounds like a faulty ignition module. ... 1989 Buick Park Avenue

95 pontiac grand am quad 4 changed coil housing and plugs 2 months ago. My car started missing a little about 2 weeks after checked plugs an 1 was cracked so I replaced all 4 again. But now my car wants to start hard at times an it sometimes makes a pop sound. But it runs great after it starts. It doesn't do it all the time


... 1995 Pontiac Grand Am

My 98 Jeep Cherokee Sport runs great. But sometimes, for no reason at all, when I try to start it it does nothing. No click, no noise, etc. After a few minutes of pressing the gas pedal, brake pedal, and pulling the gear shift back and forth, it usually starts up and runs fine. I don't know if that has anything to do with it or not, I just try anything. It did it again today but it didn't start back up for about 1/2 hour. I don't want to get stranded! Any ideas??


I also own a 98 xj im pretty sure your problem is your neutrul safety switch on the right side of yuor tranny.when you shift it back and fourth a couple times it will cause the terminals to make contact and allow the jeep to start.mine also does this ... 1998 Jeep Cherokee

1966 Mustang. Driving in 90-100 degree heat. Starts great when engine is cold, but when it gets hot, car will die instantly (no warning, just shuts off). Usually starts right back up, but sometimes struggles. In addition, after engine is hot and car sits a few minutes, it struggles to re-start. Mechanics have said I do not have an ignition problem. I've researched ''vapor lock'' and heat-related problems concerning fuel and am leaning towards that. Fuel is visually bubbing in the glass filter. L


It is running too rich, when the engine is cold it can handle the extra gas, but when hot it cannot, re-tune the carb. ... 1966 Ford Mustang

I have a 1992 Ford F250 with a 5.0 and E4OD Automatic trans. And I have a problem with it starting and idling smoothly. Usually once I cold start it, the motor would fire straight up and rev between 1500 and 2000 rpms. Now it will try to start and sometimes stall or just jump some the kick up to about 1000. Also, when the motor is warm and you restart it, it will miss for alittle bit then smooth out some. Now I posted once before on here and I was told to change the fuel filter, and I did. It ru


Old codes only confuse mechanics they have no effect on running.personally i would clean the throttle body out real good with a tooth brush and some carb cleaner. there may be a sticker on it that says dont clean it but do it anyway ive been cleaning ... 1992 Ford F250

Sometimes my car sputters and stalls, and after it stalls it doens't start very well. It's usually when I start or after I've been idoling at an intersection. (It doesn't happen all the time-and otherwise starts great, but this happens often enough to be a problem! -it happens frequently after it rains pretty hard- and then it'll be fine for a while.) Any ideas?


... 1990 Toyota Tercel

1998 buick lesabre code p1665 wont start sometimes misses and backfires


... 1998 Buick LeSabre

My 97 dodge pickup 318 engine will miss sometimes and some times it will run just fine. it will do this while driving and just idling. Pretty much the same issue but with a 95 5.9L. Usually will spit and sputter, surge then lag. It will do this a few times then run OK. This happens mostly about 5 miles after I start out. Seems to happen sooner if I let the engine warm up on a cold day. No Check Engine Light. Sometimes it will be fine for a few days. Truck has 114,000 miles.


First ... put a bottle or two of gas line antifreeze in the tank (it sucks up water in the fuel)... if that doesn't sort it out.... your coil pack may be dying ... 1995 Dodge Ram

I have a 1996 S10 pickup standard shift 4cyl. no codes pull up nothing in memory.truck runs great at times. but will start to miss. and sometimes will have a strong gas smell.i have taken truck to three different shops and the following items have been replaced,wires,plugs,fuel filter,coils, control module,map sensor,crank sensor,and fuel pump. i have over 1,000.00 already in this problem and am no better off then when i started. now they are talking fuel pressure regulator. please help am going


I hate to say spend more money but the fuel pressure regulator is what I would do next...but you dont have any codes at all?? ... 1996 Chevrolet S-10 Pickup

2001 530i turns over great but wont start, this problem comes and goes. Usually starts right up, but sometimes engine just cranks and cranks. Eventually after several minutes of engaging the starter on and off it fires right up like nothing happened


Check for ignition module ... 2001 BMW 5 Series
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.2317 seconds