Having problems with your Chevrolet Camaro ?

Where is the water temp sensor on a 89 camaro

\015 Where is the water tempature sensor on a 1989 chevy camaro rs with a v8 305 5.0 ltr\015 Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for Chevrolet Camaro

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Where is the water temp sensor on a 89 camaro


... Chevrolet Camaro

My 1996 camaro z28 - I replaced my temp sensor on the water pump - now the heat does not work and the car is overheating even more....


This issue is old but, since it is a common occurrence after opening the cooling system in one of these kinda' cars and loosing fluid. It's very important to manage the refill properly or engine damage of the serious kind it very likely.\015\0 ... 1996 Chevrolet Camaro

Detroit motor 60 series , FreightLiner problems with ECU 128 code on dash display... I can drive it fine but check engine light., engine protect light comes on still.. And turns truck off... I've changed the oil temp sensor, water temp sensor, and the water level sensor.. And still no solution.. Help please!!!!


... Cars & Trucks

97 transport 3.4 engine- New radiator, thermostat,temperature sensor, water pump and new low coolant level sensor. Temperature guage goes to 260 degrees but engine does not over heat. Bled air from cooling system, serpentine belt is on correctly. At idle, temp. goes up to red, When driving or accelerating, temp. goes to a steady 190.No water in oil, no oil in water, no smoke and no leaks or loss of coolant. Help me as I am baffled.


Are your cooling fans working? that will definately be a problem if not working. if they are working shut car off and feel the radiator is it the same temp all over or is it hot in only top or one smaller area. if you do not have same temp feeling ... 1997 Pontiac Trans Sport

97 transport 3.4 engine- New radiator, thermostat,temperature sensor, water pump and new low coolant level sensor. Temperature guage goes to 260 degrees but engine does not over heat. Bled air from cooling system, serpentine belt is on correctly. At idle, temp. goes up to red, When driving or accelerating, temp. goes to a steady 190.No water in oil, no oil in water, no smoke and no leaks or loss of coolant. Help me as I am baffled.


Check the operation of the cooling fans at the radiator. While idling disconnect the coolant temp sensor at the top left (drivers side) of the engine. It will be a 2 wire connector near the thermostat housing. When disconnected the coolant fans shoul ... 1997 Pontiac Trans Sport

Detroit motor 60 series , FreightLiner problems with ECU 128 code on dash display... I can drive it fine but check engine light., engine protect light comes on still.. And turns truck off... I've changed the oil temp sensor, water temp sensor, and the water level sensor.. And still no solution.. Help please!!!!


... Cars & Trucks

Detroit motor 60 series , FreightLiner problems with ECU 128 code on dash display... I can drive it fine but check engine light., engine protect light comes on still.. And turns truck off... I've changed the oil temp sensor, water temp sensor, and the water level sensor.. And still no solution.. Help please!!!!


... Cars & Trucks

1995 Pontiac TransAm w/5.7 l v-8. Overheats at slow speeds because the elec. fan does not start until the engine temp reaches 220 or more. Could I install a toggle switch w/ a diode in the coolant temp sensor circuit to bypass the sensor and manually turn on the fan at a lower temp. during low speed driving? Or is there a sensor available that would replace the current sensor in the water pump w/ a lower (185 deg.) to replace the existing sensor? I think the manual switch would work but a more


I think 220 is the proper temperature for the fan to turn. 220 is too hot and that's why it is turning on but should never have to ideally. What your car likely needs is new coolant and a new thermostat. I recommend a 185* thermostat. ... 1995 Pontiac Firebird

I have a 1998 1.8 16v Freelander when it gets to normal working temp, the water pushes back into the water bottle, then the fans goes on and then it is back to normal, if I disconnect the temp sensor plug the fans stay on, and then I havent got that problem. I fitted a new sensor.


We had a similar problem and fixed it by replacing the plastc overflow tank and cap. I think the old plastic tank system does not maintain cooling system pressure correctly. I replaced this about three months ago (myself for $100.00) and I have had ... 2002 Land Rover Freelander

Gauge temperature My car is bmw 318i m43, e46, european model Problem: when switch is on The gauge temp mark forward when the engine is cold, unpluged water temp sensor, water temp sender, lines wire tested is ok, but gauge temp still there no change possision, when switch is off the guage temp mark normal (cold) so i don't know wath is the real engines temp Thanks for help


... 1999 BMW 318 ti

Temp Sensor or Dash Gauge? Late 1996 K1500 Diesel Suburban. When the water pump went bad, the engine got to close to redline before I shut it down. Once parked, the temperature actually increased before cooling. The dash gauge temp needle pegged to the right and did not return once it cooled off. Does this mean the temp sensor is bad, or has the gauge run past its limit and gotten stuck? If the sensor is bad, where is it located and can it be easily detached and replace at the engine? If the gau


If the gauge stays put after you turn the key off it is the gauge. The temperature sensor should be on the drivers side of the engine block. It threads into the block somewhere near the number 5 and 7 spark plugs. It has a quick connect plug that ... GMC K1500

Hi. In a chrysler voyager 2.4 l from 2002 the temp gauge only reads the right temp, if the ignition key is on and the engine is not working,if i start the engine the water temp gauge starts to go down, even when the car is overheating because the radiator fan only work if turn the ac on,the water temp sensor near the t-stat the fan relay as well as the pcm are new,any idea of what can be the problem?


Hi! May I asked when did you purchase the PCM? Eventhough the PCM is new it is not free from failures. That's the downside on buying new PCM, sometimes it doesn't work right. I suggest that you have it replaced or resetted. ... 2002 Chrysler Voyager

Cooling fans on 1994 Caprice classic with 4.3 v8 not coming on. I have replaced the temp sensor on the water pump, temp sensor on the block, all relays, fuses are good, replaced the ecm (engine control computer). Gave up and took it to an mechanic, they sent to electrician who now says the even though the temp gauge is rising when the temp goes up it is not sending signal to computer to kick fans on. Does the gauge send the signal to the fans? Seems everyone else has been telling me the sens


On a vehicle this age, it is likely that the fans themselves have worn out. Test the fans by running battery power directly to the positive contact. If they start, they are OK. On 4.3 motors, there is also a seperate temp sensor to signal the fans ... 1994 Chevrolet Caprice Classic

Low heat output, blower works, new thermostat, temp running 195 at gage. new water temp sensor installed. Once in awhile get sensor bad messsage on the info display. If you turn the temp control quickly from cool to heat, you get short surge of heat then lukewarm. What is the operation of this unit. Is there a valve on the heater fluid circut and or a door to control the heat? Can you get at the works anyway, including cutting aux hole, to avoid removing the dash?


Small rad in heater unit possibly airlocked if you had the water drained recently one hose in one out normally inlet from top of engine ... 1996 Jeep Grand Cherokee

Engine temp normal but no pressure in radiator and no heat in heater core, changed thermostat, radiator cap, water temp. sensor on thermostate housing, and has vacuum pressure at valve cover hose


... Honda Civic

I was given a 1990 Legacy sedan. Obviously it needs work. It does start and run, but dies when the RPMs drop after revving. I analyzed the codes and it is telling me there are 8 errors! Crank angle sensor (no sig), cam angle sensor (no sig), water temp sensor (Abnormal signal emitted), air flow sensor (abnormal voltage input entered), O2 sensor (inoperable), speed sensor (abnormal voltage input), canister purge solenoid valve (inoperable) and airflow sensor (use of improper airflow sensor). Is i


... 1990 Subaru Legacy

I was given a 1990 Legacy sedan. Obviously it needs work. It does start and run but dies when the rpms drop after revving. I analyzed the codes and it is telling me there are 8 errors! Crank angle sensor (no sig) cam angle sensor (no sig) water temp sensor (abnormal signal emitted) air flow sensor (abnormal voltage input entered) O2 sensor (inoperable) speed sensor (abnormal voltage input) canister purge solenoid valve (inoperable) and airflow sensor (use of improper airflow sensor). Is it possi


... 1990 Subaru Legacy

Does ford 3.8 v 6 temp sensore thread into water jacket?


... Cars & Trucks

Here is my problem... 1998 Jeep Cherokee Sport 4.0 straight 6. Overheating. New thermostat,new water pump,hoses,sensor on the water outlet, no leaks. electric fan comes on with the a/c only does not come on when high temps are reached. Although it only heats up while at idle. Normal Operating temp is from 190-210. would greatly appreciate a reply


Sounds like you have done all but 2 things to treat this. Double check the wiring to any loose connections or breaks. If good replace the electric fan itself. Because of the nature of electric fans most are not engaged when the vehicle is moving bu ... 1998 Jeep Cherokee

MY TRUCK IS BOILING OVER I have changed the water pump, thermostat, and temp. sensor, but it is still boiling over at 100 degrees but it should not boil over until about 107 degrees (that's when the fans should cut in.) When I removed the temp. sensor plug, the fans cut in immediatily which indicates to me there is no circuit interuption. When I turn on the air cond. the fans also cuts in immediatily. If I crossover the fan relays the fans also start. Do anyone have any suggestions


Is your coolant at the correct ratio for your ambient temp??\015\012Check that out before going much further.\015\012Thanks ... 1996 GMC Sierra

1995 Dakota 2.5 cylinder. Runs up to the hot mark then comes down to about half. It continues to do this. Replaced the thermostat, coolant temp sensor and heat sensor for the temp gauge, has proper coolant levels, has been tuned up. Nothing works, heat dont work. Im thinking about flushing the system and replacing the water pump. Any suggestions?


I would flush the heater core out: open the hood and look on the \012firewall. There should be 2 rubber hoses going into the \012firewall and into the truck. If factory they will have spring clamps just\012 like on the radiator hose. Re ... 1995 Dodge Dakota

Heatng Problem! I replaced the timing belt of my car. I also replaced the water pump. Once done, I started the car and it runs perfect. The problem I made was to break the electric pin for the temp sensor. So I fitted a brand new sensor. Now I find my Kia heaing up. The temp guage is always at the 3/4 point. The guage drops at time but fluctuates in the 3/4 level. What could be my problem??


Check for proper thermostat operation and make sure coolant is topped of..Make sure ther is no air in cooling system... ... 2000 Kia Sportage

My 2005 land rover freeland over heats in egine the temp sensor read good in side but the the engine water bubles in the coolant botle and the thermostate hoses stay cool we change the thermostate but still the same water bubules in coolant bottle we check the temp on the engine with a heat gun it reads 150 but in ssid it reads good it feels like its over heating


Water bubbles in tank is normal. Rovers have a closed system, that onset an overflow bottle, it's a remote filler and you normally will see coolant circulating in tank. I'd be worried if I didn't see circulation. ... 2002 Land Rover Freelander

IS IT THE WATER TEMP SENSOR THAT CONNECTS TO THE TEMP GAUGE? WHERE IS THE SENSOR LOCATED ON A 2003 GMC SIERRA 4.8 LTR ENGINE?


On the intake manifold,toward the front. It's got 2 wires to it. That's the one for the cpu & the other has one wire & is usually in the driver's side head. That controls the temp guage. ... 2003 GMC Sierra

My 1985 toyota corolla gts with the 4age engine after 20 minutes of car running just park it stalls slowly and shutts off i have repair lots of parts like thermostat,water pump,fuel pump,fuel filter,spark plugs,wires,cap,rotor,ignition coil,temp sensor for dash gauge,temp coolant sensor,fuel presure regulator just now and still the same problem when it cools down it starts then goes back to falling on its face.Please, please help me'''''


It sounds like the ignition module is heating up,and failing,it is in the distributor,and might be cheaper to replace the distributor,used maybe,If the temp of the engine is getting a bit warmer than normal,then the exhaust is restricted. ... Toyota Corolla
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 1.3587 seconds