Having problems with your Cars & Trucks ?

My 2000 Chevy impala hesitates when accelerating on highway (at about 50mph) and rpm bounces...replaced converter and o2 sensors what could this be???

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My 2000 Chevy impala hesitates when accelerating on highway (at about 50mph) and rpm bounces...replaced converter and o2 sensors what could this be???


... Cars & Trucks

I have a 97 chevy tahoe it stumbles at low rpm and rarley at increased rpm it feels to come from the torque converter area. this problems worsens with rainy or very humid weather. also i just replaced plugs, wires, cap, rotor, fuel pump and filter. i am thinking this could be caused by a dirty or broken MAF sensor. What do you think?


... 1997 Chevrolet Tahoe

05 Chevy silverado 1500 has bad rotten egg smell and rough idle with hesitation ... Replaced plugs and wires.... Mass air flow sensor..... The guy at autozone said it sounds like catalytic converter.... Could it be o2 sensors....


Maybe it could but 10ta1 its the converter. ... Cars & Trucks

My 2000impala hesitates and rpm bounces when accelerating (at about 50mph) replaced converter and o2 ...what could this be??


... 2000 Chevrolet Impala

When I first start my car in the morning, my '04 Impala, 3.8, revs at 1500 to 2000 rpm's and continues at that high idle for the first 8 miles or so. Then, it drops to 600 to 800 rpm--normal level--and runs fine for the rest of the day. I've replace the idle air control, the TPS, the mass air sensor, and the linkage seems fine. What could be causing this?


Coolant sensor indicate cold temp ... Chevrolet Impala

My 2003 chevy trailblazer ls rpm gage has completly stopped working. when it first started going bad it would work on occasion and now the needle doesnt even move from 0. my car feels and sounds like it is shifting when it should its just the gage that doesnt work. what could cause this? is it a bad sensor, wires or something all my other gages work fine its just the rpm gage. if anyone knows how i can fix this problem please let me know what i need to check i want to be able to fix it myself if


... 1996 Audi A4

Engine surges Engine rpm surges 2 to 3 hundred rpm when highway drivng. Does not occur when it is idleing. Could it be the O2 sensor or the throtle body switch?


... 2006 Pontiac Montana SV6

While driving on the highway heard a load bang in front end. Then orange arrow started flashing , I noticed rpm's increased without increasing speed. Took car to shop and they rebuilt the trans and they also said front axle was broken and replaced. Drove car for 2 weeks and orange arrow is blinking again and same increase in rpm without speed increase. Am taking back to shop but wanted to know if there is maybe a sensor or something that could be causing the problem. thanks


Hi,\015\012\015\012I suppose more then any sensor, its a worn speedo cable. Please get is checked for any wear out or damage.\015\012\015\012Let us know for any clarification.\015\012\015\012Thanks for contacting ... 2002 Volvo S40

My 2000 Chevy Impala 3.4 shuts down when I take my foot off of the gas peddle completely. At a light I must have a foot on the brake while the other foot is on the gas and I must give it gas to start it. I.v changed the master air flow, The Idle control sensor, the throttle position sensor and the pcv valve connections. What else could the problem be? (oh yeah, there is no check engine light with all of this)


Vacuum lines are broken, cracked, or removed? I had the same thing in my Lincoln, ended up being 2 cracked vacuum lines and the Mass air flow. ... 2000 Chevrolet Impala

Codes po 101 and 102 come up for my 09 chevy cobalt lt 2.2 , i recently put a new air filter in ,after that about a week check engine light came on and those two codes popped up , the car once started up jumps high and low rpm untill eventually stalls , i just took the maf sensor out and cleaned it , disconnected battery and still came up same codes , could it be a bad sensor ? Car only has 45000 miles on it


... 2009 Chevrolet Cobalt

2005 3.5L Pacifica. When engine revs to 3000 RPM it goes into a hesitation mode (eith in park or when driving), assuming this is a protection mode caused by PCM. Garage had told me cjeck engine light was Catalytic Converter, did not ger formal printout. Plan to change O2 sensor, am I on right track? Is there more than the one on Cat Converter?


... Chrysler Pacifica

It acts likes fuel starvation in mid range throttle responce. at full throttle it accelerates normally. at approx 2000 rpm truck hesitates. ot sensor has been changed. anillisor indicates lean condition. could this be problem be with throttle position sensor?


Yes! if it the same every time at the same spot change the tps. one good way to catch it is with a analog voltmeter. you have to be real patient with a digital but it can be done. also clean the throttle body when your done using the seafoam cleaner. ... 2001 Toyota Tacoma

I have a problem with a 2002 Chevy Impala, it has a slight hesitation when accelerating,also it has died a couple times then won't start for20-45 min. I had it looked at by a local shop and was told the catalytic converter needed replaced,parts alone were estimated at 650.00 . I checked witha couple other places and the estimates were 1/2 that amount. the car was purchased from a Chevy dealer and has 830000 miles on it, my problem is no one sounds certain that's the problem, any ideas?


I am having an issue with MAJOR hesitation when I step on the gas. I've changed the fuel filter and the throttle control sensor. Any suggerstions? ... 2002 Chevrolet Impala

My 1999 chevy malibu shuts off after it sits and idle the idle is like a small jumps like its not breathing well its good on the highway, i have replaced the MAF sensor bank 1 and 2 o2 sensors, also just added an air compresser now the gas gauge wnt move off empty and just put in half a tank, if anyone could help with an answer would be great.


If there are no codes stored in the ECM, you'll have to take it to a shop and see if they can reproduce the event. When the engine dies you have to be able to determine if you have lost ignition or fuel to know where to start looking. The fuel gaug ... Cars & Trucks

1993 Saturn sl2 code 26. I changed the EGR solenoid and the canister purge solenoid and I'm still getting a code 26. This only occurs when I'm on highway speeds of 64-70. The service engine light comes on and once my speed drops to 50mph the SES light turns off. I also replaced my 02 sensor. The only part I have not replaced is my temperature sensor. could that be the problem?


... 1992 Saturn SL

I drive a 2003 Chevy Impala. I have code P0135, sensor heater, bank 1, sensor 1. I was wondering if there was a diagram or some thing that some one could show me so I know that I'm changing the right one.


It's the upstream sensor or the one in the exhaust manifold or closest to the engine. Good luck! ... 2003 Chevrolet Impala

I have a 2002 chevy malibu that has two major issues. I cant go over 40 mph, and it happened to me two years ago. They replaced the catalytic converter and oxegyn sensor. A converter last years, so of course now Im wondering why its doing the same thing. I refuse to ripped off, could it just be a bad sensoe again, I know they are cheap and dont last forever. I went to get my battery replaces at batterys plus. They plugged in a machine under my dash, and I asked what it was for. He said i


I just ran into a low power and slow acceleration on my 01 and by chance i tryied swapping out the mass air flow sensor and problem fixed..also it didn,t have any fault codes ... 2002 Chevrolet Malibu

My 2006 Chevy impala 3.9L oil pump failed, the thing is that my oil light never came on, i checked my oil almost every weekend sometimes twice a week and without notice my car suddenly jerked a few times and cut off, i had the car towed to the shop it it appears my engine blew up, can you please explain how this could happen, why did my oil sensor come on to inform me that the pressure was low so i could have pulled the car over and not destroyed my engine, now I'm out of $3,500


... 2006 Chevrolet Impala

I HAVE A 1999 CHEVROLET EXPRESS VAN ,4.3L.I HAVE THE CODES FOR EGR VALVE AND THROTLE POSITION SWITCH,BOTH ARE NEW,ALSO I MADE A MAYOR TUNE UP AND REPLACE THE CATALITIC CONVERTER,AND STILL HESITATE AT 25 OR 35 MPH,IN THE HIGHWAY RUN VERY GOOD ,AND THE PROBLEM IS INTERMITENT,SOME TIME IS WORSE SOME TIME LESS,THE SAME PROBLEM AND CODES BEFORE AND AFTER ALL THE REPLACED PARTS,IN THE HIGHWAY IS GIVING 14 MPG,COULD YOU HELP ME?


YOU NEED TO CLEAR THE CODES WITH AN OBD-II CODE READER! AND GO FROM THERE! THE CODES ARE IN THE COMPUTER MAKING IT THINK THE PROBLEM IS STILL THERE! ... 1999 Chevrolet Express

Recently replaced my fuel pump, fuel filter, fuel pressure regulator, fuel injectors, dist cap, wires, plugs, distributor and catalytic converter and my 1990 Bronco II still has a lot of hesitation on acceleration. Sometimes won't even get up to highway speeds. Not sure what else it could be.


You might try checking the catalytic converter.. it could be clogged... not letting the engine breathe like it needs to ... 1999 Ford F250 Regular Cab

I have a chevy impala 2003 the car some times starts and some times it does not the car starts only on the secound try and when it does not want to start i could only start is with carb cleaner and the car starts perfectly and stays on as long i want is to does not misfire. The car when its not starting there is spark but no pulsation, onces i but in carb claener the car starts and stays on i guess the pulsation kicks in. already changes the crank and cam sensor and the car has the same problem.


HI!!!!!! if you try all this you say ... th efirst thing i woul do is take of the fuel filter is under drver side blow one side the one goes to the engine if you have problem blow in the filter this has to be clog o dyrty inside the filter now t ... 2003 Chevrolet Impala

Had code po336 crankshaft position sensor on 2001 chevy malibu. Switched it out, car is still starting strange and the rpm gauge still bounces around.Does timing fix itself?Is there another step? Could something else be contributing to this problem? thanks for any help you can give.


Timing will only change with cam and crank sensor. cam sensor will not effect the car starting but crank sensor will and if the crank sensor is bad and cam sensor can't sync itself of of it then it will act up. so i would be looking at crank if i had ... 2001 Chevrolet Malibu

2001 chevy malibu base.Tach is bouncing, had error code saying crankshaft sensor.replaced it, still have problem.replaced the new one to make sure it was not bad and checked the wireharness. could it be the camshaft sensor? and would a catalytic converter being clogged up have any effect on that. thanks


What is the error code? also what engine do u have? also when u get an error code it means that there is a problem in that circuit, that can be a sensor or the connector to the sensor, or the wiring to the sensor or the computer control ... 2001 Chevrolet Malibu

My 2001 chevy impala keeps over heating and I don't know why. I've replaced the radiator and fans recently so they are good. The fans don't turn on most of the time though. Is there a sensor that could be bad that doesn't turn the fans on or would it just be a bad thermostat?


It's possible that the thermostat has gone bad. If the valve on the thermostat remains closed, it's possible that water isn't flowing to the sensor that controls the radiator fans, thus you wont get an increase is fan operation.The good n ... 2001 Chevrolet Impala

When I accelerate it does a fluctuation in gears...the rpm goes up and down...even when im driving at 40 mph it shifts then it hesitates at that speed..could it be the throttle sensor is dirty?


Is the "check engine" light on??? to isolate your problem have you tried MANUALLY shifting the trans (automatic) and still doing it?? check the fluid level and condition of the oil...sound more like the trans is slipping...the "TP" sensor will effec ... Ford Probe
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.6996 seconds