Having problems with your Cars & Trucks ?

99 isuzu rodeo p0402 i bought a dpfe egr sensor but where it goes and this can fix my problem

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

99 isuzu rodeo p0402 i bought a dpfe egr sensor but where it goes and this can fix my problem


... Cars & Trucks

I recently bought a 2005 Dodge Neon, the oil light was coming on so I reported to dealer who replaced oil sensor switch, now the check engine light is on so I bought a pocket scanner and it comes up with PO340. I was told by dealer to put hightest gas in it and a fuel cleaner run thru cycle and see what if light goes out. from what I have red is this going to fix problem or should I have him fix the crankshaft sensor problem?


Trouble Code: P0340No Camshaft Position Sensor Circuit FailurePossible Causes:CMP Sensor connector is damaged, open or it is shorted.CMP Sensor signal circuit is open or shorted to ground or to ... 2005 Dodge Neon

1984 C4 Corvette Crossfire Injection. After warmed up to normal temp. (220+-) and then parked for a while (30min. or so), the engine starts up but then the idle goes up and down then stalls, it becomes hard to restart, or won't start at all. Checked the ECM codes, none(only 12), I cleared the memory then its back to normal running condition! I replaced the TPS (bad), the pig tailfor TPS, coolent sensor, and EGR (bad), did no fix the problem. Any ideas what cause this starting problem? Thanks...


Hi,\012from your description it would appear that the ECU memory, having been cleared by yourself, starts and runs the car as it should, and as you stated. However, the ECU then gets conflicting signals from the system and shuts it down. Theref ... Chevrolet Corvette

1999 Dodge Intrepid tranmission problem 1 and 2 gear work fine, no slipping of any kind. No 3rd or 4th gears goes to like in neutral mode. Did computor check and got P700, P733, and P734 something like these codes which told input and output sensor problem. Changed both sensors and still the same. Someone told me it could the internal module. What is the real problem and a fix for this.


The solenoid pack inside the transmission. ... 1999 Dodge Intrepid

I posted my problem on 06/26/2009 this is pangel38,spark plugs and wires all new, new fuel filter, egr valvle, egr valvle tube, new air flow sensor, the list goes on and on, i am beginning to this this could be my throttle position sensor, or conrol arm sensor i am at a loss here pam


My best guesses would be #1. Oxygen sensor(s). #2. M.A.P.(manifold absolute pressure) sensor. #3. M.A.F(manifold air flow). sensor. I wish you the best of luck. Keep me posted. ... 2000 Oldsmobile Silhouette

MY 1993 Grand am V6 has dead Speedometer. Bought the car and It ran Fine First week. The car did need some TLC but nothing Huge. So I changed a few Belts and Threw in a New battery and terminal cables. One day the speedometer Just didnt function. Ive owned the car 2 weeks. I bought a Speed sensor and Speedometer cable. I poped the Speed Sensor and PLuged the same cable Back in and It didnt fix my problem. The cable I bought at Autozone Does not fit or Look like my old cable. SO I heard from a fr


You definitely don't need a kickdown cable, the kickdown is for the auto transmission, you may just need a new gauge cluster. also the cable you got from autozone could be a universal cable thats why it doesn't look the same, or it could just be a w ... 1996 Pontiac Grand Am

I have a problem with the heating system in my 94 corsica.When temperature gauge goes up and the heat stops working.When it goes back down, the heat works again. It goes back and forth.The engine is not overheating. I added a little antifreeze to fill it,I cahanged the thermostat, radiator cap,upper radiator hose, temperature sensor but I have the same problem. Any ideas. What else can I look for? The thermostat was bought 7 years ago, but never out of the box?!


You have air in the system, look for the highest point of the system you could try to bleed the air out as the motor warms-up ... 1994 Chevrolet Corsica

I bought the car 2 monthes ago and the check engine light came on. Some one had installed a Fujita Air intake f5 and the mass air flow sensor is causing the check engine light to go on. The shop where it is getting fixed said the code is saying the sensor is making the light come on under heavy excelleration. Is there a fix to this problem?


Use only factory units and no boy racer add ons as they will cause problems like this ,its not a mk1 cortina and you can put harry moss add on boy racer bits.want a fast car buy a jag end of story.also is this conversion legal?? is their a certificat ... Mazda MAZDA3

I took my moms 2001 ford taurus to be inspected. It fail due to EGR sensor.. Machnic said sensor needed to be cleaned. After taking apart he said valve was badly cloged. Soaked overnight and said it would fix problem. It didn't. Light came back on and when taken to get it checked before inspection was told EGR was still bad. Can you tell me why?


I would highly suspect the "EGR backpressure sensor"From experience and many conversations, a clooged EGR valve is almost unheard of these day. Get to an auto part store, were they can tell you what problem code(s) your car is getting, and poss ... 2001 Ford Taurus

91 chevy 2500 4x4 5.7 auto runs fine cold but when in closed loop runs rough. 02 volts varying 450mv on start,then goes to 115omv inclossed loop.new ecm egr valve plugs cap rotor and wires ect sensor checks ok fuel pressure within spec. i have tried different map sensor and tbi unit o2 sensor was replaced same problem. any ideas?


When the engine starts the O2 sensor volts should be around .5 volts or 500mv so the 450mv is correct now i don't know wither your next statement is 115mv of 1150 mv it makes a big difference, so get back with me and i will ... 1991 Chevrolet K2500

I just bought a 1998 Lincoln Continental with a 4.6 liter V8. The car has around 150,000 miles on it and it seems to be pretty mechanically sound. There are only 2 problems that I have noticed. The first one is that when you give it a lot of gas it has a tendency to pull hard to the left. When you let off the gas it goes back to normal. The second problem is when it shifts it pulls hard to the right really quick. I need to know what the problems are and how to fix them.


Motor and Transaxle mounts--replace them all\015\012\015\012Check Front Drive Axle CV Joints ... 1998 Lincoln Continental

I have a 2006 VW TDI Jetta. The alarm randomly goes off. I took it to the local dealership and the hooked it up and said that the two rear door sensors had gone bad and needed to be replaced. They said that the door latches need to be replaced. They quoted $920.00 for the repair. I paid them $85.00 for there diagnosis and ordered the door latches and replaced them myself. This didn't fix my problem the alarm still goes off. The battery goes dead also because the interior lights will come o


Have any of you resolved this? We are having the same problem with our Jetta. The drivers side door will be shut and the alarm will randomly go off. ... 2006 Volkswagen Jetta

Hello ... I've had severe problems with my jeep ... .. a long time when I give a few turns to the market or get my children .... my car just shuts off ... I have to put my car in neutral and turn on again ... .. and always goes back on but would like to fix this problem ... because I can not handle long distances ...the engine light say is the cam sensor...but this a ready change in twis times


... 2002 Jeep Grand Cherokee

Engine miss I am looking at buying a 1990 Ford Taurus SHO The guy is telling me that it has a miss in it when it warms up and that the car just acquired it after it set in his garage for 6 months my thoughts on this is that it is bad gas. This is what he said though that he put all this on new and that it still didnt fix the problem new parts 02 sensors,map sensor, plugs, wires, coil pack, filters, ignition module he also said that he had bought a couple trouble shootin guides vacume trouble


Ok i think that the problem is the thermostat if you change it and still the same maybe is possible that is getting water into the heater and you need to buy a new ones ore go to rectificate where is the crack in your heaters and ... 1990 Ford Taurus

My son bought a 2000 Cadillac seville from a BMW dealer. the ABS warning light was on. the dealer agreed to fix. the dealer said they checked the sensors and replace the torque converter. the ABS light still stayed on. Yesterday they brought in a wiring expert to test the system. The expert says that the replacement of the torque converter fixed the problem. When my son went down to take delivery of the vehicle, the warning now says "service suspension". What should my son be looking for the dea


I'm a retired ceritfied mechanic and license electrician. To my knowledge, although damage to the ABS (Anti-Lock Brake System) can occasionally cause transmission error codes I've never heard of the torque converter having anything to do with the ABS ... Cadillac Seville

Runs bad when i start my car it cuts off and takes some time to get it started. when it gets started it idials bad, i have to put one foot on the brakes and gas it up to shift and it some times still cuts off.but if it stays start it funs bad when i accellerate the runs good for 5 seconds then runs bsd again. when i changed the crank sensor it runs smooth for a week then goes again, and i have changed the crank sensor three times already. please help me fix this problem


Check fuel line ... 1992 Buick LeSabre

1999 Chrysler 300M, Dies on deceleration and at idle when warm. I can some time see the tach go to 0 rpm, with out the car actually dying I have had may suggestions, from EGR, throttle Body, fuel injectors, fuel pump, cam & crank sensors and more, I really would not prefere to just start replacing parts untill I find a solution. Has any body found a fix for this issue, I have seen many posts with similar conditions, but so far not a single one that says the problem was fixed...


For the price of a can of throttle body, spray cleaner, I'd remove the IAC motor , clean it, and port it came out of and try it and see what happens. It sure sounds like the same old dirty IAC problems that are frequent . Normally that will cure it, ... 1999 Chrysler 300M

I have bought a 2002 renault espace 10 days ago the service light came on so i put it i for a full service to find out that it has a few problems middle exhaust silencer is corroded and holed a serious power steering fluid leak the 02 sensor wiring corroded and the rear brake discs are corrodedand the airbag light is on are they major expensive problems to fix


... 2002 Renault Sportwagon

In my 95 z43 the check engine light comes on and goes out as i am driving to me it seems electrical and i replaced the throttle position sensor and the idle air control sensor both did not fix the problem it runs fine but when the light comes it starts doggin and it hurts performance


The check engine light comes ON when the cars computer(the ECU) notices any kind of electrical problem in car.In some cases the check engine light comes on then turns off.In that case the exact error is not getting confirmed so this happens.But ... 1995 Chevrolet Monte Carlo

Tyre flat sensor goes on/off. Sensors were checked after had I bought new tires but that's when problem started, so I had them check and re-check. No change. What is going on and what can I do?


There needs to be a calibration done on the sensors,it resets them.If this does not work,then one of them is defective ,find the one that is defective,and replace it. ... Volkswagen Touareg

We recently bought a 2006 bmw 325i at the dealership. After a few days of driving we noticed that the airbag on the passenger side keeps turning off and on along with the seat belt sign. We believe there is something wrong with the sensor. We tried to get it fixed but they only fixed the wiring and yet again the same problem occurs. What should we do?


There is a recall on this issue. You should bring it in immediately and its totally covered. ... 2006 BMW 545i

1989 Chevy Silverado, 5.3L engine, 4 Speed Automatic. I have a run problem, the idle is to low and it surges at times and dies. I cannot adjust the timing as everytime I try it goes wild. The EGR valve, Idle Air Valve, Ignition Control Module, spark plugs, plug wires, coil,TBI rebuilt,Knock sensor, O2 sensor have all been replaced. I'm not getting any codes. When I start it I have to play with the throttle to keep it running. Sometimes its running rich enough that it smokes and other times it do


Check the tps sensor ... Chevrolet Silverado 1500

I have a 2000 chevy Tahoe (old body style) 5.7L, 140K miles. I have had a problem for the last 100K miles: when going up a long hill, I get the P0300 code. I have been able to temporarilly fix it by replacing the EGR valve, but this usually only fixes it for about 6 months. Now, the engine pings at light acceleration and whenever the truck is moving, it makes a noise like an exhaust leak, but if I take it out of gear, the exhaust leak noise goes away. I guess my main concern is the pinging whene


The cam shaft sensor,and the crankshaft sensor tell the computor how to time the engine.The cam sensor or it`s reluctor on the timing cam gear could be bad,or the crankshaft sensor itself.Without the right scanner tool,there is a lot of guess work.Th ... Chevrolet Tahoe

My 2000 Isuzu Rodeo occasionally Cuts off when breaking or just sitting there idleing, I have took it to 3 different Mechanics, 1 said EGR Valve, so i replaced it Problem still Persist, 2nd said Mass Air Flow Sensor replaced Problem still persist, And the 3rd says the throttle body but not positive but i have not replaced it because the price of the throttle body over $350, So i am hoping someone might have a better cheaper solution,


Idle speed control not working or idle too low.if all good check fuel pressure.if it been a while change fuel filter. ... 2000 Isuzu Rodeo

Hello..2002 pt cuiser..trans rebuilt, in & out speed sensors replaced..Tps sensor & tcm replaced.. trans gets hot goes into safety mode.which is locked into 2nd gear..tomorrow I will change out tmc relay!! what do you think ?? I took veh to dealership..they said internal problem !! trans always shifted perfect..please help..I guess if the relay doesnt fix..off to electrical shop 4 trouble shoot..


If it is getting hot something is slipping inside ... 2000 Dodge Caravan
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.3262 seconds