Having problems with your Cars & Trucks ?

I have a 2005 mercury mountaineer which was having battery problems. I was getting a jump after first trying to remove the battery. It finally started after about a half n hr but after it started it went into engine safe mode and limp mode. I then shut it off and took the battery to an auto store and got it checked and said my battery was bad. I replaced the battery but it will not come out of these modes??? Any suggestions?

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 2005 mercury mountaineer which was having battery problems. I was getting a jump after first trying to remove the battery. It finally started after about a half n hr but after it started it went into engine safe mode and limp mode. I then shut it off and took the battery to an auto store and got it checked and said my battery was bad. I replaced the battery but it will not come out of these modes??? Any suggestions?


... Cars & Trucks

It snowed, and was freezing outside.Tried starting my car (1993 Olds Cutlass Ciera) 2 days in a row,..but nothing. Got a new battery last night, because I ran the old one down trying to start it. The car is in my driveway, with snow (ice) underneath it. The first time I tried starting it 2 days ago,..it started for about what seemed to be 20 or 30 seconds, and then shut off. It would not turn over after that. I went to the auto store, and bought starting fluid with ether, and a bottle of HEET.


Hello, My Mom lives in Latrobe, anyways, yes there is a fuse to the fuel pump. and as cold as it's been you could just have frozen fuel lines, you can check the fuse but will require a fuel pressure test, you need about 35 psi to the injectors, do yo ... 1993 Oldsmobile Cutlass Ciera

2002 Ford Escort intermittently will not start. Drove to a store, shut it off, got back in and it wouldn't turn over. Got a jump and it still wouldn't start. Put water in the battery, spilled a bit of water on the terminals. Then it started. Drove again, turned it off, again it wouldn't start. Got a jump, wouldn't turn over. Cleaned the battery terminals, it started. Drove home, shut it off, it wouldn't start. Got a jump, it started right away, let it run for 45 mins. Turned it off, once again w


Sounds like your battery terminals or cables are bad. is there any corrosion on the terminals? if so clean them with a wire brush. check to make sure that both ends of both wires are tight and not rusted or corroded. ... 1992 Ford Escort 4 Door

Put in a new battery. it didn't even last 24 hours battery light was on in car drove it and it shut off in the middle of the road when stopped at a stop light. had the alternator tested it tested good got new battery and voltage regulator got vehicle home went to start it the next day wouldn't start. Just put in a new alternator and battery went to store and came out and wouldn't start again. got someone to jump me made it home pull in the driveway barely made it in the driveway shut off a


I don't know..... but what you are saying sounds typical of a bad alternator not recharging, when you had it tested did they test it in the car or did they have you remove it and bench test it?\015\012Let the shop run the vehicle ... 1989 Ford Taurus

6 cylinder 1999 Ford Taurus Car wouldn't start when it was wet out. Got new battery. Tail lights and dash lights out. Then back to the original problem. Car now only starts when a battery charger is on about 15 minutes or by a jump. Cleaned battery cables with light sandpaper. Battery cables tested at auto parts store - OK. Now I am trying to remove the alternator to take it to the auto parts store to get checked. Good idea? Or what would you suggest next? Ultimate question is: How do


There are two bolts holding it on the mounting bracket. They are long 7 or 8 inch bolts. Remove these and disconnect the wires from it then pry it up between the alternator and the mount. It sounds more like a coil or plug wire problem to me as fa ... Ford Taurus X

Just changed my starter and battery and battery connectors on my 2000 dodge caravan and just getting a click noise. Before I had put this starter I had on now the auto parts store sold me the wrong starter I didn't know it got it put on and started it ran for a couple hours and then couldn't get it to start again took the starter off n back to the auto part store and they told me that was the wrong starter gave me the rite one. I put it on and just a click noise is all I get


Check to see if the other starter you put on drained your battery that is usually what the click means is that the battery doesnt have enough juice to make the starter turn your engine over its just got enough to make the starter try to engage and as ... 2000 Dodge Caravan

Went to gas station turned of my2002 suzuki xl7 4wd then went to start it and it would not start then got a jump and it started then when I went to drive it died on me jump started it again then it did the exact thing half an hour later jumped it again and revved it up a few times then was able to drive a few miles and then it died in the auto parts store they checked my battery and it died again while they were checking it so I replaced the battery on it. and right after I got it changed it die


Sounds like you might have blown the fuse for the alternator or the wires for the alternator are dirty loose and not charging the battery right ... 2002 Suzuki XL-7

I have a 1999 Mercury Sable and had to replace the battery a month ago. Today, after driving for 20 min on the highway I stopped at the store and shut car off. It would not start back up, it was completely dead. After letting the car sit for a couple hrs, it started right up, but then my battery light came on, and my dash lights and head lights got really dim and windows would not work, while the car was started. Then it would only go 5 mph. So I shut the car off and now it won't start agian


Has to be tested for the solution ... 1999 Mercury Sable

95 camry won't start after sitting in a lot all day. Friend says he noticed the headlights were on early in the day but this seems odd with the auto shut-off feature that kicks in when car is turned off. Got a few clicks on first attempts to start it, then not a sound. Could this simply be a battery replacement (it IS an old battery)?? Maybe solenoid contacts?? Any ideas are appreciated!


... 1995 Toyota Camry

Electrical Problems Started truck (very hot day). Instrument panel stopped working except RPM guage. ABS and Air bag lights came on. The A/C, Power windows/locks, radio, blinker lights, etc all stopped working but truck kept running. When I shut it down and tried to start later the truck didn;t start. Make a clicking noise like the battery was dead. Can't start to get over and run the tester at Auto parts store. Possibly a fuse or relay? Any ideas ???


A mechanic would start at the battery and test the circuits. If you have lights but no crank, could be a dirty connection at the battery or a dead cell in the battery. If that checks out ok, look at the fuseable links. ... Cars & Trucks

03 Explorer (V8) clicked this morning when I tried to start it. Clicked several times, then only once. Got a jump which didn't work at first, then it did. Went to auto parts store, battery tested good. When I started it there it started but clicked at the same time. Starter? Bad terminals?


It sounds like you have a bad starter. Definitly make sure your terminals are clean and tight first. Once you have checked that try to start. If unsuccesful have someone try to crank vehicle while you tap on starter with a hammer or tire iron. This i ... 2003 Ford Explorer

I have a 94 buick park avenue ultra and it shuts down while driving can any one tell me what it can be? My 1994 Buick Park Avenue Ultra always shuts off while i'm driving. When it shut down it always starts back up with no problem. The lights don't cut off with it only the engine. I got the fuel filter check that's good to go, i change the gas cap, i put a new battery in it, and it kept on cutting off while i'm driving. I took it to a auto shop and the man did the computer test on it and its no


... 1997 Buick LeSabre

My sister in has a 99 escort that I changed the alternator and battery. I had the battery and alt checked again while it was running. It acts like the battery wont turn the car over. Then it will crank like nothing is wrong. auto parts store thinks it is the starter. I talked to a mechanic and he said it was the ground module? When I got it started, as it was turning over the doors locked and unlocked. he said it was under the dash


PROBLEM COULD BE FAULTY IMMOBILIZER READ COIL OR FAULT IN THE ECM IMMOBILIZER CONTROL MODULE. ... 1999 Ford Escort

Wont't start I shut it off when I got to the store and when I started to crank it back up it would not start it wouldn't even turn the motor over like a dead battery and when I turned the key over nothing I have checked all fuses and relays all seemed to be ok.PLEASE I NEED HELP!!!!


Check battery conection to see if terrms are clean and good connection to batt and starter ... 1994 Nissan Quest

My sister in has a 99 escort that I changed the alternator and battery. I had the battery and alt checked again while it was running. It acts like the battery wont turn the car over. Then it will crank like nothing is wrong. auto parts store thinks it is the starter. I talked to a mechanic and he said it was the ground module? When I got it started, as it was turning over the doors locked and unlocked. he said it was under the dash


If it's reading14 volts at battery with engine running, alternator is OK.\012\012Sounds like starter is shorting internally to me. ... 1999 Ford Escort

Wont start I have a 1999 Daewoo Nubira. I went to start my car and it started it fine. I wasnt leaving for a little longer and shut it off. When I went to start up again it wouldnt even turn over like the battery was dead. After it got jumped it was okay but when I shut it off it wont start back up. Do you think I need a new battery or can I just get the battery charged up or could it be a whole different problem all together? I got a new engine installed last year.


Start vehicle up and take vehicle to an AUTO-ZONE they will check the entire charging system for FREE. This could BAD battery or a BAD alternator or even maybe both. So let not guess or if you have a volt meter at home with vehicle running voltage at ... 2001 Daewoo Lanos

The wipers have stopped working but the windshield wiper fluid still works. After they stopped working and I had shut the car off for about 5 hours then ran to the auto store for fuses I started the car and the wipers went half way up and stopped again. After arriving at my destination I got out of the car and shut the door (motor was turned off and keys in my pocket) the wipers went back to their normal position. Please help me, no idea why they won't work. 2001 Ford Windstar


Sounds like the wiper motor is bad. Check to see if you are getting power to the motor and if you are that should be the problem. When you turn power off to the motor it is set to go to the normal position so more then likely it just loosened up a li ... Ford Windstar

2005 Tahoe Z71: My battery died but was able to jump start. I have dual HVAC controls. Driver side worked OK, passenger side blew out extremely hot air regardless of temperature. Got to the auto store and replaced the battery. Now the passenger side works OK but the driver side blows out extremely hot air. Is there a reset anywhere on the vehicle to resolve problem or what?


When your battery died, it probably wiped the PCM memory. Drive for 20 minutes in stop and go traffic then 10 minutes on the highway to reset the PCM sensors. Check to see if this helps at all. It's wierd to think about, but the PCM can control al ... 2005 Chevrolet Tahoe

RECENTLY REPLACED THE FUEL PUMP,CAR STARTED WENT TO STORE, CAME BACK, SHUT HIM OFF FOR THE NITE AND would not START AT ALL AGAIN MY LS 400 IS A 1991 WITH A FUEL PUMP RELAY UNDER THE HOOD, PASSANGER SIDE. I REPLACED THE RELAY. TOOK THE ALMOST DEAD BATTERY OUT TO RECHARGE. PUT IT BACK IN TO NOW NOT HAVE IT TURN OVER AT ALL. NOT A SOUND EXCEPT FOR THE LAUGHTER OF SAID NEIGHBORS , I AM PREPARED TO TOURCH THE CAR.......BUT BEFORE I DO...YOU GOT ANY SUGGESTIONS


... 1991 Lexus LS 400

2004 Lincoln Ls V8- Over the past 6 months the car has been experiencing a mis-fire, took it to a local auto parts store and had them plug it into their computer. It showed a mis-fire on cylinder 1 and 5 and a bad crank sensor, I replaced all. The car seemed to run great but just a few days later it started going into etc failsafe mode, after pulling over and shutting down and restarting it would run normally again. This has been going on for about a week now. I took it back to the auto parts st


You never go to a dealer\015\012\015\012You will spend thousands and\015\012nothing will be resolved\015\012\015\012I have the same car 2004 V8\015\012\015\012You never had a bad crank sensor,\015\012a ... 2004 Lincoln LS

My 1999 pontiac grand prix gtp supercharged just shut down yesterday after adding gas about an hour beforehand got it to finally start and drove about 7 miles then it shut off again would not restart acts like bad gas or not getting any fuel then battery died so thought alternator was bad but once jumped with battery box started after three tries and ran like a champ for about 20 minutes then as we were on our way to get the battery and alternator checked it shut off again restarted and got it b


I have the exact problem.im trying spark plugs ... 1999 Pontiac Grand Prix

I have a 2005 Honda Accord Coupe and here lately it has been having a slow start. I went to the auto store to check the battery and it was a bad battery. I had the battery replaced and it worked. The next day i went to crank it up, it still had a slow/hesitating start. I took it back to the auto store to check the battery and they said it had an 88%opportunity charge. Still not sure why it wasn't 100%. He told me there could be some wires loose or the starter? Can you please shed some light on s


You need to have them check for parasitic drain. There is something that is draining the battery when the key is off. This is normal but there is something that is pulling too much.. ... Cars & Trucks

I have a 1992 eagle summit wagon dl that won't start. I've had the fuel pump changed and a new distributor put in and today a new battery. It started after the battery was put in and when I got home I shut it off and tried to start it again and it wouldn't start. Last week I tried to start it nothing....then a 1/2 later it started so I drove it back to mechanic. He's had it for a week and its starting everytime. But he did say the battery was weak so I got that today and now won't start ag


... 1992 Eagle Summit

I just bought this car Chrysler Cirrus 2000 LX with a Omega Mars remote start system. It was running good until my battery died 2 days ago. When I changed my battery the system got broken. Locks and unlocks the car very good but when start the car with remote start button, it starts but shuts off after 5 or 10 seconds. Then it starts again automatically then shuts off again. It does it couple more times and system stops. Starts and runs very good with key start! What should I do?


I would contact a Chrysler dealer and speak to a tech,they will answer for free.They would know best what may be going on.Sounds kind of like it needs a reset.That's all I got.When in doubt,contact a dealer.If they want money,call around is some basi ... Chrysler Cirrus

My wife just got back from the store in our recently purchased 2001 XTerra, and told me that even after she turned the key off and locked the car, all the idiot lights were still on. So I went out and checked, and (ya might wanna sit down!) she was right. It starts up fine, but when you shut it off, all the warning lights stay on, even after removing the key. I tried disconnecting the battery, and after a half hour, reconnected it, and it's still the same. Has anyone here ever seen anything like


This sounds like a bad body cpu or ecm. There's 3 computers that run your vehicle. The body controller affects those lights. Check the fuses first in the car & under the hood. ... 1999 Nissan Quest
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.1468 seconds