Having problems with your Cars & Trucks ?

I have a 2003 Cavalier, the coolant fan does not work, I have changed the relay and ect sensor and checked the fuse, still not working.

\015 Does that leave the actual fan itself? Any ideas?\015 Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Change the fan motor it takes a moment for the fan to come on it got to reach required temp for it to come on
Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 2003 Cavalier, the coolant fan does not work, I have changed the relay and ect sensor and checked the fuse, still not working.


Change the fan motor it takes a moment for the fan to come on it got to reach required temp for it to come on ... Cars & Trucks

No spark no fuel no start! replaced and checked everything,fuses,grounds,relays,coil, plugs,wires,distributor,crank sensor,jumped fuel pump, works. timing right on, last code given was P1500, changed fuel pump relay, still nothing, checked for ecu power supply relay #.3 is none? also checked for relay #13 ho2s also none? Fuse 18 & 15 good, 1996 VW golf gti 2.0 L4 Automatic...now what?


Funny thing is I have a 2002 GTI with the exact same problem. have spent the last three days at work trying to figure things out.. best of luckn email me if you figure anything out. [email protected] ... Volkswagen GTI

2003 malibu cooling fans don't work. I have replace the relay and the temp sensor and still nothing. When ever I disconnect the temp sensor the fans come on and work normally, but later in the day I see the temp in the instrument panel start to go up and I check the fans and they are not turning. I have check all fuses and they seem to be good. What can this be or what do I check? Thanks, Paul


Okay pull the temp sensor connector ( disconnect it) and turn car on if the fans run then its the temp sensor.... part # wt3000. Theres also 3 relays that turn the fans on in the fuse box cooling mode fan relay @15 which is part number 7234. and ... 2003 Chevrolet Malibu

Ac problem AC stopped working a few weeks back on my S10 1999 blazer, I have put a set of gauges on it blue side reads 60psi red side reads 35 psi. I jumpered the pressue sensor out and it still would not work. I then checked for voltage at the compressor and found none. So i applied 12 volts to the compressor and it kicked on and ice cold air blows. So what could be the issue why would I not begetting 12 volts to the compressor. I checked the fuse and I also swaped the relay with the horn relay


Static pressure(Non operating) usually is around 70 lbs and should be even on both sides. Sounds like the systen is too low for the computer to allow operation. I suspect a small leak somewhere. Adding as little as 1/2 lb should allow operation and l ... 2000 Chevrolet S-10

I have a 2000 Buick century the coolant fans don't work replaced relays still not working pulled relay and cross wired to see if fan motors ok did work once but all it does now is blows fuse was told to check coolant level sensor but what would that have to do with the fans please help


... Cars & Trucks

I have just purchased a 1995 Cadillac Deville Concours. The seats controls and power locks do not work. When checking the fuses, the big fuse for the seats/locks/trunk/fuel door was smoking hot. I removed it and proceded to check the wiring for obvious shorts. The trunk and fuel doors still work with the fuse removed as well as the lumbar relays still click when you use the joystick on the side of the seat, all of which should not work according to the fuse specs. If someone has encountered this


... 1995 Cadillac DeVille

I have 96 Grand Cherokee 5.2 v8 its getting no spark no power to coil have checked relays and fuses Gauges not working ive replced Crank sensor have done all checks everyone says still wont start Fuel pump doesnt cycle either Need help am really frustrated


I want to say to simply try a new Ignition switch and to reset your Inertia switch for the fuel pump. The gauge for the fuel level would be about the only gauge which will work when you turn the Key. Your water temp, oil pressure, and Amp gauge nee ... 1996 Jeep Grand Cherokee

Cadillac wont start,and ign. wires for passkey II are broke. I tried to by pass ign. & jump conn. wires but it still wont start. replaced;starter,shift sensor,&checked all fuses & relays seem to be working. Also tried to jump starter,it runs for a sec. & dies. the manual says wait 3 min.s it doesnt work.


If you try to jump the ignition start and wont work, then I suggest re-wiring the wires broke; check this wiring diagram: Cadillac Deville 199 ... 1993 Cadillac DeVille

2002 chevy s-10 blazer. Car stopped at store. Fuel is not getting to engine. Starting fluid will immediatelt start motor but after it burns off it stops. I have changed the fuel pump relay, checked all fuses, changed the fuel pump and the inline filter on the frame. The nre pmp is still not working. Have I missed a sensor or relay? Any help would be appreciated. Thanks


Have you gotten your fuel injectors checked? fuel injectors seem to go bad on later model v6 ... 1990 Chevrolet S 10 4WD

Ac problem had compressor tested today and has full freon. ac fuse is good and so is the relay..It all started with the ac fuse blowing about three weeks ago. mechanic replaced fuse and it blew again. Replaced relay and over sized the fuse from 7.5 to a 10. worked fine and blew cold till today when compressor went out again. Checked fuse and this time it did not blow.had relay checked and it is still good. had compressor checked and it is full. Mechanic says it must be an electrical problem...wh


Jump the low or high pressure switchs this switchs are located on the a/c lines of tje compresor not run check power to the compresor if you have power maybe the compressor is gone \012check the a/c control pannel to and take a second opinion befor ... 2006 Kia Sedona

2000 S10 4.3L Fuel pump stopped working out of the blue. We Put a new Fuel Pump in, new harnes to fuel pump, new fuel filter, new relay, new fuses in IGN C and ECM B fuses. Still the pump will not turn on. We traced the wires and found that the gray wire to the pump is not getting power. Float on pump is working but not the pump itself. We traced it to the fuse box under the hood and tested it the and still no power. Double checked the fuses, Can feel the Relay clicking when key is turned on. Pl


At the fuel pump relay you should have 1 full time hot wire. 1 hot wire when you turn on the switch. 1 ground, and the other wire goes to the pump. Test the ground to be sure it is good. If so then jump a hot to the one that goes to the pump and see ... 2000 Chevrolet S-10

2000 S10 4.3L Fuel pump stopped working out of the blue. We Put a new Fuel Pump in, new harnes to fuel pump, new fuel filter, new relay, new fuses in IGN C and ECM B fuses. Still the pump will not turn on. We traced the wires and found that the gray wire to the pump is not getting power. Float on pump is working but not the pump itself. We traced it to the fuse box under the hood and tested it the and still no power. Double checked the fuses, Can feel the Relay clicking when key is turned on. Pl


Did you verify that the relay terminals have the appropriate signals to them? \015\012\015\012\015\012\015\012ECM fuse B (20-amp) should provide power at all times to the orange wire of th ... 1999 GMC Safari

Lexus ls400 windows and sunroof quit. Checked fuses and relays. All seem to be intact. Didn't remove fuses just checked with meter. Dropped fuse block checked relays by hand after removing each. I believe it's the B relay But I didn't know location so checked all. Can it be master door switch? Are these able to take out all doors? The door lock button still works. Does this system get primary ground or power from anti theft module?


You can try to get a free chassis wiring diagram through autozone.com.Just register the car for free and you can get what you need. ... 1993 Lexus Ls 400

Hello Hope you all doing well... My car is Alero 2000 stopped suddenly at the road, I took it pushing to my home :(( I thought the problem with fuel pump, coz there is no fuel coming to the engine, but when i gave the fuel pump 12V directly from the battery I found it working! I checked the fuse board, I found fuse # 48 fired, i changed but still not working Also i changed relay # 18 with the relay of the horn but still the same, no change, fuel pump does not work when I connect it in his place


You will need to trace the wiring to the pump and look for an open or short. I had one where the connector from the pump to the wiring harness (near the RR wheel) had a loose ground connection. The only way I found it was to move the cable and when ... 2000 Oldsmobile Alero

1997 ford explorer cuts off while driving down road. It will not start. fuel pump is working. checked all fuses, they are good. switch relays. It still will not start. There were spark at the plugs. I changed the crank positoner sensor and coil pack.


If you confirmed spark is there, and you hear fuel pump working, I'd still try spraying WD-40 in throttle body intake for a couple of seconds, when it won't start, just to see if it kicks over, just in case pump is running but not up to pressure. If ... 2004 Ford Explorer

I HAVE A 2003 FORD FOCUS ZTS I BOUGHT THE CAR AT AUCTION AND IT WAS NOT RUNNING THE PASSIVE THEFT SYSTEM WAS ACTIVATED AND THE INSTRUMENT CLUSTER WAS NOT WORKING ,I FOUND A SHORTED WIRE UNDER HOOD AFTER I REPAIRED IT I HAD THE LOCK SMITH COME TO PROGRAM THE KEY AND HIS SCANNER WOULD NOT COMMUNICATE WITH THE ECM.I HAVE A SNAP ON SCANNER IT WILL.IVE CHANGED THE ECM AND THE SENSOR AROUND THE KEY CYLINDER CHECKED ALL FUSES WIRING AND RELAYS I CAN NOT FIND ANYTHING ELSE WRONG AND HIS SCANNER STILL WI


... 2003 Ford Focus

Running hot 2002 pontiac aztec....my car is still running hot. i have changed the the therostat and radiator cap, flushed radiator,ect sensor,checked relays and fuses. why does may radiator fans only come on if my heater (inside) is on and blowing full blast. if my heater fans are not on the car gets hot


Sounds like Clutch in your fan\015\012\015\012 The coolant level is right on, no hoses are leaking and the accessory belt is intact. You start the engine, let it idle and make a visual inspection. There's no sign of belt slippage.\ ... 2002 Pontiac Aztek

I have changed the relays and fuses checked cooling fans which worked when direct power was appied hooked everything back together fans still will not turn on also cooling fan sensor was changed also temp gauge runs hot could temp gauge be bad or wiring on a 2001 chevy mabuli


Replace coolant sensor connector?if so can u get a thermo lazer gun to check the block temp? this will tell u if the gauge is incorect,,,go ahead a bleed all the air out of cooling system and see if that does the trick ... 2001 Chevrolet Malibu

1995 Jeep grand cherokee v8 4x4. Brain stumper..., no spark from coil, fuel pump not working, both been replaced, had buddy with snap on scanner try to communicate with computer and other modules, no communication. Unplugged sensors one at a time to try to communicate and still no communication. Checked all fuses and relays and all are good.


Does the check engine light and all of the warning lights come on when you turn the key switch on ? Could be a problem with the key switch. ... Cars & Trucks

Map lights 2002 Ford F 150 Supercrew FX4. Map lights quit working. Checked interior light relay, and battery saver relay as well as the fuse all are working and in order. Also the glove box light and the engine compartment light which are acccording to the hayes manual on the same circuit are still working. checked for power at the fixture, no power to the map lights. Both rear map lights work when doors are opened but do not work independently. HELP!!!!


Just wondering if you ever found a solution to this problem. I have a similarly equipped 01 SuperCrew and the Map lights do not work independently. All come on when the door is opened and all work via dome light switch on dash, but none will come on ... 2002 Ford F150 Regular Cab

I HAVE A 1997 F-150 4X4 EXT CAB,,THE HORN AND CRUISE DONT WORK,,,CHECKED ALL FUSES AND RELAYS,HORN WORKS WHEN I JUMPER THE RELAY 5 ON FUSE BOX UNDER HOOD,,,CHANGED CLOCK SPRING STILL NOTHING WORKS,,,CRUISE WONT EVEN GO INTO DIAGNOSTIC MODE WITH KEY TEST,,DASH LIGHT DOES NOT COME ON AT ALL,,PLEASE HELP


... Ford F-150

Blower fan not working at any speed,ac clutch not kicking in , checked fuses under hood,switched heater relays but still does not work, ac light does not come on ,recirculate does come on,the position switch you can hear work when you rotate, no voltage at blower motor is there fuses or relay somewhere else? stumped!


Check the freon there are high and low pressure swithes and will prevent a/c from workin\012to protect compressor ... 2006 Toyota Tacoma

My son has a 2005 S40 Volvo. About two weeks ago, his wipers stopped working as well as the windshield cleaner! I told him to check the fuses first, however, that model has a "relay fuse" and I don't know how to check that without just replacing it! My next thought is a defective motor and pump to the wipers! It sounds more likely to me to be a fuse problem since the auto sensor does not work as well! I would have to purchase a repair manual for that car since I am not familiar with where th


Thank you for writing all the info needed and the problem to make it easy for me to help you,this problem may be a motor but as like you i dont think the washer and sensor and motor would go out, i have enclosed pictures of the fuse boxes you will ne ... 2005 Volvo S40

The wipers stopped working on all settings. I checked and replaced the fuses but still not working. Wipers still work on "wash and mist" setting. Tried to locate more information if it is a relay or the switch. Which is it? Is there something wrong with the switch and how do I get to it to fix it? Or is it a relay?


If the fuse was blown then chances are the wiper motor is shorted and needs to be replaced. ... 1999 Honda Accord

Won't start. Just cranks over and over. Checked spark on coil, works. Put a little gas down intake, tries to kick over. So I know that it isn't getting fuel. So I also checked fuel relay by swapping out with the others that worked. Still no start. Checked all fuses, all fuses are good. It does have a remote start on it, so tried with it, and it does same thing, just cranks. Out of ideas. Summary of when it started. Just died pulling into parking lot, tried cranking stayed started, but


Check the fuel pressure. ... 1994 Dodge Dakota Club Cab
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.5847 seconds