Having problems with your Cars & Trucks ?

I have a 2005 hyundia sonata 4cylinder that has oil in the head when I pull out the spark plug. it is also miss firing 190,000 miles

\015 Has oil in the cylinders when I pull out the spark plug\015 Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Usually its a head gasket if not valve seals if the oil in the head is creamy thats antifreeze blown head gasket if it got to hot it will worp the head needs to be machined before you put it back together or worn out piston rings
Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 2005 hyundia sonata 4cylinder that has oil in the head when I pull out the spark plug. it is also miss firing 190,000 miles


Usually its a head gasket if not valve seals if the oil in the head is creamy thats antifreeze blown head gasket if it got to hot it will worp the head needs to be machined before you put it back together or worn out piston rings ... Cars & Trucks

I have a 97 chevy tahoe. I changed the spark plugs, wires, distrubutor cap, rotor. About 300 miles later engine light came on. I thought maybe cheap distrubutor cap and rotor was cheap. I went to auto zone and got another one. Engine light came off on free way. Came back on later on that day. I checked compression test was good. Only miss fire on cylinder 6. So I changed plug and wires again. Still engine light is on. You can on tell the miss fire when your at a stop sign or going slow. Also I


The number 6 cylinder is located (if you are looking at it from the front of the car) it is on the left side third cylinder back from the front. you probally have a bad injector that is just dripping fuel into that cylinder. ... 1999 Chevrolet Tahoe

My husband did a tune up on my car yesterday and now it wont start it will turn over like it wants to start but it wont he said that its miss firing we have bought 3 new coil packs and still will not start he has also changed the wires and spark plugs back out to the old ones to see if maybe the problem was the new wires or spark plugs but still is miss firing what could the problem be?


Sounds like he switch or mix up the firing order. The plug wires need to fire in a certain order.\012If the #1 wire is not on the right plug it won't start up it will just turn the motor.\012You can go on line and look up the ... Pontiac Grand Am

2000 dodge stratus keeps stalling it fires right back up sometimes, other times it takes some cranking. There are three codes it's showing P0725 engine speed sensor circuit, P0108 manifold absolute pressure sensor voltage too high, and P0700 transmission malfunction present. I also pulled the first spark plug out and when the engine runs it misses and sometimes stops all together for 1-2 seconds. I'm broke and can't afford to run through 4 possible solutions.


... Cars & Trucks

Just changed spark plugs, around 150 miles later noticed a sputter or mis-fire between 45-60 mph. pulled the plugs when i got home, no obvious issues with the plugs. problem continues to persist and the truck is progressively running worse. the check engine light just now came on. runs rough at idle and all the way through highway speeds. removed all the 10mm bolts to the coil packs and pulled each out one by one. even swapping the packs that were thought to be bad. getting an intermittent spark


Hi, I recommend you get a free scan at your local parts chain and write down the trouble code. I suspect you have a bad crankshaft sensor, but the scan will confirm. Send us the trouble code if you would like further assistance, and thanks for usin ... 2003 Toyota Tundra

Orange spark Vehicle started missing. Finally would not run. Pulled the spark plug and it was firing orange not blue. Replaced distributor. Ran for a day. Did the same thing again would not run orange fire on spark plug. Waited a week vehicle started and is running now.


... 1999 Nissan Pathfinder

Low Vacuum For the last 25,000 miles (currently at 192,000), my engine has had a miss. I replaced the spark plugs, spark plugs wires, distributor cap, and rotor. I also replaced the EGR valve, ignition coil, and fuel filter. There is still a miss. It is most noticeable when the engine is cold. I drive a 1994 Chevy K1500 4.3L V6, AT. I did a vacuum test and the dial read 15 inches Hg. I don't know what Chevy says it should be, but that sounds low. My question is, is that low? If so, what are comm


You might try having someone run a compression test on it it or something you can do easily . might be valves are leaking by some and you might be loosing compression. with that amount of miles very possable its getting there. thanks Jerry ..holler ... 1994 Chevrolet K1500

Hi there my service engine light came on we had it tested and it was cylinder 1 miss fire and we had that fixed she was running rough but not as bad till i went to town and now the service engine light is back on and she is running rough again and missing,i bought brand new spark plugs and spark plug wires and a used coil pack and still running rough and service engine light is back on.And it also takes a while at times to change gear.My car is a 1999 Saturn Sl1 1.9engine single overhead cam cou


Ck compression on cylinder could have burned valve if no could be injector or coil ... 1999 Saturn SC

Engine troubles ok i have a 03 corolla with 140k miles when im driving it sometimes it seems like if it miss fires a studder or i checked all spark plugs but they all had the white stuff meaning they fire and two of the holes where the spark plugs go are brownish


Fuel injector cleaner could help... maybe check the order of the plug wires, if that doesnt help i know autozone has a free computer diagnostics your car is new enough for that and it would probably be the best way of figuring this out ... 2003 Toyota Corolla

1990 camry 4cyl. motor turns over but will not start. has 105,000 miles on it. I have pulled the plugs out and they are firing. Gas tank is full. Have unplugged and reconnected all connections for the electrical portion of the distributor. If the coil was bad would it still be firing or could it be a weak firing to the plugs, I have replaced the spark plugs and am just puzzled to what it could be please Help


Generally coils either fire or they dont fire. when cranking the engine be sure you rocker arms are moving. to see if your timing belt is not broke or stripped. hope2help shack ... 1989 Toyota Camry

Miss fire i have a truck 1996 ford ranger xlt two wheel drive engine 3.0 has miss fire cilinter #4 i chage sparks plugs and wires also but check engine light is till coming out said it miss fire cilinter #4 what can i do to fix this problem. thank you.


The fuel injector may be faulty in that cylinder ... 1996 Ford Ranger SuperCab

1994 Mitsubishi Diamante. I had this problem for a while now. When the engine is hot it gets worth. The engine is miss firing, I replaced spark plugs and wires a year ago. i also replaced Air miter. The car does not miss firing all the time as i said. It only does when the engine gets hot or when it is like 90 F temperature outside. When it idles it misses a bit . for every 2-3 seconds interval it misses one random cylinder. I have checked the wires while engine is running and they send the spar


Check or relace your coil pack due to the fact that when a coil pack is going bad it usually looses its umph. when it get hot and that would explain random miss fires ... 1994 Mitsubishi Diamante

My 2002 envoy has a miss that just started==was driving on the freeway for about 40 miles @70 pulled n a station to get a drink ==started it back up and it started missing like a dead plug or coil i changed all the plugs looked like 1 was not firing-so i put in a new coil on that plug and didnt help


2002 Envoy sle 4.2 L straight 6. Random misfire(PO300). After erasing codes for several days, I finally took my car on the highway and ran it at high speed(70+) for about 4 to 5 miles. Check engine light came on as before but this time it gave m ... 2002 GMC Envoy

I have a 2002 model manual Ford Focus. The best way I know to describe what it does is "acts like there is water in the gas". It starts losing power and has a really bad miss. It will finally quit pulling at all and I have to pull over, turn the car off, and sit for a minute or two. When I start the car back, I usually have to rev it and then it will go for 30 or even 60 miles before it happens again. This has happened 3 or 4 times. I have changed the coil, spark plugs and plug wires. (al


Hi...\015\012If you said. The scanner show the code P0304. Missfiring on cylinder # 4.\015\012The first step is: Check Compression on that cylinder.\015\012 Check or replace the FUEL FILTER. \015\ ... Ford Focus

Won't start My 1992 Lexus SC300 will not start. It turns over like it is going to but never quite gets there. There is spark coming from the coil but the spark plug that I pulled does not seem to be firing. The plugs and wires along with the cap and rotor were just changed less than 1000 miles ago. I've tried a new coil, cap, rotor and even the ignitor module. Still does the same thing. Any ideas?


U can losen the fuel line at the back of the rail by the egr and put the jey in the on position and see if gas leaks since u don't have a fuel pressure tester easiest way I know if u smoke u might not want to while checking that ... 1992 Lexus Sc 300

NO FIRE I HAVE A 99 HYUNDAI SONATA 4CYL AND CRANKS BUT DOSN'T RUN SEAMS LIKE THERE IS NO SPARK BECAUSE I PULLED SPARK PLUG WIRE AND CRANKED AND HAD NO FIRE. TE TIMING BELT IS GOOD SO NEED TO KNOW NEXT STEP TO CHECK


Hi there, you need to make sure all wires to spark plugs are tight and very snug, you will also need to check the distributer cap to make sure no burns are on it, and make sure the plugs are in proper firing positions, the spark rotation might be out ... 2006 Hyundai Sonata

I just gave my 2001 dodge ram 1500 a tune up, new spark plugs, wires, cap, and rotor. it ran well for about 3 days on the fourth day it started miss firing and threw a code. I didn't get the code number but the diagnostic machine said it was a radom miss fire on 3 and 4. I have put a new ignition coil on also.


P0303, P0304? check the routing of the wires and make sure they are snug at both ends. See if they are routed too close to the engine or any other ground point. Did the old wires have any covers or conduits that you did not reuse? You can probabl ... 2001 Dodge Ram 1500 Truck 2WD

97 Toyota Camry Has been having issues lately. First it started to miss fire a lot kept getting the code p1300 so i was advised to get a tune up i did that. Tune up included spark plugs changed, wires changed, mostly the electric stuff. They also noticed that the catalytic converter went bad i think it started to hear up to roughly 700F.. After thous two things done the car still kept miss firing so they tested if the coil was bad changed it out with a good it still didn't fix the problem so th


Has anyone checked the Crank position sensor or knock sensor? If the Crank position sensor isn't reporting the correct position of the crank when it turns the spark plugs are firing at the wrong time. This could be because of a worn timing belt or f ... 1997 Toyota Camry

'91 miata 60M miles - all of a sudden the engine runs very rough at low RPM's and when idling. New fuel filter didn"t help. I cannot detect any vacuum leaks. New spark plug wires and spark plugs at 30M miles.When I accelerate to 2500 rpm's in Park the engine runs very smoothe. In drive there doesn't seem to be much response to throttle from "O" to 30. Just a lot of missing. I have not toyed with any of the settings. I have also replaced the PCV recently. The car ran fine at that point.


Change the mass air flow meter ,the one in the pipe from the air filter to the inlet manifold ... Mazda MX-5 Miata

Low midrange power and very poor acceleration. I replaced the air filter and spark plugs, checked the wires and they looked fine. It pulls out ok and bogs down at mid throttle, then if you keep applying fuel it picks back up. It will also miss and run poor if you let off the gas slightly. When I pulled the plugs they looked like it's burning a little lean, but maybe that's normal.


Check fuel pressure/filters and airflow meter. ... 1999 Saturn SL

1997 ford expedition 190k miles. Engine was missing. code said it was miss firing in the third cylinder. Replaced all ignition coils and sprak plugs also fuel pump. After 100 miles it started with the same symtoms? What else could it be?


It could be a bad computer that doesn't fire the fuel injector on that cylinder. Or, the fuel injector is clogged on that cylinder.\015\012\015\012The fuel injector should have a telltale click when listening to it operating on that cylin ... 1997 Ford Expedition

E250 V8 5.4L van with 8 individual packs on spark plugs. I have 2 cylinders misfiring and have change both packs on those cylinders, still miss fires. Also changed the EGR, no difference what so ever. In addition, installed 8 new plugs and the van still runs with a miss and has no take off power. The one thing I havent tried was cleaning/replacing the mass air flow. What else could be causing the issue? Any suggestions would be very helpful. Thanks! Ed


Go to Autozone and get free test for DTC codes. Report them here.\015\012You may have bad drivers in the PCM caused bu the bad coils. Just a maybe.\015\012More common with 3.0L V-6 in Escape. ... Ford E-Series

I changed the spark plugs on my 2004 Mazda6s V6. The car idles great and is smooth at highway speeds. Really anything above 2K rpm it works great. When it tries to accelerate between 1400rpm and 2200rpm it seems to miss fire now, but it never did before. I used the recommended NGK Iridium plugs, any thoughts on what could be causing this? Also, it doesn't always is fire in that range, but about a third of the time it does.


Distributor cap lol...check plug gap, the plugs come pre gapped, but they aren't just used for the mazda 6. Be careful not to break the ground electrode or the tip. ... 2004 Mazda 6

I am having troubles with my 1999 Monte Carlo, it's seems smogged down, all of the exhaust system checked out good, I pull #3 and #6 spark plug wires off with the car running, no change, but coil checked out good, changed #3 and #6 spark plugs and wires no change in how it ran, so replaced coil anyway, still runs the same, had the ignition module checked and it appeared to be good also, doesn't seem to be fuel injectors, did the stethoscope diagnostic and they're all firing, could it be that the


I would be doing a compression test , could be burnt valves or a broken camshaft . I have seen the V6 3.8l Buick engines snap camshafts just in front of the 2 rear cylinders this causes the front 4 cylinders to work perfect but the back 2 do nothing ... 1999 Chevrolet Monte Carlo

2002 pontac sunfire 2.2 twin cam No the pluge are not fireing on 2 & 3 Comp is fine, inj. are working. If you physicaly pull all the plugs, and ground them only #1 and #4 fire. I first figured it was the coil packs also, so I got a new unit. But same thing No spark on 2&3 plugs. It's my nabers car, and I am just doing them a favor. They are the broke heppie types, and I have allredy waisted 150 of ther money diaging it wrong!! I am now thinking its the madual, and that is another 150 so I wont t


More than likely it is a bad ignition module. ... 2003 Pontiac Sunfire
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.2261 seconds