Having problems with your Cars & Trucks ?

Voltage alternator is only putting out 12 when it should put out 13-14amps it won't charge my new battery

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

That is no output at all, that is just battery voltage. You will need to find out what is causing this, it can be the alternator or the wiring connector to it.
Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Charging system I have a 2000 ford explorer xlt. 4.0 SOHC v6. I put a new alternator in it twice and a new battery. The old alternator tested bad and 2nd alternator tested good but still wont charge battery or run the truck. with new battery it ran for half the day 40 miles of start and stopping then is dead again. The voltage gage was barely above the L mark when new battery and alternator was put in.


Change your battery cables and check all wires on the alternator for loose connections, expecially the grounds. ... 2000 Ford Explorer

I got a new battery when my car completelty died after having trouble being stuck in some mud. The battery light was still on and my mechanic told me I more than likely needed a new alternator. So on the way to get the alternator my car died again. I got a new alternator and put that on but my car still hardly made it home. We put it on a charger ,thinking that because I drove it with a bad alternator it pulled down the battery. ...the light and battery meter still are showing low batt charge(li


Is the ceck engine light also on when its running if so find the diagnosis for the trouble code you probably should check for a trouble code even if the light is not on.you always must totally recharge a dead battery with an outside charger the alter ... Ford Mustang

I have a 92 gmc k1500 pickup with a 350 throttle body motor in it we couldnt get the alternator to charge so we cleaned all the grounds and put a new alternator and new battery now its way over chargeing is charging so hard that my red cable that runs to my battery was starting to melt so i unpluged the battery and plugged it back up and now it wont charge its got me puzzled what could it be please help


Either that cable going to the battery is shorted to ground somewhere (maybe on the body of the alternator) or the alternator is defective. there is a chance that you put one of the wires wrong on the alternator and you are forcing it into full field ... Cars & Trucks

Put a new battery in. alternator not charging-put in a new alternator still not charging. machine showed a drain on the battery what could this be?


What machine? who tested it? who sold you these parts you didnt need? take it to a qualified repair shop that knows HONDA and can fix it for you, instead of taking monbey from you for uneeded parts. ... 1998 Honda Civic

I have a 2002 nissan primera sve 2.2. battery light started flashing charge warning on screen come on got new battery still did it put everything on and it stopped it was over charging put another alternator on then 120amp fuse went put new one in warning light on all the time now batt. charging at 15.2-15.4v anybody know why


... Nissan Primera

CHARGING SYSTEM MY 90 FESTIVA SEEMS TO LOSE THE CHARGE ON THE BRAND NEW BATTERY AFTER IT SITS FOR A DAY OR TWO. I PUT THE NEW BATTERY IN BECAUSE I THOUGHT IT WAS THE ALTERNATOR, THE ALTERNATOR TEST GOOD AT TWO DIFFERENT PART STORES. NOW I DROVE IT ALL WEEK AND SMELLED AN AWFUL SMELL, OPENED THE HOOD AND THE BATTERY WAS HOT AND SMOKING AND BOILING OVER. OPENED BATTERY AND IT IS NOW BONE DRY. IS THERE A SHORT AND IS THERE A VOLTAGE REGULATOR SOMEWHERE. I COULDN'T FIND IT JUST LOOKING WITHOUT KNOWI


Well for starters your altenator is bad because what it is dolinging is over charging the battery hence why it boiled off the water/acid in the battery. the regulater is intergrated into the altenator. there is not a short because numberone your car ... 1990 Ford Festiva

1990 GMC Surburban having charging problems with. The battery drains down to the point where the truck will die. Took the battery into auto parts store, which they tested and said it was good. Thought it must be the alternator, I installed a new one and the problem remained. Removed new alternator and put previous alternator back in. The belt was frayed and cracked so I replaced that too, thinking there may not be enough tension or there may be some slipping. I have to charge the


Check the red wire from the alternator where it hooks into the battery terminal. The wire may be corroded inside the plastic insulation of the wire and not making connection. It may even look ok and still be a bad connection. ... GMC Suburban

My van looses battery charge. Just put a new alternator, and a new battery in, and now the alternator is not charging the battery . What could the problem be?


Before the alternator was replaced it was important that the charging current was measured with an ammeter to confirm charging.It is possible that the rectifier/regulator to the alternator is faulty.This electronic control unit determines the chargin ... 2003 Chevrolet Astro

Jus t put a new motor in and new alternator and starts fine but after driving,looses power to battery and I checked to see if there is charging to battery but nothing what should i look for ,I have checked wiring from alternator to fuse box for continuity is good but when car is running there is no charge to battery


Ck the back side of alt,,for power wire ,,ck voltage,,,bad part or broken wire or connector plug is goog no bent pins in plug ,,or green cheese,,rotted out,,, ... 2006 Pontiac Grand Prix

2000 ford ranger. New battery and brand new alternator. Alternator only puts out 11 volts and wont charge the battery. Is there a fuse or relay that would cause this? I assume that it would not put out any current at all if the fuse or relay where bad. What should I check?


Hi,It sounds like the alternator voltage regulator. With the engine running you should be getting between 13 - 15 volts (steady reading) across the battery terminals. I am assuming you have good cables connected between the battery and the alte ... 2000 Ford Ranger SuperCab

Alternator not charging battery but alternator is good wheni turn the car on with nothen on it put 4 amps back in the battery as soon as i turn the light and radio on it only puts a half of a amp back in i just put a new alternator and power steering unit in it


YOU MIGHT HAVE A DEFECTIVE ALTERNATOR WHAT I WOULD DO IS BRING IT BACK AND HAVE THEM TEST IT. CHANCES ARE THAT IS WHAT HAPPENED, I'VE HAD IT HAPPEN TO ME ALOT. GIVE THAT A TRY GOOD LUCK. ... 1987 Ford Tempo

Support for the charging system 2000 Lincoln T|C My alternator light stays on and the battery will not charge and I put in a new battery and alternator and the light still stays on and the battery still does not charge and all the fuses are checked and they are all good and there is no power from main plug.


Check with dealer there are recalls on the 2000. ... Lincoln Town Car

1997 Lincoln Continental new battery and alternator. the alternator is charging 11.6 volts at alternator and also at battery. I have put on three new alternators on today. They do pass load test at Auto Zone. Where should I go from herr? I have checked for burned wires.


It seems that their is a bad connection on the alternator plug or somewhere along the wires an open small area is touching the body or shorting out to earth so to speak.Clean the contacts inside the alternator plug and thouroughly examine the wires t ... Cars & Trucks

Somerset Alternator I just bought a 1986 Buick Somerset used for $100, and I was told it needed a new alternator, So i picked on up at a junk yard took it to shucks and they told me it was in good working condition. So put it in. and now its not charging my Battery. I had my uncle take a look at it, and he is stumped at the moment too, I think it could be a fuse but Im not sure which one powers the Alternator, Anybody got any ideas why it wouldnt be charging? I know the Battery is good. Addition


I have a 1985 Buick Regal Somerset with similar problem. I solved issue by purchasing a high output alternator that would charge battery and power all accesories better. This helped along with changing the size of alternator pulley. If voltage output ... 1986 Buick Somerset

1985 honda accord, put new alternator in, charged the battery, drove 100 miles, then battery lost power and lights went dim, car died.


... 1985 Honda Accord

I have a 1998 expedition and i just put a new battery, alternator and starter. but the alternator is not charging the battery at all.. what else can it be? what else is in between the battery and alternator besides the wireing harness? the wires have continuity so they are good. the battery keeps on dieing


I had a similar problem with my 93 mustang. my idle was so low that the alt. couldnt give enough voltage to the battery to charge it. If your expedition is running low RPM try checking that ... Ford Expedition

I have a 2001 ford escort zx2, just put a new alternator and battery in the car.the car will start and run, but after a short amount of time the battery acts like its not charging. the rpm and speedometer gauges stop working then the radio goes out. and eventually dies. when the alternator and battery were tested with a voltmeter the battery was reading 11.2 volts with a load and alternator was 12.1 volts


It sounds like you don't have enough belt tension and it's causing your belt to slip. ... 2001 Ford Escort ZX2

Mitsubishi Fto alternator has mind of its own? Hi want to tell you a story.Bought Fto with no alternator belt and dead battery.bought new battery,realised alternator not charging.got a quote to replace alternator and before taking it to the garage ,i've put some petrol (tank was empty),and guess what,alternator started to work.,but that's not the end.after couple of rides(i guess i drained tank again)alternator stopped charging.got car to petrol station put half a tank,alternator seem to charge


... 1995 Mitsubishi Galant

My 1978 Chevy Impala loses its charge when I put any load on the car, ie lights, radio ect. I have a new battery and a new alternator on the car, my batter continualy losses it charge and I cant figure out what the problem is. The alternator is grounded.


Most likely wiring around alt or starter any aftermarket radio,amp??? car alarm??? check for open wiring . the alt.can be checked for free at any Autozone.sounds like open wires somewhere or maybe one that is grounding out on the car engine or fram ... Chevrolet Impala

Alternator problem alternator putting out 13.2 volts new battery. a mechanic said it needs 13.8 volts just to run the computer system. Wont't start unless i put a charge on battery


Comp systems will run on 10 volts, so I don't think that's the problem. I'd check all cables and connectors pertaining to positive and ground and go from there....accordianman ... 1998 Saab 900

Put new alternator on getting fire to charge light when switch is on bulb is good but want come on fuses good new battery buy want put fire back in battery when running


You may need to go back and get another alternator cause this one sounds as if it has a bad voltage regulator in it also give these websites a try www.autozone.com and ... 2000 Mercury Sable

Was told the alternator was the problem specifically the regulator on the alternator. Bought new regulator from repco and removed old one and put new one in but car wont start it is making a funny tick tick tick noise. Do I need to have someone charge my battery to get car going or could I have possibly not put regulator in properly? Have removed and replaced it abour three times thinking I had made a mistake. Please advise me? Thank you so much.


Tick tick noise is generally a low battery have the battery checked and charged ... Cars & Trucks

Charging system light is on. Have replaced alternator with new one. Alternator is working yet i still have no charge at the battery, i have had it put on a machine. Still dies when i pull the negative battery cable.


Check the main power wire at the altenator. Chances are the fuse link or power\012 fuse in relay center is the fault.Let me know if that helps. voltmeter ,or test light would be helpful ... 1996 Mercury Mystique

Charging system light is on. Have replaced alternator with new one. Alternator is working yet i still have no charge at the battery, i have had it put on a machine. Still dies when i pull the negative battery cable.


Check fuses under hood for alternator fuse ... 1996 Mercury Mystique

I have a Dodge 3500 van with a 5.2 engine. The battery was discharged which led me to believe the alternator was not charging. I put a voltmeter on the batttery, and there was no charge. Therefore, I replaced the alternator with a new one, and the alternator does not charge.. Could it have a defective voltmeter?


Hi,Are you sure that there is battery power to the new alternator?If the answer is ' yes ', this seems to be a bad news for you.On most occasions, it is bad ECM.Make sure that the connector is fine.How ... Dodge Ram 3500
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 2.5361 seconds