Having problems with your Cars & Trucks ?

ENGINE RUNS ROUGH WHEN IDOL ON MERCEDES BENZ E500, 2003

\015 110,000 mercd. E500 runs little rough @ all times (Engine: cold, hot) only when car is idol (first start car or @ a stop sign). Did tune-up (merced. spark plugs & air filters), did not change spark plug wires. New mercd. air filters & large bottle of "Lucus fuel injector cleaner w full tank. always put super unleaded gas. Sprayed throttle box with carb. cleaner solution. There's a slight hesitation (intermittent cut-off of the engine, as it's not getting enough gas, seat shakes a little, engine also shakes a little. Not smooth continuous flow (flawless) humming of the engine. May one of the vacuum hoses is off. Also which I've had this for a long time, there's a fast "ticking" (clock ticking) sound that seems to come from the first spark-plug area directly (closer to the front of car) intermittently. I'm not sure if I should change all spark-plug wires or have them tested. Advanced auto diagnostic tool did not detect any codes??? ANY FEED BACK WOULD BE APPRECIATED. THANKS\015 Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

ENGINE RUNS ROUGH WHEN IDOL ON MERCEDES BENZ E500, 2003


... Cars & Trucks

Hello' I have a 1997 Mercedes-Benz C-230 gas engine vehicle. Here is the issue that I 'am currently having. The car will turn over and run a short time and then the engine stop running. I truly do not know at this point, what are the main problem issue? The engine could not be getting any gasoline into the injector? Could anyone with knowledge of Mercedes Engine please help me with this issue Please hit me back with the answer Please Joseph.


... Mercedes-Benz E-Class

Engine stalling hi, i have a mercedes 1992 e300 2.6 l petrol engine & the problem is that it will stall & run rough at odd times, i have had the fuel pumps, filter, relay & fuel injectors all replaced now with some success but the stalling & rough running persists. after the motor stalls & stops if it is left for a hour or 2 it will then start & run just fine. anybody got any clues. much appreciated. thanks, ken


Hi,you my check the distributor cap and rotor clean or replaced if necessary. ... 1992 Mercedes-Benz E-Class

I have a 1995 Mercedes Benz SL 500 that runs rough when started after sitting for several days.


... Cars & Trucks

Engine Dear Sir, I have problem with my 1995 Mercedes Benz C220 engine, during cold start, when I try to floor the accelerator engine choke as if there is lack of fuel, sometime cause a back fire. After warming it about 5 minutes the engine runs well. I check the timing with a timing light it's OK. What seems to be the problem? Do I have to warm it up before I run the car?


Dear FixYa Team, I have the injectors clean up and replace fuel filter, but still it did not work. I think it's the intake valve is sticky, when I remove the injectors there were carbon inside the intake. Whenever I pump the accelerator intak ... 1995 Mercedes-Benz C-Class

1986 mercedes benz 230e runs rough and stalls


Could be the fuel regulator and fuel injector need to chamge ... 1991 Mercedes-Benz E-Class

Smelling antifreeze,i hear maybe waterpump,engine lightly sprayed on top in front of fan, engine runs rough when idleing but runs great at normal riding speeds running like this since august 08, when purchased ,tachometer reads halfway between 0 and 1 grand car leaks very little oil. put on 11,000 miles.


Could be a hose or the water pump either way when it leaks your fan is blowing the coolent back on your engine and could be blowing on your ignition wires making them wet and causing a miss fire. Do you have to add coolent regulary? ... 1992 Toyota 4Runner

Mercedes c200 running rough switch off engine restart and it runs normal again


... 2001 Mercedes-Benz C-Class

I have a 88 chey k3500 5.7 litre. 4x4, the engine came out of an older blazer and was converted to a fuel injection. it runs really rough , i have put new plugs, wires, rotor , dis-cap. i did the timing set it to 0. adjusted the valves. put a new fuel filter , pump , and sending unite, i drained the old fuel and put new stuff in there, and cut out the cat converter, still runs rough, any other sugestions would be greatly appreciated. i did notice that there was a kink in one of the fuel lines ,


Check the timing chain. Aim your timing light at the mark when it's running. If the mark is jumping all over, the chain has jumped a cog, and will need to be replaced. Check the cam. Run it witht he valve covers off, and see if all the lifters are mo ... 1988 Chevrolet K3500

Engine management light comes on and when its sat at lights it runs as rough as a bears arse. replaced lambda pipe 2 sensors on the exhaust pipe and a cam sensor and still runs rough on idol


This is where it would of payed to just get it diagnosed. By your symptom description I would never of suspected those two parts as being the cause. With the light being on the code would of told you what cylinder is misfiring. This makes it easy ... 2002 BMW 5 Series

I have a 2001 Hyundai sonata. While driving home I started to lose power. I pulled over and the engine was running extremely rough like it was miss firing and halfway between the 0 and 1 on the rpms. Not sure if that is abnormal or not never payed much attention. Any ideas on what. Would be causing it. As of the moment it is not running. It turns over but does not start. And does anyone know if I can manually check the engine codes?


You can only check for codes with a code reader orProfessional Scan ToolAfter 30 years of these systems, it is had to believe peopleknow nothing,how is thatNormal,abnormal,don't pay attentionWhen I spend $40,000 fo ... Cars & Trucks

My car is running a little rough when warmed up and I'm creeping along accellerating from 0 mph to 10 mph (like in a parking lot). By "rough" what I mean is there is a slight feeling of vibration I can feel through the steering wheel. My mechanic adjusted the engine timing and that did not fix the problem. He said he thinks maybe something is slipping inside the automatic transmission, or maybe it's a problem with the engine mounts. But I have since noticed that my fuel economy has decrease


Mcdevito75 here, It is possible something in the tranny could be wrong especially if your tranny has a sensor that is read by your cars, computer system, a bad engine mount would cause the engine to shift position on the chassis while driveing, even ... 1991 Acura Integra Hatchback

My mercedes benz W202 C200 1995 engine running below 0.5 when i put on the AC


1 the fuel pump is under the car at rear on the right side of the car.2it could be degrading wiring just cut a little of the cloth insulation on the main loom by injectors and also if it's an auto then also throttle body wiring ... Cars & Trucks

Mercedes Benz 1995 C200 engine run very slow with Air condition and turn s off


... Mercedes-Benz Cars & Trucks

Radiator coolant I recently noticed a small crack in the lower radiator hose of my 1992 190E 2.6 Mercedes Benz. I quickly replaced it and started to add coolant. After adding, I turned on the engine and the coolant started to drop as the engine "burped." But now, the engine is still running very hot. What's wrong?


First question is after you changed your hose and refilled while the car was running with the radiator cap locked but loose with the heater on high and set on hot run the car till the thermostat opens shut the car down once it does anti freeze level ... 1992 Mercedes-Benz 190

I have mercedes benz ag, om442la, DIN no. 6271, v-8 engine, we want to know the Tapper valve clearance for Inlet & Exhaust valve, also we have assembled the engine new but radiator water is coming out from the cap after engine running for 10 min, we checked all the connections of water system and even replace water pump assembly but no result,


... Cars & Trucks

Engine Mechanical problem 1990 Mercedes Benz 300e 6 cyl Two Wheel Drive Automatic 190,00 miles When car is just started it runs great. As soon as it gets to running temperature it runs terrible. It appears to be fuel related because when you step on the gas it does very little unless you nail it. Then it takes off. Its not like you can feather the gas, it is all or nothing. Sometimes it makes a popping sound. No power unless you put petal to the floor. Replaced gas tank, fuel pump, fuel


... 1989 Mercedes-Benz 300-Class

1997 Ford Thunderbird LX V8. Engine running rough. Feels like it wants to bg out, but doesn't. When starting up and idoling seems okay, but when put into drive, engine


... 1997 Ford Thunderbird LX

92 geo 1.6 l shoc sounds like a missing v-8 exhaust has a lot of raw gas smell to it and it runs extremely rough until warm, if trying to drive before it is warm, tach will drop to nearly 0, engine will almost stall then jump up to 2500 rpm drop back down about 1000 rpm. runs perfectly normal once warm


... 1992 Geo Storm

Mercedes Benz B Class 150 SE Fishy smell when you get into the car. However once engine running smell goes somewhat. Then when engine is turned off the smell comes back.


Could be some type of fluid leak, possibly coolant enteringthe fan housing inside under the dashOr a water leak from sun roof onto carpet ... Mercedes-Benz Cars & Trucks

Mercedes a160 runs rough - A Mercedes-Benz Cars & Trucks


... Mercedes-Benz A

1983 mercedes 380 sl runs rough at idle - Mercedes-Benz Cars & Trucks


... Mercedes-Benz Cars & Trucks

My 1995 S500 Mercedes Benz is idling very rough. It runs great while driving but idles very rough. I have changed the spark plugs,wires,distributor cap,had fuel injector cleaned by a pressurized system,change rotors as well,it has 95000 miles on it, could you give me some suggestions. Thanks, ED


Before you spend any more money on your vehicle run a cylinder compression test. I know it seems unlikley with less than 100,000 miles but 119 engines do like to burn valves. the LH fuel injection system was only used from 93-95. LH is a germen abrev ... 1995 Mercedes-Benz S-Class

W 1990 mercedes 560 SEC. Starts fine after about 2 minutes or miles th choke kicks in and it runs rough and surges for about 10 miles or minutes. there is a strong odor of raw gasoline. If I stop and turn off the engine and let it set for about 3 minutes it will run normal. Gas milage goes to about 10 mpg during this event during this time the vacuumgages is almost pegged in the red. Is this a electrical or mechanical problem?


... Cars & Trucks

Hi there,my 2000 jeep cherokee 4.0l temp gauge keeps going up and down,goes up to normal when the car is at idle in drive and then will start to idle rough then miss and then want to stall,and then when i drive the temp gauge goes down to 0 and seems to run rich and get run-on in the revs can you please help me??????and there is no engine check light coming on, thank you


It sounds like a fualty sensor like camshaft sensor or bad 02 but the check engine light should be on if the problem is sensor or electrical related. I would change temp sensor and thermostat. Sounds more like faulty temp sensor if the car is running ... 2000 Jeep Grand Cherokee
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 5.1873 seconds