Having problems with your Cars & Trucks ?

Caprice 2002 model : At speed of 110 km, suddenly my car got heated, then i changed Radiator and scared of going at a speed of 110 or more...Whether it is rectified or still something else needs to be fixed ?

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

First, need to check the cars thermostat, it may be that you need to change this to a lesser high side temp.instead of a 185* go with a 165* or similar one, secondly make sure the system is circulating properly and all cooling parts, (fans, belts, shrouds etc ) are working good.I am assuming that these speeds are highway numbers close to or near normal.. 100km/hr is 60mph so 110km/hr is around 65mph so at hiway speeds the system should be ok..unless theres a bad gasket somewhere, usually a head gasket because thats where the engine pressure is the greatest..an easy test is to take your radiator overflow hose lose at the reservoir and dunk the end in a cup of water with the engine running, look for consistent air bubbles in the water this translates to engine pressure entering the cooling area and forcing the coolant out, thus reducing the capability of the system to cool properly..thus it calls for an upper engine gasket replacement, and this is time consuming..it takes me a couple of days to do.good luck
Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Caprice 2002 model : At speed of 110 km, suddenly my car got heated, then i changed Radiator and scared of going at a speed of 110 or more...Whether it is rectified or still something else needs to be fixed ?


First, need to check the cars thermostat, it may be that you need to change this to a lesser high side temp.instead of a 185* go with a 165* or similar one, secondly make sure the system is circulating properly and all cooling parts, (fans, belts, sh ... Cars & Trucks

1990 Chevy Suburban 4x4 shifts late and hard, particularly at highway speeds. The husband thought it was acting as if it wasn't getting fluid through the filter (starving for fluid) and he changed the trany fluid and filter. However, it is still shifting late and hard, though, and we need to try to get it fixed before winter hits us for real (we live in Iowa). Any ideas what's going on with the transmission and how to fix? What could be


There is a vacuum line that runs down to the transmission to the modulator. Either the vacuum line has came off on one end or the other. Or the modulator on the transmission is bad. It has to be one of the two. ... 1990 Chevrolet Suburban

I have a 97' Plymouth Neon, and I had it scanned for problems because the check engine light was on and it came up as the O2 sensor. I had that replaced and it is still comming up that I need a O2 senser and my car is still having the same problem.. So I was told to disconnect the batterie for a day, or clear the code and then the problem will go away, or to drive my car for 20 miles straight and then it will register that the problem has been fixed. Is this true? Have anyone else herd of this?


There is a primary and secondary sensor and someone may have changed the wrong one. disconnect the battery for 2 minutes and it will reset. if it comes back on,there is still an issue. ... 1997 Plymouth Neon

My 1997 ford aspire 5 speed manual sputters when going up hill and when taking off if your in too high a gear. It hasn't died on me yet. I can keep it in 4th but it sputters. It does need a tune up. Would this fix the problem or is it something else like the fuel filter or fuel injector? How expensive would it be to fix?


... 1997 Ford Aspire

Rough idle I have been dealing with rough idle ,put it in natural when coming to a stop because it shacks so much ...replaced the EGR valve...the idle control valve ,did full tune up ..adjusted idle speed (which did help for 3 days ) but came back ...also in the morning when I leave for work ,I am going down a small hill ..going down to a stop ,I have to push really hard on my brakes for the car to stop (scares me) ..still have great mpg ...I just don't know what else should I look for ...what e


... 1995 Toyota Tercel

My 2001 Monte Carlo with 115k on odometer has an electrical problem... first off my air fan speed control only works on number 5, second, as I am driving the vehicle the door ajar light will come on and the dome lights come on and the doors lock and unlock automatically. It is driving me nuts and I need to fix it! I also get out of the car thinking the dome lights will go off after I lock it and walk away... when I come back they are still on and never shut off! Please help me!!!


... 2001 Chevrolet Monte Carlo

Reset the wheel sensors on BMW e46 because my ABS/ACS/handbrake light comes on together and doesnt go out even when i'm driving. I recently took it to BMW to get a diagnosis done on it. It came back saying I need a wheel speed sensor. Got that fitted, but the lights are still on. How do i fix this? Please help. regards Darren Walsh


If you took this in and had BMW do the work to fix it and it is not fixed why do you not return to BMW and get it fixed, If you have paid for a repair and the repair did not solve the problem have them refund your money. ... BMW 318

My topaz has a sputtering problem! starts fine, idles fine, and switches gears fine! now it is fine when going like in first gear but when it switches then it sputters having hard time to go then at the speed I need it is fine! I can go freeway speeds also and everything is fine for most part just very light sputter! also Ive had to (truely needed to) replace starter, fuel pump, fuel filter and all tune up necessities but still has this problem! seems to also make the spark plugs go bad faster!


Here is what I would do I would get carb cleaner and clean the carberator really good and depending on what happend there I would get a set of hotter burning spark plugs after carb cleaned then I would see if it still makes sputter and then all I cou ... 1994 Mercury Topaz

Ok im not paying for anytning or going anywhere else to get advice i paid money to get advice from here so no i have a problem with a 1985 Ford f250 im switching out my AT and TC for a T-19 4-speed transmisson and TC and i need to know the color of the wires i need off the AT and TC to go to the New 4-speed Transmisson and which ones go to the clutch pedal itself and the ones to the shifter housing and Back of the TC Housing


Email me at [email protected] and I will help you free of charge...just refuse to pay anything....we will go from there.\015\012\015\012If you are on yahoo, let ... 1988 Ford F 250

I have a 97 mercury mountaineer that the front passenger seat back will not lock into place it goes backwards it is powered but has a handle lock for the back. The handle will go down if the seat is flat back but the seat still moves if the handle is up when the seat is up right it will not go down HELP I'm trying to sell it and had an interested buyer coming today. Even a temp fix will work and I can tell her she will need a new seat or whatever she needs I just want it fixed for now at least


... 1999 Volkswagen Passat

Help with troubleshooting speedometer problem. I had a "friend" do some work on my car a while back and ever since then my speedometer will just start jumping from 0 to 10 to 80 to 60 back to 0 at random. It jumps all over the place. Even in park it does this. When it does it going down the interstate it comes out of the torque convrter lockout. So I figure the speed sensor is going out in it. Replaced that and it's still doing it. Well I unplugged the sensor and it is still doing it. I dont thi


I had the same thing go wrong my buddy did not tell me that he droped the thans to the ground befor he saw that the speedo cable was not unbolted, I found out that he had STRETCHED the cable.\015\012not much but that was the problem, ... 1989 Chevrolet Corsica

I have a 1990 buick lesarbe limited with the 3800. i just recently did a dinostic test and it said i need to replace my cam sensor, so i did. now the check engine light is still on and it still say i need a new cam sensor. what should i do... it thought i should get new wiring for the sensor but i would like some one else's opinoin before i go spend money.


You will need to replace the interrupter aka. cam magnet. This will require removing the timing cover and cam gear to put it in. Also while you are there replace the cam thrust spring,chain and tensioner. ... 1990 Buick LeSabre

I have a problem with my reverse lights i found that the switch had been cut. so i went out a bought a brand new 1. i have now revmoved and installed the new part and the reverse lights still aint working can you plz help all the fuses are still fine i even bought new fuses and replace with the old one and still no go i don't no what to do and i need it fixed asap.


It sounds like you did everything correctly, the only 2 things I can think of is:\015\012\015\012Check contacts in reverse lamp housings and they're grounded\015\012\015\012And how about new bulbs? ... 1989 Honda CRX

1987 Plymouth Reliant K, 8yrs setting, still in mint condition, less than 10,000 orig.miles, I need to know if there is a fuel pump n if so where its located. I also need to know is there going to be more than just removing the straps n bolts to get the gas tank down. Yes I'm female and I need answers because I'm fixing this one for myself! Also if there is anywhere on the internet where I can get free pdf files of maintenance on this particular car


Disconnect the negative battery cable.\015\012Relieve the fuel pressure.\015\012raise the vehicle and support safely\015\012Drain the tank\015\012Remove the screws that hold the filler neck to the quarter panel\015\012Di ... 1987 Plymouth Reliant

I have a 2000 Chrysler 300m. I had a problem with it about a month ago where the car would rev on its own without me touching the gas peddle, the car would go into limp mode, and it while I was driving it it would rev up without actually increasing my speed. I read that it could be a problem with the input speed sensor. So I changed that. And now a few weeks later it is giving me the same problem. Could something else be wrong with the car, do I need to change the output speed sensor now? Thank


... 1999 Chrysler 300M

Car overheated Mechanic did a pressure check and also told me I had a small crack in the plastic reservoir and need a replacement. I was also told I would need a complete radiator flush which would be costly. A friend mentioned that it might also be a thermostat problem. I am scheduled tomorrow morning and want to have a correct diagnosis and remedy. What else can you tell me about the thermostat? If the reservoir is replaced and I still have the same problem, of course I want to have both fixed


Normal\015\012 0\015\012 \015\012 \015\012 false\015\012 false\015\012 false\015\012 \015\012 \015\012 \015\012 \015\012 \015\012 \015\012 \015\012 MicrosoftInternetExplorer4\015\012 \015\012\015\012 \015\012 \015\012\015\012\015\0 ... 1999 Mazda 626

My 2003 chevy trailblazer ls rpm gage has completly stopped working. when it first started going bad it would work on occasion and now the needle doesnt even move from 0. my car feels and sounds like it is shifting when it should its just the gage that doesnt work. what could cause this? is it a bad sensor, wires or something all my other gages work fine its just the rpm gage. if anyone knows how i can fix this problem please let me know what i need to check i want to be able to fix it myself if


... 1996 Audi A4

Fixing brakes I have a 1993 Plymouth Voyager van, the abs light stays on and when I push on the brakes it makes a humming noise. I have replaced all the brakes.... where do I go next? Still working on this 1993 Plymouth van, I can only find the fuse for the abs light on the dash, and when i pull it all of the dash lights go out....is there more fuses somewhere else?


Try bleading the brakes, sounds like you have in them. Than the ABS light should go out & you shouldn't have to worry about the fuses. ... 1993 Plymouth Voyager

My 1991 Pathfinder seems to have accelerating problems. When I step on the gas slowly, the idle seems to go too high and when I place my car on park, the idle seems to still go high... I was wondering if the problem could be that when my dad checked the transmission fluid, he put too much of the transmission fluid and now that's causing the accelerating problems??? Please help me... its my only way of transportation and I need to fix the problem right away before it gets any worse. Thankyou.


Yes that can be causing the issue and if it is not fixed ASAP you will have REALLY big problems instead of just having to drain some fluid. Please rate ... 1991 Nissan Pathfinder

Rear=end clunking Sounds like the rear-end of the 2004 F150 Lariat is changing gears very hard. One place said I needed a rear-end expert but I took it to Goodyear and they it needed a slip yoke and fluid differential exchange. It does not seem this has fixed the problem. It has become more frequent in the past several months and sometimes it tries changing gears so hard, I'm not sure its going to change at all. Anyone else having this problem?


Too much grease? that is a load of u know what, I am aware of the slip yoke noise, there is a Technical Service Bulletin (TSB) form Ford, did he use the special Teflon Grease (a 100% must use) to lube the slip yoke? regular grease won't ... 2004 Ford F150

I have been also trying to find the right firing order for a 1999 Corolla 1.8 automatic and I have seen three different answers all saying they are authoritive. One says 1.4.2.3, one says he is wrong and it is 1.4.3.2 on a 98-99 and 1.4.2.3 on later corollas, Autozone says it is 1.3.4.2. I have tried them all and I still get a P300, 302 and 303 problem. I have switched the ignition coils and still have the problem. Clearly my problem is something else, but when I do get it fixed I need to know t


1999 Toyota Corolla LE Sedan 1.8 liter DOHC L4 (1ZZ-FE) ... 1999 Toyota Corolla

I have a 2009 Camry. The dash lights are so dim during the day that I can't read the mileage or the temp. They also are very dim while driving at night. This problem just started about 3 weeks ago. There is also a maint. reqd. light on and according to the manual, it indicates an oil change is needed - I still have over 1700 miles to go before I need an oil change - I change my oil every 3000 miles. My car has no way to adjust the brightness of the dash lights, so I can't fix this problem that w


On this vehicle the dash automatically dims with an "Ambient Light Sensor"\015\012It has likely failed and needs replacement.under warranty.\015\012Thanks!! ... 2007 Toyota Camry Solara

BMW (E39)520SE 08/2001 Auto Touring. Rear wiper/washer has failed. I have located a replacement wiper motor but understand that 'the relay' is also prone to failure. I've still got the fuses to check/replace but where is the 'relay' and how do I check and replace it (if needed). Is there anything else I need to do logically so as to determine the cause and fix it (rather than throwing cash at the dealership)?


After making sure your fuses are ok, go in the trunk and behind the access cover where the battery is located. above the battery should be a fuse panel, which may be hidden under the insulation trim, there should be some fuses and relays there. the r ... 2001 BMW 5 Series

1997 Mitsubishi Eclipse RS 5 speed manual, non-turbo. Speedo and odometer stopped working. Replaced the sensor and it did not fix problem. Replaced the gauge and it did not fix the problem. Was told that whatever drives the sensor in the trans must not be working. Car needed a new transmission, anyway, so we replaced the transmission. Speedo still is not working. Mechanic is very good with Mitsubishi but says he is stumped. Odd thing is that there is actually some movement in the Odometer


Hello,Thanks for using FixYa.The problems is definitely a wiring issue. The most simple thing that you can do is to check the harness socket that goes to the gauge cluster. The speedometer signal wire might have gotten loose f ... 1995 Mitsubishi Eclipse

Anti_Theft System I have a 1998 ford exploror sport..SUV I am wondering how i can go about going around the Anti-Theft and see if it is still engaging WITH OUT using a scanner? Can someone help me with this problem? I had put it on a scanner and it said the Anti Theft is engaged with the Key ON? how can I fix this problem? I need help....


I am not quite sure what you are trying to do. The anti theft is always engaged as there is chip in the key that must match in order for the vehicle to start. What do you want to accomplish? ... 1998 Ford Explorer
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 8.2995 seconds