Having problems with your 2006 Mercury Grand Marquis ?

Today my grand marquis had battery issues. i was parked for about 20 minutes with car on then i turned off then right back on to take off but the car would not start- i can tell it was a battery problem but some of the lights in the car did work-but i would not turn on to put in drive-i messed with headlight swith and all of a sudden smoke was coming out of the hood-is this battery issue or alternator? I had someon pass me cables real quik and it didnt wrk-so a little later i passed cables again

Posted / edited by AnonymousUser on : 25-09-2017

Answers :

Check your battery posts. Over time, they tend to corrode and cause an inproper connection, but your vehicle is fairly new. If they are dirty, get a wirebrush and clean them thouroughly. Also, make sure the posts are tight and not loose. If they're clean and tight, remove the battery and have it tested at your local parts store.
Repair Help & Product Troubleshooting for 2006 Mercury Grand Marquis

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0147 seconds