Having problems with your 2006 Kia Sportage ?

My car is a 2006 KIA Sportage, Fan motor was making noise then stopped working, removed the fan and found acorns inside. Also, found that the two wires to the motor had melted together, the 40amp fuse blown, resistor/MOSFET was destroyed also. Checked resistance in both the red and yellow wires to the fan and the reading seems fine(.002 ohms). There are no lights on at the control now with of course no operation of the fan. Besides replacement of the resistor/MOSFET with replacement of the two f

Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Did you get a different blower motor relay for it, That is in the engine compartment fuse box,
Repair Help & Product Troubleshooting for 2006 Kia Sportage

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My car is a 2006 KIA Sportage, Fan motor was making noise then stopped working, removed the fan and found acorns inside. Also, found that the two wires to the motor had melted together, the 40amp fuse blown, resistor/MOSFET was destroyed also. Checked resistance in both the red and yellow wires to the fan and the reading seems fine(.002 ohms). There are no lights on at the control now with of course no operation of the fan. Besides replacement of the resistor/MOSFET with replacement of the two f


Did you get a different blower motor relay for it, That is in the engine compartment fuse box, ... 2006 Kia Sportage

I have replaced the coil pack on my 2002 ford taurus with the 3.0 24 valve engine. I have no spark to cyliders 3 and 4. I have also replaced the electical connector to the coil pack as well. All 4 wires have power and the yellow and white and the yellow and black pulse with the test light, the yellow and red and the solid red wire have a steady light with no pulse. Do you have any suggestions please. I have also checked all grounds and they seem to be fine. Do also take into consideration that t


... 2002 Ford Taurus

I hooked my battery up backwards. It took out the headlights and the heater fan. Replaced the light switch and still nothing but after much test lighting I found out the fan switch is still good. All fuses and relay are good under the hood. What could this be? Are there more relays for these two things I don't know about? Also all ground wires are still in tact.


... 2001 Hyundai Accent

1998 GMC Sierra. Blower motor works sometimes. No particular circumstances, just when it wants to. Checked all fuses, relays, even replaced the resistor, nothing. Followed the wire harness and found the two pigtails that others have mentioned. Took the wires off, black and purple, and turned ignition on. Getting around 11 volts on all sittings except for the highest setting, it reads 0 volts. The compressor turns on at the console, all the switches on the console work, just not the fan.


Could it be the blower motor it self? sometimes they have a "bad spot" when it is not working, can you hit it and make it run? pretty common on these trucks. the switch is also common. they often melt at the connector on the back making a bad connect ... 1998 GMC Sierra

The fan motor quit working.my sons replaced the cooling fan they hooked up the black wire and yellow wire were they belong but they ran a hot wire from the battery to the green wire. then the wipers and ac quit working in a couple days? how to fix ?


Step 1 - Remove green wireStep 2 - Check for blown fusesStep 3 - Pray the PCM is okay ;)Adding wires to a car to boost performance in some way, whether to the cooling fan or to the fuel system may have worked 30 years ago, but ... 1995 Ford Escort

The fan doesn't work on my '89 cavalier 2.8. I replaced the temp sensor and the fan heat switch just above it, still no good. I bypased the switch and wired the fan direct to ignition side of fuse block. That worked, so the fan motor is good. However, the car doesn't run right when this is done so I put it back the way it was. The ecm got replaced also. Unless the new switch and/or temp sensor are bad...I'm stumped!


Can't remember where they are exactly on yours but there are a group of three or four relays either back on one of the fenders or on the firewall. One of those is for the fan. ... Chevrolet Cavalier

I have a 1971 with a V6 motor. I am trying to replace the heater blower motor. My old motor has two wires...one orange, one yellow. The new motor has three wires...one ground, one black, one orange. It has both black and orange listed as hot. What do I do?


Last time I looked, black was always the ground... But, been wrong before.I'd check with parts guy to make sure you have the correct motor. If it replaces original design there is usually a sheet with wire re-route diagram. If not, use a volt meter ... Jeep CJ5

1985 FIrebird SE 2.8 six cylinder, missing AC, could this stop the electric fan from coming on? I have replaced fan sensor and relay, still no fan. It works hooked up to the battery, but not when it is hooked up correctly. I have checked the wires,ok. The sensor was located on the left front side of the intake. Also, what is the sensor next to it? It is larger and has two wires.


How about fuses, are there any fuses related to the fan? ... 1985 Pontiac Firebird

2000 Grand Prix coupe. Drivers power window stuck. Replaced switch - no help. Replaced regulator/motor assembly - no help. Was wiggling wiring and found the two wires to the motor were intermittent. Unplugged connecter, resecured the wires, cleaned connector, and re-installed. Now it doesn't work at all!! Luckily window is stuck up. One week later and now the sun/moon roof is stuck all the way open. I'm an ol' electronics mechanic and this is driving me crazy. I have seen a lot of forums on this


... 2000 Pontiac Grand Prix

The radiator fan on my 1992 Geo Prizm will not come on. I have tested the fan motor via a wire by pass and confirmed the motor is good. I have also replaced the relay and still the fan will not come on. What should I do next?


Pull the cooling switch/sensor Usually the one next to or on thermostat housing. I do believe it a 2 wire. the 1 wire is for your guage. I think you can short it and see if it comes on. take a wire and plug into each other creating a complete circuit ... 1992 Geo Prizm

2005 BMW x3, 3.0 - Was having trouble with rear liftgate not unlocking with remote so manually open and removed latch actator to check. Found it inoperable and apparently need to be replaced so reinstalled to order replacement. Also pulled fuses none appeared to be burned, reinstalled everything later went to start vehicle and noticed Brake warning light (Red), DSC-4X4 warning light (Yellow), and ABS light (Yellow) all luminated on dash. Can you help solve this problem. Everything was normal pri


... 2005 BMW 3 Series

99 honda civic lx, coolant was found in motor oil-head gasket replaced...now for some reason the ac will not work! it was working fine and mechanic claims it was working fine when he test drove it after completing work. for some insane reason he wired the fans to stay on constantly and really think in doing so he messed up the ac electrical wiring. None of the ac buttons or knobs work now,no power to the little lights like ac,defrost,circulation option...the fan knob will not even kick on the co


GOOD LORD,, Not here to knock any ones work but.. could be many things.. I guess you checked all fuses.. sounds like fuseable link didn't like being wired around.. I would make sure acc. wire is not missing from battery. check pressure switch wires a ... 1987 Honda Civic

FORD EXPLORER HEATER FAN MOTOR HAS A MIND OF ITS OWN. GOES ON AND OFF WHEN NOT IN AUTOMATIC AND IF I HIT A BUMP IN THE ROAD IT EITHER GOES ON OR OFF. I DID HAVE THE MOTOR REPLACED AND IT STILL HAPPENS I ALSO HAD THE WIRE CONNECTIONS LOOKED AT ALSO.


These can be like needles in a haystack, but here are the steps I would follow. First recheck the connections with a circuit tester, and make sure to wiggle while testing. Its also possible the fusebox itself is either loose, or has a loose fuse so r ... 2002 Ford Explorer

1995 heater blower motor: someone has replaced it before my sister bought it. The problem is it is wired incorrectly, the blower runs only on high continuously no mater where the fan speed switch is located. Upon inspection it aperes that someone wired it straight to hot. (always on) I'm not sure how to wire it, and I think the resistor is not working. I want to know where the hot wire goes and where the two wires from the blower go. The black is obviously ground. It has a 1 wire plug go


Since its presently working, don't mess with it yet. You can put a toggle switch in between so you can turn it on and off (you can even mount it under the dash). Get a good wiring diagram and use it to make sense of what you have.(Chilton makes a goo ... Ford Escort

I am replacing the heater fan motor in my 1986 Volvo 240 DL. The old motor had a black and red wire, whereas the new VDO motor comes with a resistor and switch, and is more complex to install. I want to get electrical instructions in the simplist terms on how to install the new motor. Thank you.


... 1986 Volvo DL

Wiring problem i turn a corner and everything shuts down dash lights, motor,and will not start up. it has 12.5volts at battery. the only thing that works is the head lights &horn. when i look under the hood i found nut on back of alternator loose so i tightend it well the crimp on ends of wire that goes directly to battery grounds out on alternator i yanked it red hot & smoking, the battery is good had it checked. ihave replaced all wires even close to this area checked fuses &links any ideas


Check the fusible links at the starter. One of them may be burned. You mentioned that it shuts down when you turn a corner. Check the wiring going to the ignition switch under the steering column, you may have a loose wire there as well. ... 1986 Chevrolet Chevy

Overheating overheats then drops back to normal;then overheats again;then back to normal? Ok...same problem. Car will run perfectly for a day or two then will decide to overheat. Temp guage will rise to 3/4 or higher then fall then rise then fall and so on. New thermostat installed ,rad flushed, new cooling fan relay,and new rad cap but the problem continues. Fan motor was also replaced 2 years ago Is it the cooling fan sensor?


Ok, here is what I have found with the overheating problem with my 2002 PT Cruiser. I have got all the symptoms that everyone else has gotten form, it heats then cools down, gets hot when it idles, gets hot when AC is turned on. The bottom line here ... 2003 Chrysler PT Cruiser

I went to replace the positive battery cable in the van and noticed 3 seperate wires all coming off of the terminal. The main cable and a smaller one go to the starter and a third, large thick black one go in towards the driver's side. I haven't found any store bought cables that fit this description (the old cable had a clamp they were fitted into at the terminal), so I replaced the bad cable (main red one) and jury-rigged the other two bare ends to the battery terminal. It now starts fine, but


SHOULD DO BUT I WOULD INCOPARATE FUSE LINKS TO BE SAFE! AS THESE ARE MEAN FEEDERS.\015\012\015\012O.K.? ... 1991 Dodge Ram

Fuel pump won't run (no power to pump when ignition is on), battery check in car registers a trouble warning, check engine lite stays on. Think it could be "engine control relay" but can't locate a replacement. Also having trouble locating device on vehicle. Have found 3 relay boxes, all in same location on passengers side behind glovebox. A 6 wire conn. with 2 grounds, and two other boxes with 5 wire conn's. Have an after market manual, but not alot of help.


No feed so check fuse, ... 1990 Mitsubishi Montero

Location of oil pressure sending unit on 3 8 engine, on an 1986 Oldsmobile brougham? Also I am replacing the radiator which had a disconnected, what looked like a cooling sending unit located on the side of the radiator? Is this where the cooling unit sending unit is located? My cooling fan does not appear to be working properly, so I would like to know, if I can straight wire the fan motor with a toggle switch, by bypassing the relay? I am attempting to install a set of gauges mounting insi


... 1986 Oldsmobile Regency

ENGINE OEVRHEATS ANYTIME I WAS AT A STOP LOGHT. OR MOVING AT A SLOW PACE IN RUSH HOUR TRAFFIC THE TEMPERATURE WOULD RED LINE VERY QUICKLY. IN THE PAST TWO DAYS I HAD THE THERMOSTAT REPLACED AND IT APPEARS ITS GETTING HOT FASTER THAN BEFORE. ADDITIONALLY IT SEEMS THE SMALL FAN TO THE LEFT OF OF THE RADIATOR IS'NT RUNNING. HOWEVER, I RAN A WIRE FROM THE BATTERY TO THE FAN AND IT CAME ON. WHATS THE POSSIBLE PROBLEM AND SOLUTION. AND THE IDEA OF THE COST.


You may have a bad temp sensor for the fans. Usually one fan will start in and once the vehicle gets too warm the other fan will turn on also. There usually are two sensors. One for the actual gauge or light and the other for the fans. Sometimes unpl ... 2005 Dodge Durango

Power driver seat is not moving. The support bar broke and it cause the seat to lay on two wires and ground out. My battery kept dying so my husband decided to replace the the whole power seat track and motors from a salvage yard. You can't the motor but you can hear the some clicking niose. He seems to think it may be some kind of relay or fuse. If so, where can those fuses or relays be found? Thanks for any suggestion! Mrs Trailblazer Lover!


There is a fuse box underhood on left side of fender use a test light and check all fuses there is also a fuse box under left rear seat sounds like a blown fuse. but if you hear it clicking may be a bad motor from salvage yard ... 2003 Chevrolet TrailBlazer

I need to know the wiring schematic for a 24 volt charging system on a 1994 chevrolet 3500 truck. The alternator has been checked and replaced but the new one is not charging the system. there is two wires cut and there is one that is red that runs to a solenoid. the alternator has an internal regulator and has been checked as well. what can i do to fix this current problem. the motor is a 6.5 turbo diesel.


... 1994 Chevrolet C3500

Having problem w/ the antilock system....replaced the master as per instructions....reapplied harness and battery cable....light still on and brake light too... i looked about antilock unit and found two fittings(zerk)...with pressure applied to brake peddle i attempted to bleed system...fitting closest to motor did spit some air...but the other one(nearest to the fender) was without fluid...(BONE DRY!!) I also noticed two button like items on the side of the unit that actuate in/out....Please h


You Have to bleed the whole system just like a regualer barke systey and tun ing. gey tothe run postion and off 5 times to cear the fault codes. ... 1991 Chevrolet S-10 Blazer

Blower motor resistor connector burned resistor. Went to change resistor and found insulation on two wires melted and connector was burned. Can I replace connector or do I need new wire harness?


You'll have to get the connector from an auto salvage yard. I doubt you'll wants to spend all the money or do all the work involved in changing a wiring harness.\015\012 When you get the connector get is with as much wire as possible on it. Yo ... 2001 Dodge Dakota
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.4556 seconds