Having problems with your 2006 Ford F-150 ?

Misfire & bucking

\015 I have a 2006 f150 5.4litre 4x4 130,000 miles, that started to have a slight miss on acceleration on occasion. Soon after this, the motor started to buck quite bad all of a sudden when under load. Its runs fine when idling. I took it into Ford dealership and put it on a scope. It came up as mutiple misfire on cylinders. Had all plugs changed, coil, gas filter and changed fuel. This did not solve problem. Rechecked on scope again and it came up #2 clyinder misfire. Checked plug and it looked very carboned up for a plug with only few miles on it. Checked other plugs and they looked Ok. Changed #2 plug again but still running bad. Put on scope again and nothing comes up now but fault on oil sensor. Would this have anything to do with misfire? still running bad and costing big time as plugs had to be easyout on origonal change. Seems to be worse as goes through different gears on this automatic. Any advice would be appreciated as I am mistified and so is Ford dealership.\015 Posted / edited by AnonymousUser on : 25-09-2017

Answers :

Repair Help & Product Troubleshooting for 2006 Ford F-150

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0110 seconds