Having problems with your 2006 Dodge Dakota ?

My 2006 Dodge Dakota windshield washer fluid does not spray. I checked the washer pump and it works. The fuses are all good. And the wipers work. When I press the windshield washer button inside the truck no water squirts out. Took truck to dealership and they said might need a new computer module. They reprogrammed the one on the truck and still no fluid comes out to windshield. What could be the problem and solution.

Posted / edited by AnonymousUser on : 11-12-2017

Answers :

If the pump works, something should be flowing thru the hose to the spray nozzles.
And if the pump works, everything electrical is working.
How do you know the pump works ?
Having windshield wiper/washer problems? Here are some more common problems.
\012
    \012\011
  • Motor:
  • \012
\012The wiper motor is commonly replaced and was often not the problem. Don't replace the motor yet. maybe it's not the motor. It could be a fuse or something at the wiper switch. The wiper motor has two windings, fast and slow. The wiper switch sends a ground signal to each motor winding. More often, there are problems with the relay, or at the wiper switch, or in the cable to the motor.
\012
    \012\011
  • Windshield Washer:
  • \012
\012Don't be too quick to replace the washer pump. The problem is often just a clog in the sprayer heads. You can clean out the sprayer holes with a needle, some have two holes, so look closely. Hope this helps.
Repair Help & Product Troubleshooting for 2006 Dodge Dakota

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0060 seconds