Having problems with your 2005 GMC Envoy ?

Issues with chugging on 2003 envoy - seems like fuel is not getting to the engine

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for 2005 GMC Envoy

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Issues with chugging on 2003 envoy - seems like fuel is not getting to the engine


... 2005 GMC Envoy

Acceleration issue I have a 1999 Saturn SL1. When I am accelerating between 60 - 110 km/h or so the car seems to chug and loose power as though it is not getting enough gas. It will gradually increase but slowly. If I press the pedal enough to engage the lower gear it accelerates fine. It seems like there is not enough fuel provided to the engine in the higher gear but good if more pressure by higher rpm's. The car also idles at around 500 - 600 rpm when hot. Please help as I travel on the highw


Just a suggestion, but the EGR valve can cause that problem. If that checks ok, then I would have the catalytic converter checked for clogging. Both ideas would cause that specific problem. I sincerely hope that this can solve the problem, or at leas ... 1999 Saturn SL

1991 F-150, 302 V-8, 5.0L acts like it has a vapor lock. Fuel injected so can't be vapor lock. After driving a while when I push on the gas there is no power. The engine starts to shake and chug like it isn't getting any fuel. I pull over to stop, let the truck sit for a couple of hours, the engine will fire right up. I have replaced the ignition coil, spark plugs, wires, dist cap, fuel filter, cleaned the throttle body. Flushed the cooling system and replaced the antifreeze. Seems to happen mo


It does seem like you have done a fair bit of work on this beast...just curious to see whether you had performed a cylinder head pressure test....???? If it is happpening more on hot days, it might be wise to check it whilst the engine is hot, i am s ... 1991 Ford F150

Just got tune up/major service on the 2001 expedition and was running great 2 days ago. Now it seems to be sputtering and the check engine light came on. It seems like it is having a fuel issue. I just got the EGR back press sensor replaced 2 days ago with the service. I also got new spark plugs, coil boots, fuel filter. I did not get the evap sensor replaced, could this be the problem. Please help. Thanks Joseph


5.4L or 4.6L engine?? Check your coils. Go to autozone or advance auto parts and have them scan the ECU for the check engine light!! Its recommended to replace all 8 COPs(ignition coil over plugs) upon replacing the sparkplugs. These typically go out ... 2001 Ford Expedition

2002 Impala LS 3.8 engine will not start. When I try and start car it seems like the engine is flooding and will not start and idle. Only way to get car started is to hold gas pedal down when starting, however once gas pedal is released the car stalls again. Smells like gas when trying to crank however it seems like the engine is getting too much or too little fuel. Changed plugs and wires, checked coil packs and plate for spark, changed crank shaft sensor, also changed fuel filter however nothi


It sounds like the timing chain jumped or is worn out. ... 2005 Chevrolet Impala

I recently purchased a 1999 Bravda AWD w/ the smart trac system. It's been up until about a week ago. From 0-30 mph or so it hesitates while trying to accelerate. Mainly prominent when the engine is cold but gradually gets a tad better after engine seems to warm up. No matter if you slam on the gas and throw the pedal to the floor or a slow acceleration. The issue is rather annoying and from others i have talked with, i have 2 possibilities to diagnose...the fuel pump or the cat. converter. Pl


... 1999 Oldsmobile Bravada

My 1992 honda prelude has a starting problem. When I turn the key to start, once inawhile it will just crank over and over without firing up the engine. Then 30 minutes later, it starts up perfectly. The car runs great and smooth without missing or timing problems so I think the distributor is ok, and i have new spark plugs. If its a fuel issue, I replaced the fuel filter, and starter fluid doesnt seem to help fire it up. Also like I said, the car runs fine, so I imagine its getting sufficient g


If you have the ignition system checked out you may want to have the starter checked if it is not going bad or the starter relay. Have it checked out if it is not working properly. It also has a capacitor in its circuit that may have leaks or may b ... Honda Prelude

Honda Accord 2000 lx V6 3.0 engine. Car starts and runs for awhile then at idle it will shut off. Attempts to restart gets cranking of engine but does not start. Seems like fuel starvation. Let engine cool off 10-15 minutes car will restart and run for a while again. Seems like vapor lock of the fuel pump. If this is what you believe to be the situation. How is the best way to replace the fuel pump? Is it located in the gas tank and if so is the access panel under the rear seat or in the t


The relay can be tested using a voltmeter to read volts out, if it does not switch power to the fuel pump , then the relay is faulty.A general test can also be done reading volts at fuel pump connectors.Instead of testing the ... Honda Accord

My engine light has come on in my nissan sunny VIP ex-saloon 1999 FB15 model, it seems to chug every now and then like its not getting fuel.. what must I look for???


Mass air flow sensor in the air intake pipe ... Nissan Sentra

Fuel issue 1999 Mercury Mtnr. runs great then after it gets about 10 miles starts jerking and sputtering like not getting gas, will die if you come to a start, seems like its not getting fuel after its ran for a while, could this be the fuel pump or the EGR valve?


Yes, and it could also be an ignition problem. Or a sensor problem like a coolant temp sensor.Can you let it idle for 20 min and duplicate the event ?Is the check engine light on ? ... 1999 Mercury Mountaineer

Recently the car was getting harder and harder to start. It began with one or two extra tries to get the engine to turn over, soon it was 3-4 and the engine would chug and putter out immediately like it was out of fuel. When the final attempt was successful, it was like it started as normal. But then I parked the car in a garage on a slope with very little gas in it. When I tried starting it I attempted around 10 times of this puttering out. Finally something in the engine "snapped" and it only


This is a Timing Chain Problem ... 1994 Oldsmobile 88

Put new battery in car. Now it is hard to start. Replaced fuel filter no help. What could the problem be? Engine cranks ok. Seems like fuel not getting to engine. Seems to run fine after it is started. Suspect fuel pump. Where is that located?


Fuel pump is in the tank but don't think that it is the problem if it runs fine after started. sounds like a cold start problem alot of these vehicle have what they call a cold start injector that supplies the initial fuel to get the car started and ... 2002 Daewoo Nubira

I have a lexus gs300 yr 2000 miles 130,000. It seems like maybe my fuel injector is not working properly. Seem like I am not getting gas at times, when I go to give it gas, it sort of bucks and I don't move. Seems worse in the morning, but always is an issue. Is there a way of testing to see if the fuel injector is not working properly?


Make a injector clean on worshop , also change fuel and air filters, check spark plugs ... 2000 Lexus Gs 300

Check engine light has been on since we bought the car - shop said common problem with dust getting into sensor...yesterday car started acting like there was maybe fuel not getting to engine at times and today check engine light is flashing. Car never died - but definitely runnig rougher. Can anyone tell me the most likely issue?


No need to guess. Take the vehicle to one of the Major auto parts stores like Auto Zone and ask them to connect their scanner to it and identify the fault code. That will tell you what needs to be replaced. As far as dust getting into a sensor, th ... 1997 Mercury Sable

I have a Linde h70 fork truck, with a deutz engine, currently having a fuel issue. Got diesel to the filter to block, but can't seem to get any from the injectors. Tried turning engine over with compressed air through the tank but not a drop. Could it be electrical or fuel blockage? I've limited electrical knowledge, but have tried checking for voltage at various plugs and all seems in order. Any help appreciated!!!


... Cars & Trucks

It seems like the fuel is not getting to the engine, drives, but seems like its being starved from fuel and pulling back and kicking back in constantly? any suggestions


Replace fuel filter and check for vac leaks. Small hoses in engine compartment if off, can act the same as you described ... 1986 Chevrolet Nova

My toyota celica .... everytime i start it up it stalls sometimes i can get it in reverse and then drive and it seems like it is gong to stall again but doesnt or i will make it down the road and it will stall. It also hesitates alot when you hit the gas it doesnt really want to accelerate. We had our check engine light checked and it said it needed a new fuel pump so we replaced the fuel pump and strainer. Now it seems like it is even worse. Please help me


It certainly sounds like a fuel delivery problem. You didn't say if you changed the in line filter. If it is partially plugged, it won't allow enough gas to reach the engine. After or before changing that, you would want a fuel pressure test, to see ... 2000 Toyota Celica

I have a 1988 dodge 600 2.2l. When i was driving it would seem like it was getting to much fuel, it would cost itself up to speed with out touching the gas. Yesterday on the way the last two set of lights i stopped at it seemed like the car had a hard time getting up to speed but then once i got it up to speed it would be fine. This morning the car would not start and the engine light was on.


Take battery loose and then wait a minute and rehook up. Then try to run it. If not try this:\015\012Go to online site of autozone, oreillys...etc and you may have to register but they have free online step by step manuals. ... 1988 Dodge 600

Engine turns over but won't start. Seems like a fuel issue but pump still works and filter is new. Clog in the line or another issue?


... 1992 Honda Accord

1996 suburban random misfire or runs rough changed the following sensors: O2 (all four) MAF IAT ECT and PCV, air filter, water pump (flowkooler), thermostat, cleaned ground connections then I added Lucas fuel system cleaner and now seems like the engine is not getting fuel and cuts out changed the fuel filter no improvement suspect fuel pump, due to fuel cleaner additive would like advise before changing the fuel pump ($410 at local shop)


I would check the fuel pressure first if it is in the good ranges then your pump is good. have you checked your spark plugs and wires? if not i would, if bad replace. otherwise i would have the ignition coils checked to find out if they are working c ... 1996 Chevrolet Suburban

No horsepower Hi, I have been having an issue with my van. 2000 gmc 1500 series 4.3 engine. I don't seem to have much horsepower , when you try and excellerate it seems to not be getting any gas to the motor. You are better off letting up on the gas pedal and just let the van come to you. Worst when you try and push the issue. Sometimes it backfires and just seems to have a fuel issue and is hard to start. I have had the cadalytic converter replaced, the exhaust looked at, the plugs and wires re


Check your fuel pressure as the fuel pump may be failing. It should have 60-66 psi at the test valve when you switch the ignition on without cranking the engine (as the fuel pump makes the humming noise) ... 2000 GMC Savana

The engine on my sons 91 Mazda Miata is running ruff. Like on 3 cylinders. If I pull the spark plug wire on the #1 cylinder the engine runs the same. If I pull the spark plug wires on the #2,3, or 4 cylinders the engine runs worse or dies. It seems to be getting a good spark but I changed the plugs and wires anyway and the problem remains. While running the engine with the #1 spark plug wire removed there is no accumulation of fuel on the spark plug. It's bone dry. Nor does any fuel come o


You have done a great test but If I assk you to do a swap of the Ist cylinder plug and injector with one from the 3rd , we can come to a conclusion before we can change the full set of plugs and injectors for a good performance.( only if the mileage ... 1991 Mazda MX-5

I have 2002 audi a4. does not start. engine cranks but seems like there is no power going to the fuel pump, when bypassed the relay and directed the fuel pmup it does run but car still did not start... there is also no fuel pressure, there is spark, the wiring near the ECM all seems fine do i need to replace the relay or maybe its a clogged filter or is it a security issue that has been breached that is not sending power to the fuel pump really confused please help


... Audi Cars & Trucks

I have a 97 olds 88. while driving sometimes the engine will just shut off. In rare cases the engine will quit and when i start it up again and give it gas it shuts down. after awhile it will be fine and drive great. do you think it is the fuel pressure regulator? I don't think it's a fuel pump cause it gets fuel. Seems like the pressure is not always there.


It could be both need fuel press guage also is check engine light on? ... 1997 Oldsmobile 88

I have a 1999 Chevy Tahoe. Has approx. 178,000 on it. HAVING major engine issues. If it sits for any amt. of time and I get in it to drive it, 9 times out of 10 i will not have enough power to go. Once i get going, it works itself out.....but doesn't seem to get better. I have had the whole fuel assembly replaced in the fuel tank. I have dumped bottles of stuff in to 'clean' injectors. Just had all the injectors replaced. STILL DOES IT! ANY suggestions.


You didn't mention the fuel pressure regulator. Is your check engine light on? faulty ignition coil? corrosion on plug wires? spark plugs fouled? crankshaft position sensor? Did it die all at once or slowly over time get sucky? ... 1999 Chevrolet Tahoe
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.2484 seconds