Having problems with your 2005 Chevrolet Tahoe ?

Runs rough sometimes when cold after running awhile it goes away the computer at autozone pulled up a misfire, leen fuel, and a oxygen sensor but it cleared the oxygen sensor code.

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

All these codes seem to be a compounded problem meaning they are in relation to one another.One of these codes probably caused the other two.I would try changing the o2 sensor . Be sure you change the right one though as there could possibly up to 4 o2 sensors.
Repair Help & Product Troubleshooting for 2005 Chevrolet Tahoe

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Runs rough sometimes when cold after running awhile it goes away the computer at autozone pulled up a misfire, leen fuel, and a oxygen sensor but it cleared the oxygen sensor code.


All these codes seem to be a compounded problem meaning they are in relation to one another.One of these codes probably caused the other two.I would try changing the o2 sensor . Be sure you change the right one though as there could possibly up to 4 ... 2005 Chevrolet Tahoe

1996 Chrysler Sebring LXi Coupe V6 -- Check engine light came on and had Auto Zone put the tester on the car. Report shows Oxygen Sensor at Bank 1, Sensor 1 was inoperable, fuel mixture is too lean/rich, misfire code, and a code for the fuel pressure relay. Replaced battery, battery terminals, distributor cap, rotor button, and Oxygen Sensor at Bank 1 Sensor 1. The engine spins over but will not crank. Verified there is spark by pulling one of the plugs. Is there anything specific I should


... 1996 Chrysler Sebring

Mazda misfire My car wouldn't start about 3 weeks ago. I replaced the distributor, as there was no spark, and it started right up. It sputters going uphill, or if I accelerate too fast. I replaced spark plugs and wires, fuel filter, fuel pump, and am still having the same issue. When I took it to autozone (before replacing the wires) their codes came up as a misfire in cylinder #4, and O2 sensor 2. Could an oxygen sensor cause this? After replacing the plugs, the code for the misfire didn'


Yes. If the O2 sensor is faulty, it can tell the computer the fuel mixture is too rich when in fact is is too lean. ... Cars & Trucks

My Mom's Acura is gutless! The code reader shows #5 misfire. I cleared the code and it did not return. I changed the fuel filter, pulled the plugs and preformed a compression check all ok...although a little rich on the plugs. She is using premium gas. I can power brake and feel a slight miss or shake. The only code I got was the misfire. The engine is so weak it doesn't shift correctly. So what next? O2 sensors or maybe cat converter. Thanks in Advance


Mileage?\015\0125 (2.5) or 6 (3.2) cylinder?\015\012\015\012On 5 change wires and distributor cap and rotor button. Use Borg Warner wires, they are low resistance.\015\012\015\012Use NGK iridium plugs.\015\012 ... 1996 Acura TL Series

Car: 2000 Jetta GLX V6 5 speed manual (150K miles) (engine code AFP) Lights showing: ABS (constant), brake (flashing), engine (constant) _ STOP-Brake Fault on control panel Since last fill up (added gumout high mileage fuel injector cleaner at same time) I had a few misfires on the road. I pulled the codes and came up with 13! P0300, P0304, P0303, P0306 cylinder misfires P0442 EVAP emission control sys-small leak P1131 Oxygen Sensor (Lambda) B2 S1 internal resistance too high P14


Before replacing the onboard computer, I would try a thorough tuneup with plugs, wires, etc. I would not rely on the water mist test to determine the condition of the plug wires. Multiple ... 2000 Volkswagen Passat 4Motion

Mazda sputtering My check engine light was flashing, Autozone hooked their code scanner up, and it said Misfire on #4, & O2 Sensor #2. I replaced plugs, wires, distributor, fuel pump, fuel filter all within the past 2 weeks. After replacing everything, my car still sputters if I accelerate going uphill or try to accelerate too fast. I do have an old spark plug that just won't come out, but it is still getting spark, if I run the car and pull the wire off of that plug, it idles rough, when the


... Cars & Trucks

I have a 1995 LS 400 that is misfiring and check engine light on. Mechanic read code and found P0300 Random Misfire, P0305 Cylinder Misfire, P0307 Cylinder Misfire and P0170 Fuel Trim (Bank 1). Mechanic suggested and replaced Ignition Cable Set/Spark Plug Wires, Fuel Filter, Spark Plugs and Valve Cover Gasket Set. After work was done and paid for, check engine light came back on before I pulled away from the shop. Mechanic read code and now it reads Crankshaft Position Sensor. It was end


... 1995 Lexus LS 400

I have a 2001 Volvo S40 Turbo. Several months ago, My cars turbo didnt seem to be working. and the car was spitting and sputtering. I had the codes checked and found a misfire on Cyl 1 and 2. Or possible bad oxygen sensor. I changed out the coil packs, spark plugs, wires and the oxygen sensor. Cleared the code and it seemed to be better. A few minutes later, the check engine came back on. The spitting and sputering returned. Well, I drove it like that for a long time. I took it into a garage and


Replace the mass air flow meter.Thats the sort of problem you will get when its faulty.And this should be changed every 90.000.I think your fuel consumption has gone up aswell due to the air flow meter.hope that was helpfull.Good luck. ... 2001 Volvo S40

1995 LS 400: RANDOM/CYLINDER MISFIRE, CRANKSHAFT POSITION SENSOR , ECM I have a 1995 LS 400 that is misfiring and check engine light on. Mechanic read code and found P0300 Random Misfire, P0305 Cylinder Misfire, P0307 Cylinder Misfire and P0170 Fuel Trim (Bank 1). Mechanic suggested and replaced Ignition Cable Set/Spark Plug Wires, Fuel Filter, Spark Plugs and Valve Cover Gasket Set. After work was done and paid for, check engine light came back on before I pulled away from the shop. Mecha


Up to this point in time, mechanic 1 has only done some maintenance work on the car. Things that would be done from time to time to maintain the car.Since you have lost trust in this mechanic, I would go to a different place and have them diagno ... 1995 Lexus LS 400

I have a 1999 oldsmobile intrigue that is misting a lot. It idels rough, and runs rough. I can still take off it is a little slow, but I can still go pretty fast, but it still mist at the high speeds pretty badly. I have checked the mass air flow sensor, the oxygen sensor, I have replaced all spark plug and spark plug wires, and still nothing. The computer at Autozone said there were three codes on it, Misfire in 4, Oxygen Flow Sensor, and Mass Air Flow Sensor. After we changed spark plug a


Fuel pressure regulator on the fuel rail is probably it or the egr valve is stuck open allowing burnt fuel to flood the intake, im leaning towards the fuel pressure regulator because the o2sensor is probably reading rich or if its reading lean then i ... 1999 Oldsmobile Intrigue

Hello timing is off and jumping all over the place we change oxygen sensers coil rotor and cap wires spark plugs we put it on sevrral differant code readers we check fuel pressure was reading 42 with key on and 49-50 with truck running the code reading p0300(random multi cylinder misfire), p0304(cyl 4 misfire) and p0305(cyl 5 misfire) before we change the oxgen sensor we also took the y pipe off and took it for a run figuring they were causing this problems the truck was back firing and trans no


Mcdevito75 here, Could be a worn timeing belt, a crankshaft position sensor. Have your local shop check it out. ... 1997 Dodge Dakota

I have a 94 gmc jimmy. you can hear the fuel pump running at idle over engine. jimmy runs fine until gets hot. about 40 min of interstate driving engine will seem to lose most of its power. can simply pull over or if on slow back street put into neutral turn key off and wait ten sec and it will run fine once again for 15-20min. replaced ignition control module, map sensor and exhaust O2 sensor. after replacing those reset trouble codes. only showing now code 44 oxygen sensor lean exhaust. any id


Chek filters for fuel on frame and in tank ... 1994 GMC Jimmy

Code po201 changed crankshaft sensor, camshaft sensor, plugs,plug wires,button and cap, oxygen senors. still running rough and giving same code of po201. what else is in the fuel injector circuit.all injectors check out. i can pull wire off inj. #1,2,3,4, and there is no change in the motor.


... Cars & Trucks

Replaced battery, plugs, wires, cap, rotor, air filter, fuel filter, added heet water removal and lucas fuel injector. It sputters, backfires/pops when accelerating and it has no power, drives like a golf cart with a dying battery. It starts up and idles okay and is smooth when you rev it at a certain level, but if you push more on the gas pedal, it wants to stall or sputter, backfire/pop, etc. Before, I got a code reader check, which output codes for misfire cyl. 3 and both oxygen sensors.


How many miles? I am NOT a mechanic! Sounds like possible timing belt/chain jumped a tooth. Or the timing advance mechanism is malfuctioning. (Unlikely - check distributor is tight or not shifted from normal position too far back or forward.) Assu ... 1997 Kia Sephia

Misfifring I recently changed the Bank 2 Sensor 1 oxygen fuel sensor on my 05 chev avalanche, as was diagnosed. After doing so it still has a misfire and the new code i received was a P0300 which opened up a pandora's box of what else could be wrong. Faulty fuel injectors, spark plug issue, ignition issues, wiring issues. I haven't touched anything else but i don't know where exactly i should start to find the real problem now. Can someone give me some advice so i don't go spending a fortune on


Have you tryed geting gas at a different gas station? maybe you have water in your gas. i had a missfiring problem and and dumbed a bottle of gasline deicer in the gas tank and the missfire went away. I am now running lucus oil gas treatment to make ... 2005 Chevrolet Avalanche

2000 blazer bucky under load? replaced fuel filter and did a pressure test, I get 55 to 65 psi. the specs say 60 to 66 so i think the pump is fine. I brought it to autozone and a 339 CKP code came up and a 300 misfire code. is this the CKP sensor or can the problem be somewhere eles. Fuel reg.?


I would replace the crankshaft position sensor, the codes would indicate a problem there. ... 2000 Chevrolet Blazer

2000 Dodge ram 1500 would not start in cold, it was flooded and removed fuel relay to start, Then ran ok but threw codes 0300,0302, 0308 (misfires) ran kinda rough like it was clearing out. Pulled fu


... Cars & Trucks

I have a 2002 mazda millenia. It is pulling codes regarding shift sensors. At cruising speeds it feels as if you downshift suddenly or possible like it isn't getting fuel for a moment. We have replaced speed sensors, fuel filters, fuel pump and O2 sensors. Mazda did not solve the issue nor found any codes for the transmission. Could this be the knock sensor pulling these codes and casing the car to act in such a manner occasionally.


Can't solve, but, had the same problem. Replaced everything the codes indicated. Drove a couple of weeks and the transmission went. Third gear is gone. \015\012\015\012Almost $ 2000.00 to chase the codes, now the transmission is going to ... 2002 Mazda Millenia

1999 intrigue GLS 3.5- Runs rough. The guy I got it from was told the cat convert was bad so he gutted it. Still runs rough. I took it to Autozone and the codes read "bad cranshaft position sensor" and "multiple cyl misfire". I pulled the sensor and the wires have been very hot and were bare at the plug. Some may have been touching each other. I repair the wires as best I could and retried it. Still bad. I purchased a new sensor, still bad. I now have the plugs out and tested the compression. Al


... 1999 Oldsmobile Intrigue

My 2000 mercury villager 3.3 is misfiring on multiabil cyinders so i get a code 300 and a code325 knock sensor,, I have cleared the codes and they still come back on I have done a tune up plugs, wires, cap, and rotor,,fuel filter,,and still have the same codes come on.. I think the coil inside the distrbitor is going bad???any input would be helpful thanks


I think you should replace the knock sensor first, I have seen this problem very often.The sensor is located under the intake plentum but you can get to it by using a 1/4 drive long extension and a 10 mm universal socket.Loosen the bolt and use the w ... 2000 Mercury Villager

99 ML430 143k miles, had codes for misfires on cyl 4 and 5. Replaced ignition coils to clear codes, now hard to start from cold. Had p0100 code MAP sensor, found cracked/open vacuum hose, replaced hose. Runs pretty good once it will start. It takes 10 to 15 attempts to crank it cold before it will run. CPS was changed months ago. Help Fuel filter or pump maybe????? Thanks


P0100 OBD-II Trouble CodeTechnical DescriptionMass Air Flow (MAF) Circuit MalfunctionBasically this means that there's a problem with the Mass Air Flow (MAF) sensor or circuit. You will likely not notic ... 1999 Mercedes-Benz M-Class

I have a 2001 Subaru Outback VDC. I got a 606 code (pulled the code via Autozone) and then yesterday I started to also get a 303 code. Both are engine misfires. What happens is that I start the car and it runs rough. The Check Engine Light is flashing on and off. After 3 to 5 minutes, the engine smoothes out and the car runs fine. I first put in Gumout Fuel Injection Cleaner. After that didn't work, I took it to Merlins and they indicated either a spark plug cover or Coil Pack (for cylinders 3 a


OK you got a 606 nd 303 code both for engine misfires.\015\0123 and 6 cylinders getting a misfire.\015\012\015\012I wouldn't change the injectors right off the bat.\015\012Coil pack could be causing the miss, but it could also ... Subaru Outback

2002 jeep grand cherokee 6 cyl. died in traffic new dealer parts crank sensor asd relay coilpack new ecm from dlr and vin burned in can clear codes starts runs 5 seconds engine light comes on then stalls and says misfire coil 123 new sensor on distrib. 50psi fuel press


... 2002 Jeep Grand Cherokee

Where is ignition coil on 96 blazer i am getting a p300 code random cylinder misfire already changed plugs wires rotor cap air filter fuel filter catalytic converter and muffler only thing i can think of is coil or oxygen sensors i was told timing is preset but when warm only idles at 600 rpm is the idle speed normal and what can i do to solve misfire


YOUR DISTRIBUTOR HAS A HIGH VOLTAGE SWITCH INSIDE IT ALSO CAM SENSOR.THE HIGH VOLTAGE SWITCH INSIDE DISTRIBUTOR COULD BE THE PROBLEM. ... 1996 Chevrolet Blazer

I ahve chev epica 2004 ls the problem started 2 month ago where my check engine light came on and the codes where pulled out were p0171 and p0174(both banks are lean) i replaced my fuel filter, cleaned the mass air flow sensor, there is no vacuume leak, changed the hair filter. and after clearing the code it comes back within 2 inignition cycles. please help. its costing me a lot with no results.


... Chevrolet 1500
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.5001 seconds