Having problems with your 2005 Chevrolet Aveo ?

2005 Aveo brokedown just after hearing loud tin

\015 Our 2005 Aveo brokedown on Saturday. The starter would crank, but would not turnover. We had lights and flasher worked. For approximately two days prior, we heard a loud tin type rattle coming from the engine area--only when we excellerated. After excelleration and the car was running, the noise would be gone. On the day of the breakdown, the noise had gotten worse--really loud. We stopped at a stop light, and the car just died. We could not get it to start and had to have it towed. The car has approximately 100,430 miles. It has been a great car up to this point. What do you think the problem is?\015 Posted / edited by AnonymousUser on : 11-12-2017

Answers :

If you have not replaced the timing belt, this is what is must liking what happen
You have one of several things wrong
1- threw a rod = expensive
2- locked the engine up = expensive
3- lost the timing belt or chain = expensive but not as - IF _-- you didn't bend any rods

I hope this kind of helps - as I know no one wants to hear this kind of news.
I hope the best for you but it does sound like major engine problems.
Repair Help & Product Troubleshooting for 2005 Chevrolet Aveo

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0078 seconds