Having problems with your 2004 Nissan Quest ?

I have reset the service engine soon light, no help, and unpluged the repluged the accelerator pedal harnes, nothing,

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

It will not help buy allways deled the check engine light untill the (problem) is repaired (Properly) Then the light will not come on any more,
Repair Help & Product Troubleshooting for 2004 Nissan Quest

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have reset the service engine soon light, no help, and unpluged the repluged the accelerator pedal harnes, nothing,


It will not help buy allways deled the check engine light untill the (problem) is repaired (Properly) Then the light will not come on any more, ... 2004 Nissan Quest

No voltage at the engine coolant temperature sensor. On a 1998 Chevrolet Cavalier. Had it check and got an error code P0118. Put a new engine coolant temperature sensor and put new dex-cool coolant. I don't have a scanner to reset the check engine. So i unplugged the battery and waited 15 minutes. Then repluged it in and i am still haveing the Error P0118 problem? HELP!!!


Ever since 1995 you have to turn off useing a obd2 scanner, if you do not have one, you can go to any auto parts store and they will erase the code for free. by having the light still on the computer thinks it still has an error. good luck Toolman, ... 1998 Chevrolet Cavalier

I have a 2004 trailblazer a few weeks ago it started making a rattling noise then every time I went somewhere I could smell what smells like locked up breaks a few days later while I was driving it the reduced engine power light came on and now the it will barely do 5mph with pedal to floor pedal has no pressure. I thought it might be the throttle plate so I cleaned it but it did not help I have also unhooked the battery and pulled fuses to reset it still nothing. If I let it sit over night in t


SOUNDS LIKE A POSSIBLE MASSIVE EXHAUST RESTRICTION...ESPECIALLY WITH THE "RATTLING" NOISE ... Cars & Trucks

On my 2003 audi A4 1.9TDI the glow plug light warning and ESP light keep coming on and killing the engine, doesn't cut off but there is no power. It has been to a diagnostic machine twice and codes reset and has also had a new throttle pedal. It flickered the other day so just making sure nothing has been missed as I do not want to break down again and the problem has my mechanic scratching his head! Thanks for any help Julie


... 2004 Audi A4

When my 2004 Lincoln Aviator is turned 'off' the drivers seat used to position itself for easy exit. Now this feature no longer works and the driver's side seat adjustment (up down, backward forward adjustment) doesn't work. The accelerator pedal no longer works either. The system setup display states 'data error'. This problem happened AFTER the vehicle was serviced for a 'check engine' status (which turned out to be a gas seal leak at the gas cap). Help...!!! can't adjust drivers seat, mirr


Try the relays for it, they tend to tie several systems into one relay which could cause all those things to no longer work ... 2003 Lincoln Aviator

Ill start the engine and it will go down to about 500 rpm and will start to shudder and the rpm needle will shudder too. Then when i put it in drive and press the gas pedal it stumbles and hesitates during acceleration. I checked for air vacuum leaks and tried cleaning out the fuel injectors with some fuel additives but nothing has helped. Any ideas?


I am a mechanic, and also have a 98 Tarus, I had the same problem, I replaced the IAC, and made sure my spark plugs are Gapped properly, should fix it. ... 1998 Ford Taurus

I recently started experiencing trouble with my 02 Mountaineer. It started acting like it was bogged down and didn't want to accelerate. Then the Service Engine Light came on. We took it to Autozone and had it scanned and the codes PO152 and P1152 came up. We replaced the EGR valve and the O2 sensor Bank 2 sensor 1. But I am still experiencing the same problem. The truck does not want to go over 20mph and when I push the pedal the RPMs go up but it will not go over 25mph. Any help is greatly app


It sounds like a bad mass air flow sensor...this is a common problem... ... Mercury Mountaineer

The accelerator becomes dead and if you press the accelerator quickly it will work again for a short period of time. The engine runs fine and if accelerating the gas pedal is fine it becomes dead if you go back to itle or let off the accelerator and the RPM drop like approaching a stoplight. When this happens the Service Engine Light comes on. I have changed the oil, and the fuel filter and it is still doing this. The engine always seems to run fine the accelerator just doesn't. Do you know


I believe on those you have one of 2 things malfunctioning, either the throttle pedal position sensor which is part of the throttle pedal assy, or your throttle position sensor on your throttle body at engine. I would get some electrical contact spra ... 2002 Ford F250 Super Duty SuperCab

Code drive 5 . My 2004 trailblazer posted a code "drive 5". It showed the "reduced engine poweer" light, and would not respond to the accelerator pedal. I had been driving in slow traffic. I pulled over, turned the engine off, and restarted it. The reduced engine power light went off, and it drove fine, but the service engine light stayed on. The next day, I filled it with gas, and then the service engine light went off. Then I had the code read and it came up "drive 5".


Thottle body sensor, accelerator pedal sensor, restricted air flow...will all trigger this fault light. Go to your local Autozone, they will run an OBD scan for free, and explain the fault codes to you so the correct repairs can be made.Good lu ... 2004 Chevrolet TrailBlazer

Toyota 2003 Car of 85kW 2.0 D4D diesel. Who have a similar experience with some of these engines. The problem is this: if the engine is warm and then lowering the engine speed, the car starts to twitch. The car starts to lose power. When holding the accelerator pedal at the bottom, nothing happens. Motor is thinking for 5-10 seconds, then throws a cloud of black smoke from the silencer. When the engine is cold, there is no problem. Cold start, idle, and acceleration is very good with a cold engi


... 2004 Toyota Avalon

I have a nissan pathfinder 2001 and my problem is that the "service engine soon"appears in the panel board 7 months ago and its steady while my engine runs normally,but now my engine is vibrating while i'm driving and the "service engine soon"lights is blinking and i don't even reach the number of speed i want,i change my fuel filter the other day and and nothing happens.can you help pls.thanks


I've had this issue and had the engine codes checked. It was a coil wire in one of the cylinders (nissan has ignition coils instead of the old plug wires) and this will fix the misfire if in fact that is what it is. To tell if you are misfiring, do ... 2001 Nissan Pathfinder

Engine issues 1998 dodge Grand Caravan when accelerating transmission jumps. Anytime I accelerate hard the engine jumps. Service Engine light comes on but goes off (inter mitten). Van was taken to transmission garage and I was told not the transmission. My mechanic changed some switches, but van is now even worse... Van has been modified and used for my disabled child, we miss using it any help or suggestions would be great.


You would have to repeat the problem with the scanner hooked up and someone who knows what he's doing watching it. If the check engine light came on then a code will be stored. ... 1998 Dodge Caravan

I have a 2003 chevy s-10 that displays "service engine light" constantly. Also, the horn does not work. I have replaced the engine coolant thermostat and oxygen sensor which needed replacing. The "service engine light" and horn still do not work. How do I reset the light or turn it off? Help.


Take it to your local trustworthy mechanic. They have a nifty little gadget called a code sensor and they plug it into your car and turn the light off. It takes about 2 seconds. MOST mechanics will do this free of charge, especially one that you freq ... 1996 Chevrolet S-10 Pickup

I have an 1989 chevy pick up truck. The truck has an rebult 350 engine. The engine runs good and strong, but when you put the gas pedal down pretty far and fast the truck starts running very rough. Also when this happens, the service engine ligght comes on. The truck will then try to stall. If you just keep it running with the gas pedal just a little down for a while, it will clear up and run good again. Please help, Chris


It sounds like you may have a bad fuel pressure regulator. The fuel pressure regulator is in the throttle body housing and the throttle body in your truck works best at 13psi to 15psi, Any other setting will cause problems. Check th ... 1990 Chevrolet K2500

1998 Dodge Durango 318 V8. Engine won't idle. Car has been sitting. Battery was discharged - had to jump start. If you keep your foot on accelerator, engine runs smooth. Once you take it off, it dies. Hard to start unless you press accelerator also. Is there and idle adjustment or is it computer controlled? Computer reset procedure? Thanks in advance for you help.


Probably lost idle memory,all computer controlled keep it running for a period it should regain the idle memory if not make sure no rodent chew damage to wires to the throttle position sensor, if check engine light is on scan for faults. ... 1998 Dodge Durango

Problem with starting our 2000 Saturn LS2: Please help! Symptoms: 1. Frequently won't start ( maybe one out of every ten times)... strong engine cranking when it doesn't start .... Accelorator pedal not depressed before or during cranking as should be the case with this fuel injected engine. Usually waiting ten or more minutes ... it will start. Have tried a few times when it wouldn't start to depress accelerator pedal to floor and hold it there while trying to start it again to try to ''unflood


I had the same problem with my 2000 Saturn LS2 and after replacing the fuel filter, fuel pump, ignition module, and coils I still had the same problem, I found out it was the crank sensor the whole time, after replacing the crank sensor the car is ru ... 2000 Saturn Ls 4dr Sedan

Reset computer I have a landrover discovery 2001. The service engine light in on. Sometimes goes off and then comes back on. I have service the engine,, change oil etc. It is not giving any codes but according to motor vehicle division inspection station the Landrover system is not ready. Please help?


Have a code reader reset the cpu ... Land Rover Discovery

I have a 2004 Toyota Tundra and when I press the gas pedal nothing happens the engine just remains at an idle turning off the ignition and restarting does not help any, but if I disconnect the battery for a minute then reconnect it, it will work again for very short period, then it quits working again with no warning just all of a sudden I step on the gas pedal and the engine does not rev up it just idles. R your problem?


... 2004 Toyota Tundra

I have a 2004 GMC Envoy with 82400 miles. My service engine soon light continuously stays on. I have had it in the shop numerous times and they have run diagnostics. I have had a tune up done, 2 sensors replaced, as well as replacing the gas cap. The light is still on. I have taken it back to the dealership and they have run diagnostics again and nothing comes up, it appears the SUV is fine yet the service engine soon light remains on. HELP!!!!


You need to let us know what the fault code(s) is. Did anyone ever give this information when they were working on the vehicle? There are many reasons for the check engine light to be turned on. ... 2004 GMC Envoy

I own a 2000 hyundai accent a while back the engine light came on at the time it did not affect the car..but as time went on when I would climb a hill or down shift to pass a vehicle the engine light would start flashing..when that happens I can step on the gas but theres nothing there iit will not accelerate until the light stops flashing..Ive parked the car and know when I start it I step on the gas and the car stalls out Ive changed oxgen censor plugs and wires and nothing seem to help any ad


Could be two things (both of them, not just one):\015\012The ECM is responsible for advancing the ignition timing to give your car a boost when passing.\015\012\015\012The EGR is not operating the exhaust valve correctly. It is sup ... 2000 Hyundai Accent

No acceleration plz help car starts and will idle but will not rev and starts too hunt!!! slk 1999 she starts fine idles around 900rpm then if you put your foot on accelerator nothing happens and the engine starts too struggle!! if the maf sensor is in the left hand corner of the engine bay on the airbox! i took the boost pipe off and this seems to be solid no momvement in it like its locked is this rite???


Send your car to authorize dealer to scan the fault,avoiding guessing of replacement of part,ty ... 1999 Mercedes-Benz SLK

My 2000 nissian maxima with 106k on it a couple of weeks ago the service engine light came on and then last week the car started to bogg down during acceleration, but once i get over 2000 rpm's and stay at a constant speed it runs fine. the problem is all when you accelerate, it sputters, i don't know if it needs new sparks plugs or something with the engine not getting enough fuel. please help, thanks


The MAF sensor going bad on the 2000 maxima is known to cause the bogging down problems you're having. If you're getting a code for a bad MAF, look into replacing it. ... 2000 Nissan Maxima

How to reset service engine soon light, on a 2005 dodge stratus sxt, single overhead cam 2.4 ltr.had it scanned at autozone and its not a service code, they couldnt reset it, any help would be great.


Of course autozone couldnt do it ,encrypted software as it newer than a 2005.Now their could be a way of re setting it but finding out?? could be just a case of holding the trip meter down and turning the ignition on then waiting to see what happens ... Dodge Stratus

Service engine soon light has turned on and off 4 times over the last six weeks. The last time it happened the truck suddenly lost power and began to stall. Managed to keep it running by feathering the accelerator, and finally power returned after about 1/4 to 1/2 mile. Repair shop found error code for throttle pedal positioning sensor with scan, but service engine light went off before further investigation could pinpoint the problem. Since then truck has been running properly. The only other s


... 2001 GMC Sonoma Extended Cab

Hi, i have subaru impreza 1.6L for almost 2 years. I have a acceleration problem which come and go... (not permanent) The problem is when i try to accelerate it accelerate very slow(too slow), but if i had some long drive (about 150-200 KM) and i drive with 4.5-5 RPM, the car accelerate just fine for few days. I already tried to do almost everything, i was 4 time in subaru service. They did the following things 1) Computer reset 2) Engine Flush 3) Changing spark cables 4) Changing Ignit


Well i do feel the dealer has milked the golden cow on this one ,engine flush and leads coil?? unnecessary money as far as iam concerned ,i suspect a particle filter on the exhaust system is causing the problem but iam not a subaru dealer mechanic so ... 2006 Subaru Impreza
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.2247 seconds