Having problems with your 2004 Hyundai Elantra ?

I am having hyundai Elantra 2004 crdi model , i m facing trouble with RMP it not reaching more than 3000, when i start the engine and accelerate the very frist time it will go up to 5000 and when i ag

\015 RPM was not raising more than 3000,\015 Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for 2004 Hyundai Elantra

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Problem with starting our 2000 Saturn LS2: Please help! Symptoms: 1. Frequently won't start ( maybe one out of every ten times)... strong engine cranking when it doesn't start .... Accelorator pedal not depressed before or during cranking as should be the case with this fuel injected engine. Usually waiting ten or more minutes ... it will start. Have tried a few times when it wouldn't start to depress accelerator pedal to floor and hold it there while trying to start it again to try to ''unflood


I had the same problem with my 2000 Saturn LS2 and after replacing the fuel filter, fuel pump, ignition module, and coils I still had the same problem, I found out it was the crank sensor the whole time, after replacing the crank sensor the car is ru ... 2000 Saturn Ls 4dr Sedan

2001 geo metro lsi, engine noise annoying, mostly on acceletation I just bought a 1996 Geo Metro 1 owner, Senior Lady for cheap price. I had just a little bit of gasoline. Since I realized the engine was making noise at acceleration, I started accelerating slowly up to finish the gasoline. Then I fueled with premium gasoline hopping have it fixed. None. The noise is still there on acceleration. A friend of mine at Autozone told me to check spark plugs and wires, fuel filter and timing aswell. I


Pull the valve cover & check the rocker arm adjusting screws ... 1996 Geo Metro

Having hyundai Elantra 2004 crdi model,i m facing trouble with RMP it not reaching more than 3000, when i start the engine and accelerate the very frist time it will go up to 5000 and when i ag


It almost sounds as if the rev limiter is kicking in. ... 2004 Hyundai Elantra

1981 chevy 350/or 305?, it is a rebuilt engine, but when I set the timing at 0, 2,4,6,or 8 degrees it sounds good, however, when it warms up it won't start without moving the distributor. I checked the rockers on #1 cylnder at tdc. They are both closed. When I advance the distributor the car starts when hot, but doesn't have power. I am at a lost. I am thinking that it might be the ignition module, or ignition coil. Is there a way to tell? The engine is in a 1981 Caprice Classic and don't reall


Is your heat riser siezed? If it is siezed closed you have too much back pressure. You will need to free it up. To do this you may have to take the exhaust manifold off as it is situated in it. Use heat & WD40 to free it up. Good luck! ... Chevrolet Caprice Classic

This car has just started hesitating. The problem is most noticible during sudden hard acceleration from a stop. The engine actually feels like it is running rough short 1 cylinder for a second or two and then full power resumes. The car has good pep at all speeds except hard sudden acceleration from a stop. Punching the gas and releasing to quick rev the engine in neutral also produces a slight hesitation some times. I've changed the fuel filter and air filter and am running gumout injector cle


The DAMN THING has 200,000 MILES on it, give it a break, it is just waring out, drive it easy. (most likely burned valve) ... 1998 Toyota Camry

2007 Rendezvous CXL. 1) Driving at 65 MPH and all idiot lights come on, car bogs down, hit the accelerator and car goes on. Taken to dealer 4 times and problem can not be duplicated and no code in car computer. 2) Turn key to start and sometimes you must step on tha gas pedal several times for engine to kick over. 3) Putting car in reverse, auto door locks cycle lock, unlock several times. 4) Static on most AM stations.


... 2007 Buick Rendezvous CXL SUV

Ok ..what i have at this time is heavy misfires and i can get it to start hard sometimes and easy others ... start up you get a heavy fuel odor. probably flooding after it starts up and you can drive it. it with hesitate between 0-25 mph.and be missing real bad ..what i have is a code for misfire 1 for possible break in a vacuum hose. and the vap line for the canister.I have replaced the fuel filter only right now. no help tho.i have the 31 liter engine. I pulled plugs 2,4,6..6 looked nor


Sometimes you need the more powerfull spark plugs look the old ones and see if they math ... 1997 Chevrolet Lumina

My honda 2005 Ex accord developed a very slow acceleration problem. So bad that when l packed it and stay just for 1-2mins and start it again it will move itself once l release my legs from the break but once am on the road for a little acceleration, the transmission to the tyres seem disconnected so you here the engine accelerating but to output on the tyres. Also at the time the car had moved fro sometime and l stepped on the breaks to bring the car to a stop, when l take off my feet off the b


... Honda Accord

Hi there. I have a 2000 Pajero 3.2 DID 5 door with 175 000 Km on the clock. I experience uncontrolled acceleration and loss of throttle control Firstly let me get to the good points 1) The Engine doesn?t smoke, 2) Not using oil 3) Coolant level is normal, and don?t use any coolant 4) Pulling very strong 5) Fuel consumption over n 7500km towing trip was 8.4km/litre 6) And starts first time every time in any conditions. My family and I were using our Pajero on a 7500km tour across Europ


Something electrical is playing up but what is the big question and what i need to know is this engine fly by wire or a throttle cable to the injector pump or is it common rail diesel ,because if its the later then i would suspect a computer fault ei ... Mitsubishi Montero

Was drving my 2000 dodge caravan and the car stopped working while on the expressway. The RPM went from 2 to 1 and then finally 0 and the car wouldnt accelerate. The check engine light came on but changed the oil not to long ago; less than a month. When I tried to star the car everything works electronically and have a full tank of gas. The engine doesnt start.


Did you find that your engine overheated? What was the approximate ambient temperature? Has this occurred before? Periodically? These are just some of the questions I would need answered to better assess the cause of your problem. Nonetheless, what ... 2000 Dodge Caravan

1999 Yukon, even if I start the car and let it warm up before putting it in drive, I have to drive around the block at least once or twice due to the vehicle not accelerating past 10mph and the rpm staying below or at 1. Engaging the accelerator does not do anything, it will **** ect.. like its trying to catch up with the timing. I need this vehicle to last a little longer no funds to buy a good used vehicle nor the funds to totaly replace an engine.


This sounds like you have a bum MAF sensor (mass air flow sensor). This is the sensor between the air box and the throttle body. These are really good trucks. Unplug the sensor which is a 4 pin plug. If it accelerates from there, replace the maf. If ... 1999 GMC Yukon

My 2001 Corolla displays P0171 after it idles for a minute or two. If I drive it hesitates (especially under hard acceleration) and starts also displaying P0300, P0301, and P0302. If I clear the codes and again allow it to idle for 1-2 minutes it again displayes P0171. Idle is smooth the whole time (at least after it's warmed up). Lastly, it cranks too long when starting, especially when the engine is still cold.


... 2001 Toyota Corolla

Hi my 2001 Nissan Maxima VQ30 engine , when I starting the car It's won't start but if I start with press accelerator It will so I release accelerator then It's stop so again I do the same way and keep accelerator press few minute and release accelerator then it's fine every time when the engine cold it's happen same please help me to solve the problem thanks


Try a cts coolant temperature sensor if it is out of range. ... Nissan Maxima

Hiya, I have 98 VW polo that has recently started revin up engine. Started when changing gears(i thought i was stepping on accelerator but i wasnt!!) it happended about 4 times in one day and eventually engine started speeding without me accelerating! had to stop the car and turned engine off. When i turned car on again it was still reving up engine however it did stoped after second turn on and off... Had friend checking the cables -all new.. Any ideas??


... Volkswagen Polo

2002 liberty 3.7 liter. I have replaced the coil, plugs and injector for cylinder #6. On cold starts I get a ramdom misfire code and engine is missing. If I re-start 3-4 times engine starts up and runs fine. Warm starts seem to be "OK". Engine accelerates and idles fine. One time I had a misfire code in cylinder #4 and #6. Any ideas??


If you have Coil- on -Plug you haven't found the bad one yet\015\012\015\012Your not always going to get a code that is correct\015\012e.g.PO304,PO305 etc\015\012\015\012I would buy the injector from you, as I'm sure tha ... 2002 Jeep Liberty

1984 fiero what happens is that i drive the car anywhere from 1 mile to 5 miles, it runs great for a lil while then when i have to slow down for something the car dies. it starts back up right away but every time i let off the gas afterward the car dies and the car doesn't have any acceleration almost like the theres a plug in the fuel line. I fixed the O2 sensor and replaced the spark plugs and wires. now theres a hell of a knock in the engine. the car has 93000 miles and get pretty good gas mi


Sounds like u got a timming issue or a wire on the wrong plug geta book and check your firing order ... 1984 Pontiac Fiero

I am having hyundai Elantra 2004 crdi model , i m facing trouble with RMP it not reaching more than 3000, when i start the engine and accelerate the very frist time it will go up to 5000 and when i ag


... 2004 Hyundai Elantra

I have a 2002 Volkswagen Golf with a 2.0 engine. The 'check engine' light starts to blink and the car starts to shake violently, and it doesn't accelerate past about 25km/h. Then after riding it that way for a few minutes, the engline light stops blinking, and just stays on. The car shakes a little bit (not as violent), and the car accelerates past 25km/h but has a hard time doing so. I've taken it to the mechanic and the first time, they replaced the catalytic convereter and the spark plugs.


There are a LOT of problems that could have this effect on an engine ... but from this description it sounds like your timing chain might have skipped a tooth. If your timing is off, the pistons will not fire at the correct time, and will cause a vi ... Volkswagen Golf

2003 kia sedona--ck engine with P0135 when starting car-replaced bank 1 sensor 1 O2 and car runs fine ck engine comes on every time you start car with same code--i replaced ECU and it still comes on--if i clear codes the car runs fine with no ck engine until i turn off and start again etc,,,,


... 2004 Kia Sedona

97 mazda 626 dx 2.0. manual shift, crank but won't start,install used engine w/less than 50k miles, after original engine lose power replace valve stem seals, timing belt, w/pump,oil pump,distributor cap & rotor,wires,fuel pump, MAP sensor(after code), timing marks are aligned correctly.engine starts and run on 3 cyl after 1 plug is removed,no matter which plug/wire,but after re-installing plug,engine cranks but won't start,i am getting fuel and the wires are sparking at plugs,should i replace E


First check the spark plugs.\015\012\015\012If your engine cranks normally but will\015\012not start because it has no spark, or it stalls and won't restart because it\015\012has no spark, the problem may be due to any of the follo ... 1997 Mazda 626

I have a 2002 Daewoo Nubira 2.0 L engine the check engine light comes on at random this is after the engine misses a slight bit then the light goes out and car runs ok. This has happend about 5 times. Feels like the fuel is dirty or may have water in it. 1 time the engine stopped but started again no trouble. Prior to this problen I let the fuel tank run quite empty. Then I filled it up after 40 or so KM the problem started. Can you Help. Thanks Eldon Peterson


The check engine light is associated with the engine missing.The engine computer has a misfire counter programed in it's software once a certain threshold is reached it will turn on the check engine light. Once ... Daewoo Nubira

High oil consumption, but no visibleleaks: on a 2002 Toyota Hilander V-6. I suspect valve seals (vehicle was sitting for several months), but wondered if there was some other possible source. Only one time (after vehicle sat for 3 months)..engine started hard and smoked badly for 2 minutes. This was not evident any other time. Have not noticed oil smoke in the exhaust when starting or running engine any other time. Oil consumption varies: mostly 1 qt per 300-400 miles; but one time on a 350 m


... 2002 Toyota Highlander

Hi, l have a 1991 MR2 MK2'' turbo with Ferrari 355 body kit. The car has been standing outside in the wet all winter, only being started up a few times. Now l have started the car and as usual she starts on the button every time. She runs fine, however the dash is showing three warning lights, 1) battery, 2)engine cooling fan 3)exhaust temperature. Non of which go out when the engine starts. l have determined that the battery is not being charged and when running l have removed the earth lead fr


Those are the error lights that show on the MR2 when either the alternator is giving no charge, or when it is overcharging. An alternator can fail in both ways, and it sounds exactly like what you describe - improper charging. ... 1991 Toyota MR2

In the past 3 months from time to time truck will not start. 1, cut truck off to re-fuel and would not start. engine will turn over just not starting. 2. stopped to get a drink and snack got back in would not start. 3. went to get in at home would not start. Every time it took about 10-15 min. and it would start. weeks in between times of when this happens???? [email protected]


FILL FUEL TANK UP WITH FUEL POUR A CAN OF SEAFOAM IN GAS TANK OR FUEL TANK IT WILL FLUSH OUT FUEL INJECTORS. SEE IF YOUR FUEL INJECTORS DIRTY THAT WILL CAUSE THEM TO STICK OPEN AND FLOOD OUT THE ENGINE. ... 2006 GMC Canyon

My 1989 300SEL the check engine light flashes intermittantly starting at around 70 MPH. If I accelerate it stops until I settle in at another highway speed. The car also hesitates slightly at the same time, and then picks right back up. Also have to really pump the gas to get the car to start (Check Engine List flashes a lot during this time also) once I get the car started it's fine.


The check engine light\015\012comes ON when the cars computer (the ECU) notices any kind of electrical\015\012problem in car. In some cases the check engine light comes on then turns off.\015\012In that case the exact error is not gett ... Mercedes-Benz 300-Class
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.5822 seconds