Having problems with your 2004 Audi A4 2.0 ?

Error code p0238 and p0113 the car didint start redone timing and the car was fine on the test drive the second test drive it road for approx three kays and lost power and thick black smoke and the diagnostic threw out these error code what can the actual fault be

Posted / edited by AnonymousUser on : 25-09-2017

Answers :

DTC P0238 - TC Boost Sensor Circuit High Voltage
DTC P0113 - Intake Air Temperature Circuit High InputThe powertrain control module (PCM) monitors the temperature of the air entering the engine. The PCM supplies a 5 volt reference voltage to the Intake Air Temperature (IAT) sensor. The IAT is a thermistor that varies resistance based on temperature. As the temperature increases, resistance decreases. Low temperature results in a high signal voltage. When the PCM sees a signal voltage higher than 5 volts, it sets this P0113 check engine light code.

A code P0113 may mean that one or more of the following has happened:Internally failed IAT sensorFaulty connection at IAT sensorOpen in IAT ground circuit or signal circuitShort to voltage in IAT signal circuit or reference circuitIAT harness and/or wiring routed too close to high-voltage wiring (e.g. alternator, spark plug cables, etc.)Faulty PCM (less likely but not impossible)Possible SolutionsFirst, if you have access to a scan tool, is there an IAT reading? If the IAT reading is logical then the problem is likely intermittent. If the reading is less than -30 degrees, unplug the connector. Install a jumper wire between the harness connector signal and ground circuits. The IAT temperature reading on the scan tool should be maxed out at the high end. For example it should be 280 degrees Farenheit or higher. If it is, the wiring is okay, and it may have been the connection. If it isn't install the jumper wire between the IAT signal circuit and the chassis ground.
If now the IAT reading on the scan tool is maxed out then check for an open in the IAT ground circuit. If you get no reading at all on the scan tool, it's likely that the sensor signal is open or the 5 volt reference is missing. Check using a DVOM (digital volt ohm meter) for a 5 volt reference. If it's there, then unplug the connector at the PCM and check for continuity on the IAT signal circuit between the PCM connector and the IAT connector.

Hope helps.
Repair Help & Product Troubleshooting for 2004 Audi A4 2.0

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0073 seconds