Having problems with your 2003 Chevrolet Suburban ?

2003uburban not charging

\015 I have a 2003 suburban with a 145 amp alternator. Raplaced the alternator, and had the battery tested good, battery charge light still is on. The alternator has a three wire connector that indicates 0 volts, 10 volts and 0 volts. Battery voltage is 12.8 v. Also when I remove the positive battery cable and place a light tester between the positive battery post and the hot wire to the main fuse block it lights up, ( approx 2.8 amps ) nothing is on and the key is not in the ignition. To summerize: Alternator tests good, Battery tests good, no fuses are burned, charge light is on and there is a load between the battery and the main fuse block under the hood.\015\012If you could help me out I would be so gratefull Thanks Frank\015 Posted / edited by AnonymousUser on : 18-12-2017

Answers :

Make sure you have power to the back of the alternator and make sure you have power from the plug
Repair Help & Product Troubleshooting for 2003 Chevrolet Suburban

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0147 seconds