Having problems with your 2003 Chevrolet Malibu ?

2003 chev malibu wont start due to lack of spark from the coil pack, checked the voltage from the ignition and its ok, changed cam sensor, changed the crank sensor, tested the coil pack and the processor all tests good but no spark.

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

That car has 2 crank sensors , did you replace both? One is at the front crank pulley and the other is behind and low on the engine block, above oil pan. Be sure the ICM (ign control module has a good ground, (black wire) it grounds at a bracket where the trans bolts to the engine approx at the 2 o'clock position.
If I worked for gm i would do away with all the sensors and **** that replaced the the distributor. It'a a consumer rip off. If the the diagnontics can't find anything wrong and you still have performsnce problems you are guessing at changing this sensor or that sensor. It's not cheep.
Repair Help & Product Troubleshooting for 2003 Chevrolet Malibu

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

2003 chev malibu wont start due to lack of spark from the coil pack, checked the voltage from the ignition and its ok, changed cam sensor, changed the crank sensor, tested the coil pack and the processor all tests good but no spark.


That car has 2 crank sensors , did you replace both? One is at the front crank pulley and the other is behind and low on the engine block, above oil pan. Be sure the ICM (ign control module has a good ground, (black wire) it grounds at a bracket wher ... 2003 Chevrolet Malibu

I have a 1998 dodge neon 2.0 DOHC. I have weak spark on all four cylinders. I've replaced the coil and cam sensor and still no improvement on the spark. Motor has good compression and timing is on. Putting a test light on the coil pack connector and cranking the engine over, the test light stays on, telling me that the cam and crank sensor are working. I was thinking that the PCM is bad but a local dealer told me that I would have zero spark if that was bad. HELP?


Run a jumper lead from the negative to the engine. This could be your prob. ... Dodge Neon

1990 buick lasabre with a 3.8 engine, cranks but no spark. No voltage to the primary side of coil. Code shows 22. Changed the trottle position sensor, crank position sensor and cam position sensor. Had the electronic ignition module tested. Tested fine. Still no spark. Fuses in interior fuse block test good.


1. Monitor the 5v reference, Gray wire to the Throttle Position Sensor \012(TPS) with a Digital Volt Ohm Meter (DVOM) set to the MIN/MAX setting. \012 \0122. Monitor the TPS signal circuit, Blue wire with a DVOM. Voltage \012should range ... 1990 Buick LeSabre

I have a 2000 jeep wrangler 4.0 engine it ran good for 16 miles then would quit no check engine light on so i scanned it anyway came up with a p 1391 mis fire so i changed can sensor ran good about 30 minutes and died scanned again same 1391 i returned cam sensor and got a new coil pack and crank sensor i installed coil pack ran good about 30 minutes and died so i installed crank sensor and put back on old coil pack ran good 45 minutes then actually started missing and check engine light on it s


It does sound like the ecu is bad the only other thing it could be is the antitheft system is having problems ... 2001 Jeep Grand Cherokee

I have a 1999 dodge durango, bad motor I changed it I am not a dodge person. The motor I bought to put in , was supost to be a 99 318, I find out after I put it in it is a 1994 360. need less to say I have a problem, I put everything off the 318 on the 360 everything test good bot I cant get any spark to the plugs, I have replaced the cam sensor, crank sensor coil, cap, rotor and spark plugs. the computer shows no codes. That is next? THANKS JAKE STOKES [email protected]


MAKE SURE THAT YOU CHECK OUT ALL OF THE WIRES GOING TO AND FROM THE COIL AND IF THEY ARE ALL HOOK UP TAKE THE COIL TO THE PARTS HOUSE AND HAVE THEM CHECK IT OUT FOR YOU ... 1999 Dodge Durango

2002 taurus 3.0 ohv. no spark at spark plugs. new coil pack that tests good on the primary and secondary. New ignition switch, new computer, new camshaft position sensor. The coil pack is receiving battery voltage at the connector. The connector going to the crankshaft position sensor has 1.5 volts as the book calls for. I have not changed the ckp sensor. It turns over fine but just no spark on the plugs.


... Ford Taurus

1993 Buick Lesabre. Car dropped dead while driving. Something caused fuel pump fuse to blow. Traced short to coil pack assembly. Changed module assembly and coils. Fuse no longer blows out but..sometimes there is spark on lower two coils and car tries to start. No spark from top coil, and it gets hot. Have studies schematics. Have checked wires in harness from 8 point connection on manifold, to crank sensor and to cam sensor and 14 terminal coil pack assembly plug, Continuity exists on all simil


... 1993 Buick LeSabre

2003 Chrysler Sebring convertible 2.7 recently just died while driving checked for fuel and spark and the injectors and coils were not getting power I then replaced crank position sensor cleaned a couple grounds checked voltage going to tps crank and cam sensors which tested out good now I checked the coils and injectors again and all6 are gettin power all coils are good and plugs still no life just keeps crankin


Does that motor have a timing belt that may have broken? ... Cars & Trucks

I was driving my car it started jerking then died waited a few minutes then cranked up drove it to my mecanic he changed yhe crank sensor but no spark he went to autozone to get the ignition coil tested it was good i have no spark and no fuel on fuel pump i got a multimeter to trace wires i have power going to the coils but i dont know if i have ground i have power to fuel pump but i dont know if i have good ground some tech said it was my computer so i got a used one from a junk yard but still


... Cars & Trucks

1990 Bonneville SE 3.8L won't start. No hint of problem, then complete failure. Fuel pressure at injectors. 12V supply to injector coils goes lower then hi when cranking. Spits when spray cold start fluid into air intake. Spark tests ok via use of screwdriver in plug wire to jump to chassis. Coil pack primary and secondary ohms ok. Ignition Control Module tests ok at parts store. Have Engine computer supplied 12V at ICM input plug. Replaced crank sensor, cam sensor. Am toying with idea of gettin


Did you check and see if you have compression,You might be out on you valve timeing? ... 1991 Ford Aerostar Extended

My 1999 Ford 4.0 has a hard miss at driving speeds and it also has a rough idle in gear with your foot on the brake. I have changed Spark Plugs, ohmed out the spark plug wires, changed the coil pack, cam sensor, crank sensor and MAF sensor. The only code is P1151 (Hot O2 sensor) Please help!!!


You probably have a vacuum leak and by the sound of it, it idles rough with the brake pedal depressed its your brake booster ... 1999 Ford Ranger SuperCab

I have no spark on my 1997 dodge caravan i have changed the coil, cam sensor checked for volt to the sensors ande coil pack all have there rated volts next i'm going to change the crank sensor to see if that is it ?????????


Yes def change crank sensor that controls the coil on wen to spark... cam sensr usually controls injector pulse.... good luck ... 1997 Dodge Caravan

2000 ford explorer ohv 4.0I replaced head gasket. Ran great for three days. Wife was driving home and engines quits. Check engine came on. Check gage came on. changed coil pack - have fire changed spark plugs - still nothing checked fuel pressure at injectors - good checked back pressure at exhaust - good checked injector shut of switch under dash - good changed crank shaft senser - nothing changed cam shaft senser - nothing changed computer(brain box) - nothing changed alternator - n


Do a compresion check, if Ok then timing chain is ok, try some throtle body cleaner trough a vac. hose while cranking if stars, fuel pump is out, another way if you have no codes the most poss. cuase is your fuel pump, check press is gauge handy ... 2000 Ford Explorer

I have a 96 Plymouth Grand Voyager SE, V6 3.3 engine. It's not getting spark from the 3rd and 6th ports from the Coil Pack. I have changed the coil pack, plugs, wires, and even tried a different PCM. I went ahead and changed the crank and cam position sensors too. It's still not getting a pulse from the same plugs. Could it be a wiring, or wire connector issue? Could a bad relay keep those specific ports not to fire? Please help, I am stumped.


Have your ECM (Computer) checked out, it coiuld be bad. ... 1996 Plymouth Grand Voyager

I have a 2.4 it has no spark.. thats the only thing keeping it from running i have timed it put both crank and cam sensors on new coil packs.I also have injector pulse.I have power and signal to the coil packs and still no spark. it doesnt make any sense so far the answers i have been givin werent that helpful so somebody please help... Oh and ive also performed a case learn. didnt work. All battery connections are good and fuses are also good.


Hi!!\015\012\015\012You didn't mentioned checking or changing the IGNITION MODULE, perform the next testing if fails, REPLACE IT.\015\012\015\012\015\0122.4L EnginePrimary Coil Resistance\015\01 ... 2004 Kia Optima

2000 Ranger 3.0 Flex Fuel with no start condition. Have good fuel pressure, have replaced crank sensor, have replaced cam sensor, have replaced coil pack, have checked for camshaft turning,have noid tested injector harness, originally started to act up a year ago. Developed to needing to hold throttle wide open and crank to get it to start. Got progressivly more frequent. Now won't start at all. While cranking now, it cranks and sounds more like it wants to start with throttle wide open. Help Pl


U may have an intake manifold leak or low cylynder pressure ... 2000 Ford Ranger SuperCab

I have a 2000 dodge neon es im getting intermitent spark. i have replaced cam sensor crank sensor cam triger magnet asd relay pos cable to fuse box coil pack and pcm and still getting intermittent spark checkt all grounds timing belt and timing checkt out ok. no fault codes are present cam crank and coil pack have 12v


The PCM contains the ignition control module, this may be the problem, a dealer can test on a special live data scanner and give you a 100% certain answer, they can watch the signals from the crank and cam senso ... Dodge Neon

Got a 2001 Chevy blazer 4.3L cranks but does not start. got 62 psi at the fuel rail, replaced plugs and wires, got good spark at coil, replacing car and rotor! if the cam sensor or crank senor are bad willi still have spark and fuel is there a way for me to check injectors? was gas on plugs when i changed them. sprayed either in plugs and still no fire. so I'm leaning toward spark issue and help would be greatly appreciated.


... 2001 Chevrolet Blazer

I have a 2002 TrailBlazer with the straight 6,diognostic check said #3 cylinder was dead or misfiring, also map sensor showed up. #3 cylinder was misfiring, so to test the coil pack I swapped #3 coil pack with #2 cylinders coil pack, no change and a 2nd Diaognastic now said #2 cylinder was misfiring, Ok need new coil right ? so bought new coil pack and spark plug and changed out and no change, so bought new M.A.P sensor, again no change, still runs rough and missing, what could it be ?


Did you replace only one spark plug? that can cause issues because of differences in resistances between cylinders. also, did the map code stay off after replacing? ... 2002 Chevrolet TrailBlazer

I have a 95 chevy blazer with the 4.3 .i have tested and have spark entering the distributor but no spark leaving the distributor to plugs .have put new crank sensor ,cam pos sensor ,coil,plugs,wires,rotor&cap,and yes the timing was set correctly,this thing has me and two other good mechanics baffled.can anyone help?


Are you using GM replacement parts? I put an aftermarket rotor and cap on my 93 blazer 4.3 vortec and it did the same thing ......spark at coil but no spark at plug...... Put old dist. back on and the truck started. Got a GM cap and rotor and truc ... 1995 Chevrolet Blazer

My '99 Jeep Grand Cherokee Laredo 4.0 vin S 6 Cyl. will not stay running. The fuel pressure is good, Cam Shaft Sensor, Coil, Crank Shaft Sensor and Spark Plugs. I get 3 codes when I do the Ignition Code Test, P0353, P0352 and P0351. Can you tell me how to fix this? The definitions that I get are Ignition Coil #1 Primary Circuit, Peak Primary Circuit current not acheived with maximum dwell time. Not sure what that means either.


... 1999 Jeep Grand Cherokee

Change the coil pack, cam sensor, crank sensor, and spark plugs and wires and still no spark


Perhaps the ECM has failed, that's the only thing left that produces the spark ... Dodge Neon

2000 dodge status 2.4 it had an internment run and not run problem and then threw a code ( ignition no signal form the crank or cam sensor) forgot witch one so I scanned it again and no code so I changed them both and nothing checked for spark anew nothing so I changed the coil and still nothing checked all fuses all good and have power change all relays to the pcm and computer nothing so I changed the pcm thinking its getting power but not putting out still nothing and I did the timing belt a


I think it could be the wiring between the crankshaft and/or camshaft sensors. Check for reference voltage at the sensors. ... 2004 Dodge Stratus

I have a 1997 Buick Park Avenue shut down while driving will not start change crank and cam sensor ignition coil and coil pack strip still no fire getting good fuel pressure but no fire will not start


Did you check 5 volt refrence to crank and cam sensors also 1626 should not stop spark still should crank and shut off 1626 is theft signal enabled ... 1992 Buick Park Avenue

I have a 95 Cadillac DeVille, 4.9l cranks but getting no spark. It has sufficient fuel pressure. Have had the ignition module, and coil tested, both good, replaced hall effect or cam sensor in dist, but still no spark. Any help will be greatly appreciated, thanks.


... 1992 Cadillac DeVille
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.7020 seconds