Having problems with your 2002 Oldsmobile Alero ?

02 Alero not overheating, no heat

\015 My 02 Alero had an overheating issue a month or so back. We changed the water pump because it was leaking. Worked for about a week. Thought the thermostat was the problem becuase I would get heat, then lose heat, then by gage would go between normal and hot and then would go back down to normal and I would get heat back. Well needless to say my thermostat was not the problem. I did have an oldsmobile dealer look at it and he said my intake gasket and head gasket is leaking. I smell antifreeze when my car first warms up but eventually it goes away. I am not leakin any antifreeze or anything. I am stuck on this issue. Please help!!\015 Posted / edited by AnonymousUser on : 20-11-2017

Answers :

When you say not leaking antifreeze has your coolant level gone down at all? and is it that you have seen no leaks where you park it? What worries me is you can smell it when warming up, have you felt the interior floors to see if damp and do you get any condensation if put blower onto screen, if so then heater matrix is leaking if not could be down to headgasket and/or cylinder head leak.
Repair Help & Product Troubleshooting for 2002 Oldsmobile Alero

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0065 seconds