Having problems with your 2002 Ford SVT Focus ?

Cutting out when first started the car runs very rough...almost killing..untill you press down on accel. then rough again when you let off...also engin light is on. checked air filter,o2 sensor.???

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Changed plugs and plug wires runs great now
Repair Help & Product Troubleshooting for 2002 Ford SVT Focus

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Cutting out when first started the car runs very rough...almost killing..untill you press down on accel. then rough again when you let off...also engin light is on. checked air filter,o2 sensor.???


Changed plugs and plug wires runs great now ... 2002 Ford SVT Focus

Runs rough or dies when idleing. Change mass air flow sensor and all 4 o2 sensors as this is the code it pulls. Check engine light came on after reset and still rough idle and engine dies at stop lights.


Hi,Your throttle body may be carboned up and need to be cleaned! This can\015\012cause all sorts of idle and hesitation problems. This is caused by the\015\012throttle plate not seating properly. The First thing i would do is\015\012clean ... Ford F-150

Hey guys .i have a 1990 chevy c2500. a while back it started running kinda rough when at low rpms... then it began blowing the ecm fuse after running for about 10 minutes, and the check engine light would come on. i know this was probably not the right thing to do but i put a just put a higher amp fuse in and let it be. ran good for about 6 months. about two weeks ago i gave a tune up, fuel filter air filter plugs wires, and also replace an o2 sensor that was bad. last week started running real


First check and see if you have spark at the sparkplug if you do then you need to check your fuel pressure.It sounds like to me that your fuel pump has went out to lunch.When you turn your ignition on try and listen for the fuel you should here it fo ... 1990 Chevrolet C2500

I have a 1999 Ford Explorer Sport SOHC. Check engine light came on and started flashing. Took it to have it checked. They told me engine misfire in a couple different cylinders and o2 sensor. I changed all plugs and wires, put a new coil pack and a new o2 sensor. Also cleaned throttle body and air filter. Used gas treatment. Still having same problem with check engine light. Also idles rough and is very sluggish. Doesn't stay on when idling at light or stop sign. What else should I do?


Fuel filter,module. ... Cars & Trucks

1994 F150 5.0- new mass air flow sensor, new throttle position sensor. It will start when it is cold,revs at 600-700rpm and check engine light is on.When truck warms up, check engine light goes out and now idles at 1300-1500 rpm with no power at all. It also consumed 1/4 tank of fuel for 38 kms. Also when warm, it will not start at all. I believe it is running super rich as per fuel consumption,high idle when warm, and if it does start ( hardly ever) it lets out a cloud of unburnt gas fumes that


What codes do you have?\015\012You have a check light on,you have to \015\012diagnose and repair that issue first ... Ford F-150

Wife washed engine got air intake soaked K&N cold air intake now the engine is running rough and will not clear up if i depress accelerator too far it wants to die seems to go into limp mode if i let off gas after a few miles it runs smooth again however will not let me depress accelerator too far again it starts all over again! suggestions checked maf it's good could it be throttle position sensor? P.s its a 96 yukon 5.7L 4x4


Hey, I think you are looking in the wrong area. The 5.7l distributer and rotor buttons are prone to getting wet. You need to remove the cap and clean the rotor, distrib cap and any internal components you can see. Good luck. Also check the plug wires ... 2006 Chrysler Sebring

2002 saab 9.5 2.3 lt turbo the check engine light came on and the car was running rough so plugged in my scanner and got a p106 code map sensor code repaced the map sensor the mass air flow sensor checked for vacum leaks there is none took off the throttle body cleaned it cleaned out the air box replaced dirty air filter and the code will pop up pending right away since weve done the work we have the car is running and idleing really good but the p106 code will not go away any idea


Will your scan tool erase the code. maybe check the( ITA )intake air temperature sensor ... 2002 Saab 9-5

Oil light came on runs really rough and then shuts down. so far i replaced fuel pump, mass air flow sensor, oil pressure sensor and oil level sensor. nothing yet. no check engine light either.


Don't run the engine with the oil light on. No oil pressure means no oil circulation, and damage will result. Have a shop check the oil pressure with a gauge that plugs into the oil pressure sensor port. If no pressure, check if you need a new oil ... Cars & Trucks

I own a 03 chevy 5.3 liter z71 runs good but loses all throttle response. check engine light comes on and says loss of engine power. i pull over put it in park it has a rough idle. i can push on brake and gas pedal nothing happens i push on gas pedal alone and have a little reponse in rpm. i have changed out my air intake sensor, throttle body, plugs and wires, throttle sensor, and exhaust sensors. None have fixed my problem. Is there something else i can do to fix my problem


... 1996 Chevrolet Cavalier

My 04 GMC Canyon Crew Cab, 3.5 5 cyl has a rough and irregular idle and a reoccurring engine light displayed. Light goes out when tank is full. Replaced gas cap already but no change. Fuel level is low, light reappears? Changed plugs and cleaned air filter and mass air flow sensor.


... 2004 GMC Canyon

Need Help with 2000 F350 5.4 , 2 valve misfire / rough idle problem . The truck has 120,000 miles and has ran great until a few months ago . The misfire started out , only once and a while , then got worse with time . (No "check engine light" ever has came on) I really didn't know if it was spark , fuel or air so I started with the cheapest / easiest things first . (Fuel filter , air filter , changed front two O2 sensors , cleaned mass air sensor , other simple things , etc. ) Still no real chan


... Cars & Trucks

My 2005 Ram 1500 4.7 started running bad the other day after the engine light came on a few hours earlier. I have replaced the cam sensor and the throttle position sensor. It ran 200+ miles fine and then started again this afternoon. It dies or runs rough. It idles fine and at low RPM's seems ok. Picking up the idle a little while in park, it runs fine until around 1700 RPM's + and then the engine constantly bounces around as if I were giving it the gas and letting off back and forth. Then at id


All engines have a rev limiter in them to keep from revving the engine too high,they all cut out about 1900 to 2000rpms. ... 2005 Dodge Ram 1500

96' Ford econoline E-250, 5.8 liter automatic with air. No real power, rough eitel, when going highway speed, the motor flutters with no power at all. It gets better fuel mileage with overdrive off. I unplugged the map sensor and it didn't change the eitel roughness, second thing, everytime I start the engine, it revs up to 1500 then 20 seconds later or so, it goes down to below the eitel speed. Can you help? It acts the throttle is sticking The engine light stays on and does not blink.


Read this:-Today's cars are controlled by a Powertrain Control \015\012Module (PCM), your \015\012engine's computer. To repair or modify your car's performance, you need a\015\012 scantool to communicate with the PCM.The Check ... Ford E-250

I have a audi a6 2002 3.0 I have cbnaged the mass air flow sensor, air filter, spark plugs. And the car idle is a little rough still. This car has appx. 104,000. Miles on appx. The engine light blinks on and off and I got it tested by auto zone and the say on one of the codes was mass airflow sensor and or oxygen I really need help this is my primary vechile


... 2002 Audi A6

Recently bought 2000 kia sportage has sat for sometime 95,000 miles replaced timing belt as preventative, also air filter, valve cover gasket. driving fine, and then started running rough between shifting(manuel) then would catch up check engine light came on at same time, code was knock sensor, misfire on 3rd cylinder, replace knock sensor, now after engine warmed up it will lose power as if not getting any fuel it will die, but will start right back up maybe drive fine for a minute or so then


Did it come with remotes?if so replace batteries and reset alarm/immobiliser..first step. ... 2000 Kia Sportage

Car idles rough and stalls when giving gas, I replaced plugs, wires throttle position sonsor, and mass air floe sensor I have a 99 Pontiac grand am, just replaced the fuel pump and the car runs good but when after I come to an idle at lights etc and as soon as I give it gas it starts to die and sometimes does die. Check engine light is and it does restart immediately. I have a suspicion that it is some kind of sensor..any ideas?


Have you ever changed the fuel filter? If it's not that, and it's not a vacuum leak, it is probably your idle air control valve. ... 1999 Pontiac Grand Am GT

The GLS with a 3.4 engine is running rough. It will idle high (sounds like a chain saw) with lots of exhaust. It will "hiccup" going 60 mph. The service engine light comes on when it "hiccups". We just replaced the mass air sensor. But the problems are still there. It is only getting 20 miles per gallon and we thought its suppose to get 29 miles per gallon. If it is running rough we turn it off and restart it and it seems better. Any suggestions? We would like to get better gas mileage and slo


I had a similar problem on my Aurora 4.0. These had a common problem with the air intake plenum gasket leaking. The car, in this condition, couldn't measure the air flow properly and the result was a poor air/fuel mixture. This is easily seen with ... 1999 Oldsmobile Intrigue

Engine runs roughly after returning from the dealership. They replaced spark plugs and air filter system. I thought it was the mass air sensor so I unplugged and reinserted. There is no engine warning light but there is obviously something wrong.


I would immediately take it back to them and insist that they do something to correct the issue. You should not pick up your vehicle and have more problems after supposedly getting it fixed.Not really sure what they did to your Expedition, but rememb ... 2001 Ford Expedition

I have a 1997 GMC Sierra. The truck runs fine except when I am stopped at a light or in traffic. The engine idle is rough...but it never dies. The SES light comes on often and I have replaced fuel filter, air filter, plugs, wires and one O2 sensor but the problem is still there. Could this be a problem with the Idle Air Control valve?


Could also be the EGR valve. If you're truck is throwing codes, then take it in to autozone, they will print out the codes for you and give you a piece of reciept paper with the codes and explainations on them. also, if it is the EGR vavle, you ca ... 1997 GMC Sierra

1998 Jeep Grand Cherokee Laredo 4.0 6cyl, when i crank my jeep after about 1 or 2 min it will start idling very rough and the exhaust smells very rich. Seems like the motor is starving for air but there's no vacuum leaks. I have already replaced the idle air control sensor, fuel pump, fuel regulator, plugs, plug wires and air filter. Its not throwing any codes and even though the check engine light doesn't come on Ive still check it numerous times. Has anyone else experienced this or know wh


Have you checked the coolant temp sensor. They also have something called a MAP(manifold absolute pressure) sensor that could be causing this issue. This sensor will have a 4 pin connector and 1 vacuum line going to it. Should be on the firewall, jus ... 1998 Jeep Grand Cherokee

BAD RUNNER car runs great but after you drive it come back later it turns over rough but starts and service engine light comes on but no codes come up it acts like its getting way to much gas when hot. we replaced o2 sensorcoolant temp sensor throttle position sensor intake air sensor wires and more injectors test good what next this is 1993 pontiac grand prix 3.1 HELP


Check the fuel pressure regulator. Pull off the vac line to it and see if any gas is leaking out of the vacuum fitting. If you see any fuel replace the regulator. ... 1993 Pontiac Grand Prix

99 Explorer 4.0L 4x4 when cold runs rough. When all the way warm runs just fine. Replaced with OEM parts, MAF, PCV, O2 sensors, Fuel filter, air filter, and still get the check engine light. I have the IAT sensor and Coolant temp sensor to change out, but cannot locate the IAT on my vehicle. Please can you give me specific instructions on how to replace this one and if you think this could be the problem.


Have you changed the plug and wirers ? it is runnig rich at idle .my be the injectors ar leaking ... 1999 Ford Explorer

07 3.6L Cadillac CTS running rough. engine light flashing. I got the oil changed later that night my car started idling really rough and engine light was blinking. the codes read all cylinders misfiring as well as camshaft pos sensor and crank pos sensor... i changrd all 4 cam sensors and the crank sensor and its still idling very rough


Check coil packs ... Cars & Trucks

I have a Mercedes s500 2000 with approx. 110k miles. The check engine light came on and the code reader said P0170 (fuel trim malfunction Bank 1) & P0173 (fuel trim malfunction Bank 2). I replaced the MAF with a new OEM Bosch, changed the air filters and reset the codes. The following codes came on within 20 miles of driving and the engine idles rough: P0100 (MAF circuit Malfunction), P0170 (fuel trim malfunction Bank 1), P0173 (fuel trim malfunction Bank 2), P0130 (Oxygen sensor circuit m


Hi!!\015\012\015\012What all this codes have in common is that every single one of them can be caused by a vacuum leak, so carefully check for cracked, loose or disconnected vacuum hoses, wir ... 2000 Mercedes-Benz S-Class

Engine idles rough, I have new plugs, wires, air cleaner. Could it be air sensor and where would it be on 1998 Ford Explorer, 6cyl. .. Egine light stays on. I have tried to reset it, but it eventually comes back on.


What code are you getting when you check the obd2 computer usually the problem when an ford engine runs ruff check the tps sensor which is on the side of the throttle body opposite of the throttle cables tps stands for (throttle possitioning sensor) ... 1998 Ford Explorer
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.1533 seconds