Having problems with your 2001 Volkswagen Golf ?

Vw polo stalling, not starting, took to garage did diagnostic and replaced crankshaft sensor, running fine for few hours then light back on , took it back to garage don,t know what they did but seemed to be runnng fine, but light has come back on

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

What is your engine code? (3 letters)
\015\012
\015\012What fault code is present?
\015\012
\015\012If still crank signal then it could be the dual mass flywheel at fault.
Repair Help & Product Troubleshooting for 2001 Volkswagen Golf

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Vw polo stalling, not starting, took to garage did diagnostic and replaced crankshaft sensor, running fine for few hours then light back on , took it back to garage don,t know what they did but seemed to be runnng fine, but light has come back on


What is your engine code? (3 letters) \015\012\015\012What fault code is present?\015\012\015\012If still crank signal then it could be the dual mass flywheel at fault. ... 2001 Volkswagen Golf

Having issues with jerking..check engine light came on im getting codes saying the 5 of 8 of cylinders are short circuiting. Took to garage and they tightened my transfer case bolt was loose and it ran fine for few days and now light back on and same problems. They say they dont know whats wrong with it..HELP im getting frustrated. also my RPM's as i sit or drive with go up and down. High rev at start up also


I have no idea why tightening a bolt on the transfer case would have anything at all to do with your problem.First thing to check are all the fuses in the power distribution center. (box near the battery) Replace any that are blown and make sur ... 2000 Jeep Grand Cherokee

I have a 1992 subaru svx with a couple of problems. 1. all of the gauges arent working except the tempeture gauge and i dont know why. everything else works inside the car lights, ac, radio. ive checked the fuses and they all seem to be fine. we were told that when the security system was installed the car started shutting off. i took out the fuse for the security system and car no longer shut off but ran fine. but when i would put the fuse back in the alarm would immediatley when off and when


The alarm system was most likely not installed correctly, when you install an alarm system you need to know what you are doing or you can cause countless problems in wiring, as for the gauges i would suggest checking all wiring behind the cluster (ga ... 1992 Subaru SVX

I have a 2002 jaguar xtype 2.5 liter ..both my engines lights are on dont know what the problem ..when i wash my car both engine lights turn off , but when i turn the car on my engine lights turn back on ..and when i speed up my car studders n jerks then stops ..i took it to a mechanic twice n they still dont know the problem .does anybody know?


Were the spark plugs change in it ? Did he check for bad fuel Injecters, Word of advice ,When you own a jag, don,t take it to joe boy the (mechanic) You take it to the (Dealer) Ship, In the long run, It will cost you less ,Then useing joe the mechani ... Cars & Trucks

I have this 02 lincoln ls and we just changed the motor in it and took it down the road for the first time and a light in the dash came on said check transmision and i got home shut the car off started it back up and then it didn't say it. I took it down the road again and it did the same thing and then the check engine light came on so i took it back home and plugged a handheld scanner in and got a code p0795 and it read accross the bottom (press ctrl sol. C malfunction) so i dont know if it wo


Check the neutralising switch (park neutral switch) there is an ignition wire that sould connect to the switch.. If you have loss of power that can be a likely case.. everything runs fine,, then just clear the code and see if it happens again.. ... Lincoln LS

The battery warning light in our 99 T&C started coming on. Garage diagnosed as bad (old) battery. Put in new battery, ok for about 4 days, took back and they said it was bad new battery . . . replaced and seemed ok for a few days again. Now it is back. It seems to come on from a cold start (overnight in heated garage). If you drive for awhile and shut car off and let it set a few minutes and restart, the light does not come back on. Car seems to run fine . . . no sluggishness, no dimming of ligh


The altenator will need to be replaced. ... Chrysler Town & Country

HI I BOUGHT A VAUXHALL ASTRA 1.6 16 VALVE AUTOMATIC T REG IN REALLY GOOD NICK BODY WORK FABULOUS BUT ABOUT 30 MINS INTO MY JOURNEY BACK FROM BUYING THE CAR ORANGE LIGHT CAME ON AND MY CAR WAS SLUGGISH AND WAS PULLING OFF AT JUCTIONS VERY SLOW IVE TOOK IT TO 2 GARAGES AND PUT ON THE SCANNER BUT NO ENGINE CODE SO I TOOK IT BACK WHERE I GOT IT FROM IT HAD A FEW REPAIRS ON IT THE BLOKE SAID IT WAS A FAULTY SWITCH BUT THEN ON ME WAY HOME THE LIGHT COME ON AGAIN TWICE IM JUST GETTING FED UP NOW DONT K


Some times the knock sensor gets faulty and need replacing ... 1999 Volkswagen GTI

I have a 2005 Chevrolet Lacetti and the engine light (MIL light) is on. I had this problem 2 years ago and brought it back to the garage where I bought it. Car was stalling & it was like there was a drag on the car. It took them 6 weeks to find out what was wrong. It was the Catalytic Converter & ERG valve. Both were replaced at a cost of €900. Luckily for me the car was still under warranty. The light has come back on again but no drag on the car like before. The car is driving fine. I am just


We need the trouble codes, please. \015\012Please see my tip at http://www.fixya.com/cars/r5932051-check_engine_light_check ... 2005 Chevrolet Aveo

1995 subaru impreza turbo it was running fine but then just started chugging a little bit then battery died so replaced it and gave it service then was running fine for 3 to 4 hours then started chugging again! so took 2 garage and came back with results of idol switch , knock sensor, map sensor, vehical speed sensor, any ideas which one it is? it runs fine on tick over but splutters when reved? garage dont think its the coil packs? tried disconectin them? and revving engine but engine changes w


You don't have a MAP sensor u have a MAF (Mass airflow) sensor, that sensor is located in the air inlet hose to the engine, has a four to six wire connector going to it, that may be your problem, the speed sensor will cause ... Subaru Impreza WRX STi

Problem with a 2006 ford focus My battery light cam on the other day and i brought it to autozone. Checked the battery and it was bad. Got a new battery put in and checked it again. The battery and altenator worked fine. Went to start it up the next day and it starts fine but within 5 seconds the battery light comes on. The automatic locks went off three times by themselves. I brought it back to autozone but the battery and altenator check out just fine! I dont know whats wrong with the damn thi


... 2006 Ford Focus

My 1999 ford tauras se was out of trans fluid check engine light came on had it checked it said check fluid level or faulty trans filled with fluid took negative cable off batt reconnected light went off but came back on about 8 hours later the trans is changing fine besides hesitant take offs when i take of fast but if i take off normal its ok just want 2 know why is this and why did light come back on?


I think I would go with the later, faulty trans., and where is this fluid loss going. ... 1999 Ford Taurus

My left rear back light is not working although the fuse is fine. There is an icon on the dash saying "brake" but I dont know what it is referring too. As I was checking the bulb, I noticed there was a cord that was hanging but I dont know what it connects to. Can you please help


... 2001 Mitsubishi Eclipse

I HAVE A 2005 KIA RIO THE CHECK ENGINE LIGHT CAME ON TOOK TO THE KIA SERVICE AND THE CODE SAID CYLINDER MISFIRE TOOK IT BACK 3 TIMES AND THEY STILL COULD NOT FIX THE PROBLEM, ENGINE RUNS ROUGH AFTER DRIVING AND WANTS TO CUT OFF. IT HAS 80,000 MILES REPLACE TIMING BELT. DONT KNOW WHAT TO DO ABOUT IT , I HAD THE FUEL INJECTOR CLEANED, HAD MECHANIC REPLACE BRAIN BOX, TO NO SUCCESS, KIA SERVICE TECHS REPLACE COILS WORK FIND WHEN THEY TEST DROVE IT, WHEN I DROVE THE CAR CHECK ENGINE LIGHT CA


Take it to another shop and have them do a compression check. If the compression is low, you have found the problem. If the compression is the same as the other cylinders, trade the fuel injector at that cylinder with another cylinder and see if th ... 2005 Kia Rio

1994 jeep cherokee sport, rear dome light will not come on when hatchback is opened. Works fine if I switch on all dome lights (front & rear) via turning headlight switch. I am assuming there is some electrical problem at the rear hatch, as everything else works fine.... I took a look at everything tonite, but cant spot any issues-- though I dont know what to look for in particular.... all wiring & harnesses appear intact. I WD-40'd everything, but no fix,,,


Look for a button like thing sticking out of frame where door closes, or even on door frame for same. May even look like a wedge shaped black button, spring loaded, try moving it to see. That will be your switch that turns on the light when open. ... 1996 Jeep Grand Cherokee

I dont have to excelerate the car goes by itself i have to keep my foot on the brakes all the time, the engine is racing off when on park and the car jerks when i have to change the gear. the engine light is on and when i took the car back to the dearler they told me its a glich and nothing is wrong with the car.. they keep on running me around for the whole month that i have warrantty , i took the car back about 6 times now there is a serious problem and i need yo know what is wrong with the ca


SOUND LIKE STICKING THROTTLE LINKAGE.HAVE ACCELERATOR CABLE CHECK UNDER THE HOOD ITS BINDING OR MISROUTED IN THE WRONG PLACE CAUSING A PULL ON ACCELERATOR CABLE CAUSE THROTTLE HANG OPEN CAUSING HIGH IDLE. ... 2002 Chevrolet Impala

2001 suzzuki grand vitara, engine management light came on and took it to the garage and they told me it was the throttle position sensor so i changed it and put a new part on it but the problem came back less than a week later the garage doesnt know what it is now does anyone know what the problem is or how to fix it ?????


If you live near a Autozone or simular store, they can usually pull up all the codes for your vehicle for free. try there first and then see if the codes need to be cleared. ... 1999 Suzuki Grand Vitara

We had a recall 03 windstar ABS light was on all time we had front and back brakes replaced ford checked said rear axle ok but, light is still on and brakes make a terrible noise and sometimes they go to floor sounds like metal grinding took back to garage where we got brakes they say they are fine what could problem be


I own a 2001 Windstar. Your noisy brake problem could be nothing more that new brakes being broken in. I have done many brake jobs on my 2001 Windstar as well as other vehicles that I have owned. To prevent this problem from occuring, I apply a th ... 2003 Ford Windstar

03 eclipse gs 2.4 auto.Runs rough also if you give it alot of gas it has almost no power and almost stalls but doesnt. I have replaced plugs,wires,coils cam sensor, crank sensor, cleaned throttle body.....also it did have a check engine light on codes p0335 p0340 p0300 after i replaced all those things i cleared the light and it never came back on but still runs rough...i dont know whats left to do!! It was running fine 2 days prior... Then it started and ran rough.please help


Possibly the o2 sensore ... Cars & Trucks

My abs and brake light came on and brakes feel fine the light some times dont come on for 15 or 20 miles after i sut the suburbin of and start it back up its a 2002 the dealer seams to think the abs mod is bad but the abs seams to still work there is know code in the comp for the problem any suggestions


... 2002 Chevrolet Suburban 2500

When i put my truck in reverse the back up lights dont come on how ever the bulbs are fine i dont know what the problem is can you help?


There is a reverse switch that is on the transmission that engages when you put your gear selector in reverse. This tells the lights when to come on. I would recommend that you check the connection on the switch prior to buying a new one. The wires w ... Mazda B2300

My n reg ford escort keeps cutting out when you stop a corners but it starts Straight back up.any answers? the cars only been cutting out since the bad weather, i dont know much about cars ,the car starts up fine and drives fine but some time when i come to traffic lights or coners i slow down and the engine cuts out,i changed the idle control valve and air fillter as well as the gaskit and it still dos it any idias what it could be now?


I need to know wich engine you have. if it is an 1,6 or 1,8 litre zetek or 16 v check the sensor at the gearbox ... 1993 Ford Escort 4 Door

SRS light is staying on. I took it to the dealer awhile back for the same problem. they said it was the selt belt sensor and fixed it but it is back on again. dont know what to do. please help


As this relates to your safety.unless you are fully trained/certified/insured.to fix it yourself,is potential suicide,please entrust it to a dealer that you trust and has the correct equipment to diagnose fault(s)I always got a collegue to check my w ... 2002 Acura 3.5RL

1975 buick electra 225 with 455 engine in garage 5 years started 2 times a year this year I started run outside approx 2 hours put back in garage next day started same run and purred 2 HRS 3rd day took more than usual and is missing big time. I installed new cap and roter,new set of wires,new plugs.I put Rislone eng treatment in case I have stuck lifter or valve , you have to work the gas pedel so it doesnt shut off until it warms up. missing terrible. dont know what to do except take off intake


1975?? it has a carb and points ,check the points gap first if that doesnt work then its carb strip and clean ... Buick Electra

I have a 2004 Trailblazer that has started to transfer into neutral abou 1 hour after the engine is shut off. All the different drive lights blink with a steady green "neutral lite up. Can only get it back into 2WD or $WD by following the "shifting out of neutral" instructions in the owners manual. Then it works just fine until the engine is shut off...then it goes back into neutral by itself after about 1 hour. Took it to a garage and they can't seem to find the problem . Thanks for any gui


The most likely cause for this is the Transfer Case Control Module (TCCM). At the dealer it is an expensive part (~$400), check on Ebay. If you buy a new one, it will need to be programmed by the dealer. The dealer can also check for any fault codes ... 2004 Chevrolet TrailBlazer

Took car in working fine to have remote start instlled. remote works fine but somehow it is killing battery. every morning car needs to be jumped. replaced battery w/energizer still dead in am. Headlights also stayed on for 10-15 min after ignition turned off. took it back to shop and they "bypassed the light switch'. Now lights don't stay on at all and i don't have panel lights. took it back to shop and they said i needed new computer, $300.00 later so far it works ???? SO FAR MY REMOT


... Chevrolet Impala
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.4219 seconds