Having problems with your 2001 Toyota Camry Solara ?

Keep getting cat code 420 replaced cat and o2 sensors when pulling o2 sensors noticed they were white wondering if manifold cat is bad also car shakes when parked up hill

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

It sounds as if your air-mass meter is going bad. good luck :)
Repair Help & Product Troubleshooting for 2001 Toyota Camry Solara

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Keep getting cat code 420 replaced cat and o2 sensors when pulling o2 sensors noticed they were white wondering if manifold cat is bad also car shakes when parked up hill


It sounds as if your air-mass meter is going bad. good luck :) ... 2001 Toyota Camry Solara

Water temperature is warmer than usual and cooling fan is very loud. Started car this morning and turned on the a/c. One cooling fan came on and sounded like it was about to take flight. Opened hood and noticed other fan was not running. Temperature was normal at the time. Am wondering if other fan could be bad or a bad sensor? Also yesterday, left car running in park for about 15 minutes. Temperature was past half on the gauge. Never seen it this high. Fan was running very loudly. Car cooled do


Unplug the not working fan and jumper 12 volts to it. if it works then wiring or sensor is bad ... 1995 Nissan Maxima

My car would not start, was cranking but not turning over. My cat converter was bad, I replaced it but now my car is running like **** and when driven my cat converter turns bright red. I replaced both O2 sensors and it stayed running but my car was still running bad. It is also throwing a multiple misfire code, so I replaced the coil pack and now my car wont start at all again. I also checked the spark plugs and they look fine...


Running extremely lean. Did you replace the 02 sensors? They detect lean and rich conditions and if the previous problem was too rich, the 02 sensors may have set ecu to run lean because of their problem. Now converters are free flowing and the s ... 2004 Chevrolet Cavalier

I was wondering if anyone could tell me where the cold start cyllenoid is on a 1994 ford probe gt. i was also wondering where a couple of the sensors were i.e. Heat sensor, Idle air control sensor, and the throttlebody sensor. The reason is that after my car warms up it starts to bog down really bad when i hit the gas from a stop especially. I have to be extra extra light on the gas or it goes absolutely nowhere and just sits and sputters. Also if I have the overdrive on it seems to have trouble


Your timing belt may have jumped time or maybe the catalytic converter is plugged up. I doubt you have a transmission problem. You could also have a plugged up fuel filter. ... 1994 Ford Probe

2002 nissan sentra gxe 1.8l haves horible knocking sound form engine. sound is at idle, low rpms, or load like going up a hill and with a/c on. when a/c is of still does it not as loud. car haves cel light witch was maf sensor and coolant temp sensor and remains on. i've replaced all and also throtle cable, dampner pully, thermostat, and oil changes are on time. everyday it gets louder. ive added fuel treatment and injector cleaner. car does not overheat. also deleted the cat in case of it beein


... 2002 Nissan Sentra

2001 buick regal ls non supercharged I changed the map and mass flow sensor on 3800 engine. It also has a little knock but it didn't start riding rough ro knocking intil I had the intake manifold gasket changed and they also changed some rings, moter also shakes when shift to drive or reverse, and car shakes when driving


... Cars & Trucks

I own a 1997 Honda Accord V6 and it just wont start. I turn the key in the ignition and it turns but just won't crank. I was told that the speed sensor was the problem by the diagnostic scan that was ran on my car. I was also told that it might be my ignition switch going bad and I heard it was a recall on that part. Also the day that it stopped starting the car was in park and it was on and it kept cutting back like it wanted to shut off. I replaced the Ignition control module and still had no


Check main relay for cracks ... Honda Accord

2005 impala after instaling 4 new brake and rotors and 2 new front wheel hubs abs and trac light will come on after drivivng a few miles park it a few minutes and they will go out.sounds also like a bad bearing roaring on rear of car abs and trac light and abs light never came on before this change . could it possibly be a faulty hub asembly or plug also has alitle shake a low speed like a bad tire put 4 new tires on and still does same thing feels like it is on rear passenger side


All the hubs on the car have the abs sensor built into the hub. The abs system has to be re set to read the sensor . The rear hub bearing if noisy should be replaced. There are wiring harnesses that connect to the abs sensor. The harnesses to each ... 2005 Chevrolet Impala

Rough/Hesitating Acceloration lately when I hit the gas from a stop the car hesitates bad and takes a few seconds to finally kick in. It also boggs pretty bad when it downshifts going up a hill sometimes, or even just on flat roads as well. The engine light ocassionaly flashes, and i checked it last week and it said Fuel Sensor Level B High input. I am thinking either bad fuel filter or fuel pump, but i am far from being an expert. Thanks for the help.


Hi,\015\012\015\012 Yes it does sound like a fueling issue, but could also be vacuum sensor or airflow sensor.\015\012\015\012If you haven't replaced the fuel filter in 3 years, then it may be about time you did. It is also on ... 2004 Suzuki Forenza

2001 mitsubishi galant is shaking really bad when I put it in drive also in park I even changed the motor mounts front and rear and my car is still shaking. Even put new spark plungs I just don't understand.


... 2001 Mitsubishi Galant

1993 honda accord ex is making bad creaking spring sounds when pushing down on the car when its parked, also when driving slowly it sounds bad and when i put on the breaks/stop. it doesn't do it when im driving at higher speeds. It wasn't doing it yesterday before I put wd40 on it to stop a creak it made when going over bumps, but now its making it maybe because of the wd40. Wondering what it is


You have wore out bushings in the struts that should be replaced ... 1993 Honda Accord

Cooling fan won't come on when car is up to temp. Fan came on when power wire to it was grounded out. The new thermostat is hooked in but does not work either. Wondering is the coolant temp sensor is bad (looks new). Also the headlights randomly lose power (was hooked into same circuit as cooling fan, so they'd go out when car up to temp, but we thought we'd fixed. Previous owner evidently installed all new ECM. Help!


... 1991 Chevrolet Cavalier

1994 olds cutlass cieria s with slipping transmission, its slow getting into gear when it does the car jerks. Also if I stop on a hill my car rolls backwards... What are the chances its a bad shift sensor?


... 1994 Oldsmobile Cutlass Ciera

Having engine problems with y 2004 saturn vue. looses power and shakes and uses a lot of fuel. could it be the computer and about how much will it cost to fix that. was told by another mechanic that the main computer could be going bad or a oxyegen sensor or the cadilic coverter was bad. also was told that car is not fireing on all four pistons andwas only firing on three. when check by scanner it came up with everything being wrong.


O2 senser will make it use gas. you could have bad spark plugs or wires ... 2004 Saturn VUE

When i go from park into drive, my car shakes really bad and it doesnt feel smooth at all. Also when the car changes gears it shifts hard and jerks forward. I have an automatic pontiac g6 2006.


Sounds like you have a broken engine mount. Open the hood with the engine off and rock the car back and forth if you hear the clunk then you know you have a broken mount ... Pontiac G6

When driving on the interstate going about 70-80 my car will hop/**** and the rpm jumps up to about 7000. Also when sitting at a stop light, my car will shake really bad and act like it wants to stall. I've replace the transmission range temp sensor and solenoid.


Interstate problems: Faulty Torque Converter or Transmission Electrical Harness. The shaking could mean a clogged fuel injector, fuel filter, or a bad spark plug in one or more cylinders. Your local parts house will show you how to ... 2000 Mercury Cougar

2000 Pontiac Sunfire, 2.2 litre engine, automatic. Suspected bad heater in O2 sensor. Idles really rough when first started up in the morning. Exhaust smells really gassy. After engine warms up runs great for the rest of the day. Is there 1 or 2 O2 sensors on this car? Looking up O2 sensor for this car in catalogs shows a before cat convertor type and an after cat convertor type. Is there 2 O2 sensors on the car or just one or the other?


I wouldn't be looking at the o2 sensors! look at the coolant temp sensor! when the car is cold it doesn't correct fuel & air ratio until it is warm so it is not looking at the o2's till then! if the sensor is bad and telling the computer it is wa ... 2000 Pontiac Sunfire

I have a 2000 saab turbo 9-3 and i blew a rebuilt motor just recently. when i took the head off, it looks like the first and the fourth cylinders were detonating bad. The car would barely drive but when u lat the gas go it just brakes by it self. Also when i drive it on the high way for about 5 minutes then stop the exhaust manifold is so hot that its red. Anyways i just put a new motor in it and its doing the same thing. I was wondering if anybody has any advise for me on what the problem is.


The engine sensors are badly wired/installed. Since i don't know what you did to them all i can say is to remove them all and start all over again. ... 2000 Saab 9-3 Viggen

2000 Hyundai Elantra. I replaced the O2 Sensor on the manifold, but the fault stillshows it is bad. The car also is decelarating when you give it gas while driving above 50 miles per hour. Any ideas?


Possible clogged catalytic convertor ... 2000 Hyundai Elantra

My 1995 GEO Prizm has been giving me problems for mo ths. It doesn't want to crank after has been parked for a couple of hours. I replaced the fuel pump, fuel filter...took to a shop for the check engine light and was told I needed a temperature sensor, so I got one of them. Then code 14 came up and the guy at the shop really didn't know what that was. Now the car is also missing bad and cutting off when you slow down. Sometimes, maybe one time out of 20 it will run perfect. Was told it could b


... 1995 Geo Prizm

3.5l engine, car shakes runs ruff, changed plugs,shaking lessened and car runs slightly better. took to auto zone had tested code P0344 possible problems cam sensor defective, timingbelt/out of trime, cylinder misfire...also another code said cylnder 5 missfire, also code P0340 cam sensor or timing whats the chance of it ust being the coil for #5, how involved is timing belt replacement or atleast setting the timing correct?


The chances are good for the number 5 coil needing replacement, but before i did anything else i would change that cam sensor, that could be causing your problem all the way around.. hope this helps... setting timing is a big drawn out job, i dont th ... 2003 Chrysler Concorde

I have a 2000 Buick Regal LS 3.8 and we are having trouble with it stalling while driving down the hwy. I replace fuel filter, crankshaft sensor and plugs wires along with plugs. We had the cat removed a while back on it. Tonight it stalled and it aways starts back, but i couldnt get it over 4,000 rpms in park and it acts like it might be plugged up, also it shakes at anything under 1000 rpms. It has no engine light on or throwing any codes! Got any suggestions? It has 124,000 miles on it


Try cleaning the Mass Air Flow Sensor with MAF cleaner. Then perform ECM relearn procedure. This should help! ... 2000 Buick Regal

2004 Jeep liberty 3.7 liter change the crankshaft position sensor, the car stalls sometimes and now its shaking like the motor mounts are broke or bushings bad , also the transmission fluid is not red looking and had bubbles in it on the stick, I think there might be something wrong with the fuel pump/filter, any ideas ty


... Cars & Trucks

It violently shakes when parked or when stopped with brake applied, doesn't shake when moving though, rpms is like 500rpm constant so between 0 and 1 on the gauge. it also notice at night my lights stay dim till the car warms up and than they are bright, the car also runs sluggish till the car warms up, the belt squeals till warmed up also, i start running mid grade it helped a little with the sluggishness, has a new air filter, new oil change, new tranny oil change, new brakes, new brake fluid


If it shakes, it is normally either a bad motor mount (if the car runs fine) or your car is "missing" on one or more cylinders (misfire). The belt will squeal because they stretch with use. That can be solved by replacing the belt or tightening the b ... 2003 Kia Spectra

2003 mits Lancer ES...2.0. original problem was bank 2 not burning fuel all the way which wiped out cat....it was determined that Coil pac was bad...so i replaced both coil pacs, both 02 sensors, Precat and cat. It ran good for about a month then the ck engine light came on and the 02 sensor was bad...so i replaced that and it ran good for about a week tehn ck engine light came on....same thing bad 02 sensor. I was chwecking all connectors out with car running when a got a shock from touching th


... 2003 Mitsubishi Lancer
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.7806 seconds