Having problems with your 2001 Buick Regal ?

My car start acting funny after a storm, now it will only accelerate to 1 or 2 if it accelerates to 3 it starts to act as if it wants to cut off or not go at all i can only drive if im accelerating in 1 or 2 what could be the problem

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Your talking 1st 2nd and 3rd gears in your tranny. Time for tranny service. Something got wet or broke.
Water cold have gotten in some of the electrical and it needs to dry out, or lightning may have caused a short or burnt module. Could it be possible that water got in the fuel system? This will have to dry out deveral days before you can tell if it can be resurrected or if a component needs replaced. you should get some kind of code or check engine light if something is not working correctly.
Repair Help & Product Troubleshooting for 2001 Buick Regal

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 1998 Cherokee with auto gearbox, with petrol/LPG conversuion... My beast runs fine, but having driven 250 miles it had no power due to a fuel problem ?? Accelerator pedal ineffective , although engine restarted regularly cut-out again when put into gear... Occasionally cleared & able to drive a few miles before problem reoccurred & roadside help called, Mechanics said it could have been water on plugs from smalll radiaitor leak. Drove further 150 miles to home with no problems, Tod


I think water on the plugs would make it run rough. But, that would be from the cylinder head gasket leaking into the cylinders and not a radiator leak. It's possible that the leak at the head gasket sealed up. Do you have to add coolant to the radia ... 1998 Jeep Cherokee

My car start acting funny after a storm, now it will only accelerate to 1 or 2 if it accelerates to 3 it starts to act as if it wants to cut off or not go at all i can only drive if im accelerating in 1 or 2 what could be the problem


Your talking 1st 2nd and 3rd gears in your tranny. Time for tranny service. Something got wet or broke. ... 2001 Buick Regal

Hi, My vw beetle 1.6 petrol stops taking the gas when driving and then engine would cut off. Sometimes, it jerks when accelerated as if something is blocked somewhere. The VAG error code is p16725. The car has just had a fuel pump filter changed and fuel pump relay changed. Could you please help re what is causing this problem, what the error code mean and how this problem can be sorted. Many thanks


... Volkswagen Beetle

Hi,rn My vw beetle 1.6 petrol stops taking the gas when driving and then engine would cut off. Sometimes, it jerks when accelerated as if something is blocked somewhere. The VAG error code is p16725. The car has just had a fuel pump filter changed and fuel pump relay changed. Could you please help re what is causing this problem, what the error code mean and how this problem can be sorted. Many thanks


... 1999 Volkswagen Beetle

When I accelerate to enter the freeway the engine cuts out and when you floor it the problem worsens. I can also hear some sort of vibrating noise when I do this. The other day the engine when I was doing a test drive, the engine just died, but did restart. I thought maybe the problem occured when I had the fuel injectors cleaned at EZ Lube, since the car doesn't seem the same since they did that. I took it back, but all they could find was a loose air filter. They tightened that up saying that


I am thinking your catalytic converter is plugged,But we need to run your codes to verify,but when you pull the top of your air cleaner were it goes in the engine see if it is real black and smells like alot of fuel,if it is it is ... 2004 Chevrolet Impala

Honda Crv 2003 check engine light is on. Engine cuts back at 2 to 3 thousand rpm, when accelerating. Scanner says code 1259 which says 1. open or short circuit cond. 2. Vtec solenoid valve fault 3. vtec pressure switch fault 4. blocked oil passage Don't know which one it could be without going to shop. Anyone had this problem? Just started today and I erased the codes and after 25 min. drive the engine stuttered again and light came on again. When accelerating fast it does it but not slowl


Tell me what kind of motor oil r you using.regular or synthetic. ... 2003 Honda CR-V

Hello my name is jose, i have a 1989 gmc safari slx. starts ok, accelerates fine on parking and neutral and stays on when put in drive until you depress the gas pedal, it chokes and dies. some say its the cut whatever selenoid, told me to take it off i did nothing happened, what could be the prescription to fix this problem, thanks.


... 1989 GMC Safari

My Toyota premio, 1500cc 2004 suddenly loses power / cuts off fuel after a long drive about 100km. Sometimes it loses power to a halt and has to be parked for some time before it picks up again. Pressing the accelerator has no effect even on raving at that time.Fuel pump, fuel strainer and air flow sensor were unsuccessfully replaced. What could the problem be? At one time, computer diagnostics showed something like 'fuel stream too thick in chamber one' or something like that.


... 2004 Toyota Corolla

I drive 2007 vw polo 1.6 tiptronic (hatch) when hot the engine cuts and when I accelerate after stopping at the robots or stop signs it stalls but it start immediately. I took it to VW more than three times but they could not find any faults on the Engine. I think the problem might be the fuel system. Please assist.


... Volkswagen Golf

My Opel Corsa 1.4i, 2005 Model just cuts off when idling or stopping. As i lower the gears all dashboard lights come out and the engine goes off completely if i stop or if i put the second gear and accelerate, it kicks and drives again but it will stop after few seconds. I was told to buy ignition coil and i did but the next day the same problem continued. None of the mechanics knows what could it be.


... Chevrolet Corsica

Ford Windstar (98) V6 3.0L power loss : While driving since a while suddenly the van begin to lose power. RPMs drops, speed come down slowly but could not increse power when trying to accelerate. Accelerating does nothing, the max RPM gets lower and lower as I drive. Shutting down the engine a few seconds/minutes then restarting, solves the problem temporarily. But a few minutes later problem starts again. Having this happen more often as the weather get hotter (>50-60 F). Also most of the time


Hi! Please check the auxillary fans. The fans may be faulty and weak causing the car's engine to be extremely hot. When hot... engine fails, hard to move or the baddest is that it wont move. Check the coolant level too and add some if necessary. Hope ... 1998 Ford Windstar

My 98 dodge caravan would cut off while I was driving. The problem seemed to be the grounding wire that is connected to my positive battery pole. After the wire was regrounded the van will crank up but will stall out when put in gear and trying to drive off. I changed the fuel pump, fuel filter, map sensor and throttle position sensor. My van still stalls out and cuts off when I try to accelerate. What can the problem be?


... 1998 Dodge Caravan

I have a 2002 Lexus ES-300 that has an erratic acceleration problem. It happens mostly between the speeds of 10-15 mph and 30-40 mph.The car seems to hesitate during acceleration and then it picks up acceleration all of a sudden. I got it checked with the Lexus dealership and they upgraded the drive software. The problem has not improved and they tell me that it could be because of an off-spec transmission oil. I had the transmission oil changed outside the Lexus dealership about 1000 miles ear


Hi,,ok firstly It can be the transmission, It can be an oxygen sensor and it can be the electronic acceleration (ECU controlled)Firstly,, have a diagnostic done on the vehicle and your accelerator recalibrate and all error cod ... Lexus ES 300

Acceleration Problem I was driving today and my car started to decelerate around 60mph. I tried flooring the gas pedal and it kept decelerating until it reached 55mph, then it chugged a little, started to accelerate up until 60mph and then would not exceed 60mph. Once I came to a full stop it would not exceed 15mph in Drive or 25mph in Drive 2. I have recently replaced my mass air flow sensor, throttle position sensor, and coil pack. What could this be?


Could be fuel pressure or a blocked fuel filter. need more test information, ... 2003 Kia Rio

Have a 99 expedition 4x4 xlt, have suddenly got problems with starting (takes at least two tries) and lack of power when accelerating away from junctions. Also on occassions revs drop and loss of power while driving. Fuel filter is new, was told this could be fuel pump problem but am dubious as it was changed one year ago. What should the fuel rail pressure be? Recently had the dashboard removed to replace the evaporator on A/C system, which is when problem seemed to start, could this have so


Welcome to FixyaThe\015\012 Inertia relay is behind the passengers kickpanel. There is a push \015\012button that may need to be reset. When you push down on this button, \015\012next try to start the truck. If it does not start, ... 1998 Ford Expedition

Jerky acceleration Even whilst slightly depressing the accelerator pedal the car feels quite jerky to drive. This is for both acceleration and deceleration. I've done research on this and found that it could be the ECU needs remapping or the mechatronics unit has to be replaced. I'm not entirely sure if this would fix the problem? Is there any other fault it could be?


Slipping clutch. ... 2000 Volkswagen Golf

Acceleration problems-car cuts out when underload or normal driving conditions. This problem has just started within the last 2 weeks, today it stalled while I was driving down the road and while I was trying to leave the parking lot of the local store. Help as I drive around with a 1 year old in my car and do not want to get stranded.


Hi!!\012\012You need to have the fuel pump pressure tested. Your problem may be caused by your Fuel Pump failing. This is a very serious condition as the car can die anywhere at any time.\012\012I would tell you to have the computer che ... 2002 Chevrolet Impala

Is really a 2004 Kia Rio . has a rectangular fuel thing not called a filter. I afound that. Have a replacement filter from wix . it is round with two outlest on one end one on the other. Car was driving sluggishly. Poor acceleration at other times seemed ok. one day coming into my down hill drive way it just cut out after the poor acceleration problem. Thought it would be out of gas. Typically drive it low on gas once a week or so. put gas in it and it will not crank turns over and is not firin


... Kia Rio

Acceleration problems When im driving my accelerator be jerking and slows my car down when im driving and it takes forever to pick up speed and thats normaly when it happens too i could be driving once i put my feet on the gas it takes long to climb and when it does it tends to jerk i have about 180,000 miles made like 4 trips to new york and florida im surprise i did


... 2002 Honda Odyssey

Question to Toyota Ed: How would you explain Toyotas with Sudden unintended acceleration in cars that have the Denso pedal in them? I have heard that Volkswagen Jettas are also using the Electronic Throttle Control System, also known as drive by wire, and they solved their sudden unintended acceleration problem by having their internal car computer flashed to cut acceleration when you press on the brake. Will Toyota go to this reflash system? What is your opinion since this indicates problems th


Hello, Zman777.\015\012\015\012According to the material provided by Toyota, the Denso pedal does not have the alleged acceleration issue. \015\012\015\012Also, according to information that has been provided by Toyota, the al ... 2009 Toyota Corolla

1993 Mercedez 400 SEL is cutting off when I drive it. It will start back up but cut off after a few seconds. If I wait awhile it will start I can dirve it for a minute or two and then it will cut off again while driving. What could be the problem? Thanks.


... Cars & Trucks

I own a 2012 Kia Sorento 3.6 AWD While accelerating from a 50km to 80 km zone my amber malfunction light came on and there was a loss of power. The Eco light came on and I was unable to accelerate. Could only drive at a very slow speed like it was in 5th gear. Accelerated in reverse no problem. Is it safe to drive 35 km to a Kia dealer or should I have it towed?


... Kia Sorento

Tercel 1997 Hey! I am driving across canada with my 1997 tercel. Yesterday, when the car was stopped (but still running) I noticed that the engine was fluctuating. There is no rpm display on the car but I suspect that the rpm was not stable. At a certain point it felt like it was almost going to turn off. Today, I drove the car for 80 km with no problem while driving... It accelerates normally, it makes no suspicious noise or anything. Could this be an alternator problem? I don't really know abo


I had the same problem, check if there's any oil in the spark plugs, or maybe one of the wires is loose or the plug is bad. ... 1997 Toyota Tercel

2001 intrepid first problem oil light flickers when gas is accelerated. drove on freeway accelerated gas to catch speed and had to come up once came up it cut off on me and would not start back up. just had starter put on and battery checked when you turn ignition over it sound as if it wants to start but doesn't or sometimes you hear a clicking sound when you try to start anyone have any idea of what the problem could be?


The flickering oil light is a common problem with the 2.7 engine. as long as the oil level is full and oil is changed regularly, and the light just flickers and doesnt stay on , shouldnt be a problem, or get the oil sending unit changed. the second p ... 2001 Dodge Intrepid

I Have A 93 Ford Escort Lx Im Having A Problem Accelerating After Driving It For About Ten Minutes I Will Drive It For A Little Then When I Come To A Stop Light It Sputters And Jumps Around And Sometimes Cuts Off. Then When I Try To Accelerate It Goes Really Slow And Begins Picking Up Speed After About A Half A Mile Even With The Pedal To The Floor. Sometime When I Finally Get It To Start Going Faster I Hear A Loud Knocking Noise Then It Stops When It Gets Up To The Speed I Need It To Be, It Als


By the sounds of it, its like once your car gets hot its starts playing up.\015\012You should run a compression test on all ur cylinders..you can get a tester from your local automotive store quite cheap, you just screw it in or shove it in and hold ... 1993 Ford Escort 4 Door
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 2.5837 seconds