Having problems with your 2001 BMW 330 ?

Bmw 330d auto/triptronic gearbox fault nocks car into limp mode

\015 The car revs up over the limiter goin up the gears and then goes into limp mode, had put a tuning box in just before this happened removed it and still faulting year is 2001 what can i do ? gearmonitoring 2 is showing up on the diagonstic\015 Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Repair Help & Product Troubleshooting for 2001 BMW 330

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Bmw 330d auto/triptronic gearbox fault nocks car into limp mode


... 2001 BMW 330

Hi, I have a Mercedes A170CDi Auto that has gone into limp-mode on the gearbox. I have had a diagnostics check done and it shows a P1841 Current fault code which is a Solenoid Valve Y3/7y2 3 shift fault. Can anyone help me with what exactly this is and, more importantly, how much should it cost to fix or is the gearbox finished? Please help!!! Many thanks. PS - Please ignore the car selection section as there were no options for A Class Mercedes. The car I have IS a A170CDi Avantgarde on an 02 p


The code is consistent with an electrical short within the shift motor solenoid. These solenoids open and close fluid passageways within the gearbox that cause clutches engage and disengage with the planetary gear system that make up an automatic ge ... 1984 Mercedes-Benz 190

My jeep gand cherokee went into limp mode 150km after having a custom made freeflow exhuast system fitted. My regular mechanic who has a diagnostic box with limited capacity picked up fault code "p1652 Combust". The gearbox was also reconditioned 3500 km ago and the gearbox-engine harness repaired at the same time. My mechanic "cancelled the problem" so the car is going fine, but no actul lwork was done on the car. Can I take it that the problem is solved (by itself) or should I have the car tak


According with the parts ans jobs there, sound like a electrical problem or harnesses connections problem; Jeep DTC P1652 is refer at J1850 Communication Bus short to ground.The J1850 Connector is the connector that you plug the OBDII Scan to ... 2004 Jeep Grand Cherokee

My 2004 X-Type suddenly went into 'Limp Home Mode' displayed 'engine fault' and 'gearbox fault' After pulling off the road I shut off the engine and remove the key and wait about three minutes. Restarted the car and all was well. This has not happened for over one year. I even asked my Jag Mechanic while in for routine service and he said that it is not a big deal,


... 2004 Jaguar X-Type

Chrysler grand voyager 2004 gone in to limp mode, gearbox repaired (told a broken tooth on one of the gears (auto box)). Car returned and gone back in to limp mode after fill up with fuel? Gearbox ''expert'' said it was not solenoid and must have been this broken part, obviously another problem,


Get diagnostic codes to get a starting point for repairs required ... Chrysler Voyager

Have a Jeep Grand Cherokee 2002 diesel. The engine management light is on and the car is in limp home mode. The garage has scanned the ECM and there are no fault codes stored. They can clear the light but as soon as the car is started the light comes back on and stays and can't get it out of limp home mode. They have checked the real time readings and nothing looks abnormal


The issue, then, may be with the OBD or ECM itself.Thanks! ... 2001 Jeep Grand Cherokee

I recently brought a BMW Z3, it has a auto steptronic gearbox. On The first few days of driving the car the 'Automatic transmission' fault light came on a number of times and the transmission switched to emergency run mode, The light has not come on since (about a month now). I had a system diagnostic run, which showed no record of the fault evident on the cars computer. Any thoughts on what may have caused this? Should I be concerned? The gearbox changes gear very smoothly in both auto or manua


Mine has just done the same is in for diagnostic will let you know the outcome ... BMW Z3

Fault in gearbox p1754 limp mode


... 2005 Nissan Pathfinder SE

My Xtype 2.5 Y Reg suffers from a strange fault. After driving on the Motorway for approximatly I hour or more the MIL light comes on the Temp gauge motors to full scale the overtemp light comes on. If you turn off the ignition the fault clears and the car runs ok in limp home mode but the MIL light stays on. It always throws the DTC code P0116. The car is clearly not overheating I have changed the Coolent temp sensor and traced the wiring with no effect. Reseting the computor clears the fault a


1. check electric fan comes on.( this is done by bridging the wires coming from the switch on the rad\015\0122. replace themostat could be intermitant sticking, i am not sure but there may be 2 one in the engine and one in the water pump, depen ... 2002 Jaguar X-Type

Vauxhall astra 03 1.6 engine management light been on for ages but had driven fine some one has earthed the Ecu before I got the car. went out to out yesterday morning battery was dead. put new battery on went in to limp mode, turned engine of and on again was fine, temp got above 90 in traffic went back in to limp mode , turned engine of and on again it was fine. Tends to be when it gets warm it does have various fault codes its sending about five in total do I need a new ecu.


NO, you need not a new ecu, but a diagnostic tool for your diy work. i recommend you this one ... Cars & Trucks

99 hyundai excel automatic, serviced the auto gearbox with new filter and used about 4 liters of ATF SP-III. Drives ok for first 10 mins but when engine warm, the auto gearbox goes into limp mode and drives like pulling a big truck, no low gear from take off and stays in second or third gear when cruising at 80kph. What could have gone wrong? The car was ok before the transmission service even with very dirty looking oil in it. The car service manual says 6.7 liters of ATF for a complete fill bu


... Cars & Trucks

Have had constant power loss for 3 months .Dealer cannot find the fault. First the engine management light comes on and car goes into limp mode then after switching car off and on again car is fine. Then when going up hill or overtaking car sometimes cuts out totally and engine is completely dead. Dealer said it was wiring on common rail but did not work . Seems to happen only when car is hot or got up to a speed of 130 km plus. Won't happen if just driving around town.


If the car was pluged in and no codes it will be trail and error it must be fuel if seals go on fuel lines your would not tell or find problem it could be sucking air change o ring seals in fuel lines and check fuel pressure switch o ring seal the m ... 2004 Mercedes-Benz CLK-Class

Transmission Fault I have had some trouble with my transmission - at first it drove fine only in the "sport mode" position - if it wasn't in the sports mode, you would hear grinding. I just rode it like that for about 12,000 miles, and now it finally gave out. It is in its safe limp home mode of 5th gear, and I still have a reverse and park that work. I have heard it might only be the tork converter in the transmission, but is it possible I need a new one all together? I love my car and don't wa


You can get a rebuilt transmission, including repair it will cost you about $3-4k. I had the same done to mine. ... 1998 Jaguar XJ8L

Volvo xc70 2005 D5 huge gearbox plroblems, just had it renovated and the thing is doing it again!!!! Transmission service required lights up and fault code 149 is given. It is in limp mode. but when y


... 2004 Volvo XC70

The engine icon warning light has come on in my 2005 S-type 4.2 jag (50,000 miles). According to the manual, this means that something is likely wrong with the electronic control system for the engine. It happened once before, and the car went into limp home mode, but it has not done that this time. I have my car into a jag dealer, and he says the diagnostic for the engine controls has not revealed the source of the problem, but it does indicate many "faults". His solution is to begin trying


HI. I find it strange that the certified dealer technician cannot pull the codes properly. This is very strange, your car is equipped with a very sophisticated Engine CPU. The trouble codes should be accessible with the correct diagnostic equipment, ... 2005 Jaguar S-Type

When driving hard or trying to go over 70 mph, car goes into limp mode! A light comes on dash stating take to dealer, also the glow plug light keeps flashing and have loss of power! My car is a 2005 '55 reg passat sport 2.0 diesel. Checked on diagnostic machine with light still on and no fault showing! Any help would be appreciated. Thanks


Check it in eobd as well as vw specific what scanner did you use to check for the fault code ? because when that light comes on it has logged a code,it could be anything from a brake light switch to the vains sticking in the turbo ... 2006 Volkswagen Passat

Poor running 2001 hyundai amica si car is running badly,stuck in limp mode,almost like constant 1st gear fault code 0343 camshaft position sensor fault code 0444 purge valve where do i find these parts in the engine thankyou


CAMSHAFT POSITION SENSOR IS LOCATED BANK 1 ON BACK TOP ENGINE HEAD. YOU ALSO ANOTHER CAMSHAFT POSITION SENSOR ON BANK 2 ON TOP FRONT OF ENGINE.YOUR PURGE SOLENOID VALVE IS ON BANK 2 ON TOP ENGINE HEAD CLOSE TO CMP SENSOR ON BANK 2 ALSO. ... 2006 Hyundai Azera

Xtype hi sometimes the car goes in limp mode it says engine failure gearbox failure when i turn the car off and on again its fine any ideas thanks


Was the cruise control on? [2003 x] this happens to me when I use the cruise control to slow down or accelerate. just setting the cruise for one speed seems to be ok, but if I use the cruise button to change speed, it goes into limp mode rather than ... 2004 Jaguar X-Type

I have a hyundia tucson 2006 deisel which has been absolutly fine until a couple of days ago when it suddenly went into limp mode and the EML started flashing, there has been no sign of any problem prior to this. my car has got 64,000miles on it. I took the car for diagnostics and the fault code found was PO299 which said turbo under boosting, does this mean that the turbo has gone or may it be something else??


Theresa,\015\012\015\012Turbo under boosting means that the turbo is not supplying enough diesel to the cylinders. And thats how it goes into a limp mode as you say. This could mean an obstruction in the supply chain. which can be cleaned/clear ... Hyundai Tucson

I have a gearbox fault on a 2004 Jaguar X Type, 3.0. the car began driving in a ''safe'' mode. What can cause this. Is it worht fixing or should I buy a new car?


... 2004 Jaguar X-Type

I have an xtype 2.5 sport which is showing powertrain malfunction.initial error code is p1643..can network tcm ecm but on another diagnostic machine it also showed p 1582..wiring inertia switch activated/defective, the car is in limp home mode. there,s no sign of water ingress,chaffed wires or blown fuses and the car starts first time with no uneven running . also, the g/box changed gear perfectly b/fore lights came on.car had been parked up for 2wks. prior to fault


... 2002 Jaguar X-Type

Need to isolate a speed sensor on a 2000 VW beetle (2.0, non turbo automatic). Car is in limp mode, have PO715 hard fault and P0722 pending codes. There are 3 sensors, would like to find out specifically which might throw this code on the 01M transmission. With cleared codes the transmission will work into overdrive for a while before retripping, so clutchplates, gears, and solenoids seem okay.


... 2001 Volkswagen Beetle

I have a Mercedes S class diesel saloon built in 2007 and the car has developed a fault wherby the engine management comes on (but not always). When it comes on it sometimes goes into limp mode and sometimes not. My local MB dealer found it hard to pin-point, despite all the sophisticated diagnotics, and decided it was a particulate sensor on the front end exhaust. They fitted a whole new front end exhaust and sensor last week and today thesame problem has reapppeared with the engine managment l


... 2007 Mercedes-Benz S-Class

I have merc c240 1999 model the car went into a limp mode we have replaced the electronic plate at the bottom of the gearbox after a month it did the same problem they replaced the ms sensor one week later same problem what can i do


Possibly a bad ecm throwing codes/ because it cant monitor the problem correctly if its defective ... 1999 Mercedes-Benz C-Class

Please help ! My Renault 1.9 DCi ,the glow plug light comes on while driving and the car goes into limp mode ,EGR valve isnt blocked and glow plug relay has been replaced ,all the faults started when i replaced the battery.


... Renault Sport
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.8119 seconds