Having problems with your 2000 GMC Jimmy ?

Replaced fuel pump and spider injector still wont run

Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Repair Help & Product Troubleshooting for 2000 GMC Jimmy

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 1997 cutlass supreme and she wont start i replaced the fuel pump and found out when i i pull the curcuit breaker and use a jumper the pump runs. I also put fuel in the intake hose and she want s to start so i got spark.I replace the ECU inside the car still no start. Is there something that runs the fuel pump and injectors only .help....lol


If it runs with a jumper wire the fuse is most likely blown ...check all the fuses with a test light do you mean a jumper wire to the pump itself ? if so follow the wires up and ensure they are not corroded or broken also a test light will dete ... 1995 Oldsmobile Cutlass Supreme

Replaced fuel pump and spider injector still wont run


... 2000 GMC Jimmy

I HAVE A 96 CHEVY CONVERSION VAN WITH A 1500 5.0 ENGINE I REPLACED THE CATILLAC CONVERTER, COMPLETE TUNE-UP,COMPUTER,FUEL PUMP,IT RUNS BUT,IT'S RUNNING TO RICH AND AT TIMES ITS HARD TO START THE FUEL PRESSURE ON THE RAIL IS GOOD,I WAS TOLD I NEED, A SPIDER INJECTOR, I WHICH I REPLACED WITH A USED ONE,IT NOT KICKING OUT BLACK SMOKE OR FUMES ANYMORE,BUT STILL NOT RUNNING RIGHT,I NEED SOME SUGGESTINGS ,PLEASE HELP


If it was a used one the regulator on the spider is most likely bad,dried up,and not working ,do not use your old one,cause that is most likely all that is wrong with the old spider,the fuel pressure regulator,you can buy a new regulator for about 50 ... 1996 Chevrolet G10

1993 astro van fuel pump has 64psi and computer is sending spark to the injectors yet there is no fuel getting to the cylinders. I replaced coolant sensor, fuel hose and injectors still same issue. Van wont start after sitting overnight? When it does it start it idles very rough until it reaches normal running temperature.. Then it runs Great.. How do I resolve this?


... 1993 Chevrolet Astro

I HAVE A 2000 SC MODEL SATURN. IT IS THROWING TWO CODES 107 LOW MAPSENSOR VOLTAGE AND 300 RANDOM MISFIRE CODE . THE CAR WONT RUN. THE FUEL PUMP ISNT RUNNING I JUMPED OUT THE OLD PUMP AND IT RAN BUT I DECIDED TO REPLACE IT AND ASSOCIATED FILTERS. IT STILL WONT RUN I HAVE CHECKED FOR VOLTAGE AT THE PUMP PLUG AND I HAVE IT IN THE ON POSITION FOR 2-3 SECONDS AND I HAVE IT WHILE CRANKING BUT THE PUMP STILL DOSENT RUN I CHECKED THPLUG PINS, SWAPPED OUT THE FUEL PUMP RELAY AND CHECKED THE 10AMP FUSE I


Have you checked for fuel at the engine and also at the cylinders? If your getting voltage to a nw pump while cranking the starter, there's no reason why it shouldn't be moving fuel. Disconnect the ... Saturn SC1

I have a 1999 oldsmobile bravada i have replaced plugs plug wires ignition coil ignition module and distributor cap and button even reprogrammed the computer and it still will not start. it will turn over but will not start. this vehicle has been sitting for about a year. the fuel pump runs and the injector and fuel line seem to be working properly.but yet it still wont start! can someone please help me??


... Cars & Trucks

I have a cummins, 5.9, it quit running. No fuel. Went to the fuel pump, replaced it, filled the filter with fuel, it started, then quit. Bled the line, lots of bubbles, thought we had a fuel line issue. Dropped the tank, replaced the Module ( gauge didn't work anyway). Still can't get it to run past the fuel filter. Since I am getting bubbles from the bleed valve I assume the pump is operational. I'm guessing the injector pump does not have "suction" to pull the fuel from the filter to run, so t


THERE IS A SWITCH ON THE INJECTOR PUMP THAT CUTS FUEL OFF NEED TO MAKE SURE IT HAS POWER, ... 1994 Dodge Ram 2500

Starts and runs fine but after 15-20 miles if you let off the gas the RPM gauge spikes and the engine cuts off. I have replaced the Idle Control Valve, EGR, Fuel Pump Relay and Fuel Pump, Water Pump, Torque Converters. Also after the engine cuts it wont restart for 15-20 min at least. Not overheating at all on heat gauge either. Another problem is the brake lights stopped working. I replaced the bulbs, fuse, and brake light switch. Still they wont come on. The operating lights and blinkers still


Have you performed a voltage test on ther TPS? If so, what was the results? Was there any dead spots? ... 1995 Chevrolet Monte Carlo

95' Honda Civic 1.6 liter, will crank but wont stay running. Distributer, rotar, wires and plugs, fuel Filter and fuel pump have been replaced. We have been able to get the car running on occassions after replacing something and using carb/choke cleaner into the fuel intake. Once running the car runs great, this is why we do not suspect injectors. We call it a night and next day we go to start car, nothing! Will crank but won't catch. Not sure where the fuse for fuel pump is located. Not sur


I have a 95 honda civic and it will crank but not start, ive heard they have a common fuel pump relay problem so i bought a new 1 and also a new fuel pump but yet still the car will not start. we i turn the key the fuel pump does not engage and am st ... 1995 Honda Civic

Replaced fuel pump in a 2000 nissan frontier 3.3 still wont run checked fuel pump its working fine truck still wont run


... 1999 Nissan Frontier

Fuel problem i put in ignition coils today on 2000 kia sephia and also replaced the fuel filter the pump is running and i am still not getting any fuel possibly a bad fuel filter because after i replaced the ignition coils it would run for 10 seconds or so then cut off which lead me to the fuel filter which was really dirty so bought a new one and now it still wont stay running.


Is there muck in tank\015\012take filter of and tip contents into jar\015\012and see if clean ... 2000 Kia Sephia

I have a 1997 chevy s10 4.3 v6 4 wheel drive the fuel pump whent bad I replaced it I had the truck running good. but now it wont start when i dump gas in the top of the flap thing on top of the intake this truck is the one with spider injectors it spits and sputters there is a vacumn check valve broke on the side of the intake i replaced it now im having the problems this vacumn check valve the PCV valve is hooked to it and a little vacumn on it i checked them all and they look fine its acting


... 1997 Chevrolet S-10 Pickup

We replaced fuel pump in 1998 camry and it still wont start power is running to and from injectors and pump.


Unhook the fuel line to the filter and check if gas is coming through....i just recently had to replace the fuel pump in a costomers car 4times because the other ones i was gettin were bad and yes i was buying them brand new...and if your not getting ... 1998 Toyota Camry

Car cranks fine, it has spark at plugs,replaced fuel pump,fuel filter,replaced cam shaft sensor,replaced fuel pump relay,still wont start.i can use starting fluid to get it started and it runs fine but after it sets over night it wont start


Sounds like you either have a weak fuel pump and or dirty clogged fuel injectors. now you said it won't start but if you spray starting fluid in it it will start and continue to run on it's own?don't really make sense. but please clarify. ... 2004 Pontiac Grand Am

My 1985 mercury grand marquis 5.0 litre tbi wont run. fuel pump wont come on unless you run wire from battery to fuel pump but car wont start with fuel pump running. new fuel pump because i wasnt getting pressure to tbi.was havin g to spray starting fluid directly on injectors for it to start and run and it would run fine.now im not getting nothing but if i straight wire fuel pump(new) it runs but injectors wont prime and spray. eec relay and fuel pump relay are good. took ecm out of ford ranger


... 1997 Mercury Grand Marquis

No fuel replaced fuel pump replaced relay (i think) theft system light is on still wont start, fuel pump wont run


Turn the car on for ten minutes, then try to start, you may have to do this three times ... 1996 Buick Skylark

05 jeep liberty 2.8 diesil. wont run. i cleaned the injectors, the where completly plugged. if i disconnect 1 injector and crank the motor over, there not much fuel pressure there. can the plugged injectors ruin the injector pump? the fuel filter housing has been replaced too. i have injector pulse too. but no fuel will come out of the injectors. it will run for a second if i spray starting fluid in the air filter. no engine codes at all, same goes for all the other modules in the vehicle. i don


... 2005 Jeep Liberty

I have a 1989 pontiac 600 LE, 2.8 liter. I accidently let the car run out of gas. After that it wouldnt start, we replaced the fuel pump already and the car still wont start, I think i have burnt the Fuel Pump Relay Switch and I have already bought the replacement but I dont know where the old one is to replace it. Where is the Fuel Pump Relay switch. Ive already taken my dash apart.


Fuel pump relay is under the hood,,usually on the passenger side on top of the inner fender. ... 1989 Pontiac 6000

5.0 fuel injected tpi 88 firebird replaced fuel pump map sensor and now the vehicle will start and idle great i can give it gas and will continue to run but excessive gas was leaking on manifold. i took apart plenum and runners and fuel rail and 3 fuel injectors appear to have been replaced by previous owner and o-rings appear to be new. Fuel pressure regualator also appears to have been replaced. I checked injectors while still hooked up and they appeared to be firing and i checked the socket a


Hi, Even though the Pressure Regulator has been replaced,It could have a raptured Diafram. Check to make sure your fuel return line is not Plugged, Other possibilities are Leaking Injectors or Damaged. Also check your Throttle body gaskets and Fuel F ... 1988 Pontiac Firebird

2000 chevy 3500 7.4L cranks and hits every once in awhile, but wont stay running. checked fuel pressure had 60psi, checked fuel flow appears to be good . checked for spark it has good spark, removed plenium and ohmed injectors all turned 12.4 . checked all injector plugs with a noid light and i have pulse. no codes in computer , replaced crank sensor , replaced fuel filter, replaced fuel pump,


The\012following are the general instructions on the start of diagnosing any\012electronically controlled engine or transmission problem.\012The\012engine and the automatic transmission (transmission control is\012only for ... 1998 Chevrolet C3500

I have a 1987 fiero gt with a 2.8 v6. After setting for a winter, the car would not start. Fuel pump wasn't running, so I replaced it and it now pumps but still car will not start. Removed and cleaned injectors, replaced coil, plugs, distributor cap, rotor - still will not start. Car will run briefly with spray of starter fluid.. Please help!!!


You need to do a little detective work here. Based on your question it appears the engine is not getting gas. You changed/cleaned the injectors, yes. Do you test them somehow to see if they were actually squirting fuel. In the injector system the ... 1987 Pontiac Fiero

My 89 ranger runs when you pour gas in it. replaced fuel pump.pressure reg, tps, computer .still the same wont run pump only runs for a little while. fuel pressure is to low why is fuel pump shutting off before pressure comes up.


Switch to primium gas ... 1989 Ford Ranger

I have a 96 chev blazer it had a leaky fuel line i replaced it it fixed the problem , after a few months it wouldnt start so i sprayed starting fluid and it got me 60 miles now wont start i replaced fuel pump, fuel pressure regulator checked relays still has spark n suffecient fuel pressure up to the injectors but injectors are not spraying fuel what else could i do?


SCAN IT FOR CRANKSHAFT SENSOR PROBLEMS AND PCM PROBLEMS.CHECK THE ECM FUSES THEY ARE 20 AMPS.CHECK ALL IGNITION AND ECM FUSES THEY ARE 20 AMP FUSES.LOOK FOR BLOWN 20 AMP FUSES. ... 1996 Chevrolet Blazer

Replaces fuel pump, replaced fuel filter , replaces tps, replaced idle air control, replaced crankshaft sensor, still still wont run will start but when you step on the throdle it dies 1990 olds cutlass supreme 3.1


I'm not too familiar with those motors or their ignition system but i would suggest looking into the ignition system as the culprit in this situation. Check for corrosion under the cap(if applicable), coil, and at the spark plug wire ends. ... 1990 Oldsmobile Cutlass Supreme Conv

1988 s10 2.5, 4 speed. I have replaced the iac, tps, map sensor, fuel pump, fuel filter, fuel pressure regulator, injector, egr, fuel pump relay, and removed a clogged catalytic converter. So why does it still run like crap and stall when I try to move it? Unless I disconnect the vacuum line from the bottom of the map sensor, then it goes into a high idle but I can drive it no problem. I need this thing to run I drive 55 miles to a jobsite and 55 back home daily. Any help would be great. Thanx i


... Cars & Trucks
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.1026 seconds