Having problems with your 2000 Ford Escort ?

2000 escort - tuner does not work but CD and TAPE are fine

\015 Radio acts as though the memory wire is dead ( tuner does nothing - no display and no sound ) however both the CD player and the TAPE player work fine. I have checked all the fuses under the left hand side of the dash board and in the engine compartment. All checked OK. Is there a fusible link somewhere, or another set of fuses? Do you have any other ideas as to what could be causing the problem?\015\012\015\012Thanks in advance for your help,\015\012Tom\015 Posted / edited by AnonymousUser on : 18-12-2017

Answers :

Most likely is the radio itself- typical ford radio... best bet is look in a junkyard for a new radio- there are no fusible links- there usually is just one 10amp fuse in the inside fusebox. but if the cd& tape players work it is in the stereo itself. hope this helps and good luck
Your receiver is probably fried or your internal power leads have come lose so if you are not a soldering expert and have a multimeter and just have to have a radio. I would buy a new deck there are many great brands out there you can get a sale on.
Repair Help & Product Troubleshooting for 2000 Ford Escort

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0061 seconds