Having problems with your 2000 Chevrolet S-10 ?

There is no power going to the stereo. The fuses are intact and all the other electrical works.

Posted / edited by AnonymousUser on : 18-12-2017

Answers :

It is hard to troubleshoot this type of problem without a volt-ohm-meter. If you have one (or get one from Radio Shack or the hardware store) use it to measure the actual voltage getting to the red power cable getting into the radio (you will to remove it from the dash) if there is power, the problem is in the unit, if there is none you need to find where it is getting interrupted (probably at the fuse box). If a fuse blew, you still need to ask yourself why it blew. It could have been a bad fuse but more likely something downstream from the fuse malfunctioned, demanding more power than the radio is supposed to need. One way to deal with this is to pop in a new fuse. If it blows too, stop! Something is wrong with the radio or the wiring and it need to be fixed first.
Have you removed stereo from dash? check fuse in rear of stereo. Make sure you have got the stereos sequrity number before removing stereo if its the genuine system fitted to vehicle if not stereo wont work until code entered.
Repair Help & Product Troubleshooting for 2000 Chevrolet S-10

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0116 seconds