Having problems with your 1999 Suzuki Vitara ?

INEED AN ASISTANCE OF ENGINE TIMING V6 H20A cc 1998

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for 1999 Suzuki Vitara

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

INEED AN ASISTANCE OF ENGINE TIMING V6 H20A cc 1998


... 1999 Suzuki Vitara

I have a 2002 VW TDI with 140,000 miles, but engine was rebuilt after broken timing belt, and trans was replaced under warranty at 98,000 miles. My problem is that the engine cranks eight or nine times when starting next morning, even though car is parked in indoor and heated garage. All services have been performed right on time and I use nothing but MOBIL 0-40 OIL and high quality oil filters, etc, etc. It has a new timing belt (the newer type which came out in 2003) Glow plugs are all okay a


Hello, I have something that might help you. If you know where your fuel line goes into the engine. I would let it sit overnight and then take the line loose. Then hold the fuel line into a bucket and have someone turn on the key in the car. This sho ... 2003 Volkswagen Jetta TDI

Ignition When I turn on the ignition I drive a few feet and when I stop the rpms goes down to 0 and the engine turns off, some times it turns on but the rpms go down to 0 without driving and the engine turns off. No check engine light is on.


Check your fuel filter and fuel pump. ... 2000 Mitsubishi Montero Sport

What is the ignition timing set for on a 1989 Chevy 350CID 6 Liter engine. My truck was manufactured in Canada an there 350 CID engines are 6 Liter. When I adj mine for 0 Degree TDC like a 5.7 Liter engine it runs like the timing is wrong.


Try 10 btdc. ... Chevrolet Silverado 1500

Propercrankpositionfor correctbelttiming is there a timing mark onthe crank pulley for refrence to line up with a notch on the engine ,besides the flyweel mark? i am puzzled because i have already bent some valves & dont want to repeat my mistake. i have put the #1 piston at TDC, flat with deck ''0'' deck is this right or should it be slightly below ''0'' deck hight and or should the key way be at 12:00 position. please help me P.S, this a 89 honda accord 2.0 carb.3V A20A1 engine


Send me your email address and I will send you the proper timing positions. I can copy them from mitchel and email it.... ... 1989 Honda Accord 4 Door

Overhaul of the top in of 2003 jeep 4.7. It had jumped time, broke a valve spring and bent a valve. After the overhaul oil pressure at idle drops to 0 after the engine warms up. No engine noise what so ever. pressure jumps up while driving, but at idle drops back to 0. Afraid to drive, what should I do?


First thing you need to do is put a mechanical gauge in place of oil sender and read actual oil pressure. If mechanical gauge shows same condition, take a look at the connecting rod bearing serving the cylinder where the valve bent. If the piston hit ... 2003 Jeep Grand Cherokee

Ok here we go, 1978 chevy nova sb 350. timing was kinda close, but i heard a lil bit of a knocking put my ear to it and determined lifter, adjusted lifters as book states (til no slack then 3/4 turn #one intake and exhaust so on in a specific order) "thought i had the engine at tcd made sure # one cylinder valves where NOT MOVING! aligned balancer mark with timing mark already on engine "0" placed plastic rod in spark plug hole til IT WAS WAY OUT AND RIGHT NEAR PINCHING. again aligned the mar


You might not have #1 at tdc on the COMPRESSION stroke. You're trying to get it to tdc the hard way. Take #1 plug out and have someone bump the starter while you hold your thumb over the plug hole. You'll know when its a tdc cause it'll blow your thu ... Chevrolet Nova

Had the head redone, new Carb fitted, new distributor cover and leads new spark plugs, crank timing set to mark (0)and cam timing (2e)set to mark on head. the engine swings, fires from the carb, spark on leads. engine wont start, backfires but not running


Sounds like you have your timing off. If it is backfiring, that means that 2 of your wires are crossed, causing the plugs to fire on the exhaust stroke versus the compression stroke. Recheck your timing. ... 1984 Toyota Corolla

I have an 85 22r the #1and2 cylinders are missfiering. Replaced plugs and wires and swaped out distributor with one off my old engine. Timed the engine at 0 degrees per the manual. Still missfires. i noticed when i put the vacume lines on the distributor the timing doesnt change.


Compression check ?sounds like head gasket ... 1993 Nissan Pickup

98 cherokee sport : charging problem. when i first start the engine the volt meter goes to about 12 volts. most of the time, the volt meter will drop to 0 and the check gauges light will come on. however, if the engine is at normal operating temp and has been that way for about 30 mins. i can shut off the engine and restart it and the volt meter in the dash will jump up to about 14.5 volts


You will haft to take it to the jeep deller and have them scan it to check your pcm wich cuntrols your voltage ... 1996 Jeep Grand Cherokee

Ineed a diagram of isuzu dmax 2.5D engine timing marks


... Geo Tracker

1981 chevy 350/or 305?, it is a rebuilt engine, but when I set the timing at 0, 2,4,6,or 8 degrees it sounds good, however, when it warms up it won't start without moving the distributor. I checked the rockers on #1 cylnder at tdc. They are both closed. When I advance the distributor the car starts when hot, but doesn't have power. I am at a lost. I am thinking that it might be the ignition module, or ignition coil. Is there a way to tell? The engine is in a 1981 Caprice Classic and don't reall


Is your heat riser siezed? If it is siezed closed you have too much back pressure. You will need to free it up. To do this you may have to take the exhaust manifold off as it is situated in it. Use heat & WD40 to free it up. Good luck! ... Chevrolet Caprice Classic

Rebuilt my 454 engine, installed distributor with rotor at 0 TDC on #1 cylinder. Engine ran fine but ses light was on. Code was P1345-- disagreement between cam sensor and crank sensor. Scanner showed anywhere from 19 to 25 degrees advanced. Rotated dist. shaft. to ****** timing. Wouldn't run. Tried two teeth positions in either direction from original setting. Ever have a sensor go bad. The crank sensor is new, cam (on distributor) is not.


The ignition timing is not adjusted with a timing light or with the engine running, and to set the ignition timing follow these procedures.There is a mark or notch on the distributor housing that the rotor should be pointing to when the e ... 1998 Chevrolet K2500

1984 928 began running very rough & lost all power. Shop indicates 0 compression on 4 cylinders and that likely cause is slipped timing belt and damage to valves on one side. I thought 1984 engine had ''non-interference valve design'' and that valve damage would not result from slipped timing belt. I don't want to spend $4,000 on a repair I don't need. Does the diagnosis make sense?


Depending upon the rpm that the engine was turning at, I have seen "non interference" engines bend valves on a timing belt or chain failure. if you have 0 compression on that bank, it will need to be torn down to find out why. BUT I would do a ... 1984 Porsche 928

I have audi A8L 2004 4.2L. The car starts and after 30 sec. main fuel pump relay shuts off and pressure drops to 0 and engine shuts off. I'm auto technician, I checked circuits to main fuel pump relay and signal from ECM to relay is disapering after 30 sec. Car starts fine every time after shut off and every time it shuts off after 30 sec. Tell me what problem could it be or what I should check? Thank you. Sincerely Jerry


Could be an oveheated fuel pump! Extract the pump out from fuel reservoir and test it! ... Audi A8

I drove my 98 Camry 200 miles to reach home with flickering low oil light but oil was ok, got home and had checked with oil pressure gauge, pressure goes to almost 0 after 10 minutes of drive. Engine noise not too great may be little noisy then before. I have 102k miles on the car, up for timing belt change etc. Wondering if this repair is worth it if i have already done damage to the engine. Can you advise what are my options. Sem


There's a low oil level light and a low oil pressure light. You checked the real pressure and the right pressure is35PSI not more than 80 If ti revs up and the pressure doesn't rise your stopped up some way. ( sludge). If you got a little money to ... 1998 Toyota Camry

At elev. 8500 severe power loss under load. Live feed engine data as follows:0-5 engine timing retarded,pending code fuel system fault OL and sometimes will set mass air flow code. mass a sensor replaced recently. removed air filter resonator from behind bumper,left top portion w/filter element in place. once vehicle returns to lower elev. runs great.will not set code again until returns to 8k .vehicle 30k mi. org. owner.have own scanner w/live feed.


Does your scanner give you a reading for barometic pressure? ... 2001 Hyundai Sonata

I have a 1968 mustang with 1966 289 c. code .engine starts good .idels ,good till it reaches running temp. then it sounds like the rockers start to chatter .and mis fires till it dies.it has 40psi on oil gage while its cold . but drops to 0 psi when it warm .im guessing the oil pump is bad . and causing the bearings to get hot and binding the engine. if some one could help me it would be great. thanks for your time.


Yes.sounds like the oil pump is laying down when oil gets hot,,,,,,but,,,,i would try changing oil filter..I have seen Oil filters will **** together after a few min. of run time.....I would never use a WIX oil filter,,have had 3 friends loose engine ... 1966 Ford Mustang

My Suzuki Alto (year 2000, 1,0 ) does not run well. I get brownish/black exhausts and the engine runs uneavenly. When i do not use the gaspedal the engine makes short speed-up and down, speed-up and down all the time. When in gear and medium speed it does not run eavenly. A test has shown exhaust-recirculation fault and I have tried changing the EGR valve. No result. Same problem


... 2000 Suzuki Swift

I just replaced the timing chain on my 2000 Jeep Wrangler 2.5 Liter engine and Ineed to know how to set/check the base timing.


... Cars & Trucks

Hello, I have a 2002 GMC Envoy and my check engine light is on. The code populated is P0014, I've read different solutions to this code, however I am still unsure as to which route to go. Would the replacing the Camshaft sensor resolve my issue? Also, when my AC is on the timing appears to go up and down (from 0-2), as if my truck wants to shut off, and then Pressure Oil Low // Stop engine displays. Thank you for any assistance you can provide.


DTC P0014 - "B" Camshaft Position - Timing Over-Advanced or System \015\012Performance \015\012 (Bank 1) = to see Trouble Code P0011DTC P0011 - "A" Camshaft Position - Timing Over-Advanced or System Performance (Bank 1)What ... 2002 GMC Envoy

I HAVE A '88 OLDS CALAIS WITH THE 2.3 4 CYL ENGINE. THE ENGINE WILL START TO SURGE AND WILL NOT IDLE AND EVEN CUT OFF WHEN SLOWING DOWN. AT THE SAME TIME THE SPEEDOMETER WILL STOP WORKING AND THE NEEDLE WILL JUMP BACK AND FORTH FROM 0 TO THE SPEED YOU ARE RUNNING. THE TACH NEEDLE ALSO GOES CRAZY.


Check the motor ground wire it is a braided copper wire usually off the back of the motor to the frame of the car ... 1988 Oldsmobile Calais

Timing belt is it true that the 2000 ford explorer 4,0 engines has 2 timing belt on them; its a 6 cyl. thank you godbless


The 2000 Ford Explorer that has the 4.0 Liter engine, is an SOHC engine. Single OverHead Camshaft.It has one camshaft sprocket, one camshaft chain, and one crankshaft sprocket.The 2000 Ford Explorer that has the 4.6 Liter engine, is ... 2000 Ford Explorer

My car is running a little rough when warmed up and I'm creeping along accellerating from 0 mph to 10 mph (like in a parking lot). By "rough" what I mean is there is a slight feeling of vibration I can feel through the steering wheel. My mechanic adjusted the engine timing and that did not fix the problem. He said he thinks maybe something is slipping inside the automatic transmission, or maybe it's a problem with the engine mounts. But I have since noticed that my fuel economy has decrease


Mcdevito75 here, It is possible something in the tranny could be wrong especially if your tranny has a sensor that is read by your cars, computer system, a bad engine mount would cause the engine to shift position on the chassis while driveing, even ... 1991 Acura Integra Hatchback

I want to improve grip to 0.90g on my 08 infinity fx35 n reduce my braking time to 119-125ft from 60mph. is it possible & what would require? also reduce my 0 to 60 time without tempering too much with my engine that i adore...pls help me Thanks.


Yes, cross drill rotors and calipers will give you lot more than stock brakes can offer. Wider wheels with low profile tires will get you lot better handling such as cornering, stock tires are tall and will flex off the rims in the tight G's and caus ... 2008 Infiniti FX35
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 2.6827 seconds