Having problems with your 1999 Mercury Cougar ?

99 cougar won't start

\015 Slight clicking noise when starting (not like battery dead clicking). Lights full power. Did this 3 months ago and started fine in 3 hours. Suspsecting something with the factory alarm system or a ''chip''.\015 Posted / edited by AnonymousUser on : 11-12-2017

Answers :

Get a breaker bar on the motor and see if you can turn it over by hand.. if not, your engine is seized, if it does turn over, its probably the alarm.
I am having this problem right now! Same year! The lights and all turn on. When I turn the key, the starter solenoid energizes, as I hear the "click". The battery shows 12.5 volts, and it won't crank off of a jump.

The car started fine 2 days ago before I removed the alternator (battery not charging, new battery, also "new" alternator) for testing. Once it tested good, I was told to try a new battery cable to the alternator. I removed the old, which had a junction block about half way down the cable, and installed the new, which does not. Now I can't get the car to crank, or even try to crank - just clicks. Any help would be appreciated, because the car is not mine and I want to blow it up.
Repair Help & Product Troubleshooting for 1999 Mercury Cougar

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0060 seconds