Having problems with your 1999 Lexus RX 300 ?

RX 300 will not idle. Runs fine over 1000 rpm otherwise dies.

Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Repair Help & Product Troubleshooting for 1999 Lexus RX 300

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 1998 Ford WIndstar. It died on us the other day. we put a refurbished alternator in it, changed the clamps that attach to the top of the battery, when the battery is in OUR van and is charged, it will hold the charge running for 1-2 minutes, then the radio goes off, the RPM goes to 0 and then it dings a couple times, then it dies. However, when the battery was in my friends truck it ran it just fine. so its not the battery. we are pretty much stumped. anyone have any ideas? I would grea


I suspect you hav a defective alternator. Remans are famous for this. Take it back where youbought it and have them put it on their testor to make sure it works.\012\012A battery should read about 12 1/2 volts when charged, engine off. ... 1998 Ford Windstar

Abs light well i have a 98 honda accord v6. the abs light started to come on and when it did my cars idle would go down below 1,000 rpms and then it would die i would start it up again and it would run fine. a coule of weeks later when i was going down the road the abs light would come on and my rpm would go down and my speed amotor would go down to 0 speed and when it would do this my radio would make this noise light stadic going through it. so id pull off the road and my car would die.


1. Your fuel pump is going bad.2. Your brake pads has gone flat too.3. Have a look at your plugs and fuses.See an expert if you are confused.Please rate afterall has been looked at. ... 1998 Honda Accord

Helpless My 1994 Ford Exporler has been running fine until about a month ago, everytime i turn it on the RPM's go straight up to 1 or 1 1/2, twice awhile i was drivin the car it wouldn't stop i had to pull over, and when i put it into park the RPM's went straight to 4 so i turned it off, waited for about 2 mins and turned it back on and everything was fine. It was so werid! Last week the C & H (for cold and hot)gauage on the dashboard, when i turn on the car it goes straight to H! And when I'm d


Frist of all what do you mean the car would not stop? If you are saying what I think you are saying is that you went to brake and the car seems to be still at driving speed? If this is the case then don't drive the vehicle its an hazard and somone c ... Ford Explorer Sport

My pontiac gran prix starts just fine i have been driving it for 7 months never had a problem. on day i left work for home n as i got to 35mph it stopped speeding up and jus ran up the rpm. it drives just fine in r,3,2,1, but when in drive it goes gear 1-3 then wont shift


CHECK TRANSMISSION FLUID LEVEL AND TV SHIFT CABLE ADJUSTMENT BUT COULD BE LOW.IN FLUID LEVEL OKAY. YOU COULD HAVE FAULTY VECHICLE SPEED SENSOR OR FAULTY SHIFT VALVE OR SERVO BUT HAVE CAR CODE SCAN FOR TRANSMISSION FAULT CODES. ... Pontiac Grand Prix

2000 Eclipse GT auto trans. Car stalls at stop lights. will run fine in all gears. R, N,. When gas is aplied car will run fine untill it shifts to first and the rpm goes to idle. The car will jump between 0 and 2500 rpm a couple of times then stall. I have no warning lights showing.


Thats one of two things i had the same problem with my 94 honda civic and my 00 mitsubishi eclipse both were not cheep to fix saddly for you man on my civic my tranny was catching and it would stall the motor out idk if that was the complete problem ... 2007 Mitsubishi Eclipse

I am working on a 2002 Cavalier. It runs fine without the AC on, but when the AC is on the rpm's go crazy. Normal idle for this car is about 700 rpm's, but when the AC is on the rpm's will randomly shoot up to 1,500 rpm's for a few seconds and back down again. It also does this when driving slow speed, or up hills. Any ideas on what the problem could be?It has new spark plugs and wires, air filter, and I have checked the battery and alternator.


It could be a defective (IAC) Idle Air Control valve or a dirty MAF (Mass Airflow Sensor, Clean the MAF, and have the IAC tested and replaced if necessary. ... 2002 Chevrolet Cavalier Coupe

1993 Toyota Camry V6 starts fine, I let it warm up, I think it's ideling high but I drive off. At the second stop light the car dies. You see the RPM which when ideling is a one notch below the 1, is quivers and then drops to and the car dies. I put the car in neutral and it starts ups and then it makes it thru the next two stop lights before I get on thre freeway. The RPM's still seem to run high on the way to work. I'm driving 65-70 mph and the RPM's are at the 3 versus at about 2.5. Ju


What is required to compliment entire compbustion are new spark plus to create efficient rides eleminating the idleness at stops. ... 1993 Toyota Camry V6

I have a 1999 gmc suburban k1500 5.7 vortec it has a throttle body injector it has started to miss at about 4000 rpm runs fine throught the rest of the rpm range it misses no matter the temp i have changed the cap rotor wires plugs are less than 1 year old new coil and high flow air filter can any one help as it stands i can not pass because it pretty much wont accel past the 4000 rpm mark just stays there n misses no problems with idle or reving it up in park or neutral and dose the throttle bo


Check the fuel pressure and the fuel filter. You've eliminated the ignition probables. ... Cars & Trucks

I replaced fuel pump aprox. 2 months ago car ran fine then idle went up to 4000 rpm then i shut down tried to restart idle very rough let sit 1 hr. started and ran fine drove 10 miles or so turned off sat 15 min. same very rough idle let sit over night restart ran fine could it be fuel pres. reg. or check valve check valve rattles sometimes


Pres.reg.or TPS ... 1991 Pontiac Firebird

My 1992 Jeep Cherokee Laredo 6 cyl 4 WD speedometer went to 0 for 5 minutes then started working fine, 1 week ago; speedometer cable or sensor?


... Jeep Cherokee

95 Dodge Ram 1500 Rough Idle, fine above 1,000 rpm's


I would check the fuel pressure regulator ... Dodge Ram 1500

My car will be driving just fine and then all of a sudden the rpm just drop to 0 and the car dies. The oil lamp light comes then as well. I have checked the oil and it is fine. If I let the car sit long enough it will start and all the lights will be gone. What could be the cause of this?


The most popular failure with the Pontiac whether you are a 6 cylinder or 4 cylinder. Is the fuel pump module,this module has a faulty strainer that made the vehicle starve for fuel,or even gave it hesitation and low power,go with a aftermarket fuel ... 2003 Pontiac Grand Am

I just replaced MAF Sensor on my 2002 nissan altima it worked fine for 1 day and then the engine wants to stall out when at a stop light but when driving on freeway will run fine. Took the new MAF Sensor off to see if car idles at normal RPM and it did. Could i have another bad MAF Sensor


... Nissan Altima

1990 ford bronco 351 windsor engine, e40d at transmission. Drove on hwy at hwy speed for 2.5 hrs, turned off and engine started to sputter and pop with very low idle rpm. Shortly idle went to 0 rpm and engine stopped runing, 1 hour afterwards engine started up and ran normall next day also. What is problem?


I have an 89 with a 351w. Mine did the same thing. Sounds like its vapor locking. After you let it sit for an hour or so it should start up but you should take the EGR valve off and either replace it or clean it with carb. cleaner. That should el ... 1990 Ford Bronco

1999 taurus. 6 cyl OHV. Ran fine over the weekend. Parked car in driveway. Started this morning. Heard high(RPM) pitch winding sound coming from engine or tranmission. Noticed will not reverse or move into any gear after shifting. Transmission fluid is full. Recently changed transmission filter and Vehicle speed sensor about 1 month ago.. Ran fine after that.Serpentine belt is ok. Linkage on driver's side appears shifting ok. Could something have broken inside tranmission or maybe a sensor not a


Check for vacuum lines going to transmission or any vacuum line under hood. It is possible an animal chewed on the lines or wires. We get a few reports of that at Fixya.\015\012\015\012You might also look under the dash by the pedals fo ... 1998 Ford Taurus

When the car is in perk the engian rpm's reve and drop from 1 to 3 to1 to 3 1991 honda accorg lx, When the car is in drive it idels fine and runs fine. Only in park dose it have this problem.I tried to replace the idle air valve. No change.Also the elect idle controle valve,No change.


Check the throttle position sensor ... 1991 Honda Accord

Car pulls lazily from 1800 to 2000 rpm when under load. After that it works fine. It is CVT trans. A Tiida Latio 2004 Model. The engine stutters a little and loss in power but after the crosses this rpm it works fineI changed the throtle body assembly about 1 year ago. there was a slight "flat spot" at about 2000rpm with the new unit. It now seems to have gotten worse. The scan revealed no engine codes but 7 different codes for the trans


... 2006 Nissan Versa

I have a 2000 dodge durango 5.9L and it idles high when in park it also will act like it wants to die out. when the rpm goes over 1 and 2 it seems fine. but than it will drop under 1 and idle funny.. we have changed the camshaft sensor that was the code it was throwing. but it didnt work. we have checked the hoses no leaks anywhere.. what do you think???


I'd pull IAC , (idle air control) motor off and clean it as well as hole it comes out of with throttle body cleaner, especially pintle (pointed part ) of IAC motor. Re-install it & see if it solves problem. If it does & starts to do it again ... Dodge Durango

My 2003 chevy trailblazer ls rpm gage has completly stopped working. when it first started going bad it would work on occasion and now the needle doesnt even move from 0. my car feels and sounds like it is shifting when it should its just the gage that doesnt work. what could cause this? is it a bad sensor, wires or something all my other gages work fine its just the rpm gage. if anyone knows how i can fix this problem please let me know what i need to check i want to be able to fix it myself if


... 1996 Audi A4

Where is the iac valve on a 2003 f150 5.4l triton v8? my truck will idle steady but when shifted into drive or 1 the rpm drops and stalls engine also when coming to a stop it will act like its stalling just before coming to a stop then the rpm will jump back up to normal this will happen around 80% of the time i drive. Also when I get to 45mph the truck will shake fairly hard until i get to about 65mph and then its fine. Had some mechanic say it was my transmission going out from the torque conv


... Cars & Trucks

Transmission reverse wrks fine 1 st gear fine but wont shift out into second or third as rpm increases of my van is a1991 g van series


Sounds like the solenoids in the transmission are unresponsive, check the wiring or replace them ... 1984 Chevrolet Chevy

Bouncing RPMs I have a 6cyl 1986 pontiac fiero GT 4speed manual. When i put in the clutch and start the car, the rpm goes to about 2000 rpm then drops to 0 and dies. Then I start it again and the engien goes to about 2000rpm again, then down to about 500rpm and back up to 1500rpm. It will bounce like this until i give it a little gas and then it will even out and run fine. Can this be fixed and if not is it bad for the car? Thank You


My car would do the same thing turned ot to be a loose wire at the coil/distributor. there is a plug connector with tow wires one wass loose I crimped the wire no works great ... 1985 Pontiac Fiero

1990 F250 E40D transmission heck of a time with drive must rev engine to 3-4 rpm to ingage? once she moves all drive is fine 0-65 great no problem. put in park reverse fine back to drive must rev moter to ingage drive??????


... 1990 Ford F250

Where is the iac valve on a 2003 f150 5.4l triton v8? my truck will idle steady but when shifted into drive or 1 the rpm drops and stalls engine, also when coming to a stop it will act like its stalling just before coming to a stop then the rpm will jump back up to normal, this will happen around 80% of the time i drive. Also when I get to 45mph the truck will shake fairly hard until i get to about 65mph and then its fine. Had some mechanic say it was my transmission going out from the torque co


The iac is located on the throttle body. It should be on top to the rear area center. Go to kragen.com. Put in your info and a picture should show you what it looks like. ... 2004 Ford F150

How do i test to determine if oil sending unit, pressure sensor or pump is bad. I changed oil cooling lines. everything was fine for 3 days then oil pressure dropped to 1 psi and warning came on. pressure reads reads 1 psi even when i increase rpm's. The gauge in the dash has been broken along with the speedo for some time. I have a programmer that displays all my gauges


... 2005 Chevrolet Silverado 1500HD
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 1.4410 seconds