Having problems with your 1999 Ford Escort ?

Idles high after starting - 1999 Ford Escort

Posted / edited by AnonymousUser on : 11-12-2017

Answers :

Older cars tend to get vacuum leaks, either by detiorated hoses, or something being overheated, or accidently knocked off. A can of carburetor cleaner can be carefully sprayed using the extension tube, near the hoses & connections of vacuum lines to identify any leaks while the engine is running. Just spray a shot at a time near the areas (hoses, Throttle Body, Intake) in question and the engine will slow down if it sucks in the cleaner. Other than this, there's the throttle position sensor and idle control motor to test. Look around the engine compartment & be sure nothing is loose or obviously broken. There is a schematic diagram of the vacuum hoses in your engine compartment & you can check to be sure what it says is supposed to be there, is still there.
Repair Help & Product Troubleshooting for 1999 Ford Escort

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0091 seconds