Having problems with your 1999 Chevrolet Silverado 1500 ?

1999 chevy express 1500 van hard to start when cold. will start up fine with a shot of starting fluid. no engine codes. starts fine when warm

Posted / edited by AnonymousUser on : 22-01-2018

Answers :

I had same issue. I thought it was a fuel delivery problem but I then noticed that while I had it on a battery charger it started up immediately. I noticed that the speed of the starter/flywheel was significantly quicker leading to the conclusion that the battery just needs to have more cranking amps. When I told this to a mechanic friend of mine he told me that it had something to do with the computer and that I just needed a better battery, more cranking amps. I just bought a battery today might even get a bigger one
Repair Help & Product Troubleshooting for 1999 Chevrolet Silverado 1500

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

1999 chevy express 1500 van hard to start when cold. will start up fine with a shot of starting fluid. no engine codes. starts fine when warm


I had same issue. I thought it was a fuel delivery problem but I then noticed that while I had it on a battery charger it started up immediately. I noticed that the speed of the starter/flywheel was significantly quicker leading to the conclusion ... 1999 Chevrolet Silverado 1500

Engine-no go this car had been running fine then went to store 3/4 mi away, shut it off then when leaving car ran fine until I shifted to 2nd gear and then it died. Could not start it again, had wife tow me home. Changed plugs (old plugs were SHOT), plug wires, dist cap and rotor and it started and idled fine but when accel pedal depressed the motor would bog down bad and die. Engine will start and idle fine but when accelerating the engine, it WILL NOT rev up, unless the pedal is feathered quic


I think the dist is adjable try advanceing it some times the after market caps are a little diffront ... 1996 Ford Aspire

1986 Jeep Cherokee Pioneer 2.5l engine 5 speed manual trans. stalls while driving after engine warms up or won't start if engine warm. Cranks but doesn't catch. When it stalls while driving, sounds like it's sputtering. Fuel pump comes on when I turn the key in the ignition. Changed spark plugs and wires, replaced TCM. Thought it was running fine but drove it, then stalled while driving. Pulled into a parking lot and it wouldn't start. Let the engine cool off for 45 minutes then it started and I


... 1986 Jeep Cherokee

My 1993 ford Festiva W model is smoky at start up mostly first start for the day and fine through out the day guessing cause the engine is warm, I have since done a service including- engine cleaning detox flush, new air filter, oil filter, fuel filter, penrite everyday 20w50 engine oil with a engine oil resealer additive for reducing exhaust smoke ect. When I start I still get a large amount of white smoke then only slight black until warm. Any ideas on what this could be and ways to fix and es


Well first i thot it wld be ur oil rings whn u said whn first start up!! But u mentioned WHITE smoke!! Tht usually means a head gasket issue! Take it to a repair shop to get diagnostic checkup!! ... Cars & Trucks

2002 liberty 3.7 liter. I have replaced the coil, plugs and injector for cylinder #6. On cold starts I get a ramdom misfire code and engine is missing. If I re-start 3-4 times engine starts up and runs fine. Warm starts seem to be "OK". Engine accelerates and idles fine. One time I had a misfire code in cylinder #4 and #6. Any ideas??


If you have Coil- on -Plug you haven't found the bad one yet\015\012\015\012Your not always going to get a code that is correct\015\012e.g.PO304,PO305 etc\015\012\015\012I would buy the injector from you, as I'm sure tha ... 2002 Jeep Liberty

I am haveing trouble with my 1996 Mazda B2300, When I start my truck after its been sitting for any length of timeI have to rev the engine to get it started, I have to continue reving until engine is warm other wise engine will stall, rough idle while engine is cold. Once engine is warm, truck idles and runs fine


... 2005 Dodge Caravan

Timming belt routing on 2002 montero xlt 3.5 engine vin code R 6g74 This car came in to me with the complaint that it starts fine cold but after it warms up the engine turns over a few times then locks-turn the key off-turn the key on again engine will crank -lock-will not start.After the engine totaly cools off it will start and run fine intill it is turned off. Engine lite was on-code for crank sensor and cam sensor were both set.The customer also said that they had another mechinic work on it


The Marks are different (ie 12oclock/11:30 or so) as pictured here. I will post again if it is too small to read (sometimes fixya shrinks pictures) ... 2002 Mitsubishi Montero

When my 93 mazda b2600 is cold it will try to start for a second or two with the engine bouncing around. It will do this four or five times. If I leave it in the start position for a minute then try to start it, it starts right up. It will run a little rough for a few little bit then it smooths out and is fine. This doesn't happen when it is warm or warm outside. Engine rebuilt, new injectors and full tune up. New fuel pump and filter. any ideas


... 1992 Mazda B-Series

Hi everyone i have a iszu trooper 3.0d turbo 4jx1 engine,i have a problem with rough idleing i have cleaned the egr valve and replaced the fuel filters and bleed and all seemed fine when i started her up its only when the engine was getting warm didi i notice there was blue smoke coming out of the exhaust and the engine started to rough idle again she would surge between 750 to 1200 rpm,ive checked all the vac pipes for cracks they all seem fine,i do have a check engine light on but dont have a


... 2002 Isuzu Trooper

My 2005 Ford Expedition has intermittent starting problems. The engine cranks just fine but it will not start. After trying to start it for a few minutes it will start and then runs just fine. It will restart when the engine is warm but after it cools down it has difficulty restarting. No error codes were retuned on the diagnostic test and the fuel filter was changed 14 months ago. What is causing this problem?


Hi\015\012\015\012Please check the links bellow to diagnose your problem when your car engine cranks but won’t start…\015\012 \015\012 ... Ford Expedition

I have a 1998 chevrolet s10 2.2 liter engine. I have changed the coil packs,ignition mog,plugs,wires,EGR,IAC,FPR,knock sensor,fuel filter. I don't knw what else to do. It boggs out real bad when It warms up but is fine on cold start. When it warms up real good it boggs out to the point it shuts off when I push the gas and I try to start back up and it does but just for about 20 sec. If that. If I let the truck cool down it will start up fine but repeats the prosess of bogging out and shutting o


... Cars & Trucks

1998 olds regency with 3800. On startup car stumbles and hesitates a bit then smooths out. If starting when car is warm it is worse and sometimes won't start at all. Sometimes reving up helps to smooth it out. Sometimes it runs just fine. The times that it won't start is only when it is good and warmed up. The engine light is not on and there are no trouble codes present. I've had the control module(under coil paks) tested and tests fine. Also car has new cam sensor. I'm getting frustrat


... 1998 Oldsmobile Regency

My wife has a Hyundai Getz diesel (1.5 CRTD GSI) which starts fine from completely cold. It also starts fine after it's warmed up completely. The problem is when you try to start the engine when it has not warmed up enough. Revs won't go higher than about 1500 and you press the accelarator thick black smoke comes out of the exhaust. If you try to drive off while the car is in this state it won't move much faster than about 5 mph while it's giving out black sooty smoke out of the exhaust


Hi,\012\012I've the same probem, it's been 'fixed' twice in the cars life but re-occurs.\012\012I believe the throttle body gets 'gunked-up' possibly due to a faulty solenoid or sensor.\012\012I don't have a full solution but will p ... Hyundai Motor S

Won't idle when cold. Engine starts and runs fine and after making a few blocks coming to a stop at a light, it no longer idles. You can turn off the engine for 20 to 30 minutes and start it up and this time it will run fine. I can go several days before it happens all over again. It only seems to happen when the engine is cold. I tried letting it warm up but no success. 1997 Land Rover Discovery XD V8


... 1997 Land Rover Discovery

Cold start problem,engine took a while to start,cranked over fine but felt like it was missing or starving for fuel.once warmed up seemed fine but chick engine light was on,after driving awhile light went off.did this for two days,i changed the fuel filters but still wont start,acts like its starving for fuel.the dealership said it could be many problems ,i dont half to tell you how much they want just to hook this thing up to a computer to find out.if anyone could possibly help i would be very


... 2006 Ford F-250 Super Duty

I have got nissan almera 2.2 turbo diesel. about one week ago in the morning my car wouldn't start. after few attempts it will start. i have also changed the glow plugs, but today again it starts off fine but cuts off after 5secs. so i tired the samething after few attemps it started fine. car starts fine once the engine is warm. can anyone please help me thanks


That sounds like either immobilizer prob or dirt in the filter inside your tank ... 2001 Volkswagen Jetta TDI

Have a 1994 toyota 4x4 ext cab with a 22re engine that over heats down the rd and also engine noise issues other than that it ran fine ,took engine out of a 1992 toyota 2wd reg cab with a 22re also that ran fine , the 1992 engine is now in the 1994, starts and runs fine till it warms and switches into the closed loope phase and imeadiatly begins to run very poorly what would cause this ?


... Toyota Pickup

I'm having trouble getting my 90 ford ranger to start i can give it a shot of either and it will start and i can shut it off and it will start fine but i leave it off for an hour and it won't start. see it ran fine when i got it and the heads went to **** but it still ran fine so i took it to a mechanic to have them changed and after that it hasn't ran right since the check engine light is on i've changed the map sensor,distributor,plugs,wires. andit has gas and spark. it has a 2.9l


Stupid answer but the fuel filter has a check valve to stop the fuel from draining from the fuel lines .If the fuel filter is bad it would do exactly as you described ... 1990 Ford Ranger SuperCab

After starting the engine it runs fine for a few minutes until it warms up. After it warms up it starts to idle erratically. I put a vacuum gauge to it. Initially when it starts up it holds steady around 18 until it warms up, then the vacuum fluctuates between 14 and 16. The idle is about 525 rpm after it warms up which is within specs. If I give it a little gas to raise the idle to slightly over 1000 rpm the needle approaches 18 and holds steady until I release the gas pedal then it goes back t


Hithis sounds like an air fault, I would check the air mass sensor, this is the wire going into a sensor on your air box, it basically measures the correct amount of air to mix with the fuel, when they get dirty they can cause this fault. ... 2007 Mazda B2300

I have a vw polo 1.4 16v afh. It runs fine on driving but idles rough. It is fine when started cold but as it starts to warm up then it starts to become rough going from 500-900rmp but doesnt stall. As soon as rev up its fine for a sec then starts again. It has had the tb cleaned a new lambda sensor fitted, checked for air leaks. The engine was taken out and refitted due to cam belt breaking. New valves were fitted. now i been told it could be the ECT because it is running very rich or ive been


Hi RAF340 have you found the solution to your car coz my polo doing the same thing and i cant work out what it is. HELP ME PLZ ... 1997 Volkswagen Golf

How do I troubleshoot problems for a hemi car engine? Car has been back and forth to dealer six or seven times, do to check engine light. Car has been tuned up, wire harness changed and engine decarbonized. Still engine starts rough and check engine light comes back on,   but after 8 to 10 minutes warming up, engine seems to run fine, yet the engine light remains on. This happens every time the car sits more than six hours (rough starting and so on as stated above). It has been hooked up to Auto


Misfiring is often due to ignition system components. "Decarbonizing" is Chrysler's version of using "SeaFoam" in your engine. In fact, the product is basically the same, only more expensive. It has nothing to do with misfiring unless your spark plug ... 2006 Dodge Charger

Engine hunting 1.8 rover 25 techtronic gearbox, automatic. the engine has started to "hunt" when cold, and has blown fuse often when starting cold. runs fine when warm, but warning light for "powerdrive" lights when fuse blows ! could this be a simple problem ( low transmission oil) or some underlying serious fault ? it's a 2001 car, 120,000 miles, last full service unknown but has run fine for 5 years


What a lovely car -if it was a manual ,i have a diesel manual one and its a flier ,as for this iam not sure so try reading the codes but if this is a gearbox related fault car then its the scrapyard as this car has no value in the UK but if stuck fo ... Cars & Trucks

Recently bought 2000 kia sportage has sat for sometime 95,000 miles replaced timing belt as preventative, also air filter, valve cover gasket. driving fine, and then started running rough between shifting(manuel) then would catch up check engine light came on at same time, code was knock sensor, misfire on 3rd cylinder, replace knock sensor, now after engine warmed up it will lose power as if not getting any fuel it will die, but will start right back up maybe drive fine for a minute or so then


Did it come with remotes?if so replace batteries and reset alarm/immobiliser..first step. ... 2000 Kia Sportage

I have a 1994 Cavalier 2.2L that has a couple of problems. When the engine is warm and the car has sat for a couple of minutes after being turned off, it is hard to start. There is a strong odor of fuel. It will start eventually and sputter and then be fine. Also when driving and the engine is hot, it will occasionally shutter a few times when you let go of the gas petal. According to my analisys tool it appears everything is fine. The coolant sensor is registering the correct temperature. I don


Check the fuel injectors, right on the top rear of the intake,theyre notorious for leaking slightly from theyre o-rings that hold them in place,the fuel usually leaves a residue telltale,ie the intake is clean in that area,....also check the fuel reg ... 1994 Chevrolet Cavalier

At oil temp light flashes 1995 Subaru legacy when starting the car, then goes out and the engine stops. When starting again and car warms up it seems to run fine. Every so often the engine sort of loses power then runs fine.


Sending unit may be faulty replace with new unit also check for a loose ground and or alternator belt ... 1995 Subaru Legacy
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.5609 seconds