Having problems with your 1998 Isuzu Trooper ?

3.0L TD. DIESEL IN OIL. WHITE SMOKE FROM EXHAUST. ENGINE ROUGH RUNNING. ALSO RUNNING ON. ( NEW INJECTORS FITTED.)

Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Repair Help & Product Troubleshooting for 1998 Isuzu Trooper

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

3.0L TD. DIESEL IN OIL. WHITE SMOKE FROM EXHAUST. ENGINE ROUGH RUNNING. ALSO RUNNING ON. ( NEW INJECTORS FITTED.)


... 1998 Isuzu Trooper

Mercedes E300 turbodiesel, 1999, is poor to start when cold, almost/is impossible to start when hot. no air visible in fuel lines, all seals etc replaced, new fuel tank strainer, fuel pre filter and fuel filter fitted, new cut off valve fitted, new pressure regulator valve fitted to the injector pump and new crank sensor has been fitted. im running out of ideas. engine has a rattle (that im told is an injector fault and wont affect the starting in any way) that gets worse when the engine is hot.


Yes sir , you have a failing valve, soon it will snap in two....please have your head checked. You can do this yourself by placing a long-handed screwdriver , business end down to each cylinder while pressing your ear to the handle(while engine is ru ... 1999 Mercedes-Benz E-Class

I have a 92 Accord EX. It sat for a year and a half before I bought it. The engine runs very rough in spite of the following repairs. New air filter New wires New Distributor Cap and rotor New Plugs New Alternator (repair shop for a separate issue) Muffler Repair (repair shop) Oil Change The engine does not shut off at random points. After starting it runs rough and has a noticeable decrease in power. One of the repair shops said that I had a misfire in cylinder 3. My check engine light does not


I had a similar problem with a 91 prelude, several mechanics including the dealership failed to find the problem.It ended up being a bad O2 sensor. The guy that finallly this out for me said the computer on early 90's hondas rely heavily on this s ... 1992 Honda Accord

I have a 92 Accord EX. It sat for a year and a half before I bought it. The engine runs very rough in spite of the following repairs. New air filter New wires New Distributor Cap and rotor New Plugs New Alternator (repair shop for a separate issue) Muffler Repair (repair shop) Oil Change The engine does not shut off at random points. After starting it runs rough and has a noticeable decrease in power. One of the repair shops said that I had a misfire in cylinder 3. My check engine light does not


From what is mentioned from your vivid description of the car, it seems that the engine has to be checked up in th first place. There must be a good mileage clocked by the car for which adequate systematic service jobs were not done on schedules. ... 1992 Honda Accord

1994 volvo estate 940SE is haemorrhaging coolant to internal floor areas. new heater matrix has been fitted but it's still happening. no water in the oil and no white exhaust but garage mechanic insists it must be head gasket though there is no evidence of this and engine running smoothly as always. also have tried radweld with no effect except smell of radweld in car when running. please advise. Terry


You need a new heater core. ... 1994 Volvo 940

I have a 1998 chevy 2500 4x4 6.5 diesel pu.truck starts and seems to run normal ,maybe a little loud, i heard chevy diesels this year are louder than fords etc. blows a little white smoke at startup some times at idle not alot though ive seen gas engines w/bad head gaskets blow white smoke but alot heavier.problem is oil dipstick shows about 4 or 5 qts overful and coolant low . i drained all oil and coolant from engine and rad.new oil and filter in engine new antifreeze in rad . i ran the engine


The head gaskets are blown you can believe that anytime on any engine gas or deisel that you get oil in the radiator and there water/ antifreeze in the oil pan the gaskets and or cylinder heads are bad ... Chevrolet 2500

Have a 2001 Volvo s40. it was low on oil and check engine light began flashing. when I stopped the car, the oil was very very low. begin to see puffs of white smoke. After checking oil and adding 3 qts. when I cranked the car, lots of white smoke came from tailpipe and under engine. No oil and water mixing, car did not ever overheat. had a friend come by and he changed the spark plugs and ignition pack according to the code that was being given. Car is still running rough and white smoke.


\012HelloWhen the service engine\012soon light (Also called the check engine light or engine management\012light) is turned on this is to alert you to the fact that Powertrain\012Control Module (computer) has detected a failure somewher ... 2001 Volvo S40

My 2001 Jeep Cherokkee engine light has been on for a couple of years and at one point it was running very rough and I spent about 2 grand having 2 different shops work on it at that time This work (fuel injector cleaning, new plugs, etc,they also told me I needed a new alternator which I suspect that was not part of the problem) did not totally solve the problem and now it is running rough again. I will try to describe some of the symptoms. The check engine light will flash much of the time


Check that the throttle body is cleaned out, throttle position sensor and o2 sensors are clean. ... 1985 Jeep Cherokee

1992 Chrysler LeBaron 3.0 L. V6 Engine runs beautifully but after 16-20 miles highway driving engine stalls as if flooded, or as if fuel is cut-off. After sitting for a few minutes, will start and run normally again, usually for the same 16-20 miles when it repeats the symptoms again. We've changed spark plugs and wires, distributor cap, rotor, new battery and wires, new exhaust system (not including catalytic converter), changed oil and oil filter, ran fuel system and injector cleaners throug


The owner probably rerouted the fuel line because like my 92 chrysler lebaron v6 3.0 the fuel lines keep seeming to come off and the clamps always break. I have replaced the clamps 5 times in a month and replaced filters 2 times in 2 months. The on ... 1995 Chrysler LeBaron

I have a vw polo 1.4 16v afh. It runs fine on driving but idles rough. It is fine when started cold but as it starts to warm up then it starts to become rough going from 500-900rmp but doesnt stall. As soon as rev up its fine for a sec then starts again. It has had the tb cleaned a new lambda sensor fitted, checked for air leaks. The engine was taken out and refitted due to cam belt breaking. New valves were fitted. now i been told it could be the ECT because it is running very rich or ive been


Hi RAF340 have you found the solution to your car coz my polo doing the same thing and i cant work out what it is. HELP ME PLZ ... 1997 Volkswagen Golf

1985 chevy runs rough when hot outside and runs hot,took thermostat out and has new radiator , new timing chain new oil pump , can't figure out why it's running rough , it's a 350 engine ran great for about 200 miles also had heater hose leaking and replaced it also


Water pump cud be failin--plugs wire probly hav inside wear as well as distributer-inspect--du a scan of vehicle for any codes ... 1987 Chevrolet V20

Dodge 3.3 engine began running rough. Poor idle. Stumble's on accelloration and backfires. New O2 sensor, new coil, plugs and wires recent. Dissimbles upper engine checked injectors, egr and found vaccum leak at intake plenum, also found fouled #5 plug. I put the engine back to together, started engine - no codes, still running as poorly as before. If it was an old distributor engine I was say that the timing was off.


Had a similar hard-running problem with a 96 ES 3.8 V6; pulled the front valve cover and rocker-arm tube over #5 had split and no longer controlled the i/o valves. had to replace and re-machine #5 valves in the head. ... 1996 Dodge Grand Caravan

1999 dodge ram runs rough in the morning and backfires. Does this occassionally other than in the morning as well? When it runs rough and backfires it has no power. Then after a few seconds it runs fine. New wires, fuel injectors clean, new spark plugs. Check engine light does not come on. Have had diagnostic test done and found nothing. It is hard to have the problem fixed when it does not happen all of the time. Any ideas would be helpful


... 1999 Dodge Ram

Truck has been sitting for almost a month in colder temps. Started running rough. Scan Gauge gave code relating to cyl 8 misfire. 4.6l engine. Found potential burnt plug wire boot. Replaced wire. Truck seemed to run better. Next day, truck running rough. Same code plus new ones. Recent codes: P150A C0051 C2081 B28C0 P0308 - CYL 8 MISFIRE P0301 - CYL 1 MISFIRE Put in new tank of gas. Also added gas line anti-freeze and injector cleaner, both 250ml bottles to 55l of gas Within past 3 mo


Hello! Sounds as if you were successful..However, this is being listed as a trouble report...Is the F 150 running OK; Or does it still have a problem?....Guru...Saailer ... 1998 Ford F150 Regular Cab

I have a 96 F-350 with a 7.3 diesel skipping on number 1 and 2. It passes injector buzz test. It fails cyl. cont. test on 1 and 2. It has new valve cover gaskets, and i have flipped injectors around. It has a new IDM controler in it as well. The truck didn't run when it got here and after changing the oil it was skipping on 1,2,3,4 but it ran. I replaced 2 injectors and that seemed to take care of 2 cyl. however regardless of new or used injectors in cyl. 1 or 2 they still skip. Engine has equal


... 1996 Ford F350 Crew Cab

Drove thru ditch with water very deep on exit saw white smoke and running rough now on new start it productes white smoke untill engine gets up to speed and then runs good but an engine light comes on. also the gas milage has gone from 16 to 6


You probably bent an intake of exhaust valve by getting water into the engine, or cracked the head. The white smoke is from water and oil burning out of the cylinders upon start up. Sorry.... ... 1994 Isuzu Trooper

Bosch edc 5.3 fitted to MAN D2876 lf02 engine .Truck starts normal and idle ok for a while, then starts to push out white smoke frm the exhaust and runs uneven, and within seconds starts to run evenly again.Remove the plug on top of vertical slider on injector pump and found that if i hold the slider fixed with a tool the engine keeps on running evenly and doesnt start to misfire or smokes.The edc light does come on,on the centre panel(when the smoking starts) but goes away as soon as the engine


Try blocking off the valve that connects the inlet manifold to the exhaust and see what happens ??? or just disconnect it from the inlet manifold and try that before you remove the pump to have it overhauled ,Yes we do seem a bit short of motor vehic ... 1999 Mercedes-Benz C-Class

I have a 1990 chevy corvette with the L98 engine. I have replaced the fuel injectors, all the sensors, the cap and rotor. Plugs and wires. And a new ecm. My car runs and sounds like a million bucks untill you kick it, then it just goes nuts. Its starts stumbling and blowing white smoke out the back. It continues to run this way untill I turn the engine off and restart it . Then it runs great again unless you give it full throttle. It even does this when the car is in park. If you rev the engine


Have you checked the timing? Your timing may be off and although the car would run, it would not run correctly if the timing was off...I would also take the ECM out and get one from a corvette salvage yard..this will insure you are getting an OEM fac ... Chevrolet Corvette

My 1994 J30 with 200,000 miles starts fine, but runs rough after a-while of using it and it will not start when you turn OFF then ON the engine. I have to wait the next day to start it and be okay. After replacing the TIMING BELT, BELT TENSIONERS,AC BELT, ALT BELT, PS BELT, CLOG INJECTOR, SPARK PLUGS, FUEL FILTER as regular maintenance, the car now runs great and very smooth like new. But, the OFF and ON problem of the engine is still there, It runs great when its running, but once you turn th


Hi sierrabridge,\015\012Check the igniter, the ignition switch and the ignition coil\015\012\015\012Best regards Johngee10 ... Infiniti J30

Have 2002 C4500 with 6.5 diesel. Have large amount of diesel fuel in oil (over 3 quarts high). Engine seems to run fine, though. Engine has 110,000 miles on it, might be able to get injectors installed, because there was a bullitin on this motor. I have the old style injectors, and there are now new style injectors. I am assuming the problem is the injectors, but I am unsure at this point.


I think it is an injector problem. It could be one of the injector is loose and releasing fuel into the head or one or the entire assembly may go bad. The leak may occur also on high rev and not in idle so you have to test while it is reving. The ... 1994 GMC Suburban

Engine runs smooth and the head gasket has been replaced,I already know I need a new radiator..There is a small amount of white smoke at start up,and my oil is milky looking>


... 1999 Chevrolet Suburban

Only running on 3 cylinders number 2 plug keeps oiling up other 3 are fine put full set of new plugs in and ran great for 2 wks now running rough againtook plug out and cleaned it still no good wet black oil on number 2 plug no oil in water ford focus 2.0l petrol engine


If the oil is on top of the plug, your valve cover gasket is leaking. (easy fix). If the oil is on the bottom of the plug (on the screw threads) you have a problem. It could be a burnt valve, blowed piston ring, or even a head gasket. Please let me k ... 2002 Ford SVT Focus

My 2009 H2 is idling rough for 2-5 min with a cool start, after 2 weeks of doing this, its now blowing white smoke on the first start of the day for 2-5 mins, after that it runs normally, I have NO Engine error codes , No visible oil leaks... This started more or less a few days after the cars 5000km oil change. Engines hrs is around 230. correct oil was used.


My guess would be a leaking intake or head gasket. Water in the cylinder(s) is shorting the spark plug until the temp comes up on the engine. The white smoke is the coolant being burnt off. check your coolant level it may be low. ... 2009 Hummer H2

Hi, I'm new to this site, I recently brought a 98 1348cc 8valve daewoo lanos. The oil pump was gone so I fitted a second hand engine, the problem is it will not start when cold unless I squirt easy start into it, and then it struggles to rev! it seems to lose power at high revs. I know the engine I fitted was running fine. If I use my hands to restrict the flow of air into the inlet it will rev as it should but when I remove my hands on full throttle the engine will die and stall! Any ideas beca


Does it have a Mass air flow sensor? If yes, unplug it and see how it acts. ... 1999 Daewoo Lanos

Hi. I have a cadillac BLS with a saab engine. It has a very high oil presure reading and the engine is rattling because of this. It has been stripped and all oil ways blown through, new turbo fitted, oil pump stripped and rebuilt, new timing chain set fitted and the head removed oil ways cleared and then re-fitted. The car now smokes like hell on start up but dose get better after a short time but the oil pressure is still way to high. Apart from a new engine, any sugesstion?


... Cadillac Escalade
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.0859 seconds