Having problems with your 1998 Ford Escort ?

We just got a 1998 ford escort, automatic with 106,000 mi on it. two weeks passed and the check engine light came on. It was the tps, it was changed n no change. The car turns on after third try, jumps at 20mph, and once in a while turns off at a light.when you put foot on accelerator, the motor seems like it stays accelerated. throttle cable seems too loose but dont know how to tighten it.took apart throttle body cleaned it out, no change, dont know what else to do. can you help!

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Did you reset the computer because if you don't the computer does'nt reconize the new sensor and it will run as if you did'nt even replace it.You can reset it with a scan tool,or take the ground cable off battery for 30 seconds or pull the ECM fuse then put it back.
Repair Help & Product Troubleshooting for 1998 Ford Escort

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

We just got a 1998 ford escort, automatic with 106,000 mi on it. two weeks passed and the check engine light came on. It was the tps, it was changed n no change. The car turns on after third try, jumps at 20mph, and once in a while turns off at a light.when you put foot on accelerator, the motor seems like it stays accelerated. throttle cable seems too loose but dont know how to tighten it.took apart throttle body cleaned it out, no change, dont know what else to do. can you help!


Did you reset the computer because if you don't the computer does'nt reconize the new sensor and it will run as if you did'nt even replace it.You can reset it with a scan tool,or take the ground cable off battery for 30 seconds or pull the ECM fuse t ... 1998 Ford Escort

I just changed the mapsensor, both fuel injectors and truck will start but wont stay running, I have a 4.3L 2wd and TBI System, dont know what to do at this point so far engine seems good, just did major tuneup, it was driving and then one day it just shut off , figured out it was the fuel injectors but now when those got changed and the throttle body got cleaned it wouldnt start , then replaced map sensor , it started but wont stay idle, dont know what to do at this point


... 1992 GMC Jimmy

I have a 2007 dodge ram 1500 4.7 flex fuel and my car turns off at high speed 70/60/50mph etc it just dies out completely and I pull over put it back in park and car turn on right away the code that comes out is p2074 , I've change iac motor , TPS , map sensor , computer , done a vacuum leak check and nothing , cleaned throttle body . Car when in idle stopped at a light sometimes stays accelerate above 1100 rpm and sometimes below 500 rpm . I drive in fear all day not knowing when the car is goi


... Cars & Trucks

I have a 99 Nissan Pulsar, Ill turn it on and start driving. Ill stop to turn a corner and then when i go to put my foot on the accelerator the car has no power and seems to nearlly stall, (its an automatic). I will then pull over and push the accelerator and nothing will happen and that car sounds like it is going to die. I turn the engine off, restart it and then it seems to run fine for the rest of the trip. I've changed the fuel filters and oils and was wondering why this keeps happening. It


Check your vacuum lines for leaks and the MAP sensor and pcv valve on the valve cover. ... Nissan Pulsar

I have a 99 Nissan Pulsar, Ill turn it on and start driving. Ill stop to turn a corner and then when i go to put my foot on the accelerator the car has no power and seems to nearlly stall, (its an automatic). I will then pull over and push the accelerator and nothing will happen and that car sounds like it is going to die. I turn the engine off, restart it and then it seems to run fine for the rest of the trip. I've changed the fuel filters and oils and was wondering why this keeps happening. It


Sounds like its a faulty throttle position sensor ... 1990 Nissan Pulsar

My ford f250 wont start my pumps are not on when i turn my key on, they are intank fuel pumps, but i cant seem to find my relay to change the tanks over, i think either that is my problem or one of my fuel tanks blew a pump and it dosent have any pressure to switch to from tank to tank. The engine is a 300 6cil and i dont have a fuse box under the hood. i dont know see if anyone knows what a solution might be i gotta fix this


Hello, usually the all relays are under the hood were your fuses are located, if they are okay then you need to check if a wire is loose or broken at the fuel pump or were the switch is first if all is well, then look at changine your fuel pump. ... Ford E-350 Super Duty

Radio I have a saturn 2005 vue -- for some reason my radio seems to get stuck -- this started around june or july -- but it seems to be getting worse. turn on radio but cant change the stations with the buttons - it will turn itself off and stay on the same station a few times and this weird line comes up on the station area - so you know that is happening and i have lost the face of the clock more that once when this is happening.


THIS IS NOT SOMETHING YOU CAN FIX IT IS A SMALL CIRCUIT BOARD INSIDE THE RADIO THAT RUNS THE DISPLAY AND BUTTONS FOR STATION CHANGE ETC. THE ONLY WAY TO FIX IT IS TO PULL THE RADIO OUT AND SEND IT TO A AUTHORIZED GM/STAURN ELECTRONICS REPAIR CE ... 2005 Saturn VUE

I dont suppose anyone on here knows what voltage the throttle position sensor should test out at do ya? I know that I need to unplug the plug from the TPS, and use a voltmeter with the key turned forward. I just am not sure what the voltage should be at idle, and at load acceleration. PLEASE HELP!! If anyone knows!!


1.5 volts to .8 for yours\015\012\015\012please check out this website for a vidio with a example of testing different tps sensors\015\012\015\012\015\012 ... 1986 Ford Ranger 2WD

I have a 2007 ford explorer whose engine light stays on. the oil change light also stays on. its been on for a while,but it doesn,t affect the performance of the car.its in my opinon using more gas. when i go to fuel up it takes along time to get gas in. air seems to be boiling up thru the tank, and that keeps cutting the flow off. my friend put his computer on it and it went off for a day or two. i dont know when or how it started , my daughter was the driver.


If the oil change light is coming ON,then check the oil level and replace the oil.Also if the check engine light is on then get the codes checked.The check engine light comes ON,when there are codes stored in the cars computer.\015\012. If\015\ ... Ford Explorer

Have a 1998 Nissan Altima gxe. I seem to be experiencing a problem with my left headlight. I have changed both headlights with new bulbs. The right side is fine. When i turn on my headlights, only the right one is turned on. The left one stays off, but another event that occurs is the high-beam indicator is always on (in my dashboard)!!??. But, i know for a fact that i have not activated my high-beams. t.y for help...


Hello! The main light switch is defective and needs to be replaced...See photo below...Guru......................Saailer ... 1998 Nissan Altima

Nissan datsun 280zx seems to be flooding out. Black smoke out of the tailpipe, If i dont keep my foot on the pedal when sarting the car it dies! This car has a straight 6. It also has a 1st generation fuel injector, which I know little about. Changed spark plugs, no change. Where should I start to look to get this car running?


The coolant temperture senser could be disconnected or open ( no circurt ) If it's disconnected The computer thinks the engine is real cold and turns up the fuel. OHM meter ther coolant temp senser and it should read something to ground 400-1000 OH ... 1983 Nissan 280ZX

On my 1998 Windstar, when I press on the brake pedal, my left turn signal comes on (dimly). If I am using that signal, it stops flashing and goes dim until I take my foot off the brakes. The right turn signal behaves normally. I had changed the signal switch assembly for a different problem, but it did not affect this malfunction. This only seems to happen during cooler weather. I have not yet been able to find where the left signal and brake light are grounded, so I don't know if this coul


Could be a bad earth unscrew light and check bulb contacts are clean your earth is against the body work when you tighten your light assembly so make sure its clean ... 1998 Ford Windstar

Fiat ducato will not start in cold weather . have changed glow plugs put in bosch, also changed cold start relay box . glow light stays on for about 10 seconds then try to start white smoke and smell of diesel. will go out later in the day and she starts no problem. seems tobe that if its icey first thing then she dont want to know


Try adding a fuel additive..to stop the fuel from jelling ... Fiat Pininfarina

2004 nissan sentra it turns on easy but immediately the RPMs drop so the engine is just staying on. you step on the gas and no responce.car will not accelerate you turn off the car, and restart a couple of times and then all ok runs good oh not the throttle body nissan just changed. back at dealer now but their computer is not showing anything wrong cause the check engine light is not activated to reveal a code on their computers. and only has done it in the morning when leaving for work night t


Have they checked all connections? Gas pedals seem to be all electronic these days (see Toyota headlines) Also MAF, MAP, min idle speed switch. All aspects of fuel delivery? Especially psi regulator. Sorry these weird problems are difficult to pinpo ... 2004 Nissan Sentra

I have an 2006 lincoln navigator and i had 2 codes p2104 and p2112 i changed #2 spark plug and coil then i got a fail safe mode turned truck off then back on then went away then i got the two codes p2104 forced idle and p2112 throttle actuator control system actuator stuck closed now the codes are gone but my diagnostic tool has a yellow light like the codes are pending and the problem is still there a hesitate a jurk when i press the gas i dont know what to do i even replaced throttle positio


Hi, there is a post here on this issue: http://www.fordf150.net/forums/viewtopic.php?t=50060&highlight=p2104Since you have already changed the TPS, I assume you also cleaned the throttle body? Is the throttle actuating smoothly? If not ... Lincoln Navigator

2001 blazer goes into 4 wheel by itself. Light on button stays on 2 hi if i slow down it will go back to 2 wheel but after a few minutes it goes back to try 4 wheel. I changed the tccm but now im thinking its the actuator under the battery because it seems like it doesnt release all the way but i really dont know for sure. Is that possible??


... 2001 Chevrolet Blazer

Hyundai excel 1994 hard to start after sitting. Problem: After the car sits for a while it is hard to start. It is not cranking but I hear a click on turning the key. I need about 5 -8 tries until the car starts. All those tries give me only a click noise like the battery is discharged. The car drives then very bad until it is warmed up. If I put my foot off the accelerator to change gears the motor seems to close down a bit, that is until the car is warm. Once the car is on temperatur


Even i had a similar problem with my Suzuki SUV. It is a bendex problem It is about to go. Bendex is a part of the starter motor and moves forward to engage the flywheel when you turn the key. It can be repaired yet as it is working although intermit ... Hyundai Excel

Blown head gasket, replaced and now cant time. all books and web say that the vehical is not timeable it has to be done by a comp. tech 2. but we went to dealer and their tech 2 couldn't read it. i cant seem to find out what its timing should be set at, like tdc or 2-6-10 btdc or atdc. dont know where to start before we drop the distributor in. we have tried it at 2 btdc and got the distributor in and it runs but has a miss to it. if we turn the distributor a little there is not much change and


The ignition timing is not adjusted with a timing light or with the engine running, and to set the ignition timing follow these procedures.There is a mark or notch on the distributor housing that the rotor should be pointing to when ... 1999 Chevrolet Silverado 1500

IT COULD BE A LITTLE PROBLEM BUT I DO NOT KNOW WHAT IS IT ,I JUST WASTED MONEY AND TIME FOR GETTING NOTHING ,FROM TIME TO TIME I FEEL THERE IS NO POWER COMING TO CAR'S ENGINE WHEN I WANT TO ACCELERATE THE PEDAL IT SEEMS LIKE THE ENGINE WILL TURN OFF BUT IT IS NOT ,IT CAN BE SENSORE OR SOMETHIN LIKE THAT AND I REALLY CHANGED MANY SPARE PARTS LIKE COILS ,Mass Air Flow Sensor AND FUEL PUMP WHAT ELSE CAN I DO


Replace your plugs, wires, cap and rotor, and fuel filter and go from \015\012there; probably low fuel pressure. Get your fuel and air filter replaced, could\015\012 be the fuel injector(s), fuel pump... I doubt it's your plugs if you \015\012get a t ... 1997 Infiniti.5 Q45

My 1997 buick lesabre runs fine for about 10 minutes then dies while im driving, i can wait a few minutes and it usually starts back up unless its being stubborn then i might have to leave it for a few hours. the engine turns over but it wont start so i dont know if its the VATS but the little waiting time seems like it might be the VATS, also my security light stays on when the car is running.


It's when the security light starts flashing that the infamous "chip" in the key becomes a nightmare to many. Gradually the car begins not cranking anymore or if it cranks it would start and die in a second. Randomly it will do this more and more oft ... 1997 Buick LeSabre

I have a 1992 Ford Ranger. Woke up one morning, put my foot on the brake to put it in gear and noticed my hazard indicators were lit up....then realized I had no turn signals. My flashers come on every time I push on the break. I changed the flashers....and bulbs...and still nothing is fixing this problem. I checked the grounds and they all seem to be fine. Anyone know what the hell to do next?


Check the brake switch underneath dash, if faulty it will ground out the circuit, causing causing voltage to jump to the haz switch ... Ford Ranger

A square green light with a picture that looks like a key showing in it comes on when I turn the ingition on & off . It used to flash at these times but seems to be staying on longer lately, or it may be that I am more aware of it now? ..Is this normal or indicating a problem. Unfortunately as a second hand car i do not have a manual so dont know what this indicater is. I am worried that by driving it with potential problem I may be causing more damage please help me understand this.


If you click on the following URL (it's the owner's manual for your 99 CRV), and go to page 53, you will see the instrument panel. I don't see the light you are referring to, but maybe you can find it easily. You must have Adobe reader (free progra ... 1999 Honda CR-V

I just bought 06 quadropote and i dont know how to put it in parking...does it automatically go in N when i turn it off?? and i was driving 100mph and rpm stayed a lil bit passed 3rpms when does it change gear??


Yes ... 2006 Maserati Quattroporte

The pad for the windows and lock on the driver door do not work, the light does not come on when i open drive door but does for rest of doors, also the radio no longer stays on when i turn ignition off. also the oil light just came on, i have changed the oil, but i dont know it thats connected or coincidence. thank you.


{: ) Check the DDM fuse10amp at the fuseblock rear. If okay, try to remove the driver door switch. Use a flat bladed tool to snap it out from its clips at both ends. Check for 12volts on the two thick orange wires and the ground (black wire). If ... 2006 GMC Envoy

I got a 1996 ford F150 XL single cab inline 6, and it wont crank, i can turn the key and eveerything shuts off like its cranking but its not, the silinoid aint even clicking, i drove it around earlyier today and it started just fine. i dont know what could be wrong with it. and the battry and everything seems to test out ok , and the batttery light stays on all the time


Disassemble and clean the battery connections. If you have a yellow or white residue on top of the battery, you probably have a cracked seal around one or both of the battery posts. This releases a small amount of battery acid which can cause connect ... 1996 Ford F150 Regular Cab
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.5839 seconds