Having problems with your 1998 Chevrolet C1500 ?

I have a 1998 Chevy Silverado 5.7L AND WHEN TRYING TO START IT.IT POPS BACK THREW THE AIR CLEANER'' AND CANT GET TO START AT ALL HAS NEW FUEL PUMP AND FILTER

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

I would check timing and if ok check compression and then a leak down test. it sounds like a timing issue to me. thanks, any questions you have i will help
Repair Help & Product Troubleshooting for 1998 Chevrolet C1500

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Have ford f 150 302 fi cranks good only runs when i jump the fuel pump relay how do i fix 1992 f- 150 300 i-6 ,i have a new fuel pump, new fuel filter , new fuel line ,my truck stalls some times and i cant get it started , i think its my relay but i dont know wich one it is , i only have 3 in my truck, and cant figure out wich one it is , 2 of them thump when i turn the key to the on position.what does that mean and wich one is my fuel pump relay?


I got a 6 cylinder ford truck when i drive it with the first tank it loose power. then i push the second tank and it runs normal . ... 1992 Ford F150 SuperCab

I have a 1998 Chevy Silverado 5.7L AND WHEN TRYING TO START IT.IT POPS BACK THREW THE AIR CLEANER'' AND CANT GET TO START AT ALL HAS NEW FUEL PUMP AND FILTER


I would check timing and if ok check compression and then a leak down test. it sounds like a timing issue to me. thanks, any questions you have i will help ... 1998 Chevrolet C1500

95 s10 4.3 blazer new fuel injectors(spider) 2 new fuel pumps new filter was getting 50/60 psi on guage but had to start with starting fluid...now only getting 10/20 psi changed fuel pump again(#2) still getting 10/20 psi when i was getting 50/60 it would drop down to 10 after i turned off key... now wont start even with starting fluid


... 1995 Chevrolet S-10 CA Edition

1998 gmc jimmie 4.3, 2 wd. wont start. getting no gas at the fuel bleeder valve. has new fuel pump and new fuel filter. started and ran fine after new pump and filter install. drove 15 miles and parked all day, drove 20 miles and parked again. came back 15 minutes later and will not start. will run if you pour gas into throttle body. all fuses under hood are OK. fuel pump can be heard priming when ignition turned on. any suggestions appreciated.


I just looked at this problem again .\012Try this check the connection at the junction box before the fuse box \012Its drivers side near the ABS unit under a plastic cover .\012 What it is is the connection that feeds power from the batte ... 1998 GMC Jimmy

Changed out fuel filter because engine did not seem to get gas or start enless i put a gas soaked rag in the air cleaner...start for a couple on seconds then die...fuel pump seems to be working there is gas going to both sides of new filter...what else could it be.even unhooked the battery to reset computer....Please help Thanks John


You may have a faulty MAF, ( mass airflow ), sensor. Often an engine appears to have a fuel problem, when it's actually an airflow problem.\012The MAF is usually easy to check.\012Sitting on top of the air intake duct, between the air fil ... 1998 Ford Explorer

No start car died while driving. wants to start got it started once but did not run good and died. fuel pump is coming on. changed fuel filter. new battery elect. is ok. suspect the timing is off. icm module or timing chain. sprayed crank sensor with carb. cleaner that when I did get it started. is there a way to check timing externally without tearing the front off. it is the d.I.S. engine. ty so much


Hi, there is no sure way to check valve timing except to remove the cover, as there is no access hole to observe the timing marks. If your compression is low, that is a pretty good indicator. What you describe does sound like a chain that has slipp ... 1995 Buick Century

Replaced fuel pump. module/coil, new fuel filter, getting spark, but back fires through engine exchaust. firing order of plugs correct, But after priming engine throttle with ether, car only back fires and wont start. Cant seem to get engine to fire or get gas to the engine


Sorry but you have a timing problem,recheck the fireing order because that what is causing the backfire through the exhaust i think you are nearly there stop useing ether it will blow the head of the engine or blow a piston out through the engine tak ... Buick LeSabre

I have a 1990 Chevrolet, 4X4, 1 ton, 454, 4 speed truck. It will not start with starter. Engine turns over good with starter but will not start. However, if I pull the truck and pop the clutch it will start and run great. Fuel pump is new, all new plugs, wires, cap, rotor, fuel filter, air filter. Fuel pump runs properly when switch is turned on. Getting fuel into throttle body. Have had to various mechanics.


... Chevrolet 3500

In the morning when i go start my car, the first time i put the key in and doesnt start it rotates but doesnt start i turn the key agian and it does,please help i put a new starter in alternater,water pump,heads cleaned up at a machine shop fuel pump,fuel regulator,fuel filter,pvc,160 thermostate.spark plugs,wires new egr and a K&N filter and rebuilt transmission and cant find the problem im growing gray hair from stress in can somebody please help me with this issue. thanks alot!


You moght check the ground straps and make sure the engine is grounded solid ... 1996 Chevrolet Impala SS

The car ran out of gas, and after putting new gas in the car it started up then died. I took it to a mechanic he said he tapped on the fuel pump and it started right up, but suggested I replace the pump. Do I need to replace the pump or just get a new fuel filter? Where is the pump located? Do I need to take the gas tank off to get to the pump?


Yes. the pump has gone out on the car it is a comon problem on chevy's it is located in the fuel tank under the car. get ready to spend some money they ain't cheap and I would recomend replacing your fuel filter every other oil change because its the ... 2001 Chevrolet Cavalier

Mercedes E300 turbodiesel, 1999, is poor to start when cold, almost/is impossible to start when hot. no air visible in fuel lines, all seals etc replaced, new fuel tank strainer, fuel pre filter and fuel filter fitted, new cut off valve fitted, new pressure regulator valve fitted to the injector pump and new crank sensor has been fitted. im running out of ideas. engine has a rattle (that im told is an injector fault and wont affect the starting in any way) that gets worse when the engine is hot.


Yes sir , you have a failing valve, soon it will snap in two....please have your head checked. You can do this yourself by placing a long-handed screwdriver , business end down to each cylinder while pressing your ear to the handle(while engine is ru ... 1999 Mercedes-Benz E-Class

Van quit while driving down driveway. Found not getting fuel, zero fuel pressure at the fuel pressure tap under the hood and no fuel pump "hum"...not even for 2 seconds. Replaced fuel pump assy, relay, and fuel filter and van will still not start. The relay does not click and I do not get 12v to the pump between the gray and black, which go to the fuel pump motor. I have ck'd all connectors for burning or melting and all look like new still. Both old and new relays the coil cks good on meter


I have a 2003 chevy venture and 2 years ago my van just quit, replaced relay, fuse and fuel pump. finally had to take in to chevy garage and they found a short in the wires to the fuel pump up under the dash. cost me about 150 bucks at the garage, th ... 2002 Chevrolet Venture Passanger

I have a 1993 cavalier wagon and i cant find the fuel filter the car is lagging when you start it it takes a few to turn over already put a new switch on it and that didnt solve the problem sometimes it dont want to start at all just click then when i get it to start sounds like it wants to stall untill i pump the gas a few times


It will be a few feet in front of the fuel tank underr the car ... 1993 Chevrolet Cavalier

1999 chevy silverado 5.7L 2wd truck would not start, could not hear the fuel pump, lifted truck bed and cked pump, i have power to pump, it appears that the fuel pump relay is working like it should, power cycles when ke is turned on and when it cranks, i also found what appears to be a plugged fuel filter, i changed the filter also now engine want to start just cant seem to get going it will pu and run if i pour gas down the intake. is there a pressure regulator that may be the problem or what


Did you check the fuel pressure? there is a sharder valve on the fuel rail to do this. i know you have to have a certain amount of pressure in order for it to run.i think on fuel injection its around 60 to 70 psi.and on throtle body is around 30 to50 ... 1999 Chevrolet Silverado 1500

I have a 1997 blazer 4door had a new fuel pump & filter put in it now it gets hot shuts off & u cant hear the pump come on after 20 min it will start up & run fine thank you for your time


Take mass air flow sensor off and clean it with a non-chlronated brake cleaner let it dry for 30 minutes then reinstall.. ... 1997 Chevrolet Blazer

90 Honda prelude is not getting fuel from the back to the front. Already put on new filter and pump. Still wont get to the front. So right now I have a wire going from my pump to my battery and when it wont start I touch the wire to the battery and fuel will run to the front then it will start. What would that be ? Also blew a water hose, changed it, now sometimes it acts like it has no power. Like its not getting gas annd its gonna die. But then it will start going again ? I opened up the bleed


Check the ECM main relay. It supplies power to the fuel pump and the injectors. If there is no power to the pump this is the first thing I would suspect. I believe it is located up under the drivers side of the dash and the very drivers side. ... 1990 Honda Prelude

Just finished jputting a new fuel pump in the tank. Put a new fuel filter on. Put ten gallons of gas in the tank and I still can't get the pump to pump the gas to the carburater. Took the line apart from the fuel filter and the carburater to see if gas was coming through when I tried to start it. No gas is coming out of the tank.


Replace the relay under the hood on the rt.(passenger) fender just in front of the hood shock. ... 1983 Lincoln Mark VI

My 94 full size blazer starts and idles fine in park and in neutral. When I put the truck in gear and hit the gas, it'll start, then act like it wants to die. The Catalytic converter is off, I'm going to get that replaced. I've done the basic spark plug/wire/distributor cap replacement. Last year I changed the EGR valve. I changed the ignition coil today. Put on a new o2 filter. New fuel Filter. New k&n air filter. Could it be a bad fuel pump?


... Chevrolet 1500

I ALSO HAVE A FUEL ISSUE WITH MY JAG XJ6.I CAN STILL HEAR THE FUEL PUMP WORK, BUT I'M NOT GETTING GAS TO THE BAR ABOVE THE INJECTORS. SO I REPLACED THE FILTER THAT IS BACK BY THE DRIVERS LEFT WHEEL. WHEN I TOOK THE OLD ONE OFF THERE WAS PRESSURE IN THE LINE. BUT EVEN WITH THE NEW FILTER (THE CORRECT ONE) I AM NOT GETTING FUEL TO THE INJECTORS. THE CAR STARTS RIGHT UP WITH STARTING FULID, SO IT HAS TO BE NO GAS. IS THERE A 2nd FILTER? OR SOMEWHERE ELSE I CAN CHECK?


There's no 2nd filter for JAG XJ6. You mentioned that the car starts right up, but did it die after a second or two? If yes, then: You need to check the "Block diode relay" and a "Inhibitor relay". But you need to consult a mechanic to ch ... Jaguar XJ6

01 chev cavalier 2.2l 181000km a week ago car wouldnt start not getting fuel replaced filters and pump ran for two days wont start again. No codes no engine light.. replaced fuel pump relay, fuel pressure regulator even tried replacing gas cap.. no luck.. car will run for a second when you spray gas in the throttle body/intake... all new plugs and i should mention they are dry fuels not getting to them but why? Any ideas on what to do next? I am stumped please help!


Check into your VATS system ... Cars & Trucks

Fuel pump pressure at the manifold is 60 psi blazer sits over night will start but takes quite a bit to get it going after it starts it runs ok a little bit of a hesitation replaced regulator has new fuel tank and pump and new fuel filter thought it could be a leak in the fuel injection line on one of the spiders any help would be appreciated


... 1999 Chevrolet Blazer

I have a 03 duramax 2500hd with 6.6 died while i was going down the road. I changed fuel filter added more fuel still wont start. Its now in the dealership has been for a month put in new fuel injuction pump, 2 new glow plugs still wont start now they say its the return pump pluged up, has anybody a clue what it could be or has it ever happened to anyone befor bill is getting to high to just keep adding parts


There is an electric fuel cutoff activated by the ignition key switch..did they check this item,,is fuel getting to the engine at all..they can actually squirt raw diesel into the intake and it should fire up momentarily..if its really cold outside t ... Cars & Trucks

My truck stalled tried to start it ran for a 2nd .was told it was the fuel pump ,so put new fuel pump in and filter and new lines ,now my truck wont start cant hear the pump ,dont know wa


Does the pump have voltage and ground ?Did you check the fuel pump relay and fuse ? ... Cars & Trucks

My 1995 gmc sonoma 4.3L SLS vin# W, has a new fuel pump, new cpi injector system, new filter and still doesn't start, I understand it needs 58 to 60 psi to start, after checking the pressure at the end of the line just before the injection system I only get 10 psi. I also checked the pressure at the pump only . I still get only 10 psi , I just don't know where to go from here.


Hi\015\012Please read the bellow article thoroughly to have an indepth knowledge about your problem…\015\012 ... GMC Sonoma

99 ram 2500 4x4 24 valve diesel. normally when you change the fuel filter.. you bump the ignition to start the factory lift pump to prime the new filter. My factory lift pump is getting no voltage. I have looked hi and low for a fuse. I have changed the fuel system relay and still no voltage. I am stumped.. any ideas? thanks Mike T. the lift pump is mounted on the back of the engine near the fuel filter housing


... 1999 Dodge Ram
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.9717 seconds