Having problems with your 1997 Volkswagen Jetta ?

I removed the front left fender on my 1997 VW Jetta (2.0 Liter) and after I removed it, there is this black box with a few different hoses going into the engine... I am having trouble identifying what this box is, PLEASE HELP?!

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

I believe it's the charcoal canister for the EVAP system.
Dear Sir,
\015\012 That is a part of air filter to reduce engine noise,it carry air for engine combustion through that hose till air filter,that known as air resonator. thanks.
Repair Help & Product Troubleshooting for 1997 Volkswagen Jetta

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I removed the front left fender on my 1997 VW Jetta (2.0 Liter) and after I removed it, there is this black box with a few different hoses going into the engine... I am having trouble identifying what this box is, PLEASE HELP?!


I believe it's the charcoal canister for the EVAP system. ... 1997 Volkswagen Jetta

Hoses my husband removed some hoses on our 89 cadillac sedan deville. He says that they are vacuum hoses. He can't remember how they go back on. Help!! Is there a diagram of the engine that I can look at to see how they go? Any help would be appreciated.


If you are lucky there will be a sticker on the hood when you open it.... look up.... it will have at least some of the routing of the vacuum hoses. if not your next best bet is to go to the public library and look thru a manual.... search their dat ... 1989 Cadillac Sedan DeVille

Please help my bmw 318is overheated, fan does not go on, engine makes very loud sound stops only when remove oil dipstick- engine cold on oneside and extremely hot on other. please help! -ash


Possible coolant blockage in engine. Fan does not run because temp sensor is located is part of coolant that is not getting hot. Describe loud noise please. You are likely facing terminal engine failure, however, try back-flushing coolant passages on ... 1997 BMW 318

My rig is a 1991 Ford F250, auto, 4x4 with a 460 engine. I have a antifreeze leak somewhere above my oil filter. I think it is coming out of the silver box that my bottom radiator hose goes into... but I don't know what that is called to look it up. There is a small 4 inch hose with a 45 degree turn in it that I replaced, that hose also goes into this box. Please help. Thanks


From your disciption i think your talking about the transmission cooler.it may look like asmall radiator with 2 lines going to trans & 2 to radiatorhope this helpsgood luck ... Ford F-250

Engine trouble Car has sat for quite awhile and is now hard to start, even in warm weather. It does not idle properly, continually stalls out until engine has warmed up. When the gas pedal is depressed,the engine seems like it is starving for gas or air. Also, the oil pressure gauge goes off the scale upon startup. I have replaced the spark plugs, fuel filter, oil, and removed the injectors which I soaked in diesel and then replaced. None of these things made any difference! PLEASE HELP


Car runs rough, ... 1985 Mercedes-Benz 190

Engine sputters We replaced the spark plugs, and the hoses from the distributor. (Don't remember what they're called, they go from the cap and into the sockets where the sparkplugs go.) And she started just fine. My wife drove it for awhile, and when she got to work, she left it off for a bit; when she got on her break, she went to go check it, and the car sputtered a bit before turning on. Please help.


Those hoses are spark plug wires.Does it sound like it has a cylinder miss, or more like it is not getting enough gas ? ... Honda Accord

Please help I have a 1988 Chevrolet C3500 Ext. Cab Truck with a 5.7L TBI engine and TH400 Transmission. While going down the road engine dies, the injectors are shutting off. Remove breather and wait a few minutes they start working again. Problem continues to occur with out any consistancy. The only thing that shows on flashing check engine light code is a repeated 12. What do you recommend?


Code 12 is no tachometer or reference signal to computer.means a bad ignition module.replace it.also test coil make sure its not open or bad. ... 1988 Chevrolet C3500

Starts up like normal but jumps up to about 3 grand on the tach then falls down to 1.5 and stays there, engine surges at this idle. Runs good on the road till u have to stop and surges(jumps a little). Have checked vaccuum hoses and throttle cables, can't figure it out, took it to get coded and it came up P1294 and engine lite stays on most times, will go off runnin down the road and sometimes goes off when just idling. Please Help.


P1294 indicates a vacuum problem or a idle motor control problem. Since you already checked for vacuum leak then the iac on the side of the throttle body will need to be removed and cleaned. The best thing to do is remove the whole throttle body so i ... 2001 Dodge Caravan

Cadillac Catera stalls for no apparent reason, I cannot get my trunk open. Of course, the most important is to get my car to not stall anymore. I'm a single mom and cannot depend on my car! I have been reading the helpful solutions on this web site. I am going to first try the least costly one of spraying CRC Intake Cleaner (4.69 at local auto parts store) into my intake. Solution tells me to remove the intake hose to the engine. 1.) Where is the hose? 2.) Where solution advises me: hold the


Your best to have the car properly diagnosedat a local shop Have the real cause of all the issues at least diagnosedor found ... Cars & Trucks

Hi, I remove my p flow for my 2004 matrix XR, its was there since 2005, i had no trouble with it just tired of the noise. i reinstal the original air filter box and tubes, its all well instal but i got a chek engine. at idle everyting ok but i cant go over 2800-3000 RPM because there is like a cut-off. i got the codes from my corner garage its 101,102,113 he told me to go to toyota to get my comput reset. what should i do ? Thx Ben


... 2006 Toyota Matrix

1998 nissan sentra gxe 1.6L....... replaced the distributor twice with used ones. runs but when i take off or go uphill...no power... press gas too hard and it wants to die. let off gas and it gradually kicks in and goes. trouble codes po340 and po100... in morning it dont start and i can take off the big hose to the intake off, where the MAF is located and it starts up..runs fine it seems except for during takeoff and going uphill i gotta kick in passing gear to make it up....need help please!!


Did you replace the distributer cap itself. Thats my guess good luck. may be plug wires also. ... 1998 Nissan Sentra

Clicking noise when i turn a/c on for back passengers using the dial above me in front. after awhile will stop, but once i turn off the a/c & turn it on it clicks again. also had trouble w/gas gauge needle going to full after a fill up. slowly reclined as i was driving but didn't get to full for like several hrs after. was curious if this could be a problem w/the speed of my car? I was think'g maybe nt enuff gas being pushed into engine? idk...please help.. Doesn't seem to go as fast as it use t


The clicking sound when you turn on the A/C is typical of a system that is a little low on Freon(R134/R12). The compressor kicks in just for a moment to build up pressure then off quickly if it is low since there is a pressure sensor in the system, ... 2003 Ford Explorer

I just fought a 85 honda crx that got parked because the water pump went out. i replaced water pump and timing belt. there was a controll box that had been removed by previous owner it sat over dop the drivers wheel i put it back on and guessed where the hoses. I cand find a diagram for hose routing... the car will start and run as long as you have your foot on the accelerator let it off and it dies. could you help please


What kind of box is it? ... 1990 Honda CRX

I have a 2000 Ford Windstar. While driving the other day I lost all electrical power. Nothing would work and engine cut off. After sitting for a brief time the van cranked back up and I drove it home. Now the van will do nothing. I have no electrical power. I have checked the battery and alternator, both are fine. I have voltage going to the fuse box undert he hood, but no voltage goingt o the fuse box under the dash. This is strang. Could someone please help.


Most probably...a loose electrical connection. Since you mentioned that the electrical power and the engine got cut off and after sitting for a brief of time, the van cranked back up. You need to check the wiring to see if there's any loose connec ... 2003 Ford Windstar

I hit under my car in the front going into a driveway...it made a huge pressure release hiss... I looked under the car and one of two aluminum angled pipes has a hole. they go into two long rubber hoses into the front. they are hooked to something that runs by a belt at the bottom of the engine... what are those pipes coming out of? Is it air conditioning? It still runs and there is light oil that dripped out. Help Please.


Yep its the a.c. you need to replace the lines or not run the a.c. it will ruin your compressor ... 1998 Volkswagen Passat

There is a square box shape attached to the back wall of the engine that has 4 small i think metal hoses coming out of it that i believe go to the brakes. What is the name of that box please


It is a combination valve, sometimes called a splitter valve or a isolater valve. It is a safety device that senses a sudden drop in brake fluid pressure and closes off the fluid flow to 2 lines when necessary. It will aslo cause the BRAKE light to l ... 2000 Kia Sephia

I have a 1990 Nissan Sentra that isn't blowing heat out properly so I was going to change the Thermostat out. I can't find the stupid thing. The top radiator hose on the passenger side goes straight to the motor and really should be right there. No thermostat. The bottom radiator hose on the drivers side goes up and around the back side of the engine. I can't see where this thing goes. Please help. Thanks


Hi,\015\012 \015\012Thank you for contacting Fixya.com.\015\012Generally in this type of case the cooling system is either air bound, meaning ... Nissan Sentra

05 silverado sometimes shifts into 4-wheel drive when coming to a stop. Turning ignition off and restarting engine clears problem. Will not do it again for several trips, but seems to do it after traveling longer distances. Disconnected control buttons, removed 4-wheel drive fuse, and cleaned plugs going into transfer case, but nothing helped. Please help a Senior Citizen find a solution. Thanks, ldg1936


Have you got a maintenance light or check engine light coming on ?If yes you may need to have a diagnostic done to the vehicle in order to retrieve any error codes which will help you to locate the cause of the problem. Hope this helps. ... 2005 Chevrolet Silverado 1500 2WD

Hi i have an audi a6 1.9tdi with the awx engine in it it keeps going into limp mode there is no air leaks ive read the codes and it say says turbo over boost? new egr, you can see the actuvator arm move when you remove the vacum pipe from it so that seem ok to. on the motorway it goes into limp mode at 60mph switch engine off then its perfect for about a week round town then it goes back into limp mode again so then back on motorway then give it some then ok again. any help please. I have a good


In your case the turbocharger is responsible for engine losing power. The car goes in "limp home" mode!!! After scan the EDC-15P engine control unit with a VAG or KTS -BOSCH ... Audi A6

Hello I have a 2002 Chrysler sebring 2.7 v6 dohc engine. I just replace the thermostat housing on the upper radiator hose going into the engine. I also replace main serpentine belt and powersteering belt. I replaced spark plugs also. After putting everyhting back together, the car has a loud knocking sound or like the timing is off. I was very careful not to dmage wires or unplug unnecessay plugs. Can you please help me. The car will start but just sounds loud as if metal is hitting against meta


Hi, here is what you don't want to hear...A loud knocking noise from inside your engine is generally caused by a crank or rod bearing...when caught very early, sometimes they can be replaced. however, once the noise is loud, the attending crankshaft ... 2002 Chrysler Sebring

My car keeps turning off usually at red lights and stuff. but today i was going 70 in the hwy and it just shut off. all the lights remain on but no engine.. it was off. i pulled over then cranked and had trouble till it finally started.. need help please!


Check fuel pressure when it is running. Pump may be mechanically bound from time to time. Gas filter needs to be half decent,not years old. ... 1997 Pontiac Firebird

My 92 ford explorer is not getting power to the starter I have jumped it straight from the battery and it works I got a new starter and nothing now I have back tracked the starter wires and it did not go to my battery as the manual said it went to the relay box what do I do now should I remove it from there and send it to the battery or what? Please help asap.


First, if an auto trans, does it start in neutral? It could be a bad neutral - park safety switch.\015\012\015\012The ignition siwtch could be bad too. ... 1992 Ford Explorer

Mine is an S40 2001. My AC works perfectly when my engine is cool though y Thermostat has been removed which I am looking for one to replace. My AC compressor goes off when the tempreture gauge is getting closer to Half and that be it. After some time it when you put it it will come and go off in some few minutes. When travelling on a long journey, my Ac works perfectly till I slow dowm in a traffic then it goes off. Please Help .... Koxo Ghana


\015\012\015\012\015\012\015\012Cooling system, ThermostatThermostat, s40, v40 \015\012\015\012\015\012\015\012Dealer Price\015\012Core Price\015\012Savings\015\012Final Price\015\012\015\012$23.5 ... 2001 Volvo S40

2002 jeep wrangler 6 cylinder: error codes P0455 and P0442: replaced gas cap: removed, taped, and reinstalled hoses to what i believe is the evap canister. what else could be wrong? it still idles rough...what about the leak detection pump or purge valve? how long will it take for the codes to go away? where can i get an engine diagram that clearly shows the parts? the haynes manual is less than helpful.


THE P0455 CODE POSSIBLE CAUSES ARE \015\012\015\012\015\012Leak at Gas Cap \015\012\015\012Vehicle History and Service Bulletin Investigation ... 2002 Jeep Wrangler

I just got in my car and found a fuse by my gas petal. It is directly underneath a white square plug and a black rectangle plug. I believe that the white plug is where you plug in the computer for the check engine light problems. Please help. Where does this fuse go?? (my regular fuse box is by my door hinge-so its not that)


Mcdevito75 here, That may have been a bad fuse that was changed earlier, before you had the car and was lost a flopped to the gas pedal. Unless you also found a fuse holder for this fuse, check the fuse see if it looks the same as all others in the f ... 2002 Mitsubishi Galant
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.0263 seconds