Having problems with your 1997 Volkswagen Golf ?

My 1997 VW POLO CLASSIC has a new fuel pump installed. But it seems the performance of my car is not efficient, it has low power acceleration. My mechanic diagnosed the problem that my car's "computer box" is not working as expected. Please , anybody could inform me it the diagnosed is correct.

Posted / edited by AnonymousUser on : 16-10-2017

Answers :

It is possible if there are codes in the ECU(computer)
\015\012which leads you to that conclusion.
\015\012And it's hard to tell you if your mechanic right or wrong without having the car for diagnostics.
\015\012There are many other causes for engine to loose power.
I'm assuming this is a gasoline engine. First check for vacuum leaks or possible cracks and the intake system. Second checked the ignition system. If the engine runs smooth and is not missing and may not be the ignition system. Scan the computer for codes this could be helpful. Just remember computers usually don't go out. Most likely it could be a sensor, throttle position sensor, mass air sensor, or oxygen sensor. Also check for bad grounds. Good luck.
Repair Help & Product Troubleshooting for 1997 Volkswagen Golf

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0056 seconds