Having problems with your 1997 Pontiac Firebird ?

My car idels fine when u start it but after u get going and push in the clutch the rpms jump to 4500 wats the reason? Done changed egr and tp sensor and iac

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Thanks for choosing FixYa and welcome. This is a hard solution to point out because it could be a power surge from something. A idle control sensor or map sensor can cause it to spike. You may need an idle adjustment. If you have a check engine light on, take it to Autozone and have it scanned. If not, your best bet is having it put on a diagnostic machine instead of throwing money away on parts you don't need.
Repair Help & Product Troubleshooting for 1997 Pontiac Firebird

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

My car idels fine when u start it but after u get going and push in the clutch the rpms jump to 4500 wats the reason? Done changed egr and tp sensor and iac


Thanks for choosing FixYa and welcome. This is a hard solution to point out because it could be a power surge from something. A idle control sensor or map sensor can cause it to spike. You may need an idle adjustment. If you have a check engine ligh ... 1997 Pontiac Firebird

2005 dodge neon posted earlier about not shifting out of second gear speedomoter jumping around changed output speed sensor code said done ran great approx 5 miles then started not shifting could only go about 25 miles per hour rpms reved high changed input sensor same code done but still same running cond. and code po700 again checked the cables others suggested still no luck any suggestions please


... 2005 Dodge Neon SXT

I HAVE A P0300 OBD CODE I DID A COMPRESSION TEST TO ENGINE AND IT PASS THE TEST,I DID CHECK EGR VALVE,CHANGE SPARK PLUGS,IGNITION WIRES, CAP AND ROTOR, I DID CHECK TPS SENSOR MAF SENSOR,FUEL PRESSURE,AND OXIGEN SENSORSI I FOUND THAT ON BANK 1 BOTH SENSORS (UP STREAM & DOWN STREAM )WORKS NORMALY BUT ON BANK 2 THE SENSOR 1 CHANGE FROM 0 TO 600 MILIVOLTS BUT NO CHANGES FROM RICH TO LEAN &SENSOR 2 HAS 0 MILIVOLTS & NO CHANGES FROM RICH TO LEAN SO I SWICHT SENSOR TO TEST THEM FROM BANK 2 TO BANK 1 AN


... 1997 Nissan Pathfinder

1993 cougar, v6, about 2,000 miles. Engine is misfiring on cylinder 6. Code scanner does not reveal any codes or anything other than the misfire.I have changed the spark plug and wire with new ones. I have done a compression check, the whole bank checks out fine. Also have checked engine vacuum, its steady at 19. The distributor is brand new and timing is about 7 degrees BTDC. Mass air, IAC, throttle position sensor, coil, Ignition control module and EGR are all brand new. I can hear what seems


Replace the coil ... 1993 Mercury Cougar

1993 cougar, v6, about 2,000 miles. Engine is misfiring on cylinder 6. Code scanner does not reveal any codes or anything other than the misfire.I have changed the spark plug and wire with new ones. I have done a compression check, the whole bank checks out fine. Also have checked engine vacuum, its steady at 19. The distributor is brand new and timing is about 7 degrees BTDC. Mass air, IAC, throttle position sensor, coil, Ignition control module and EGR are all brand new. I can hear what seems


Spray carb.and choke cleaner back there and see if it makes a differance ... 1993 Mercury Cougar

I have a Subaru Legacy GX from 2000. It jumps from idle 750 rpms to 1500-2000 rpm when i barely touch the gas pedal. Ive changed the throttle position sensor, and measured 0,5-4V from closed to open. Hope u can help me?


Hi there,\012\012Erratic idle is often due to a vacuum or air leak in one of the engine systems, or faulty sensors sending incorrect data to your engine's computer.\012\012As your vehicle is OBD-II compliant (ie has OnBoard Di ... 2000 Subaru Legacy

!999 Dodge 2599, 4x4, V10, rpms jump up 200 RPMS and immediately drop back 200 RPMS for no apparent reason. Gusts of wind or bumpy road sometimes seem to cause the jump. Especially bad at 45 mph or in cruise control at a slightly higher speed. Dodge dealership reflashed the computer, no change, replace the PCM, no change. Dealer now wants to replace the throttle body but unsure this will correct pb. Any suggestions? Tks


Loose wire or bad throttle body ... 1988 Dodge D-Series Pickups

Hyundai sonata 2000 gls. v6. HAs no EGR. Emission test, first try, HC(0) CO (0) nox 1033 mechanic said my engine seems hot (there was also heat out of vents blowing out. I cleaned my maf sensor and put on high octane gas and fuel cleaner drove for a week and retested. ssecond try HC(0) CO (0) nox 1250. failed agian. I changed my mass airflow from anotehr car and change my 3 front spark plugs myself not the three at back. Car seemed to be running better and engine definitely cooler no mor


... 2000 Hyundai Sonata

I dont know where the egr sensor is located on my 2000 isuzu trooper its a 4 wheel drive.. please help i done have it brought to autozone and it said the valve or the sensor. i changed the valve and i still have the same problem, so i wanted to change the sensor. when i try to drive the truck it doesn;t want to go its like its straining and it will go in low, i know its not the transmission cuz i just had that replaced bout a year ago. any sugestions ? i need help.


... Isuzu Trooper

I have a 2001 Oldsmobile Aurora that has a high idle; had diagnostic done, says to replace PCM. Replaced PCM after having programmed by Chevy dealership in town, and it still has a high idle of 1100 RPMs. This PCM operates just like the one that was taken off. When the IAC was replaced, RPM jumped to 2500 RPMs and wouldn't come down. Put back on the IAC that was on the car originally. Idle was set to 500 RPMs.


Why wasn't the Throttle Position Sensor replaced? The first suspect should probably have been the IAC (but you would have gotten a code), the next logical step would have been checking for something mechanical like the throttle body being gummed up ... 2001 Oldsmobile Aurora

1995 chevy k1500 4.3 5 speed 150,000 stumbles at idle and while driving slow, and even at higher speed while maintaining my speed it will go erratic and smokes black. Have changed map sensor and ignition control module, plugs and wires just about a week ago, egr about a year ago, idle air control valve about a month ago. Injectors are spraying good, fuel pump is working. Im told to clean the egr passages which i did not do when i changed the egr a year ago. haven't done that yet, but gut say


... 1995 Chevrolet K1500

I dont know where the egr sensor is located on my 2000 isuzu trooper its a 4 wheel drive.. please help i done have it brought to autozone and it said the valve or the sensor. i changed the valve and i still have the same problem, so i wanted to change the sensor. when i try to drive the truck it doesn;t want to go its like its straining and it will go in low, i know its not the transmission cuz i just had that replaced bout a year ago. any sugestions ? i need help. Posted by Guest on 2/8/2013 D


You don't have the knowledge to work on your own carForget Auto Zone & chain store placesForget codes,they aren't used to change partsFind a local shop that has been in business for 30 years& actually knows how to ... Cars & Trucks

Hi I have a 93 Beretta GT 3.1 was having problems puttin the car in gear and the car staying running and would stall out and when driving it would jump like the car wasnt gettin enough gas...i changed the fuel pump, catalytic converter, IAC, MAP sensor and changed the TPS sensor now the car wont start back up... also changed all plugs and wires


If you pull a breather hose loose and spray some carb cleaner down the throat and replace the hose will it try to start? You may have burnt the ignition fuse while tring to start it before. Check all fuses including under the hood. Check them all but ... 1993 Chevrolet Beretta

I dont know where the egr sensor is located on my 2000 isuzu trooper its a 4 wheel drive.. please help i done have it brought to autozone and it said the valve or the sensor. i changed the valve and i still have the same problem, so i wanted to change the sensor. when i try to drive the truck it doesn;t want to go its like its straining and it will go in low, i know its not the transmission cuz i just had that replaced bout a year ago. any sugestions ? i need help. Posted by Guest on 2/8/2013 D


... Cars & Trucks

RPMs drop I have a 1999 Tiburon and when i drive it bucks. The RPMS now go from idle to almost zero and the car shakes and almost dies, this occurs when i am at a stop or when im coasting in neutral. It cuts out when i am accelerating. I have done a recent tune up, changed the fuel filter, changed the tps, and crank sensors. I also changed the fuel pressure regulator. The car throws no codes and none are stored. What should i try next?


Does it have a throtle body sometimes alittle carb and choke cleaner sprayed around inside get black carbon biuldup and dont seat righr ... 2003 Hyundai Tiburon

I have a 1996 pontiac firebird straight drive with a 3.8 v6 motor. The car has 46000 miles on it and now for some reason it runs about 3000 rpms unless the clutch is pushed in. We have tuned the car up including wires changed the tps sensor and air sensor without any change


You may have a vacuum leak or a fauly/sticking Idle Air Control valve. ... 1996 Pontiac Firebird

KDH223 08 Hiace EGR issues. I have cleaned egr and added a blocking plate, engine flush, oil (15w40 ESP mobil) & filter change change. Has done approx. 1000kms since (oil looks great!!) Engine light has come back on. Been doing this dince 60k and now 250K. Can I bypass the sensor?


... Cars & Trucks

I have a 2006 Kia spectra . At about 70 mph the rpm gage will jump 2 or 3000 rpms every 4 or 5 seconds. I can feel a slight jump when it does. It almost feels like the trans. slips but I'm not sure. It has done it at around 55 mph but mostly around 70 when the trans is hot. I took it to the dealer but he said they could not find anything wrong. I had the fluid changed but it did not help. It has done it for 2 or 3 years now. Any ideas? Thanks


More than likely it IS your trans (servos that provide pressure to shift or a clogged filter try a flush before you change fuid AND filter) however it could be in the elec.system (wire short or bad plugs) change plugs and wires this may cure your pr ... 2006 Kia Spectra

2000 dodge grand caravan sport, the check engine light is on, but no codes found after checking with reader, speedometer is jumping all over the place, from 0 to 120 mph, when the speedometer jumps around, vehicle gets jerky, as if loss of power, then surge, then loss. i have changed the speed sensor, it made no change, van still the same. please help


No codes found because your checking the PCM,your problem is you need codes from the TCM,the computer for the transmission,since you replaced the speed sensor the other two things that affect a speedometer and transmission are the input and ou ... 2000 Dodge Grand Caravan

I have a 1997 ford expedition which lurches when it runs it sometimes stalls at a light or stop sign. The rpm go from normal to zero then jumps back up again. I've changed the egr valve and the sensor and the 3rd compoment. I've also changed ther iar valve and both oxygen sensors help.


... 1997 Ford Expedition

When i start my car in the mornings to warm up it idles for about 5 minutes then the starts to jump up and down from about 1500 rpms to about 2500 rpms one the car warms up more then its from 1000 to 1500 rpms. it does it constantly and never finds an idle point. ive sprayed carb cleaner over the vacuum lines and the motor pitch didnt change i have also replaced the iac and no fix. it is a 91 eclipse.


Check engine light on??? ... 1991 Mitsubishi Eclipse

My 2002 2.2 L grand am wouldnt start the mechanic said it need a new catalitic converter so I had it changed I was driving back to the shop and it died again. It has a new coilpack,module, sparkplugs,crank sensor,when I start it the rpms jump up and down, if I rev it to 2000 rpms it runs fine, if I rev it to3000 or 4000 rpms it kills . what could be wrong


I don't see mention of a fuel filter or fuel pump. It sounds more like a fuel pump as they can often run sporadically until they finally quit. ... 2002 Pontiac Grand Am

99 gmc suburban -Service lite on= o2 sensor -unplugged battery when change -Just changed battery 3 days ago - close to e,gotta get gas -ck eng lite not on 65 miles drving - today firedup drove 4 miles for groceries - done w/ shopping ready to drive home get about one mile truck flutters then shuts off in middle of road - got a jump, wont turn over= 2x - all lites on in truck uhear it trying but no go.... - it has 94k onithad 1 month - what could be wrong? -


It sounds like the fuel filter may have reached it life time and needs to be replaced. The fuel filter should be replaced every 15,000 miles if not once every year to ensure that the fuel system is running 100%. A dirty fuel filter is the #1 cause of ... 1999 GMC Suburban

Falls on it's face when throttled ,but runs good when rpm's are up.rough idle checked forvacume leaks changed iac valve ,egr,cap and rotor,adjust throttle positioning sensor with butterfly My 1988 Chevrolet Blazer fuel injection engine is extremely accelerated in idle and running throttle, I have checked vacuum sistem and have no loose pipes, would you please help me in how can I dismount and clean the IAC valve? Also I thought that the superior air filter container should have a gasket or rubb


Please check out this link for proper instructions and diagrams with step by step help as some else who was facing the same problem and how he replaced it and dit it himself.\015\012\015\012\015\012 ... 1988 Chevrolet Blazer

I have a 2001 town & country 3.8l lxi and the speedometer goes crazy jumping from 0 -120 and then back again. When this happens the car starts jumping if you try to drive it. I changed both sensors input/output and also the pcm. ANy other ideas on what could be wrong


The PCM does not calculate the speedometer the TCM does.Most of the time if is not a bad output speed sensor it is the connector.You can purchase a replcement connector from the dealer or a local transmission supply house.Also you must have the corre ... 2001 Chrysler Town & Country
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.6537 seconds